Skip to main content

Topic: EAC v1 beta 3 doesnt read title/artist (Read 2512 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
EAC v1 beta 3 doesnt read title/artist
Greetings;

I recently upgraded my EAC software to the latest and greatest V1.0 beta 3; configured everything according to rec's on various hydrogenaudio pages - and the program does not seem to be reading the title or artist of the cd; or the title of the tracks.  Don't know what's up.  Upgraded from V0.99 - haven't used the software in over a year - and never really used it to begin with - just never got around to this little project!  But the previous version I had read the cd title, artist and tracks. 

Any idea what's up? 

Thanks

Kelly

  • trout
  • [*][*][*][*]
EAC v1 beta 3 doesnt read title/artist
Reply #1
Quote
... the program does not seem to be reading the title or artist of the cd ...

It's not reading it from where? Are you speaking of discs that are known to have the info stored as CD-Text, or should the info be gathered from a local or online database? Maybe you previously had the program set up to automatically fetch the info online. In which case you may want to enable:

EAC Options >> General tab >> On unknown CDs, >> automatically access online freedb database

And maybe also configure: freedb/Database Options


  • Apesbrain
  • [*][*][*][*][*]
EAC v1 beta 3 doesnt read title/artist
Reply #2
You may be using old settings that no longer work with b3:
http://wiki.hydrogenaudio.org/index.php?ti...AC_placeholders

If you are encoding to FLAC, default commandline options are:

Code: [Select]
-6 -V -T "ARTIST=%artist%" -T "TITLE=%title%" -T "ALBUM=%albumtitle%" -T "DATE=%year%" -T "TRACKNUMBER=%tracknr%" -T "GENRE=%genre%" -T "COMMENT=%comment%" -T "BAND=%albuminterpret%" -T "COMPOSER=%composer%" %haslyrics%--tag-from-file=LYRICS="%lyricsfile%"%haslyrics% -T "DISCNUMBER=%cdnumber%" -T "TOTALDISCS=%totalcds%" -T "TOTALTRACKS=%numtracks%" %hascover%--picture="%coverfile%"%hascover% %source% -o %dest%

If using this commandline, untick the box that says "Add ID3 tag".

Easiest way to fix this is to run the "Configuration Wizard" under the "EAC" menu item.
  • Last Edit: 04 August, 2012, 04:40:05 PM by Apesbrain

EAC v1 beta 3 doesnt read title/artist
Reply #3
Gee . . .  like I said - haven't used this software in a year - never really knew how to use it in the first place!!  I downloaded the software - manually configured to rip to .flac and all seemed well - with the old version - I stuck a cd in the drive and EAC went to work!  Now when I stick a cd in, and I've tried 3, EAC (new version) doesn't read the title, artist or track titles;  it just tells me how long each track is.  Now, Real Player will play the same cd and it knows the title, artist and all the track titles.  so  . . .    I don't think I had "unknown cds . . . " checked in the previous version of EAC. 

Kelly

EAC v1 beta 3 doesnt read title/artist
Reply #4
Greetings Apesbrain;

Just saw your note:  I copied the command line you provided;  unchecked "Add ID3tag" and still no luck.

BTW - you had sent me a personal message last year when I was on another HA forum trying to figure all this out the first time - your message recommended I try Musicbee - having just found your message (I didn't know I had 'personal' messages on this website) I am wondering if this is still a reasonable alternative.  Does Musicbee do 'accurate' rips?  (yes - still a newbie - life intervenes!)  and thanks (though much delayed) for your message!
  • Last Edit: 04 August, 2012, 04:49:24 PM by hondochica

EAC v1 beta 3 doesnt read title/artist
Reply #5
If you want something super simple to securely rip your disks, try CUERipper thats included in CUETools.
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
EAC v1 beta 3 doesnt read title/artist
Reply #6
Neither of your responses acknowledge trout’s post or whether you have followed the suggestions therein.

EAC v1 beta 3 doesnt read title/artist
Reply #7
Greetings all;

Was out of town last week - back at this!

In response: 

Trout:  Don't think I had "on unknown cds . . " checked in previous version;  but had freedb configured already per you links - went back and checked this box - no change .  . . .

Well . . wait . .  - went back and played with the program s'more while drafting this . . .  Got the info I needed when I hit the 'freedb' button - then everything was filled in.  Funny - I thought EAC would do this automatically since I have freedb enabled and configured etc.  Apparently the cd's I tried didn't have the info written to the CD - I didn't know this!  but hey - IT WORKS!!!!!  and that's all that matters

Thanks so much for you help!

Oh - and 'man-eating-duc' . . .  thanks for that suggestion - I'll take a look at it .

Kelly
  • Last Edit: 12 August, 2012, 11:43:21 PM by hondochica