Skip to main content

Topic: foobar2000 1.1.12 not honouring TPE2 -> "Band" (Read 808 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • montyview
  • [*]
foobar2000 1.1.12 not honouring TPE2 -> "Band"
I've already posted about this in another thread, but with further experiments I think I may have identified a regression with how foobar2000 1.1.12 maps the id3v2 TPE2 tag. Of course, I might just be being thick.

With "Preferences>Advanced>Tagging>MP3>ID3v2 revision and quirks>Map TPE2 to Album Artist (more compatible)" UNCHECKED, foobar2000 1.1.11 consistently maps id3v2.4 TPE2 to "BAND". However, foobar2000 1.1.12 and betas only appear to do so when the media library is initially monitored. Modifying a TPE2 tag on an MP3 file externally with another tag editor (in this case MPTag v2.51) sees it re-mapped to "Album Artist" within foobar2000. Re-editing it back to "Band" within foobar2000 sees the tag mapped to TXXX "Band". (This applies to viewing tags in Properties Dialog, Album List, and Playlist viewers). This also applies to converting FLAC -> MP3 files (using foobar2000's lame preset, no additional command line parameters): FLAC "Album Artist" is written to id3v2.4 TPE2, and not TXXX "Album Artist" as expected.

I've tested this against 1.1.11 final, 1.1.12 beta 5, beta 6, final and 1.1.12a.

Using DUI, Win7 Pro 64-bit. No unusual components, but will post if requested.

  • Peter
  • [*][*][*][*][*]
  • Administrator
foobar2000 1.1.12 not honouring TPE2 -> "Band"
Reply #1
Bug acknowledged, thanks for reporting.