Skip to main content

Topic: FAAD or PsyTEL bug?? (Read 3877 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • superorc
  • [*][*]
FAAD or PsyTEL bug??
i used eac with psytel 2.11 using the -archive switch. went it gets to the end of any track i encoded with psytel aac i get an error from the FAAD winamp plugin stating "Unable to find ADTS syncword". the entire song is encoded fine tho. any suggestions on what causes this?

  • LordCorvin
  • [*][*]
FAAD or PsyTEL bug??
Reply #1
It happen also with "old" (pre 2.0 ver) aacenc aac...
It has something to do with a new faad2 lib, coz it works fine with the original faad-based plugin.

  • menno
  • [*][*][*][*][*]
  • Developer (Donating)
FAAD or PsyTEL bug??
Reply #2
It doesn't work fine with the old faad, it just doesn't show an error message.

Menno

  • LordCorvin
  • [*][*]
FAAD or PsyTEL bug??
Reply #3
Quote
Originally posted by menno
It doesn't work fine with the old faad, it just doesn't show an error message.

Menno


So, are you sure that there is a bug that exists in every version of aacenc released, and this is what leading to this error message? If so, I appologize about my mistake... I just thought that the "guilty" is faad2, because at first, it just closed winamp at the end of every aac, and then you changed something and this message is started to appear...
Is Ivan aware of this?

  • menno
  • [*][*][*][*][*]
  • Developer (Donating)
FAAD or PsyTEL bug??
Reply #4
Well, there was a little bug with files with an id3v2 tag, it could be that that is the problem. Try a newer version from Robertos page and you'll see. I can't tell for sure if that is the problem, but it was also there in the old winamp plugin, just didn't give the error message.

Menno

  • layer3maniac
  • [*][*][*][*][*]
  • Banned
FAAD or PsyTEL bug??
Reply #5
Sometimes I think ID3v2 tags were created by the RIAA...  :ponder:

  • superorc
  • [*][*]
FAAD or PsyTEL bug??
Reply #6
well i believe i downloaded the current faad2 source and compiled it myself. i guess ill try robertos version.

EDIT: still does it with roberto's version

EDIT 2: deleted all traces of id3v2 and still does it

  • menno
  • [*][*][*][*][*]
  • Developer (Donating)
FAAD or PsyTEL bug??
Reply #7
What options are you using for the winamp plugin?

Menno

  • superorc
  • [*][*]
FAAD or PsyTEL bug??
Reply #8
the plugin im using doesnt have much for options

  • menno
  • [*][*][*][*][*]
  • Developer (Donating)
FAAD or PsyTEL bug??
Reply #9
Are you buffering the whole file in memory or not?

Menno

  • superorc
  • [*][*]
FAAD or PsyTEL bug??
Reply #10
that options doesnt fix anything

EDIT: i downloaded the 2nd newest faad, and compiled the winamp plugin. while it may still have the problem, it doesnt give the error at least ;-)

  • Lizard
  • [*]
FAAD or PsyTEL bug??
Reply #11
Removing the commas from the title tag with the editor seemed to resolved the problem for me.