Skip to main content

Topic: "Unable to open item for playback (device is not ready)" (Read 2952 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • maxson924
  • [*]
"Unable to open item for playback (device is not ready)"
First of all, my apologies if this topic already exists; I looked throughout this forum and didn't find anything like it.

As for my problem, I've been using foobar on an old PC for years with no problems. I store all my music on an external hard drive and have always just told foobar to monitor the music folder on that. Today I got a new computer and installed foobar, copying over the config files and all that from my old computer to this one (via my external drive). I've told foobar on this computer to monitor the music folder just like before. It recognizes all my files, no problems. But then when I try to actually play any files, it shows the error in the topic title.

As for specs, Asus X44L-BBK4, Windows 7 Home Premium, foobar v1.1.11. The old computer was a Dell Inspiron 1300 (yeah, it was old) with Windows XP and foobar v1.0.3. The external drive is a Seagate 500 GB USB drive, but I don't know the exact model nor how to check.

Any help is much appreciated!
  • Last Edit: 12 May, 2012, 05:17:32 PM by maxson924

  • Ouroboros
  • [*][*][*][*]
"Unable to open item for playback (device is not ready)"
Reply #1
Try copying a few files to your new PC hard drive, just to make sure they play properly.

Run foobar2000 as Administrator (right click - run as Administrator) and try playing the files on the USB drive. If that works check the permissions and ownership of the USB drive and its contents.
  • Last Edit: 12 May, 2012, 05:50:00 PM by Ouroboros

  • Porcus
  • [*][*][*][*][*]
"Unable to open item for playback (device is not ready)"
Reply #2
Everything is OK in Preferences > Playback > Output ?

Today I got a new computer and installed foobar, copying over the config files and all that from my old computer to this one (via my external drive).

(Or does it perchance try to play with the old device which isn't there anymore?)

  • maxson924
  • [*]
"Unable to open item for playback (device is not ready)"
Reply #3
Quote
Try copying a few files to your new PC hard drive, just to make sure they play properly.


Yup, that worked.

Quote
Run foobar2000 as Administrator (right click - run as Administrator) and try playing the files on the USB drive.


This worked too!

Quote
If that works check the permissions and ownership of the USB drive and its contents.


Assuming I did the right thing (Right-clicked the drive -> Properties -> Security), it's set to allow full control for all users (I'm the only user). A friend of mine had suggested that before I came here but that alone didn't do the trick.

Quote
Everything is OK in Preferences > Playback > Output ?


I don't really know what to check for, but nothing strikes me as off.

Quote
(Or does it perchance try to play with the old device which isn't there anymore?)


If you mean the external drive, I have it plugged in as I'm trying this. So it is there, but I think I'm misunderstanding you.


Well, running foobar as an administrator seems to solve the problem! Now my only question is if I can get Windows to do that automatically, since I can't do that from the shortcut that's pinned to the taskbar. If anyone could tell me how to do that, that'd be great, and thanks again guys. :3

  • Ouroboros
  • [*][*][*][*]
"Unable to open item for playback (device is not ready)"
Reply #4
If it runs as Administrator then it's definitely a permissions problem.

Have you set permissions for the entire disk, or just looked at them? Also, have you checked for all groups? Try again, this time make a change, then change it back again. It should take a while as it goes through every file on the disk.....
  • Last Edit: 12 May, 2012, 07:40:16 PM by Ouroboros

  • maxson924
  • [*]
"Unable to open item for playback (device is not ready)"
Reply #5
Well, I've set the permissions, but oddly enough it now automatically opens as administrator, so... problem solved, I think? o_O

  • kode54
  • [*][*][*][*][*]
  • Administrator
"Unable to open item for playback (device is not ready)"
Reply #6
Have you fixed the permissions from the Properties dialog for the entire partition? I don't know what I used to format it as such, but my large storage drive's default base permissions are Full control for Everyone.

Also, opening as Administrator by default only occurs if you check the administrator permission setting in the compatibility page of the executable's Properties dialog, or if you set it to a Windows 2003/XP or older OS version compatibility mode.
  • Last Edit: 12 May, 2012, 09:26:13 PM by kode54