Skip to main content

Topic: Foobar stutters during 1st second of playback and then again at about  (Read 2215 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Johncan
  • [*][*]
Foobar stutters during 1st second of playback and then again at about
I have the latest stable (non-beta) version of Foobar2000 installed on a WinXP SP3 laptop.  The PC is a single core AMD cpu laptop with 1 GB ram.  I am playing FLAC files (16/44.1) that are being served wirelessly from a server in basement.  The soundcard is M-Audio USB Transit into a Musical Fidelity X-DAC V3. Whenever I start a new album, the first song that I play from that album has a stutter or drop-out in the 1st second and then again in about the 5th or 6th second.  It does not stutter again until I change the track order (skip from track 3 to say track 7) or start a new album.  It does not stutter going from track 1 to track 2 to track 3 and so on.

I am not using any DSPs.  My output is Direct Sound at 24-bit with no dithering.  The Transit drivers are the most current (from 2012).  When I switch from wireless to wired, the stutter does not go away.  I have the latency maxed out on the Transit.  My buffer size in Foobar2000 is 10000 ms.

Any ideas what may be causing this or how I can fix it.  If I left out any needed information, please let me know what you need to answer my question.

Thanks in advance.

  • Porcus
  • [*][*][*][*][*]
Foobar stutters during 1st second of playback and then again at about
Reply #1
Does it depend on your choice of buffering?

  • Johncan
  • [*][*]
Foobar stutters during 1st second of playback and then again at about
Reply #2
Does it depend on your choice of buffering?



I have not found a buffering setting that seems to make it go away.  I am open to any suggestions.

  • kode54
  • [*][*][*][*][*]
  • Administrator
Foobar stutters during 1st second of playback and then again at about
Reply #3
Did you mean that it also occurs near the end of the track? Are you using a large cross fade duration in the output settings? The player must start decoding another track early so it has something to cross fade into.

  • Johncan
  • [*][*]
Foobar stutters during 1st second of playback and then again at about
Reply #4
Did you mean that it also occurs near the end of the track? Are you using a large cross fade duration in the output settings? The player must start decoding another track early so it has something to cross fade into.


No, it only occurs on the very song I play during the 1st second and then again at about the 4th, 5th, 6th second.  If I am playing an CD in order, it only does it on the first song.  If am jumping around, it does it on almost every song.  The stutter does not happen at the end of the song.

I hope that makes sense.

  • washu
  • [*][*][*]
Foobar stutters during 1st second of playback and then again at about
Reply #5
What kind of NAS/Server do you have?  Are both ends (PC and NAS) on wired when you say you switched from wireless?

Copy some tracks to your local drive and see if they do the same thing.

  • Johncan
  • [*][*]
Foobar stutters during 1st second of playback and then again at about
Reply #6
What kind of NAS/Server do you have?  Are both ends (PC and NAS) on wired when you say you switched from wireless?

Copy some tracks to your local drive and see if they do the same thing.



The "server" is basically an old Dell Pentium 4 PC running XP SP3.  It has a 2TB HD with about 1.2 TB of FLAC files.  The Dell is connected to a N wireless router via 100 MB NIC.  I tried switching to a powerline adapter for the laptop and the stutter remained when connected via wired 100 MB network.

The "server" has no issue streaming FLAC files transcoded to WAV via Asset to a Roku Soundbridge.  This indicates to me that "server" and the network are fast enough for FLAC files.

I try some local files on the laptop HD and see what happens.

John

Foobar stutters during 1st second of playback and then again at about
Reply #7
You might try disabling skip silence if it's enabled. I had issues with it consistently on one of my songs even when it was clearly not silent.

  • Johncan
  • [*][*]
Foobar stutters during 1st second of playback and then again at about
Reply #8
Quote
Copy some tracks to your local drive and see if they do the same thing.


It does it off the local drive as well.

John

  • washu
  • [*][*][*]
Foobar stutters during 1st second of playback and then again at about
Reply #9
Try running the DPC latency checker and see if you get any high times when the music drops out.  If you do then you need to track down which driver is causing it. 

http://www.thesycon.de/deu/latency_check.shtml


While it is not related to your issue, powerline network is not the same as ethernet at all in performance.  It is much closer to wireless performance.  If you want to eliminate network issues then don't use it.

  • Johncan
  • [*][*]
Foobar stutters during 1st second of playback and then again at about
Reply #10
Try running the DPC latency checker and see if you get any high times when the music drops out.  If you do then you need to track down which driver is causing it. 

http://www.thesycon.de/deu/latency_check.shtml


While it is not related to your issue, powerline network is not the same as ethernet at all in performance.  It is much closer to wireless performance.  If you want to eliminate network issues then don't use it.



I ran the DPC latency checker and it says that some device drivers behave bad and will probably cause drop-outs in real-time audio and/or video streams.  Current latency hovers around 185 - 200 us when playing Foobar.  It can jump as high as 2150 us but usually jumps to about 1200 us and then back down to 185.  I will keep troubleshooting.

John

  • Johncan
  • [*][*]
Foobar stutters during 1st second of playback and then again at about
Reply #11
Try running the DPC latency checker and see if you get any high times when the music drops out.  If you do then you need to track down which driver is causing it. 

http://www.thesycon.de/deu/latency_check.shtml


While it is not related to your issue, powerline network is not the same as ethernet at all in performance.  It is much closer to wireless performance.  If you want to eliminate network issues then don't use it.



I ran the DPC latency checker and it says that some device drivers behave bad and will probably cause drop-outs in real-time audio and/or video streams.  Current latency hovers around 185 - 200 us when playing Foobar.  It can jump as high as 2150 us but usually jumps to about 1200 us and then back down to 185.  I will keep troubleshooting.

John


I wiped the laptop and did a clean reinstall of XP.  It is much better now.

John