Skip to main content

Topic: ID3 Tags not being read for some songs (Read 2225 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • civint
  • [*]
ID3 Tags not being read for some songs
My problem is essentially all in the topic description;

After importing my library (as organized by iTunes) into fb2k and getting it set up how I like it, I noticed that about 300 or so songs were only being displayed with their file name as the 'track' with no other information.

I converted all the files' tags to ID3 v2.4, which didn't change anything, and I wondered if perhaps it was just that the information was being saved in an itunes database and not in a common format, so I tried to import the library to Winamp, and everything was displayed as expected (as in iTunes). Ordinarily this wouldn't be an issue, but since the volume is so high I don't really want to go through them all file by file and fix the data!

As it happens all my Genre metadata is messed up but that was also common in itunes etc

Any ideas etc are more than welcome!

(I had looked at some of the other threads with similar problems, but there were very few which presented any answers, unfortunately)

Thanks,
Civ

  • Porcus
  • [*][*][*][*][*]
ID3 Tags not being read for some songs
Reply #1
This looks like much more lost than can be explained by http://wiki.hydrogenaudio.org/index.php?ti...ID3_Tag_Mapping . An application like MP3Tag can report what tag version(s) are used for each file, tried that?

  • Cetena
  • [*]
ID3 Tags not being read for some songs
Reply #2
Hi all,

I noticed the same problem. Some tags of some tracks cannot be properly read by foobar (as if they were missing).

The tags should be of no problem.

To further test with the issue, I've converted the track from mp3 VBR V2 to mp3 VBR V0 to make some difference in the audio data. Then I applied the exactly identical set of tags to the newly converted mp3 with mp3tag.
And this time foobar can correctly show all tags for this new mp3!!

Thus I'm quite sure there is a bug in tag parsing in foobar.

=========================
more info: the tags are in id3v1, id3v2.3 (utf-16), apev2 format (reported by mp3tag)

=========================
Another test:

For the mp3 which foobar cannot read the tags properly, I re-saved the tags with mp3tag in id3v2.4 format and then foobar can read all tags properly.

Then I re-saved the tags again with mp3tag in id3v2.3 (utf-16) format and foobar can read all tags perfectly.
  • Last Edit: 10 April, 2012, 01:03:29 PM by Cetena

  • neothe0ne
  • [*][*][*][*]
ID3 Tags not being read for some songs
Reply #3
I noticed the same problem. Some tags of some tracks cannot be properly read by foobar (as if they were missing). […] the tags are in id3v1, id3v2.3 (utf-16), apev2 format

You're probably experiencing an inconsistency between your ID3 tags and the APE tags.  If what you see in foobar2000 isn't what you want, I suggest removing the APE tags in mp3tag.
  • Last Edit: 11 April, 2012, 05:18:47 AM by db1989

  • illu
  • [*]
ID3 Tags not being read for some songs
Reply #4
There must be an inconsistency between reading tags of the playing and other songs. As long as i don't play a song, i can see it's artist overall in foobar. When it's playing, it disappears (not visible in title and status bar etc. but properties).. after rewriting the artist with properties dialogue, it works?!