Skip to main content

Topic: sound quality with drivers (Read 3674 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • chronek
  • [*]
sound quality with drivers
Hello,

I am using window7 + creative sb x-fi hd usb + some sennheiser headphones and lately found that after install driver 1.2.21 over original 1.2.20 my sound got worsen (I usually playing flac files with foobar + sox resampler plugin + asio). After reinstall driver sound got back better quality.
I just wondering, i always do resample sound to highest profile what my card can play (24bit/96kHz) for bypass windows/driver resampling, and using even asio for bypass that but looks like that driver have own resampler and filters and even if i try best - driver can corrupt sound.
Know anyone a way to bypass driver and play original sound as much as possible?

Mike
  • Last Edit: 01 April, 2012, 09:27:33 AM by chronek

  • xnor
  • [*][*][*][*][*]
  • Developer
sound quality with drivers
Reply #1
Sound got worse how exactly (TOS #8)? What asio driver, the asio4all "wrapper"?

If you want to play the "original sound" then why do you resample everything?

The soundcard driver cannot be bypassed if you want it to play sound.
  • Last Edit: 01 April, 2012, 11:05:08 AM by xnor
"I hear it when I see it."

  • JimH
  • [*][*][*]
sound quality with drivers
Reply #2
Sound got worse how exactly (TOS #8)? What asio driver, the asio4all "wrapper"?

If you want to play the "original sound" then why do you resample everything?

The soundcard driver cannot be bypassed if you want it to play sound.

If the device has an ASIO driver, use that.  If not, WASAPI is good.  Kernel Streaming next.

ASIO4All is a wrapper for Kernel Streaming.

Upsampling is harmless.

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
sound quality with drivers
Reply #3
Don’t misinterpret the above post to refer to quality. These modes are designed not for any effect upon the output audio but rather to achieve unrelated goals such as exclusive access to hardware, reduced latency, etc.

  • Nessuno
  • [*][*][*][*]
sound quality with drivers
Reply #4
Don’t misinterpret the above post to refer to quality. These modes are designed not for any effect upon the output audio but rather to achieve unrelated goals such as exclusive access to hardware, reduced latency, etc.


Which nevertheless (and correct me if I'm wrong), under certain conditions (e. g. many concurrent sound clients, heavy average system load etc...), might have perceivable effects on output sound quality.
... I live by long distance.

  • phofman
  • [*][*][*][*]
sound quality with drivers
Reply #5
I am correct that X-Fi, unlike most other cards, employs extensive DSP in hardware? At least the older Audigy cards did so. In such case I can imagine an updated firmware, a part of the driver upgrade, causing different sound.

  • Nessuno
  • [*][*][*][*]
sound quality with drivers
Reply #6
I can imagine an updated firmware, a part of the driver upgrade, causing different sound.


Already tried to downgrade the driver and verify the effect on sound?

By the way: you haven't jet detailed this difference in sound. We can't try to help you if we actually don't know anything about it.
In doing this, please follow the guidance of Hydrogenaudio TOS, especially  point #8.
... I live by long distance.

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
sound quality with drivers
Reply #7
I am correct that X-Fi, unlike most other cards, employs extensive DSP in hardware? At least the older Audigy cards did so.
It should do so only if the user has X-Fi processing enabled.

In such case I can imagine an updated firmware, a part of the driver upgrade, causing different sound.
Yes, perhaps. So, chronek should check this.

Which brings us back to:
Know anyone a way to bypass driver and play original sound as much as possible?
If this is your goal, you’ll want to have X-Fi off; that’s for sure.
  • Last Edit: 02 April, 2012, 06:11:10 AM by db1989

  • slks
  • [*][*][*][*]
sound quality with drivers
Reply #8
Indeed, one of the selling points of the X-Fi line are their DSP capabilities - I've never used one, but given the marketing, I'd say there's a high chance that some of the sound processing features could be turned on by default. Upgrading your drivers could have caused some of the settings to be changed, that is - turned on or turned off, compared to what they were before. There should be an option to change all these things in Creative's settings somewhere. These are things like "concert hall" reverb presets etc., although they're probably called something fancier for the X-Fi line. For the highest level of fidelity to the source material, you'll want to turn all such DSPs off.

You could also try going to Creative's site and see if there's a changelog or bug reports or something for the new drivers. It depends on how good their documentation is, but I should think any large changes to the drivers that influence sound quality is noted somewhere.

My money is on there being a setting misconfigured, though. Probably something to do with either the DSP stuff or maybe resampling. Unfortunately I haven't used a Creative card in years and can't tell you where to access these settings... but I'd advise looking over them very carefully. The eye-candy GUI bloat on some of these manufacturer tools can make it difficult to tell what the settings actually are and what can be changed. (Controls designed to look like analog knobs, switches, and indicators, for example... yuck)
  • Last Edit: 03 April, 2012, 04:37:44 AM by slks