Skip to main content

Topic: Portal appears to be broken in Chrome (Read 2918 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Ron Jones
  • [*][*][*][*]
Portal appears to be broken in Chrome
The portal (landing page for hydrogenaudio.org) appears to be malfunctioning. It displays only the header, footer and the navigational breadcrumb:


  • tpijag
  • [*][*][*][*][*]
Portal appears to be broken in Chrome
Reply #1
Fine here. Maybe clear your browser cache. Close and reload browser and page.

  • Ron Jones
  • [*][*][*][*]
Portal appears to be broken in Chrome
Reply #2
Yeah, that's the first thing I did.

A closer look indicates that some of the HTML generated is malformed and may be causing issues within Chrome (but IE9 is fine):

Code: [Select]
<td class='row2''>


(That's two apostrophes, not one quotation mark. That's bad.)

  • kode54
  • [*][*][*][*][*]
  • Administrator
Portal appears to be broken in Chrome
Reply #3
I fixed that single quote bug in the template, but I don't know what else it needs.

Apparently, the bug only affects Chrome dev channel or newer. Neither beta nor stable exhibit the issue.

I would like to fix the glaring validation failures on that portal code, and heck, the main template, but I don't even know where some of the template bits are stored. Like that meta description tag that isn't terminated like an XML tag should be. And then a link or two that contain raw ampersands instead of &amp;, but that should be easier to find.

  • Garf
  • [*][*][*][*][*]
  • Developer (Donating)
Portal appears to be broken in Chrome
Reply #4
The site's (X)HTML isn't 100% compliant but that shouldn't be the problem - Chrome's devtools have no problem parsing the structure. This is simply a bug in (the development version of) Chrome.

I fixed some of the issues kode54 pointed out. If you point out more, I can fix those too. But it doesn't help Chrome.

You can also use Firefox, Opera, or hell, even IE. They work.
  • Last Edit: 26 March, 2012, 08:17:46 PM by Garf

  • GenjuroXL
  • [*]
Portal appears to be broken in Chrome
Reply #5
Seems to work in the 18.x branch of Chrome, only 19.x is broken.