Skip to main content

Topic: Found yet another bug in PsyTEL... :( (Read 2939 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Sachankara
  • [*][*][*][*]
Found yet another bug in PsyTEL... :(
I´ve found a sample that causes PsyTEL (2.11) to crash at 57.91% no matter what settings you (I) use... (Actually, I´ve only tried three different switches in random orders... ihsc, vbrhi and safems...) I´ve compressed it in WavPack format, unless you have anything against it...(?)  It´s quite "big" (for 56k:ers) though... 3.58MB even though it has an lossless compression ratio of 61.04%...

You´ll find it here: http://www.stockholm.bonet.se/annorax/dune.track14.sample.wv

By the way, it´s not the %-error someone mentioned in another thread, since the whole file isn´t encoded and when playing the encoded sample in Winamp, FAAD returns an error message saying "Pulse coding not allowed in short blocks"...

  • M
  • [*][*][*][*][*]
Found yet another bug in PsyTEL... :(
Reply #1
Hmm... I'm not on a fast enough connection right now to download your sample and check this myself, but I did check Roberto's software page for the latest PsyTEL encoder and noticed that the download link is still (accidentally) pointing to v2.1 instead of 2.11. You've probably already double-checked your version number, but on the off chance that you haven't I would try downloading the updated program and see if that fixes things. Here's a corrected link:

    http://www.inf.ufpr.br/~rja00/files/aacenc_v211.zip

  (Roberto seems to keep on top of things fairly well, so the original link may already be fixed before anyone else checks his site... although if anyone else downloaded the program over the past few days and didn't notice the error, they might also need to update their own copies.)

  I hope this helps. Interesting photo, by the way...

    - M.

  • Sachankara
  • [*][*][*][*]
Found yet another bug in PsyTEL... :(
Reply #2
Yeah I know he linked to the wrong version... But I did download 2.11 (PsyTEL® MPEG-4 AAC Encoder V2.11 (build Jan 31 2002)), so at least it´s not my fault in that way...  It could be an OS error, but I doubt so...

The error message from FAAD indicates that it might be some kind of MS/JS error or some other wierd thing which happends when the quality shifts quite a lot... But what do I know? I´m just a newbie...

  • Ivan Dimkovic
  • [*][*][*][*][*]
  • Developer
Found yet another bug in PsyTEL... :(
Reply #3
Latest build (Feb 24th) should have this bug fixed

  • rjamorim
  • [*][*][*][*][*]
Found yet another bug in PsyTEL... :(
Reply #4
This latest build is already available at my page.

Regards;

Roberto.
Get up-to-date binaries of Lame, AAC, Vorbis and much more at RareWares:
http://www.rarewares.org