Skip to main content

Topic: PysTEL % done bug ? (Read 2180 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • sam
  • [*][*]
PysTEL % done bug ?
Whenever I encode useing aacenc -br 32 -resample 22050 the % done always stops at 28.49%, althouth it has infact completed the entire sample no problem. Here is some output.

Sam

Code: [Select]
C:MediaMusictest>aacenc -br 32 -resample 22050 -if life.wav -of life2.aac



*********** PsyTEL(R) MPEG-4 AAC Encoder V2.1 (build Jan 17 2002) ***********



{snip}



in:  44100 Hz, 2 Channel(s)

out: 22050 Hz, CBR 32000 bits/s (AAC Profile: Low Complexity)

Cut-off frequency: 6500 Hz



Encoding life.wav:

Frame 2720 of 9546 ( 28.49% ) - 31.9 kbits/s - 2.70x Real Time



Finished encoding life.wav in 1 minutes 22 seconds



Thank you for using MPEG-4 AAC.

  • john33
  • [*][*][*][*][*]
  • Developer
PysTEL % done bug ?
Reply #1
Sam,

There is an updated aacenc at Roberto's site. No idea whether it addresses this, but it addresses some other issues.

john33
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • Ivan Dimkovic
  • [*][*][*][*][*]
  • Developer
PysTEL % done bug ?
Reply #2
This is just a display bug, it does not have impact on encoding. This bug is caused by resampler, because if you use -resample, the number of samples will not be the same, but encoder assumes number of samples of original sample rate configuration.

  • sam
  • [*][*]
PysTEL % done bug ?
Reply #3
I downloaded it this morning from Roberto's site. I think its just calcualtes the % etc wrong, the encoded files seem fine.

Oops, sorry about this post, please ignore me