Skip to main content

Topic: Apple Airport Express: serious audio issue with firmware 7.6 (Read 3042 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Nessuno
  • [*][*][*][*]
Apple Airport Express: serious audio issue with firmware 7.6
I've owned an Apple Airport Express for the last year, using its analog output to drive my amp (MacBook running OSX Snow Leopard as source) and its audio quality has always subjectively satisfied me, but lately I've been experiencing a very annoying problem: clearly audible "pops" and "clicks" superimposed to music, something like just playing back an analog record!
Wel, to cut a long story short, I finally located the cause in the latest firmware 7.6. Downgrading to 7.5.2 all the noises disappeared. Just as a proof of concept: upgrading again the pops and clicks were back.

Anybody else experiencing this same issue?
... I live by long distance.

  • Busemann
  • [*][*][*][*][*]
Apple Airport Express: serious audio issue with firmware 7.6
Reply #1
Haven't noticed anything like this, but then again I use optical out

Apple Airport Express: serious audio issue with firmware 7.6
Reply #2
Is this the older 802.11g AirPort Express base station or the newer 802.11n model?  I have the older 802.11g release but I don't remember what firmware it is running.  In fact, I haven't used it in a few months (ever since upgrading to a Netgear N3000) but I can tell you that everything was fine in terms of outputting audio before I stopped using it.  I used to hook it up to my Sony system via an analog connection and the audio streaming to it from iTunes on my Mac, iTunes on my Windows 7 nettop, my iPad 2, and 4G iPod touch were all fine without any noticeable pops.  Maybe you had an isolated incident or maybe it is widespread, I don't know.

  • Nessuno
  • [*][*][*][*]
Apple Airport Express: serious audio issue with firmware 7.6
Reply #3
Haven't noticed anything like this, but then again I use optical out


Could you please test if the analog output of your unit is also affected by this (supposed) firmware bug?

@kornchild2002: mine is a 802.11n unit, about one year old.
... I live by long distance.

  • Nessuno
  • [*][*][*][*]
Apple Airport Express: serious audio issue with firmware 7.6
Reply #4
By the way, definitely I'm not the only one experienced it: just found a thread in Apple support forum on this same issue.
... I live by long distance.