Skip to main content

Topic: LAME 3.99 is out (Read 213555 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • vinnie97
  • [*][*][*][*]
LAME 3.99 is out
Reply #350
'Cuse the ignorance/possible forgetfulness (and I thought I'd previously heard that 4.0 was being developed concurrently with all these 3.x releases), but will there ever be a fanfare for 4.0 beta?  I realize some alphas have been released in the past 6 years...

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #351
'Cuse the ignorance/possible forgetfulness (and I thought I'd previously heard that 4.0 was being developed concurrently with all these 3.x releases), but will there ever be a fanfare for 4.0 beta?  I realize some alphas have been released in the past 6 years...

4.0 was the personal project of Takehiro who 'retired' from the scene several years ago, sadly. It was a total rewrite of the LAME project but, unfortunately, is never likely to see the light of day.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • vinnie97
  • [*][*][*][*]
LAME 3.99 is out
Reply #352
Thanks!  Wow, that's a pity...what will become of LAME version numbering after 3.99 is exhausted?  Any roadmaps detailing the plan or will fine tuning likely continue into perpetuity of the current branch?

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #353
Thanks!  Wow, that's a pity...what will become of LAME version numbering after 3.99 is exhausted?  Any roadmaps detailing the plan or will fine tuning likely continue into perpetuity of the current branch?

3.100 already exists as an alpha.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • JJZolx
  • [*][*][*][*]
LAME 3.99 is out
Reply #354
I'm curious about how it got to 3.99. Surely there weren't 99 3.xx versions before this one.

  • vinnie97
  • [*][*][*][*]
LAME 3.99 is out
Reply #355
Thanks!  Wow, that's a pity...what will become of LAME version numbering after 3.99 is exhausted?  Any roadmaps detailing the plan or will fine tuning likely continue into perpetuity of the current branch?

3.100 already exists as an alpha.

Oh, sure enough, I see it at Rarewares down there at the bottom...apologies for the oversight.

  • rohangc
  • [*][*][*][*][*]
LAME 3.99 is out
Reply #356
I've only encountered a similar behavior with programs that require a CPU with SSE2 support. (using an AthlonXP without SSE2)
Could that may be the case for this new release (LAME 3.99.4)?

You may be right. I just tried AMD Athlon XP 3200+ on Win 7 (32-bit). LAME 3.99.4 did not work when using the same foobar2000 settings that work fine with 3.99.3.

foobar2000 reported:

Conversion failed: The encoder has terminated prematurely with code -1073741795 (0xC000001D); please re-check parameters


I see the exact same behavior on my machine running Windows 7 64-bit and with an AMD Phenom II X6 processor (that does support SSE2 instructions). I see the crash on both LAME 3.99.4 and 3.99.5.

Can someone please tell me how I can resolve this issue?

Thanks!

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #357
I see the exact same behavior on my machine running Windows 7 64-bit and with an AMD Phenom II X6 processor (that does support SSE2 instructions). I see the crash on both LAME 3.99.4 and 3.99.5.

Can someone please tell me how I can resolve this issue?

Thanks!

3.99.5 (all versions) were built and tested on a Phenom II X6 1075T with Windows 7 Home Premium 64 bit. I just checked all versions and they run without issue. Also tested on an Intel i7 2600K/Win 7 Pro 64 bit and an Intel i7 920/Win 7 Pro 64 bit. 32 bit versions also tested on Win2k Pro.

Anyone else with any issues?
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • apodtele
  • [*]
LAME 3.99 is out
Reply #358
You may be right. I just tried AMD Athlon XP 3200+ on Win 7 (32-bit). LAME 3.99.4 did not work when using the same foobar2000 settings that work fine with 3.99.3.

foobar2000 reported:

Conversion failed: The encoder has terminated prematurely with code -1073741795 (0xC000001D); please re-check parameters


Please post the parameters that cause the crash. That would be swell.

  • Alex B
  • [*][*][*][*][*]
LAME 3.99 is out
Reply #359
I see the exact same behavior on my machine running Windows 7 64-bit and with an AMD Phenom II X6 processor (that does support SSE2 instructions). I see the crash on both LAME 3.99.4 and 3.99.5.
Please post the parameters that cause the crash. That would be swell.
3.99.5 fixed this problem for me. (on Athlon XP 3200+ / 32-bit Win 7)

I just retested 3.99.3, 3.99.4 and 3.99.5. Here are the foobar2000 console logs:

3.99.3
Code: [Select]
CLI encoder: C:\Soft\Lame\3993\lame.exe
Destination file: F:\Rip\Jam & Spoon\1997 - Kaleidoscope\02 - Kaleidoscope Skies.mp3
Encoder stream format: 44100Hz / 2ch / 16bps
Command line: "C:\Soft\Lame\3993\lame.exe" -S --noreplaygain -V 1 - "02 - Kaleidoscope Skies.mp3"
Working folder: F:\Rip\Jam & Spoon\1997 - Kaleidoscope\
Encoder process still running, waiting...
Encoder process terminated cleanly.
Track converted successfully.
Total encoding time: 0:16.125, 12.85x realtime
3.99.4
Code: [Select]
CLI encoder: C:\Soft\Lame\3994\lame.exe
Destination file: F:\Rip\Jam & Spoon\1997 - Kaleidoscope\02 - Kaleidoscope Skies.mp3
Encoder stream format: 44100Hz / 2ch / 16bps
Command line: "C:\Soft\Lame\3994\lame.exe" -S --noreplaygain -V 1 - "02 - Kaleidoscope Skies.mp3"
Working folder: F:\Rip\Jam & Spoon\1997 - Kaleidoscope\
An error occurred while writing to file (The encoder has terminated prematurely with code -1073741795 (0xC000001D); please re-check parameters) : "F:\Rip\Jam & Spoon\1997 - Kaleidoscope\02 - Kaleidoscope Skies.mp3"
Additional information:
Encoder stream format: 44100Hz / 2ch / 16bps
Command line: "C:\Soft\Lame\3994\lame.exe" -S --noreplaygain -V 1 - "02 - Kaleidoscope Skies.mp3"
Working folder: F:\Rip\Jam & Spoon\1997 - Kaleidoscope\
Conversion failed: The encoder has terminated prematurely with code -1073741795 (0xC000001D); please re-check parameters
could not enumerate tracks (Object not found) on:
F:\Rip\Jam & Spoon\1997 - Kaleidoscope\02 - Kaleidoscope Skies.mp3
Total encoding time: 0:08.657, 0.04x realtime
3.99.5
Code: [Select]
CLI encoder: C:\Soft\Lame\3995\lame.exe
Destination file: F:\Rip\Jam & Spoon\1997 - Kaleidoscope\02 - Kaleidoscope Skies.mp3
Encoder stream format: 44100Hz / 2ch / 16bps
Command line: "C:\Soft\Lame\3995\lame.exe" -S --noreplaygain -V 1 - "02 - Kaleidoscope Skies.mp3"
Working folder: F:\Rip\Jam & Spoon\1997 - Kaleidoscope\
Encoder process still running, waiting...
Encoder process terminated cleanly.
Track converted successfully.
Total encoding time: 0:16.484, 12.57x realtime
  • Last Edit: 30 March, 2012, 02:57:39 PM by Alex B

  • alter4
  • [*][*][*]
LAME 3.99 is out
Reply #360
Hi Guys!
I encoded the same file with lame 3.99.5 using -V0 and -b320.
There are a few questions here.
-V0
Code: [Select]
LAME 3.99.5 64bits (http://lame.sf.net)
CPU features: SSE (ASM used), SSE2 (ASM used)
polyphase lowpass filter disabled
Encoding 1.wav to 1.mp3
Encoding as 44.1 kHz j-stereo MPEG-1 Layer III VBR(q=0)

misc:

scaling: 1
ch0 (left) scaling: 1
ch1 (right) scaling: 1
huffman search: best (outside loop)
experimental Y=0
...

stream format:

MPEG-1 Layer 3
2 channel - joint stereo
padding: all
variable bitrate - VBR mtrh (default)
using LAME Tag
...

psychoacoustic:

using short blocks: channel coupled
subblock gain: 1
adjust masking: -6.8 dB
adjust masking short: -6.8 dB
quantization comparison: 9
^ comparison short blocks: 9
noise shaping: 1
^ amplification: 2
^ stopping: 1
ATH: using
^ type: 5
^ shape: 1 (only for type 4)
^ level adjustement: -7.1 dB
^ adjust type: 3
^ adjust sensitivity power: 1.000000
experimental psy tunings by Naoki Shibata
  adjust masking bass=-0.5 dB, alto=-0.25 dB, treble=-0.025 dB, sfb21=8.25 dB
using temporal masking effect: no
interchannel masking ratio: 0
...
-b320
Code: [Select]
LAME 3.99.5 64bits (http://lame.sf.net)
CPU features: SSE (ASM used), SSE2 (ASM used)
Using polyphase lowpass filter, transition band: 20094 Hz - 20627 Hz
Encoding 1.wav to 1.mp3
Encoding as 44.1 kHz j-stereo MPEG-1 Layer III (4.4x) 320 kbps qval=3

misc:

scaling: 1
ch0 (left) scaling: 1
ch1 (right) scaling: 1
huffman search: best (outside loop)
experimental Y=0
...

stream format:

MPEG-1 Layer 3
2 channel - joint stereo
padding: off
constant bitrate - CBR
using LAME Tag
...

psychoacoustic:

using short blocks: channel coupled
subblock gain: 1
adjust masking: -10 dB
adjust masking short: -11 dB
quantization comparison: 9
^ comparison short blocks: 9
noise shaping: 1
^ amplification: 1
^ stopping: 1
ATH: using
^ type: 4
^ shape: 0 (only for type 4)
^ level adjustement: -12 dB
^ adjust type: 3
^ adjust sensitivity power: 1.000000
experimental psy tunings by Naoki Shibata
  adjust masking bass=-0.5 dB, alto=-0.25 dB, treble=-0.025 dB, sfb21=0.5 dB
using temporal masking effect: yes
interchannel masking ratio: 0
...

-b320 on HA wiki considered as "best quality settings", but what is my concern
1) -V0 doesn't use polyphase lowpass filter but -b320 does
2) q value is 0 for V0 but q=3 for -b320
3) ATH setting looks more cautious for V0.

Is -b320 always best in compare with -V0? I am not sure looking into this dump or may be I miss something?



  • [JAZ]
  • [*][*][*][*][*]
LAME 3.99 is out
Reply #361
First, don't try to see more than what it is in there anyway.

the "q" you see next to the VBR text is the VBR range (-V0 = q0). The "q" you see in CBR is really the "-q" setting, which defaults to q3 in both VBR and CBR. In VBR there is no difference from q 3 to q 0. in CBR, there is a difference, but lower than q 3 just controls how strong it tries to encode, which may or may not give a better quality (I mean it literally).

Next, not using a filter, with the MP3 format never means a better file. (It does not necessarily mean a worse file either).

I am not knowledgeable enough to give my oppinion on the values relative to the ATH (Things are only comparable when they use the same algorithm, and here there are clearly different options)

Now, VBR vs CBR:

The 3.99.x versions have had tweakings on both, the CBR and VBR modes. CBR is using some tools from VBR, and the higher VBR levels (like V0) have been made stronger (using more bitrate).

The general consensus is still he one mentioned, (by definition, VBR can only use up to 320kbps anyway) but the different ways to pack those 320kbps might give one or the other an edge. I guess only user tests and information from the developers can answer that, but it can not change drastically.
  • Last Edit: 31 March, 2012, 11:41:32 AM by [JAZ]

  • ggunnell
  • [*]
LAME 3.99 is out
Reply #362
Are there other download sites for compiled Lame 3.99.5 other than Rarewares?  My Norton 2012 is currently blocking Rarewares downloads, reporting w32.leave.worm and fake AV redirect 31.

  • tpijag
  • [*][*][*][*][*]
LAME 3.99 is out
Reply #363
That is a false positive. Either ignore or you could use these Google search on "compiled lame 3.99.5"
  • Last Edit: 07 April, 2012, 01:25:04 PM by tpijag

  • lvqcl
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #364

  • Thundik81
  • [*][*]
LAME 3.99 is out
Reply #365
Are there other download sites for compiled Lame 3.99.5 other than Rarewares?  My Norton 2012 is currently blocking Rarewares downloads, reporting w32.leave.worm and fake AV redirect 31.


Few bad links remains on Rarewares :
http://www.rarewares.org/files/ogg/angelineoconnor.php
http://www.rarewares.org/files/mp3/galoiscepheus.php

  • ggunnell
  • [*]
LAME 3.99 is out
Reply #366
Link from previous page: http://www.john1205.webspace.virginmedia.com/LAME/

Thanks -- got it!
It may be a false positive, but clicking on the Rarewares download link for 3.99.5 64-bit bundle triggered the anti-intrusion on my firewall -- something I have learned the hard way not to bypass.

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #367
I'm not home right now, but can those who have had a problem accessing Rarewares confirm whether they were using IE? Other browsers do not exhibit the same problem, or so I have thought from one previous notification.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • Ferongr
  • [*][*]
LAME 3.99 is out
Reply #368
Hey John, is the lame_enc.dll build that uses an .ini file for the settings built using your own patches? Is it possible to update it to the latest release?

BTW, I'm using this version successfully with SAM Broadcaster to stream 200kbps ABR audio through Shoutcast DNAS V1. The reason 192kbps CBR was not transparent was because of many transcoding artifacts from lossy originals, especially extreme smearing of high frequencies at certain tracks. Using ABR at 200kbps reduced the artifacts dramatically.

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #369
Hey John, is the lame_enc.dll build that uses an .ini file for the settings built using your own patches? Is it possible to update it to the latest release?

BTW, I'm using this version successfully with SAM Broadcaster to stream 200kbps ABR audio through Shoutcast DNAS V1. The reason 192kbps CBR was not transparent was because of many transcoding artifacts from lossy originals, especially extreme smearing of high frequencies at certain tracks. Using ABR at 200kbps reduced the artifacts dramatically.

I'll try to get this done this evening.  I'll post again when it's available.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #370
New build - 3.99.5 - of the modified dll is now at Rarewares.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • Ferongr
  • [*][*]
LAME 3.99 is out
Reply #371
New build - 3.99.5 - of the modified dll is now at Rarewares.


Excellent. Thank you very much!

Edit: Just a small question: Per LAME documentation, the "q" switch accepts values from 0 to 9, yet in the bundled .ini it's set at -1. Does that set it to use the default (5?) setting?
  • Last Edit: 10 May, 2012, 05:19:18 PM by Ferongr

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #372
New build - 3.99.5 - of the modified dll is now at Rarewares.


Excellent. Thank you very much!

Edit: Just a small question: Per LAME documentation, the "q" switch accepts values from 0 to 9, yet in the bundled .ini it's set at -1. Does that set it to use the default (5?) setting?

When set to '-1', it uses whatever is the default value for the Lame Preset selected.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • Emiliano55
  • [*][*]
LAME 3.99 is out
Reply #373
Guys, I have just upgraded to a 64bit Windows (i've always used 32bits systems). Do you guys recommend me to use the 64bit version of this new Lame, or should I still be using the 32bit version even though I'm on a x64 Windows now ?

What are the differences between both on a x64 Windows platform ?

Thanks!

  • antman
  • [*][*][*]
LAME 3.99 is out
Reply #374
Speed.  Use x64 and shave some time off your transcoding.