Skip to main content

Topic: LAME 3.99 is out (Read 213553 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • apodtele
  • [*]
LAME 3.99 is out
Reply #300
yes the Winamp mp3 encoder settings dialog isn't great / needs to be updated to whatever the suggested guidelines are now, but it otherwise works.


DrO,

Take a look at http://wiki.hydrogenaudio.org/index.php?title=LAME  for the guidelines

In comparison to Winamp mp3 plugin, the modern LAME recommendations
-- do not even mention -q
-- do not dwell on bitrates
-- instead settle on --vbr-new by making it default
-- instead explain a lot about -V for VBR that are not offered by Winamp

That is how much Winamp mp3 plugin is behind.

A.

  • lvqcl
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #301
-- instead explain a lot about -V for VBR that are not offered by Winamp


Yes they are:


  • apodtele
  • [*]
LAME 3.99 is out
Reply #302
That is -q rather than -V, it never changes from 2 with any --preset or quality setting,
  • Last Edit: 16 December, 2011, 08:22:05 AM by db1989

  • lvqcl
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #303
-q is "Quality" when it is equal to Low / Normal / High / Very High. And then "VBR Q" is -V switch.

  • apodtele
  • [*]
LAME 3.99 is out
Reply #304
-q is "Quality" when it is equal to Low / Normal / High / Very High. And then "VBR Q" is -V switch.


When I read this http://lame.cvs.sourceforge.net/viewvc/lame/lame/USAGE
I expect -q to be either numeric or Fast / Slow / ... as an algorithm speed rating
and -V is either numeric or High / Low / ... as in quality/kbps or whatever.

Do you see my confusion while lacking Winamp documentation?
The layout is also confusing because VBR Q appears to be the least important (bottom) setting.

What you said and what I see simply does not chime with the Lame documentation.
The only thing that rings the correct bells is "--preset fast standard" and this is what I use.
  • Last Edit: 15 December, 2011, 04:02:30 PM by apodtele

  • DoctorO
  • [*]
LAME 3.99 is out
Reply #305
apodtele: the link you've directed at me doesn't seem to be the one i remember seeing some time back on what is meant to be done in a UI for controlling lame. which was http://lame.sourceforge.net/lame_ui_example.php and as i've not followed things closely, my comment was worded as such to cater for things having changed with those suggested guidelines (though looks like i remember it being).

either way, no one is disagreeing that Winamp's mp3 encoder config needs to be overhauled, but trying to base what is currently there against documentation which has most likely changed since the encoder's ui was created (which if i remember correctly goes back to the original Winamp dev team) is never going to match up. also without checking, i was under the impression that the encoder's defaults have changed over time time to better fit with more of the 'preferred' options even if it's still based on the -preset method.

then again if you don't like it, you don't have to use it and just use whatever actually fits with what you want to use / get the results you deem important  (plus i'm pretty sure the mp3 encoder is only available if you're a pro user...).

-daz
  • Last Edit: 15 December, 2011, 06:32:23 PM by DoctorO

  • krafty
  • [*][*][*][*]
LAME 3.99 is out
Reply #306
Is it a good time to encode with 3.99 or should I stick with 3.98...
Audibly both doesn't matter, but in matter of bugs and the new -V0 lowpass extended, does it make any sense?

  • dxiv
  • [*]
LAME 3.99 is out
Reply #307
I cannot see why such DLL is better for Winamp users. 

The INI-driven DLL wasn't invented just for Winamp users. Other rippers/encoders used to offer less than satisfactory control over LAME's options, older PlexTools for one.

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #308
I cannot see why such DLL is better for Winamp users. 

The INI-driven DLL wasn't invented just for Winamp users. Other rippers/encoders used to offer less than satisfactory control over LAME's options, older PlexTools for one.

Actually, I did it originally for older versions of CDex, but any software that uses the old .dll can take advantage of it.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • SnakeSnoke
  • [*]
LAME 3.99 is out
Reply #309
Hi,

not sure where to post this. I just encoded a 32000Hz wav file with foobar and LAME 3.99.3 64bit (from rarewares) with the setting "-V 5". For the result mp3 file Foobar says: Codec Profile: MP3 VBR V3 (132kbps)

I didn't make any more tests.

Something is wrong here, I guess.
  • Last Edit: 18 December, 2011, 07:28:07 AM by SnakeSnoke

  • halb27
  • [*][*][*][*][*]
LAME 3.99 is out
Reply #310
I ran upon this phenomenon while working on 3.99.3x.
-V level is remapped when using 32 kHz sampling frequency. It's a feature.
It would be better of cause if the user demanded -V level would be used to compute the quality item within the Lame tags which tools like foobar use for recalculating the -V level (the -V level isn't stored directly in the mp3 file).

If this is something that bothers you, you can use 3.99.3x where I fixed this. When using 3.99.3x with the usual -V n 3.99.3x works exactly like 3.99.3 does.
lame3995o -Q1

  • lvqcl
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #311
test32.wav is a 32kHz test file;

lame.exe -V 5 test32.wav => 118.6 kbps

lame.exe --resample 32 -V 5 test32.wav => 102.4 kbps


There is no difference between "-V 5" and "-V 5 --resample 44" for files with 44 kHz samplerate.

  • exx
  • [*]
LAME 3.99 is out
Reply #312
Posted in the old 3.98 topic; might as well post here again.


Was using dbPowerAmp (which uses LAME) to convert some FLAC for my ipod and noticed it wasn't using my CPU to its full potential.

http://i.imgur.com/Kv9bR.png

Only goes up to ~15% per process (max would be 25%). Total encoding speed was around 120-130x, which is much slower than normal. I was doing the same thing yesterday and all 4 cores were maxed. I don't have anything running in the background. Could it be a HD speed issue? The input and output paths were on the same drive, but it's a WD Black so it's not terribly slow, and I didn't hear any drive noise.
Update: have since tried writing to a RAM disk as well as a different drive than the source; it goes a bit faster, but I still can't reliably max out each core. I feel as if there is wasted potential here. The CPU will often be maxed at the start of the batch, but drop off soon after.

Any ideas?

  • d_headshot
  • [*][*][*]
LAME 3.99 is out
Reply #313
What's the deal with the lowpass filter? Is it on both v3.98 and 3.99? Has anyone viewed the frequency spectrum of two files at the same quality setting?

  • antman
  • [*][*][*]
LAME 3.99 is out
Reply #314
My observations:

1.  My library with 3.98 V0 clocked in at 35GB, with 3.99 V0 it's at 36.8GB.

2.  Usually something NIN or metal is highest encoded song in my collection, with 3.99, it's Nirvana - From the Muddy Banks of the Wishkah - 08 - Sliver @ 307kbps (?!).

3.  In Windows Explorer (WinXP) when I highlight over that song, and all 3.99 encodes for that matter, the bitrate comes up at 656kbps.

  • DARcode
  • [*][*][*][*][*]
  • Members (Donating)
LAME 3.99 is out
Reply #315
As mentioned a bitrate increase is to be expected, and I subscribe to shadowking's take on the matter here http://www.hydrogenaudio.org/forums/index....st&p=769219.
WavPack 4.80.0 -b384hx6cmv / qaac 2.59 -V 100

  • apodtele
  • [*]
LAME 3.99 is out
Reply #316
As mentioned a bitrate increase is to be expected, and I subscribe to shadowking's take on the matter here http://www.hydrogenaudio.org/forums/index....st&p=769219.


I did not get this. If you equate VBR V3 from 2011 and CBR 256kbps from 2000, that's a big big progress. Just compare the file sizes and bitrates.

To V0 people: If you are so paranoid about the quality, stop complaining about the size.
  • Last Edit: 03 January, 2012, 11:12:18 AM by apodtele

  • greynol
  • [*][*][*][*][*]
  • Global Moderator
LAME 3.99 is out
Reply #317
What's the deal with the lowpass filter? Is it on both v3.98 and 3.99? Has anyone viewed the frequency spectrum of two files at the same quality setting?

Are you suggesting that there is a difference that you can actually hear and it has gotten worse with the new version?

If not then I fail to see why this matters!
  • Last Edit: 03 January, 2012, 11:21:37 AM by greynol
13 February 2016: The world was blessed with the passing of a truly vile and wretched person.

Your eyes cannot hear.

  • d_headshot
  • [*][*][*]
LAME 3.99 is out
Reply #318
What's the deal with the lowpass filter? Is it on both v3.98 and 3.99? Has anyone viewed the frequency spectrum of two files at the same quality setting?

Are you suggesting that there is a difference that you can actually hear and it has gotten worse with the new version?

If not then I fail to see why this matters!


By George of course I'm not 

All versions of lame are transparent to me so I'm not concerned about any difference in sound. I'm just curious about it because I'm in engineering and people like me are interested in stuff like that lol.
  • Last Edit: 03 January, 2012, 04:41:48 PM by d_headshot

  • instaud
  • [*]
LAME 3.99 is out
Reply #319
If not then I fail to see why this matters!

As a reader who finds valuable information on this great board I have to say that the only posts distracting from the flow of information are your regular attempts to shove in reminders about TOS #8, even if it was not the typical "320kbps rulez" kind of post.

If you own thousands of CDs you try to inform yourself thoroughly before switching your encoder and reencode. Technical background information and details about the developer's motivation to change things in the code helps with that decision.

  • naturfreak
  • [*][*][*]
LAME 3.99 is out
Reply #320
Update to Version 3.99.4 a few hours ago...

Quote
Changelog:
LAME 3.99.4  January 25 2012

    * Robert Hegemann
          o Fix for tracker item [ 3475581 ] lame crashes at .w64 input file
          o Addressing things brought to attention by tracker item [ 3463197 ] 3.99.x problem WFED and PCST frames
                + WFED and PCST frames can now be added, to tag podcasts iTunes recognizes
                + USER frames are now supported
                + COMM frames can now have a description, when passed via --tv "COMM=description=full text"
                + possible divide-by-zero exception should be fixed
                + adding malformed user-defined-frames could result in abnormal program termination, fixed
  • Last Edit: 25 January, 2012, 04:43:54 PM by naturfreak

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #321
I have all the new compiles ready to go, but I am currently unable to access Rarewares FTP to update the site!! I have emailed Roberto to find out what's up and am awaiting a response.

Temporarily, they can be downloaded from here:

EDIT: Link removed - see below.

but please don't pass the link around otherwise my ISP will hit on me for too much traffic!! 

I'll get them up on Rarewares as soon as I'm able.
  • Last Edit: 28 January, 2012, 05:43:53 AM by db1989
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #322
All compiles now available on Rarewares so the above link is removed.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • bbrabant
  • [*][*]
LAME 3.99 is out
Reply #323
All compiles now available on Rarewares so the above link is removed.


Thanks for the new Lame compiles but on my windows xp pc (32bit) I am unable to run these compiles. I had no problem running the previous compiles of  Lame.
Do I need to install additional libraries ?

Greetz,

Ben

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #324
I don't believe there are any dependencies. These (32 bit compiles) were tested on Win 2000 Pro and worked fine. The compiler is unchanged. What error message do you get, if any?

I won't be able to reply further until Monday as I'm away now until then.
  • Last Edit: 28 January, 2012, 05:44:07 AM by db1989
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/