Skip to main content

Topic: LAME 3.99 is out (Read 213285 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • bbrabant
  • [*][*]
LAME 3.99 is out
Reply #325
What error message do you get, if any?


Immediately after running lame a windows dialog box comes up "Application Failure lame.exe 3.99.2.4 in lame.exe 3.99.2.4 at offset 0001afa6"

  • biomega
  • [*]
LAME 3.99 is out
Reply #326
Thanks for the new Lame compiles but on my windows xp pc (32bit) I am unable to run these compiles. I had no problem running the previous compiles of  Lame.


Same problem here. NO error messages. Nothings happens (in the command-line window it simply jumps to a new line).

I've only encountered a similar behavior with programs that require a CPU with SSE2 support. (using an AthlonXP without SSE2)
Could that may be the case for this new release (LAME 3.99.4)?
  • Last Edit: 28 January, 2012, 09:34:14 AM by biomega

  • Alex B
  • [*][*][*][*][*]
LAME 3.99 is out
Reply #327
I've only encountered a similar behavior with programs that require a CPU with SSE2 support. (using an AthlonXP without SSE2)
Could that may be the case for this new release (LAME 3.99.4)?

You may be right. I just tried AMD Athlon XP 3200+ on Win 7 (32-bit). LAME 3.99.4 did not work when using the same foobar2000 settings that work fine with 3.99.3.

foobar2000 reported:

Conversion failed: The encoder has terminated prematurely with code -1073741795 (0xC000001D); please re-check parameters
  • Last Edit: 28 January, 2012, 11:42:57 AM by Alex B

  • bbrabant
  • [*][*]
LAME 3.99 is out
Reply #328
I've only encountered a similar behavior with programs that require a CPU with SSE2 support. (using an AthlonXP without SSE2)


I am using a AMD Athlon XP 2200 also without SSE2 support

  • R3D
  • [*]
LAME 3.99 is out
Reply #329
Hey, I've got a question and I hope you can help me. (I hope it's the right topic)

I would like to convert my CD's new. For the last nearly 2 years I used Rarewares Lame bundle 3.98.4 64-Bit all the time. But deleted it by mistake.
The problem is that I can't find the Rarewares 3.98.4 64-Bit version on their website anymore. Just the 32-Bit version of 3.98.4.

And I don't know if I can trust Lame 3.99.4 because I read about artifacts.


So, my question is... does someone know where I can find the Rarewares 64-Bit version of Lame 3.98.4?

Thanks.

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #330
  • Last Edit: 03 February, 2012, 02:47:27 PM by db1989
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • R3D
  • [*]
LAME 3.99 is out
Reply #331
Thx for your quick help! 
  • Last Edit: 03 February, 2012, 02:47:40 PM by db1989

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
LAME 3.99 is out
Reply #332

LAME 3.99 is out
Reply #333
Hi all. I wonder when we will see regular (non-test) LAME 3.99.5 32- and 64-bit compiles at RareWares?

  • ZinCh
  • [*][*][*]
LAME 3.99 is out
Reply #334
LAME 3.99.5 final version released today (  February 28 2012 )

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #335
A full set of 3.99.5 compiles is now at Rarewares.

For anyone who may have used the most recent test compile; there are no code changes in the release version so there is no need to re-encode anything.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • eahm
  • [*][*][*][*][*]
LAME 3.99 is out
Reply #336
Good birthday present thank you
  • Last Edit: 28 February, 2012, 07:18:53 PM by eahm

  • apodtele
  • [*]
LAME 3.99 is out
Reply #337
I run Windows 7 64-bit, however...

32-bit Winamp uses lame_enc.dll. Do I have to take 32-bit build?
32-bit foobar2000 uses lame.exe. Can I take 64-bit build?

See how confused I am?

Unfortunately, those players do not come in 64-bit form to bring me peace.

  • Jebus
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #338
Appologies and thanks in advance, because I know this increases the work for you every time a new release is made, but any chance we could get those libmp3lame downloads updated to the latest as well?

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #339
Appologies and thanks in advance, because I know this increases the work for you every time a new release is made, but any chance we could get those libmp3lame downloads updated to the latest as well?

Done.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • DoctorO
  • [*]
LAME 3.99 is out
Reply #340
32-bit Winamp uses lame_enc.dll. Do I have to take 32-bit build?
you need to use the 32-bit compile of lame_enc.dll as Winamp cannot load / use the 64-bit version.

-daz

  • yakuman
  • [*]
LAME 3.99 is out
Reply #341
32-bit foobar2000 uses lame.exe. Can I take 64-bit build?

See how confused I am?

Unfortunately, those players do not come in 64-bit form to bring me peace.

I've been there too.  foobar2000 can encode with 64-bit LAME.  This is what I've been doing ever since I recently discovered the 64-bit version.  I don't know if there's any quality or size difference in the result of MP3 files, though.
  • Last Edit: 01 March, 2012, 06:30:46 PM by yakuman

LAME 3.99 is out
Reply #342
I'm getting an error when trying to compile with "nmake -f Makefile.MSVC MSVCVER=8.0 PREC=DOUBLE"

Code: [Select]
Setting environment for using Microsoft Visual Studio 2010 x86 tools.

C:\Program Files\Microsoft Visual Studio 10.0\VC>cd lame

C:\Program Files\Microsoft Visual Studio 10.0\VC\lame>nmake -f Makefile.MSVC MSV
CVER=8.0 PREC=DOUBLE

Microsoft ® Program Maintenance Utility Version 10.00.30319.01
Copyright © Microsoft Corporation.  All rights reserved.

----------------------------------------------------------------------
building LAME featuring RH
+ ASM
+ MMX
+ using MSVC 8.0 32-Bit Compiler
+ optimizing for Pentium II/III
----------------------------------------------------------------------
Pass GTK=YES to build the frame analyzer. (requires installed GTK)


--- LAME MP3 ENCODING LIBRARY UPTODATE ---


--- HIP DECODING LIBRARY UPTODATE ---


--=* .\output\libmp3lame-static.lib ready *=--


--- COMMON FRONTEND STUFF UPTODATE ---

Microsoft ® Windows ® Resource Compiler Version 6.1.7600.16385
Copyright © Microsoft Corporation.  All rights reserved.

libmp3lame-static.lib(psymodel.obj) : error LNK2001: unresolved external symbol
_static_assert_tab_mask_add_delta
.\output\lame.exe : fatal error LNK1120: 1 unresolved externals
NMAKE : fatal error U1077: '"c:\Program Files\Microsoft Visual Studio 10.0\VC\BI
N\link.EXE"' : return code '0x460'
Stop.

C:\Program Files\Microsoft Visual Studio 10.0\VC\lame>
  • Last Edit: 02 March, 2012, 11:44:49 AM by db1989

  • robert
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #343
You'll have to remove the /GL compiler option in Makefile.MSVC line 209.
The _static_assert_tab_mask_add_delta symbol is there to do some compile-time assertions, there should be no such symbol actually compiled into the object files. I don't know, why the linker thinks it should find such a thing, when using /GL for whole program optimization.

some variations on static asserts

  • ZinCh
  • [*][*][*]
LAME 3.99 is out
Reply #344
Can someone post LAME 3.99.5 builds using MS VC 11 (beta) ?

LAME 3.99 is out
Reply #345
You'll have to remove the /GL compiler option in Makefile.MSVC line 209.
The _static_assert_tab_mask_add_delta symbol is there to do some compile-time assertions, there should be no such symbol actually compiled into the object files. I don't know, why the linker thinks it should find such a thing, when using /GL for whole program optimization.

some variations on static asserts


Thank You

  • Kilu
  • [*]
LAME 3.99 is out
Reply #346
Wonderful, wonderful.
made of radiation

  • alexz721
  • [*]
LAME 3.99 is out
Reply #347
Here you go:

http://homepage.ntlworld.com/jfe1205/LAME/lame3.98.4-64.zip

Hi, was wondering if you could re-up this as the link is dead.

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.99 is out
Reply #348
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • alexz721
  • [*]