Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: MP3 gapless playback broken since 1.1.8 beta 5 (Read 2571 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

MP3 gapless playback broken since 1.1.8 beta 5

Hey folks,
I was listening to a music CD that's split into multiple MP3 files when I noticed that I could 'hear' the song changing, like a 'step' in the sound when foobar changed files.

To confirm it wasn't any of my components or configuration, I went ahead and reinstalled older beta versions of foobar 1.1.8 in portable mode and noticed that this problem starts happening in 1.1.8 beta 5; it doesn't happen in any of the older versions including 1.1.7.

System information:
· Windows 7 Ultimate x64
· AMD Phenom II X4 965 @ 3.42GHz
· 4GB RAM
· Realtek sound using the ALC892 codec

Hope this is helpful

MP3 gapless playback broken since 1.1.8 beta 5

Reply #1
my lame encoded mp3s still play perfectly gapless. it might help if you mentioned the encoder? also, i noticed this in the changelog which might have caused a regression of some sort...

Quote
Support for iTunes gapless information in MP3 files (beta 5)


MP3 gapless playback broken since 1.1.8 beta 5

Reply #2
Just the regular LAME 3.98.4 64bits.

Now that I've been paying attention to the problem, it looks like it doesn't happen with all MP3s; though the ones that do make the problem appear in beta 5 and 6 are played gaplessly in older ones without a problem...

MP3 gapless playback broken since 1.1.8 beta 5

Reply #3
Thanks for the bug report.
It would be very helpful if you could share a sample file demonstrating this issue.
We are the bork. Your software bugs will be added to our own. Resistance is futile.


MP3 gapless playback broken since 1.1.8 beta 5

Reply #5
Thanks, but I meant specific MP3 files that trigger this issue rather than recorded output.
We are the bork. Your software bugs will be added to our own. Resistance is futile.

MP3 gapless playback broken since 1.1.8 beta 5

Reply #6
Just a reminder: as per #9 of our Terms of Service, please either trim copyrighted tracks to 30 s or less before uploading to Hydrogenaudio; or, if that isn’t feasible, upload the complete files elsewhere and send Peter the link privately.

MP3 gapless playback broken since 1.1.8 beta 5

Reply #7
Ouch, sorry for the misunderstanding.

Anyway, the files that trigger the issue are from CDs I ripped to my PC or that I bought from the internet, so I'm not quite sure if I'm allowed to post them (as per the Uploads forum rules).

Should I upload them anyway, or do you prefer me sending you the files via PM or e-mail?

EDIT:
Ninja'd by db1989. PM'ing Peter now.

MP3 gapless playback broken since 1.1.8 beta 5

Reply #8
Fixed for the next update, thanks for reporting.
We are the bork. Your software bugs will be added to our own. Resistance is futile.

 
SimplePortal 1.0.0 RC1 © 2008-2021