Skip to main content
Topic: foo_uie_lyrics3 (Read 572127 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: foo_uie_lyrics3

Reply #1600
The plugin doesn't seem to work anymore, all i got is this anytime i try to load lyrics.
<?xml version="1.0" encoding="UTF-8" ?>
<result errmsg="Search ID or Code error!" errcode="32006"></result>

Same here..

I thought it might be a change in Windows Firewall rolled out to everybody in a Windows Update. I checked Windows Firewall, but everything *seems* fine to me -- an exception for foobar2000 TCP and for UDP, in private domain for inbound connections (with outbound connections being allowed by default without need for exceptions). I'm definitely not very familiar with Windows Firewall though, so people are welcome to check into this more if they want...

Re: foo_uie_lyrics3

Reply #1601
The plugin doesn't seem to work anymore, all i got is this anytime i try to load lyrics.
<?xml version="1.0" encoding="UTF-8" ?>
<result errmsg="Search ID or Code error!" errcode="32006"></result>

Same here..

I thought it might be a change in Windows Firewall rolled out to everybody in a Windows Update. I checked Windows Firewall, but everything *seems* fine to me -- an exception for foobar2000 TCP and for UDP, in private domain for inbound connections (with outbound connections being allowed by default without need for exceptions). I'm definitely not very familiar with Windows Firewall though, so people are welcome to check into this more if they want...
It's obviously not a firewall issue.

Re: foo_uie_lyrics3

Reply #1602
I also had this problem, i read the last page of this thread, installed the dll's and still no results.
Thereafter I went into the advanced options of the lyrics component and selected "always asume charset for lyrics". Mine is now "OEM 437 United States" and now the lyrics3 component is working with the azlyrics source.

How do you add the azlyrics source?

Re: foo_uie_lyrics3

Reply #1603
The plugin doesn't seem to work anymore, all i got is this anytime i try to load lyrics.
<?xml version="1.0" encoding="UTF-8" ?>
<result errmsg="Search ID or Code error!" errcode="32006"></result>

Same here..

I thought it might be a change in Windows Firewall rolled out to everybody in a Windows Update. I checked Windows Firewall, but everything *seems* fine to me -- an exception for foobar2000 TCP and for UDP, in private domain for inbound connections (with outbound connections being allowed by default without need for exceptions). I'm definitely not very familiar with Windows Firewall though, so people are welcome to check into this more if they want...
It's obviously not a firewall issue.

I solved the XML problem by changing the lyrics search order by only selecting the AzLyrics from the OnlineDB and now it works well.

Re: foo_uie_lyrics3

Reply #1604
The plugin doesn't seem to work anymore, all i got is this anytime i try to load lyrics.
<?xml version="1.0" encoding="UTF-8" ?>
<result errmsg="Search ID or Code error!" errcode="32006"></result>

Same here..

I thought it might be a change in Windows Firewall rolled out to everybody in a Windows Update. I checked Windows Firewall, but everything *seems* fine to me -- an exception for foobar2000 TCP and for UDP, in private domain for inbound connections (with outbound connections being allowed by default without need for exceptions). I'm definitely not very familiar with Windows Firewall though, so people are welcome to check into this more if they want...
It's obviously not a firewall issue.

I solved the XML problem by changing the lyrics search order by only selecting the AzLyrics from the OnlineDB and now it works well.

How do you did this? Please help us!

Re: foo_uie_lyrics3

Reply #1605
Ok, I've tried for 2 days now, and can't seem to find an answer, so I registered specifically to ask this - please help
- What I want to do -
Save lyrics to the SYLT tag (synchronized lyrics) of my files, and have them show through Lyric Show Panel 3, that's all!
- What I tried -
I set my Preferences to "Tag Search" and "Associations Search" only, Properties of "Tag Search" are "Read lyrics from these tags: LYRICS" (assuming this is the SYLT tag)
The Lyric Saving - Save Method is set to "Save to tag" with synced lyrics tag "LYRICS", and unsynced lyric tag empty.
Now, whatever I type, and save, it will not save it to the SYLT tag, nor show it.... I haven't got a clue why, please help

Re: foo_uie_lyrics3

Reply #1606
Ok, I've tried for 2 days now, and can't seem to find an answer, so I registered specifically to ask this - please help
- What I want to do -
Save lyrics to the SYLT tag (synchronized lyrics) of my files, and have them show through Lyric Show Panel 3, that's all!
- What I tried -
I set my Preferences to "Tag Search" and "Associations Search" only, Properties of "Tag Search" are "Read lyrics from these tags: LYRICS" (assuming this is the SYLT tag)
The Lyric Saving - Save Method is set to "Save to tag" with synced lyrics tag "LYRICS", and unsynced lyric tag empty.
Now, whatever I type, and save, it will not save it to the SYLT tag, nor show it.... I haven't got a clue why, please help
Tag search properties - add SYLT tag source.
Edit: that's for reading, for saving SYLT instead of LYRICS

Re: foo_uie_lyrics3

Reply #1607
Ok, I've tried for 2 days now, and can't seem to find an answer, so I registered specifically to ask this - please help
- What I want to do -
Save lyrics to the SYLT tag (synchronized lyrics) of my files, and have them show through Lyric Show Panel 3, that's all!
- What I tried -
I set my Preferences to "Tag Search" and "Associations Search" only, Properties of "Tag Search" are "Read lyrics from these tags: LYRICS" (assuming this is the SYLT tag)
The Lyric Saving - Save Method is set to "Save to tag" with synced lyrics tag "LYRICS", and unsynced lyric tag empty.
Now, whatever I type, and save, it will not save it to the SYLT tag, nor show it.... I haven't got a clue why, please help
Tag search properties - add SYLT tag source.
Edit: that's for reading, for saving SYLT instead of LYRICS
Well, for the unsynced lyrics, I can get it to work (it saves to UNSYNCED LYRICS, and it shows up in Mp3tag/MediaMonkey/...), but the synced lyrics.... When I edit the file with e.g. SYLTEdit, foobar2000 doesn't recognize it, and when I save synced lyrics (like you suggested) in foobar2k, only foobar seems to recognize that (SYLTEdit claims the SYLT tag is empty)....

Re: foo_uie_lyrics3

Reply #1608
Quote
Well, for the unsynced lyrics, I can get it to work (it saves to UNSYNCED LYRICS, and it shows up in Mp3tag/MediaMonkey/...), but the synced lyrics.... When I edit the file with e.g. SYLTEdit, foobar2000 doesn't recognize it, and when I save synced lyrics (like you suggested) in foobar2k, only foobar seems to recognize that (SYLTEdit claims the SYLT tag is empty)....
I don't know what SYLTedit is and why it's not compatible but in foobar you can
- set up both synced and unsynced target tags choosing whatever name you want SYLT, UNSYNCED LYRICS etc.
- add those tags to tag sources
and it should work.

If SYLTedit saves lyrics to SYLT tag in a standard format and you added SYLT tag in sources it should work too.



Re: foo_uie_lyrics3

Reply #1611
https://github.com/tripod31/foo_lyricsource
That fixed the azlyrics add on, however it couldn't find lyrics for track 4 of David Bowie's Darkstar - Sue (Or In a Season of Crime) - despite azlyrics having the lyrics. Maybe something to do with the brackets in the title.
Thank you tripod31 and blaxima.
AZlyrics works partially for me too.  Same as for Wirrunna sometimes it doesn't find lyrics even though they are available on AZlyrics (e.g. White Stripes - [De Stijl] Apple Blossom). I tried to wipe all metadata except 'Artist Name', 'Track tittle' and 'Album Title' but it didn't help, I checked for spelling mistakes no luck as well :/. Any idea how to resolve this?

Re: foo_uie_lyrics3

Reply #1612
Can confirm, with out-of-the box settings the plugin no longer finds anything. I also tried the tips but without luck.

Re: foo_uie_lyrics3

Reply #1613
AZlyrics works partially for me too.  Same as for Wirrunna sometimes it doesn't find lyrics even though they are available on AZlyrics (e.g. White Stripes - [De Stijl] Apple Blossom). I tried to wipe all metadata except 'Artist Name', 'Track tittle' and 'Album Title' but it didn't help, I checked for spelling mistakes no luck as well :/. Any idea how to resolve this?

Yeah, all of my White Stripes songs return no lyrics in spite of them being on the site. I'm going to assume that it's something to do with the query. I've tried messing around with the settings with no luck so it might be inside the lyric_source plugin itself.

Re: foo_uie_lyrics3

Reply #1614
AZlyrics is able to find most of the lyrics, but the problem... its downloading non synced lyrics & saving its as LRC  (overwriting my few of my previously synced lyrics), the LRC with no timestamp, its just plain lyrics saving as .lrc instead of .txt  as i have configured to save only timestamped lyrics.

this site has lots of LRC http://lirik.mobi/ does anyone know how to include this as a source ?

Thanks

AZlyrics works partially for me too.  Same as for Wirrunna sometimes it doesn't find lyrics even though they are available on AZlyrics (e.g. White Stripes - [De Stijl] Apple Blossom). I tried to wipe all metadata except 'Artist Name', 'Track tittle' and 'Album Title' but it didn't help, I checked for spelling mistakes no luck as well :/. Any idea how to resolve this?

Yeah, all of my White Stripes songs return no lyrics in spite of them being on the site. I'm going to assume that it's something to do with the query. I've tried messing around with the settings with no luck so it might be inside the lyric_source plugin itself.

Re: foo_uie_lyrics3

Reply #1615
Any fix would be appreciated.
[quote author=Arcane-BLUE link=msg=0]After installing the new component and placing the 2 DLLs in the Foobar directory, Go to Preferences > Tools > Lyric Show 3 and add "www.azlyrics.com" from 'Available Sources' to 'Search Order'.
I would suggest deactivating the "Online DB: Google Search" by moving it back to 'Available Sources'.

AzLyrics has nothing to do with my request or issue but here's your pat on the head. Congrats. Well done.
[/quote]
Indignant ingrate. That's the last time I help on this borked component.  It's people like you that drive help away.

Re: foo_uie_lyrics3

Reply #1616
Sheesh. Good going syrupbuccaneer.

Re: foo_uie_lyrics3

Reply #1617
Cant figure out how to add http://www.azlyrics.com/ in Lyric Show 3?
That option is not working for me, I must be missing something.
http://web.comhem.se/u5127956/lyric%20show.jpg
All lyrics I had before updating foobar is somehow lost, have no idea what happened to the stored ones.
Just gone, so I'll have to start all over again, but that's OK, keeps me busy...
Hopefully someone has ideas on the lyrics issue, it's really sad they don't work anymore.

Thanks and best regards

Re: foo_uie_lyrics3

Reply #1618
Cant figure out how to add http://www.azlyrics.com/ in Lyric Show 3?
That option is not working for me, I must be missing something.
http://web.comhem.se/u5127956/lyric%20show.jpg
All lyrics I had before updating foobar is somehow lost, have no idea what happened to the stored ones.
Just gone, so I'll have to start all over again, but that's OK, keeps me busy...
Hopefully someone has ideas on the lyrics issue, it's really sad they don't work anymore.

Thanks and best regards

You need to install an additional component and some additional .dll's before the azlyrics source will show up as an option in lyric show 3. Here: https://github.com/tripod31/foo_lyricsource

Re: foo_uie_lyrics3

Reply #1619
After installing the additional components it works now ok for me.
Thanks!

Re: foo_uie_lyrics3

Reply #1620
Any fix would be appreciated.
[quote author=Arcane-BLUE link=msg=0]After installing the new component and placing the 2 DLLs in the Foobar directory, Go to Preferences > Tools > Lyric Show 3 and add "www.azlyrics.com" from 'Available Sources' to 'Search Order'.
I would suggest deactivating the "Online DB: Google Search" by moving it back to 'Available Sources'.

AzLyrics has nothing to do with my request or issue but here's your pat on the head. Congrats. Well done.
Indignant ingrate. That's the last time I help on this borked component.  It's people like you that drive help away.
[/quote]

Thanks for the concise instructions and help to get this component working again!  I really appreciate it.  I find karaoke to be very therapeutic.

Go to https://github.com/tripod31/foo_lyricsource and download the two .zip files and foo_lyricsource.dll

Note: follow the directions closely and take the two .dll files--one each from the two .zip files--from inside the bin\ folders (iconv.dll and libxml2.dll)  and put them in your "program files (x86)\foobar2000\" folder. Then install the foo_lyricsource.dll plug-in to your components folder.

Voila! azlyrics is added to the list of sources in the show_lyrics_3 options! Getting David Bowie ★ (RIP) lyrics right now.

Thanks, Arcane-BLUE!

I know these boards can be combative and frustrating sometimes, but it's better to assume ignorance rather than ill intent and manners.

Hope this helps.

Re: foo_uie_lyrics3

Reply #1621
Hallelujah, I've been saved by "jmcyang" and "rogue"!! :D
The culprit was -->foo_lyricsource.dll<--
Missed that one completely!
It should be mentioned here, that would make things easier:
http://www.foobar2000.org/components/view/foo_uie_lyrics3
Exchausted... but happy!
Thanks a lot, problem solved!

Re: foo_uie_lyrics3

Reply #1622
Got everything set up and it still won't download any lyrics.  Any time I try and go to azlyrics.com on any device in my house in a browser I get a "Connection Reset By Peer" page.  So I'm thinking that's the issue.

Anyone else having connectivity issues to azlyrics or is it just me?

EDIT:  Odd part is, I use my VPN service and VPN in from Germany, and the page loads just fine.  I may need to call the fine folks at Verizon FIOS tech support.

Re: foo_uie_lyrics3

Reply #1623
https://github.com/tripod31/foo_lyricsource
That fixed the azlyrics add on, however it couldn't find lyrics for track 4 of David Bowie's Darkstar - Sue (Or In a Season of Crime) - despite azlyrics having the lyrics. Maybe something to do with the brackets in the title.
Thank you tripod31 and blaxima.

I've noticed the same i think %title% needs some kind of regexp $replace function i however an no good with regexp so its beyond me
i tried $replace(%title%,(, ,),) but something is obviously wrong as its still doesn't work for tracks with () in the title

EDIT: finally sussed it
$replace(%title%,$char(40),,$char(41),)

works fine

Re: foo_uie_lyrics3

Reply #1624
It's nice if some people even get azlyrics working.
For me still nothing is working - the plugin doesn't find any lyrics, no matter what conviguration of sources or search order.
Would appreciate any help!

 
SimplePortal 1.0.0 RC1 © 2008-2019