Skip to main content

Topic: Converted MP3 to AAC, can't get tags working (Read 3553 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • mikeroq
  • [*]
Converted MP3 to AAC, can't get tags working
I recently converted my 2,000+ songs from mp3 to aac. I spent a good couple hours tagging half of them with TagScanner 5.1 which was saving them as APEv2 tags. I moved an album over to my Sony NWZ-E344 media player and there was no tag data. I imported an album into Foobar and there were no tags there as well. I then tried saving the tags in various formats ID3v1, ID3v2, ID3v1+ID3v2, APEv2+ID3v1,  ID3v1 + ID3v2 + APEv2, and still can't get foobar to read the tags. Anyone have any idea whats going on here?

  • Soap
  • [*][*][*][*][*]
Converted MP3 to AAC, can't get tags working
Reply #1
First off, I don't know the answer.
Second.  I honestly want to know why you converted your MP3s to AAC?
Creature of habit.

  • mikeroq
  • [*]
Converted MP3 to AAC, can't get tags working
Reply #2
I read online at various sources that the sound quality of an 128kbps AAC is comparable to a 320kbps MP3. I converted them to save space and to fit my library on my MP3 player without loosing too much quality, since it is an 8gb model.
  • Last Edit: 30 June, 2011, 09:37:10 PM by mikeroq

  • mixminus1
  • [*][*][*][*][*]
Converted MP3 to AAC, can't get tags working
Reply #3
No one can make a general statement that a 128 kbps AAC is "comparable" to a 320 kbps MP3 - with *some* material it may be true, but it's quite likely you could find some material that would cause artifacts in a 128 kbps AAC but not in the 320 kbps MP3.

Furthermore, that statement has even less meaning in your situation as you're *transcoding* from MP3 to AAC, so the AACs may have artifacts caused by the lossy-to-lossy conversion that they wouldn't have had if you'd encoded straight from the original lossless sources (CDs, FLACs, etc.).

As far as the tags are concerned, try a different program on a couple albums, such as Mp3tag, and see if your Sony and fb2k can read them (and make sure you at least write ID3v1 and ID3v2.3 - I'm quite certain the Sony has no idea what APE tags are).  If they still can't, then something is really wrong as I've tagged thousands of files with mp3tag and literally never had a problem with reading them in anything.

Edit: You may need to experiment with the ID3 settings in Mp3tag - it will tag AACs to be compatible with iTunes by default, but I have no idea what the Sony wants to see.
  • Last Edit: 30 June, 2011, 10:56:38 PM by mixminus1
"Not sure what the question is, but the answer is probably no."

  • Kohlrabi
  • [*][*][*][*][*]
  • Global Moderator
Converted MP3 to AAC, can't get tags working
Reply #4
Did you put those AAC files in a MP4 container?
  • Last Edit: 01 July, 2011, 03:47:50 AM by Kohlrabi
It's only audiophile if it's inconvenient.

  • SamDeRe81
  • [*][*]
Converted MP3 to AAC, can't get tags working
Reply #5
That's a damn good question but my advice is begin using MusicBrainz Picard and stop trying to manually mess with tags, it's just a headache and causes nothing but a huge waste of time. Also don't transcode it's bad