Skip to main content

Topic: Windows Media Player and Windows Explorer won't read some ID3v2.3  (Read 10587 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
Windows Media Player and Windows Explorer won't read some ID3v2.3
I had posted this on another forum, but they couldn't help me there no matter how much they tried (this problem is kind of weird), so they told me to ask for help here. I'll try to describe my problem in detail here, as well as talk about what was already suggested to me and didn't work.

I had hundreds of tagged MP3 files on my old notebook (which broke a few days ago), whose tags showed correctly both on iTunes and on Windows Media Player. I bought a new computer recently and, when I transferred the files from the old to the new one, most of the tags were gone. Well, they're still being shown on iTunes, which means my ID3v2.4 tags are safe, and if I open them on Mp3tag it'll show all the correct tags, and it'll say they're ID3v2.3, which means that, in thesis, Windows Media Player and Windows Explorer should have no trouble reading them, but most songs have absolutely no info on both. There doesn't seem to be a pattern as to which files' tags can and can't be read; some are fine and some gone, for no apparent reason. If I try to add tags using Windows Media Player, they're correct for a few seconds, but then they're back to being blank. I can't edit tags using the Details tab on the Properties menu of the files; when I click on the tag I want to edit, instead of a text box appearing, nothing happens; I just can't type. This happens on both the tagless files and the OK ones. It's as if the files were read only, but they're not. I'm not getting error messages nor anything like that; I just can't change tags. I've also tried saving the tags on Mp3tag, but nothing happens. I mean, if I make any changes, they do show on Mp3tag itself, but the tags are still wrong (or nowhere to be seen) on Windows Explorer and Windows Media Player.

Also, there's an odd detail: when I opened the contents of the external HD my old computers' songs are in using Windows Explorer on that old computer itself, the files would all be OK; if I open them on the new one, they'd be wrong.

I think I know how this mess started: a few weeks ago, I was trying to find a way of making Devnagri (a non-Unicode script) song and album titles and artist names show correctly on iTunes. I Google it, and got to a website that had rather confuse instructions. It looked like the site was telling me to change the ID3 version of the files. As I had no idea what that was by then (see? There's always a bright side: all this crap has at least taught me something about MP3 file tagging! Yeah, thank you, Lord, though I still think you could've found a better way to teach me about that), I thought it could do no harm, and selected all files (why, oh, why all? Couldn't I have tested it with only ONE?), right-clicked, selected "Convert ID3 Tags..." and changed the ID3 version lots of times. I think I tried all available versions, and none did what I wanted it to (i.e., make Devnagri text not show as little squares). The problem started when I converted the tags to ID3v1.0; since it has a character limit, all tags that were longer than X characters were partially lost and I spent a few hours retying everything (do I even need to comment on how pissed off I was? This should teach me to test first, THEN risk my whole music folder). So, perhaps that caused this issue; I mean, before that happened, I had successfully transferred MP3 files from my old computer to other ones (including this very same one) with no tag problem, and also, the MP3 files I downloaded AFTER all that happened have all their info correct, and their tags CAN be edited using the Properties thing on Windows Explorer. However, why only some files of the files that had they tags messed up that day, and not all of them, lost their tags, is beyond my knowledge. And since I can't use that old laptop any more, I can't restore that computer to an earlier date and try to get the "unmessed up" versions of the files, so I MUST find a way to fix the files I currently have, unless I have to redownload everything - which would be nearly impossible, as I have 300+ broken MP3s.

Could anyone please, please, please help me?

ETA: If this helps, here are the files on Mp3tag; here you can see the very same files on Windows Explorer, and here, on iTunes.
  • Last Edit: 07 May, 2011, 04:34:00 PM by rajkumari

  • 2thumbs
  • [*]
Windows Media Player and Windows Explorer won't read some ID3v2.3
Reply #1
Hrmm. It is possible that the files ended up with chained ID3 tags? In other words, an ID3v2.3 tag followed by an ID3v2.4 tag? This could explain some of the behaviour you're seeing. You can check for this by opening the file in a hex editor and looking for the sequence 0x49 0x44 0x33. This will be followed by the version bytes, 0x03 0x00 for 2.3, 0x04 0x00 for 2.4 respectively. Generally these will appear before the first MPEG frame. If you find more than one of these, you ended up with chained tags.

Since you already have MP3Tag installed, you can also test for this by going into the options and telling MP3Tag to remove ID3v2 tags (tools -> options -> tags, check "remove ID3v2").  If you then right-click on one of your files and select "remove tag", you should see the ID3v2.3 tag disappear and the 2.4 return. If that's not the case, something else is going on. This works because MP3Tag only "sees" the first ID3v2 tag and ignores anything after. So if you remove it, MP3Tag will then "see" the 2.4 tag. Obviously any kind of potentially destructive editing should be done on copies or test files.

If you've added your music to the "Music" folder in Windows, it's possible that WMP will scan these files for artist info and album art. In this case it will continue to modify files only tagged using ID3v2.4.
  • Last Edit: 07 May, 2011, 08:01:31 PM by 2thumbs

Windows Media Player and Windows Explorer won't read some ID3v2.3
Reply #2
OMG, thank you, thank you, thank you!  Now I can add info manually!  I couldn't get the right info back, but I had already lost my hopes of ever seeing those tags again; at least I can re-add everything now. I'm so happy! Seriously, you don't know how much you've helped me! I have OCD, and not having tags was driving me completely crazy. I never thought I'd ever say this, but I can't wait for tomorrow afternoon, when I'll retype everything.  Thanks a lot, one more time!

  • Andavari
  • [*][*][*][*][*]
Windows Media Player and Windows Explorer won't read some ID3v2.3
Reply #3
Wouldn't Foobar2000 do this a bit easier? By right-clicking and selecting:
'Tagging'->'MP3 tag types'->and then make a proper selection of the preferred tags by using 'Override ID3v2 revision'.

I don't know off hand if it would work or not since I don't have the issue the original poster is having. In any event please do what's already suggested by working on copies first.
Complexity of incoherent design.

Windows Media Player and Windows Explorer won't read some ID3v2.3
Reply #4
If only I had seen this a few hours ago! Now I've already retyped everything.  Well, what matters is: I've finally solved my problem

Windows Media Player and Windows Explorer won't read some ID3v2.3
Reply #5
I am so happy that I found this thread.  This is one of the great perks of forums.  I have been experiencing the same problems with my mp3 files when I transferred all of my files from my computer to a cloud hosting service. I thought it would make things easier to plug in my ipod to other people's home theater systems when visiting their homes.  That way I could upload my files from anyone's computer.  I soon realized that I had made a huge mistake.  I had thought I had lost those files for ever.  Thank you rajkumari for asking this question.  I can't wait to see if the same solution will fix my mp3 files.  I'm so thrilled that I found this! Yay!
  • Last Edit: 27 June, 2011, 01:32:11 PM by whitejason

Windows Media Player and Windows Explorer won't read some ID3v2.3
Reply #6
Is this happening because extra tags are getting into the file and the tag software (or player) isn't reading them or merging the data from them together correctly?

Are there really that many applications that aren't smart enough to scan the entire MP3 for tags and just look for a V1 at the end and V2 at the beginning?  I suppose that's the norm, but with sync-safe IDv2 tags, an IDv2 tag can be anywhere in an MP3 file and not hurt its playback.  Then again, I've never seen a software write a sync-safe tag...so maybe the software doesn't support it.

A non-sync-safe tag in the middle of the file would/could certainly hose a player that's not knowledgeable about ID3 tags...wonder how many decoders/players could handle that?
  • Last Edit: 27 June, 2011, 03:37:25 PM by DreamWarrior

Windows Media Player and Windows Explorer won't read some ID3v2.3
Reply #7
DreamWeaver,
I was able to tweak it to get it to work.  I think it had to be because there were extra tags getting into the file. Thanks to the advice earlier on this thread and yours, I know have it working again.
  • Last Edit: 28 June, 2011, 04:30:22 PM by greynol

Windows Media Player and Windows Explorer won't read some ID3v2.3
Reply #8
i found another solution to the problem, open foobar2000, add the folder with your songs, then select them all, right click, select utilities and then Rebuild MP3 Stream and later Fix VBR MP3 Header, it solved the problem and windows now sees the tags!!!