Skip to main content

Topic: Noise coming through onboard soundcard. (Read 15245 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Spots
  • [*]
Noise coming through onboard soundcard.
My apologies if this question is a little bit simple and 'read the faq/google it'.

So I've just built a new computer, and I was getting horrendous sound coming through my speakers (a kind of whirring/whining/buzzing, and few pops etc). I experimented and found that turning the system volume down, doesn't affect the volume of the noise.

Did a bit of a google and 'bad grounding' kept coming up. I'll mention that if I turn the light switch on and off, I can hear it cause a buzz on my flatmates sub. Also - cheap cables -I just bought a 3.5 mm to RCA cable from the $2 shop - if I pull the cable out and touch it with my fingers, the speakers give a hum).

Anyway - so I've switched to using my Hercules DJ console for audio - that has lessened the noise a lot, though it  is still slightly there.

So just wondering what the deal is here?

Like... the noise coming from my onboard, was ridiculous - one wouldn't need to be an audiophile to rage at it.
Do producers and such typically go for an external sound card?




Noise coming through onboard soundcard.
Reply #1
Hi Spots,

Usually the on-board audio interfaces are not very good, but they should not produce the kind of interference you are experiencing.

A lot of issues with sound can be tracked down to earthing, but that usually involves a 50 or 60 Hz. hum. 

BTW, it is quite normal to get a hum when touching the input-plug.

What I would do:

- Make sure the PC is connected to a properly earthed / grounded outlet
- Disconnect all (external) equipment you do not need for operating the PC, and connect a headphone to the headphone-jack (assuming you have a mainboard that has 6 jacks for audio, it should be the green one), and see (= hear) if the same noises are still there.

For me to help better, I need to know your findings, and some more info (used mainboard, the way you connect it etc...)

Please let me know...

Regards,
Peter

  • Alexxander
  • [*][*][*][*]
Noise coming through onboard soundcard.
Reply #2
Had very similar problem with my desktop PC (Asus PB5 Deluxe motherboard). The solution was disconnecting the case speaker cable from motherboard.

  • Spots
  • [*]
Noise coming through onboard soundcard.
Reply #3
Had very similar problem with my desktop PC (Asus PB5 Deluxe motherboard). The solution was disconnecting the case speaker cable from motherboard.


Do you mean the tiny one that plugs in with the other ones (for like the power button, LED, Usbs etc)? Is that the one that is for the BIOS beep?



So since my last post:
I've also been having trouble with my power supply. Sometimes when I turn comptuer on, it turns off straight away, so I'll do it again and it'll boot. Or sometimes it'll give me 'CHECKSUM ERROR!' and have to load the BIOS from the harddrive or something.
Anyway - it does boot eventually.
Also, some times it'll just shut off.

I'm wondering if this is a faulty powersupply issue, or something else?

I'm considering swapping out my powersupply see what that does.


Also, I've noticed the whining increases if I have my browswer open (if I minimize it, it goes away).
And if I've running Ableton Live, (minimized or not). Foobar doesn't seeem to affect it though.

  • Spots
  • [*]
Noise coming through onboard soundcard.
Reply #4
Also, I'm using an external USB soundcard now, still has this problem.

  • Spots
  • [*]
Noise coming through onboard soundcard.
Reply #5
Further, testing using the onboard as well, if I goto the ableton 'Test Tone' - turn the volume right down, but simulate increased CPU load, it definately makes more noise. I think we can definitely say that this is an issue of CPU load affecting the sound.

I attempted to swap the PSU, but my other one doesn't fit.
  • Last Edit: 21 April, 2011, 09:15:55 PM by Spots

  • Spots
  • [*]
Noise coming through onboard soundcard.
Reply #6
No way to edit posts?

Just tested:

Onboard: Noise occurs whether I'm using speakers or headphones.
External: Noise occurs on speakers, but not headphones, it seems.

Noise coming through onboard soundcard.
Reply #7
First of all, it sounds like you definitely have a power supply issue.  How can one that have not fit?


Secondly, it sounds like you have a bad grounding somewhere... perhaps a motherboard standoff or (as was mentioned) the case speaker. 


How clean is the power where you live?
"You can fight without ever winning, but never win without a fight."  Neil Peart  'Resist'

  • pdq
  • [*][*][*][*][*]
Noise coming through onboard soundcard.
Reply #8
No way to edit posts?

Yes, but I think there is a one hour limit.

I would also be careful editing a post that someone has already replied to (could cause confusion).

  • Spots
  • [*]
Noise coming through onboard soundcard.
Reply #9
Hi guys, been a while since I started this thread. I've been just putting up with this sound.

A few things:
- Tested it with a friends external USB soundcard, didn't fix it.

- Moved computer inside - interference seemed less, there, but still apparent.

- Used a DC powered DAC device, which fixed it (though then it seemed to have the 50/60hz hum). What it was was a component of a surround sound system, powered by a DC lead from the amp uni. Sent digital signal from my USB soundcard to this DAC, and then analouge out.

Quote
How clean is the power where you live?

I think it's pretty dodgy. I live in a sleep out.  For example, if I turn my desklamp on and off I can hear a click in the speakers. If I turn my lights on and off, it causes my flatmates sub to hum.

I'm yet to move my comptuer and speakers to a friends house to test it there.


One more thing, which you might be able to help with. Sometiems when I turn my computer on, it turns off straight away, and has to recover the BIOS next time it starts. Any idea what this is? It's only occasionally that it does it. Am thinking that perhaps it's a faulty PSU, but perhaps I've just installed something wrong somewhere?
Am considering taking the computer apart and rebuilding it.

I don't recommend building your own computer - if you have any hardware trouble it's much harder blaming it on the parts.  It's worth that extra one or two hundred dollars to get someone who has done it a hundred times before, to do it, have peace of mind.

  • AndyH-ha
  • [*][*][*][*][*]
Noise coming through onboard soundcard.
Reply #10
I recently put together a new machine. It has both "ATI High Definition Audio Device" and "Realtek High Definition Audio" listed in Device Manager. I haven't bothered to look for a definition of these but they involve a really stupid concept that things don't seem to even exist without something plugged into various of the MB audio jacks. As far as I can tell, one has no access at all to the controls without first triggering whatever switches are in the jacks.

However, this does not mean the circuitry is not functioning, just because you cannot see any signs of it. The system was originally producing a lot of extraneous noise , including some weird buzzing whenever the mouse was moved.

When I did manage to get a full audio control panel, I turned most of the inputs and outputs down to zero with the volume sliders. This produced a very clean output on the one thing, the headphones, I was trying to use. I did not experiment further, having no interest, but one can probably successfully use other functions, perhaps all, if the configuration is correct at the time one tries to use them. The headphone output is completely clean and seemingly of high quality when it isn't being interfered with by (various unused inputs?)

One of the outputs, a dialing, etc. sound simulation for the modem, absolutely would not stay at zero. It kept adjusting itself every time the modem was used. I had to disable the "modem call progress audio" service via msconfig to stop it. That should also be accessible through Services in Administrative Tools in Control Panel.

  • nagual
  • [*]
Noise coming through onboard soundcard.
Reply #11

  • Juha
  • [*][*][*][*][*]
Noise coming through onboard soundcard.
Reply #12
Since you have USB audio interface there, if you disable the onboard sound totally (through BIOS) ... is the unwanted noise still there?


If you did build the PC by yourself then, try re-build it with good care.


Juha
  • Last Edit: 22 October, 2011, 04:30:53 AM by Juha

  • Spots
  • [*]
Noise coming through onboard soundcard.
Reply #13
Ok, to do list:

-Move my computer to different house, check if that fixes it.
-Borrow a friend's PSU, see if replacing PSU fixes it.

If that doesn't work, I think the rebuild is going to have to be it.
  • Last Edit: 26 October, 2011, 01:59:27 AM by Spots

  • Spots
  • [*]
Noise coming through onboard soundcard.
Reply #14
An Update here:

Tried computer at a friends house. Problem still exists.
Tried a different PSU. Problem still exists.

What do now?
Something to do with the motherboard?

Noise coming through onboard soundcard.
Reply #15
An Update here:

Tried computer at a friends house. Problem still exists.
Tried a different PSU. Problem still exists.

What do now?
Something to do with the motherboard?


You said earlier the noise was fine with headphones but noisy with the external system. If that is the case the motherboard is fine. Someone mentioned about the grounding mounts under the motherboard. Did you verify that at least one metal (often brass) standoff is installed and very important, is it tight into the case? It doesn't need to be 'torqued' but does need to be snug. You said the problem is only with speakers. What exactly are you connecting to? To find the loop you'll need to run the computer with as few cables as possible even disconnecting the monitor while listening to the noise so you find out what causes your problem. Since ethernet cables are transformer coupled it shouldn't be a problem but disconnect that too. Are these amplified speakers with a 3 wire cord or perhaps an amp with a 3 wire cord? What I'm going to suggest is 'illegal' but it's needed to verify where the ground loop originates. If the amp or speakers uses a 3 wire cord get a ground lifter (3 prong to 2 prong adapter) and plug in so that the ground is NOT connected. You only need to run it this was long enough to hear if it changes. There are ways to make the hum go away and use the 3 wire cords as designed if that's what's needed. Tell us more.




  • andy o
  • [*][*][*][*][*]
Noise coming through onboard soundcard.
Reply #16
As far as I can tell, one has no access at all to the controls without first triggering whatever switches are in the jacks.

IIRC this is monitored by a startup entry. You should be able to disable it with msconfig.

ATI High definition blah blah is the HDMI device, btw. Realtek is the analog speakers audio.

  • andy o
  • [*][*][*][*][*]
Noise coming through onboard soundcard.
Reply #17
Did you try disabling or muting all the audio inputs like AndyH proposed?

  • Spots
  • [*]
Noise coming through onboard soundcard.
Reply #18
Seemed to have fixed it with a simple ground loop isolator. Simple, simple fix.

If I put my ear close the speak, I can still hear a little fuzz, but it's screeds better than what it was.

Will test this muting inputs later though.

Noise coming through onboard soundcard.
Reply #19
Seemed to have fixed it with a simple ground loop isolator. Simple, simple fix.

OK. What exactly is a ground loop isolator? Does is plug into the audio cable or is it one of those 3 prong to 2 prong ground lifters for the AC plug or something else?


  • Spots
  • [*]
Noise coming through onboard soundcard.
Reply #20
One of these:




  • chrizoo
  • [*][*][*][*]
Noise coming through onboard soundcard.
Reply #21
Seemed to have fixed it with a simple ground loop isolator.
doesn't this only mitigate the problem rather than fix it ?

(edit: your results "If I put my ear close the speak, I can still hear a little fuzz" seem to agree)
  • Last Edit: 14 December, 2011, 05:03:28 PM by chrizoo

Noise coming through onboard soundcard.
Reply #22
doesn't this only mitigate the problem rather than fix it ?

(edit: your results "If I put my ear close the speak, I can still hear a little fuzz" seem to agree)


His problem comes from 'ground loops'. The transformer isolator fixes the problem by isolating the grounds but has limitations of transformers. If it were mine I'd build opamp based differential input which would outperform the transformer - but that's just me. As for noise, EVERY system has some noise though it's often so low we can't really find it but it is there. It's not unusual to have more than one ground loop and this transformer only addresses one of them.