Skip to main content

Topic: SPDIF on Win 7—stuttered, perfect via exclusive mode for 3 d, now none (Read 3825 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Lucian23
  • [*]
SPDIF on Win 7—stuttered, perfect via exclusive mode for 3 d, now none
Hello everybody!
I am running genuine Windows 7 Professional 32-bit and have installed K-Lite Mega Codec Pack 6.7.0. I am using Media Player Classic - Home Cinema 1.4.2803.0 for watching HD movies with Dolby Digital (DD) and Digital Theater System (DTS) formats.   
My sound card is a Creative Sound Blaster X-FI XtremeGamer and my audio system Logitech Z-5500 Digital 5.1 Speaker System. 
I have the latest driver installed for Windows 7 from Creative website 2.18.0015. 
I couldn't get a clear, crisp sound through SPDIF; sound stucks like it was a bad CD that hangs over and over again; sometimes (very strange, happened only 2 times) the Power button from Logitech System fade away for a few seconds then comes back and the sound interrupts and crackle.
Eventually I managed to get PERFECT sound through SPDIF ticking only "Allow applications to take exclusive control of this device" from the Advanced tab of SPDIF Out Properties, but ONLY for 3 days. 
My PROBLEM is that (no matter what settings I have) suddenly I have NO SOUND AT ALL through SPDIF !!!
I use AC3 filter for SPDIF passthrough and the Logitech Digital SoundTouch™ control center shows "No Digital Data". 
I would also like to mention that on Windows XP I had NO PROBLEM.   
I want from now on to have Windows 7 on my computer but also to be able to listen DD & DTS audio formats. 
Can someone help me, PLEASE?   

Thank you in advance,