Skip to main content

Topic: foo_dsp_convolver (Read 14571 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • lvqcl
  • [*][*][*][*][*]
  • Developer
foo_dsp_convolver
Another convolver DSP for foobar2000 (foobar2000 1.1 or newer is required).

Discussion thread.

Download:

Component: [ Specified attachment is not available ] Source code: [ Specified attachment is not available ]


Changelog:

0.4.7 - fixed possible crash
0.4.6 - doesn't change current directory during "Open File" dialog
0.4.5 - requires less memory; other minor changes
0.4.4 - PFFFT (Pretty Fast FFT) is used instead of FFmpeg FFT routines
0.4.3 - algorithm & code simplification; slight speed increase
0.4.2 - maintenance update
0.4.1 - workaround  for WinXP and portable mode
0.4.0 - code cleanup, minor fixes
0.3.8 (experimental) - use relative path to impulse file when foobar2000 is in portable mode.
0.3.7 - minor tweaks
...
  • Last Edit: 10 August, 2014, 03:58:35 AM by lvqcl

  • lvqcl
  • [*][*][*][*][*]
  • Developer
foo_dsp_convolver
Reply #1
--
  • Last Edit: 10 August, 2014, 03:58:10 AM by lvqcl

  • gl.tter
  • [*][*]
Re: foo_dsp_convolver
Reply #2
Hi, is the source code still available?  And the component itself?  The attachments have disappeared.

I want to add support for automatic loading of matching sample-rate impulses, so no resampling is required.  Will post my changes when it's done.
Author of -Wavpack4Wavelab- and -CheckWavpackFiles-

  • kode54
  • [*][*][*][*][*]
  • Administrator
Re: foo_dsp_convolver
Reply #3
I see the attachments right here in this topic. I just downloaded them.