Skip to main content

Topic: foo_vst: VST 2.4 adapter (Read 310138 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
foo_vst: VST 2.4 adapter
Reply #375
It doesn't work on win8.
foo_vst is recognized, but VST are not visible


Try to disable windows theme and/or desktop composition.
The issue might be a font displayed in white over a white background.
I  say this , because this remind me an old issue, when I've upgraded to vista, with a particular software.

  • sdixit3
  • [*]
foo_vst: VST 2.4 adapter
Reply #376
The dowload is not working. It says zip file is invalid.
Could some one upload a working copy ?

thanks
  • Last Edit: 28 December, 2012, 08:56:27 AM by sdixit3

  • lvqcl
  • [*][*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #377
foo_playlist_attributes.dll 0.5.1 (default settings)
foo_vst.dll 0.9.0.3

Add any VST plugin into the DSP chain, play a file and close foobar2000 while playing or when the playback is paused => fb2k crashes.

However it doesn't crash without foo_playlist_attributes.

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
foo_vst: VST 2.4 adapter
Reply #378
The dowload is not working. It says zip file is invalid.
Could some one upload a working copy ?
It works for me using Windows 7 Explorer and the free program 7-Zip, but just in case anyone else has this issue, I’ve added another ZIP that I unarchived and re-compressed using the former.

  • PJay-Z
  • [*]
foo_vst: VST 2.4 adapter
Reply #379
It doesn't work with the latest version?

  • nine09
  • [*]
foo_vst: VST 2.4 adapter
Reply #380
Hey guys. I just made a very basic tutorial for beginners on how to use this brilliant plugin.

http://youtu.be/RaFcdAxpaQY


  • Northtech
  • [*]
foo_vst: VST 2.4 adapter
Reply #381
Anybody can fix crash in this plugin?
Thanks.

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
foo_vst: VST 2.4 adapter
Reply #382
What crash? Are we to assume that you are referring to this report from 15 months ago?

foobar2000 1.1.9

--
Online Troubleshooter:
foo_vst.dll : VST 2.4 adapter 0.9.0.3
Reason: Repeated crash reports.

Either way, did you not think it would be helpful to everyone involved if you posted some actual information? When does it crash, what else was being done in fb2k at that time, what hardware are you using, which other details of your installation/configuration may be relevant to people trying to help you, etc.

  • Northtech
  • [*]
foo_vst: VST 2.4 adapter
Reply #383
db1989
This crash - http://www.hydrogenaudio.org/forums/index....st&p=819766
My report from 15 months ago is directly related.


Code: [Select]
Windows 7 sp1

Core (2013-02-13 11:26:10 UTC)
   foobar2000 core 1.2.3
foo_albumlist.dll (2013-02-13 11:24:52 UTC)
   Album List 4.5
foo_converter.dll (2013-02-13 11:24:22 UTC)
   Converter 1.5
foo_dsp_eq.dll (2013-02-13 11:24:54 UTC)
   Equalizer 1.0
foo_dsp_std.dll (2013-02-13 11:24:44 UTC)
   Standard DSP Array 1.2
foo_fileops.dll (2013-02-13 11:23:12 UTC)
   File Operations 2.2
foo_hdcd.dll (2012-07-20 20:41:44 UTC)
   HDCD decoder 1.15
foo_input_monkey.dll (2012-06-06 12:48:14 UTC)
   Monkey's Audio Decoder 2.1.6
foo_input_std.dll (2013-02-13 11:23:54 UTC)
   Standard Input Array 1.0
foo_rgscan.dll (2013-02-13 11:24:30 UTC)
   ReplayGain Scanner 2.1.2
foo_simplaylist.dll (2011-08-18 16:01:36 UTC)
   SimPlaylist 1.0
foo_ui_columns.dll (2011-02-27 20:22:58 UTC)
   Columns UI 0.3.8.8
foo_ui_std.dll (2013-02-13 11:23:58 UTC)
   Default User Interface 0.9.5
foo_unpack.dll (2013-02-13 11:24:22 UTC)
   ZIP/GZIP/RAR Reader 1.6
foo_unpack_7z.dll (2011-08-13 14:27:58 UTC)
   7-Zip reader 1.8
foo_vst.dll (2011-03-05 04:19:04 UTC)
   VST 2.4 adapter 0.9.0.3

So far i deleted plugin (Playlist Attributes).
  • Last Edit: 17 February, 2013, 01:11:33 PM by Northtech

  • Propheticus
  • [*][*][*]
foo_vst: VST 2.4 adapter
Reply #384
The latest version of Foobar 1.2.3 does not play when resuming playback on restart while VSTs are loaded in my DSP chain using foo_vst 2.4 (using two VST plugins Electri-Q posihfopit and Headfit). Any playback action (stop, pause, play) won't work and result in 'program not reponding' with 25% cpu usage (1 core 100%). So whatever you do... foobar crashes. This does not happen when there are no VST plugins loaded in the DSP chain (reproducable time after time).
Could this please be fixed? The only workaround for now is disabling 'resume playback after restarting foobar2000' in the playback settings.

plugin report:
Code: [Select]
Core (2013-02-13 11:26:10 UTC)
foobar2000 core 1.2.3
foo_ac3.dll (2012-09-09 19:48:27 UTC)
AC3 decoder 0.9.7
foo_albumlist.dll (2013-02-13 11:24:52 UTC)
Album List 4.5
foo_cdda.dll (2013-02-13 11:24:22 UTC)
CD Audio Decoder 3.0
foo_channel_mixer.dll (2008-03-12 09:37:47 UTC)
Channel Mixer 0.9.6.5
foo_converter.dll (2013-02-13 11:24:22 UTC)
Converter 1.5
foo_cuefilter.dll (2013-02-16 11:18:17 UTC)
CUE Playlist Filter 0.1.7.0
foo_dsp_crossfader.dll (2010-01-13 19:46:10 UTC)
Gapless Crossfader 1.3.4.1
foo_dsp_eq.dll (2013-02-13 11:24:54 UTC)
Equalizer 1.0
foo_dsp_resampler.dll (2012-08-17 18:41:42 UTC)
SoX Resampler 0.8.0
foo_dsp_std.dll (2013-02-13 11:24:44 UTC)
Standard DSP Array 1.2
foo_dsp_xgeq.dll (2012-02-13 12:17:29 UTC)
Graphic Equalizer 0.3.7
foo_fileops.dll (2013-02-13 11:23:12 UTC)
File Operations 2.2
foo_freedb2.dll (2013-02-13 11:22:46 UTC)
Online Tagger 0.7
foo_input_dts.dll (2013-02-10 23:53:10 UTC)
DTS decoder 0.3.1
foo_input_monkey.dll (2012-09-09 19:48:27 UTC)
Monkey's Audio Decoder 2.1.6
foo_input_std.dll (2013-02-13 11:23:54 UTC)
Standard Input Array 1.0
foo_keep_queue.dll (2011-08-03 23:29:28 UTC)
Keep Queue 0.3.5
foo_masstag.dll (2010-07-17 16:50:37 UTC)
Masstagger 1.8.4
foo_out_upnp.dll (2013-02-10 23:53:10 UTC)
UPnP MediaRenderer Output 1.0 beta 4
foo_out_wasapi.dll (2013-02-10 23:53:10 UTC)
WASAPI output support 3.2.1
foo_playcount.dll (2011-08-30 19:57:43 UTC)
Playback Statistics 3.0.2
foo_plorg.dll (2011-09-17 00:23:26 UTC)
Playlist Organizer 2.4
foo_queuecontents.dll (2012-03-20 23:45:53 UTC)
Queue Contents Editor 0.5.1
foo_quicksearch.dll (2012-11-06 01:54:29 UTC)
Quick Search Toolbar 3.4
foo_rgscan.dll (2013-02-13 11:24:30 UTC)
ReplayGain Scanner 2.1.2
foo_scheduler.dll (2013-02-10 23:53:10 UTC)
Scheduler 4.11
foo_softplaylists.dll (2011-03-23 11:29:41 UTC)
Soft Playlists 2011-02-05
foo_texttools.dll (2010-11-07 17:51:39 UTC)
Text Tools 1.0.5
foo_ui_columns.dll (2011-02-27 20:23:00 UTC)
Columns UI 0.3.8.8
foo_ui_std.dll (2013-02-13 11:23:58 UTC)
Default User Interface 0.9.5
foo_uie_albumlist.dll (2009-06-13 22:49:19 UTC)
Album list panel 0.3.5
foo_uie_biography.dll (2010-12-13 20:38:26 UTC)
Biography View 0.4.2.4
foo_uie_elplaylist.dll (2011-01-06 09:07:35 UTC)
ELPlaylist 0.6.9.1.2(beta)
foo_uie_esplaylist.dll (2011-02-19 08:20:42 UTC)
EsPlaylist 0.1.3.7
foo_uie_lyrics3.dll (2012-09-09 19:48:27 UTC)
Lyric Show Panel 3 0.3.5.2
foo_uie_panel_splitter.dll (2010-05-27 11:03:02 UTC)
Panel Stack Splitter 0.3.8.3(alpha)
foo_uie_vis_channel_spectrum.dll (2010-03-07 08:23:55 UTC)
Channel Spectrum panel 0.17.2
foo_uie_vis_peakmeter_spectrum.dll (2010-03-07 08:24:47 UTC)
Peakmeter Spectrum Visualisation 0.2.0.0 beta
foo_uie_wsh_panel_mod.dll (2012-10-16 00:45:19 UTC)
WSH Panel Mod 1.5.6
foo_unpack.dll (2013-02-13 11:24:22 UTC)
ZIP/GZIP/RAR Reader 1.6
foo_vis_shpeck.dll (2009-09-28 10:32:16 UTC)
Shpeck - Winamp vis plugins wrapper 0.3.7
foo_vst.dll (2011-03-05 07:19:04 UTC)
VST 2.4 adapter 0.9.0.3
foo_wave_seekbar.dll (2012-12-18 15:56:12 UTC)
Waveform seekbar 0.2.29
foo_wlm.dll (2011-02-13 13:00:20 UTC)
Windows Live Messenger Notifier 1.1.7
System:
- Win 7 x64
- Q6600 @ 3Ghz, 4GB ram DDR2
- Asus Xonar DG @ 96Khz/24bit with ASUS XONAR Unified Drivers v1.63
- Foobar 1.2.3 with DSP chain: Gapless Crossfader, Convert 5.1 to stereo, Electri-Q posihfopit edition (VST), head-fit-lite (VST), Advanced Limiter | output: Wasapi (event), 24-bit, 2000ms buffer, replaygain enabled
  • Last Edit: 17 February, 2013, 06:11:04 PM by db1989

  • patul
  • [*]
foo_vst: VST 2.4 adapter
Reply #385
The latest version of Foobar 1.2.3 does not play when resuming playback on restart while VSTs are loaded in my DSP chain using foo_vst 2.4 (using two VST plugins Electri-Q posihfopit and Headfit).


I got same crashes using this specific vst plugins, Electri-Q posihfopit. In my case, it is reproducible by changing the preset rapidly. I've never got this kind of crashes before, so I suspected it was the vst plugin.

foo_vst: VST 2.4 adapter
Reply #386
What annoys me , is that foobar crash when I close it directly during playback (when there's a dsp chain using vst).
To avoid crash, I must press first stop , and then only close.
This is especially true with vst with big latency : I guess there's something in cache/buffer, and foobar don't have time time to clean it  when you close it.
I'm wondering why it couldn't be automated  ?  ( a safe stop, when you close).


  • Propheticus
  • [*][*][*]
foo_vst: VST 2.4 adapter
Reply #387
The latest version of Foobar 1.2.3 does not play when resuming playback on restart while VSTs are loaded in my DSP chain using foo_vst 2.4 (using two VST plugins Electri-Q posihfopit and Headfit).


I got same crashes using this specific vst plugins, Electri-Q posihfopit. In my case, it is reproducible by changing the preset rapidly. I've never got this kind of crashes before, so I suspected it was the vst plugin.


Never had these crashes in earlier versions of Foobar though... Yet indeed, Electri-Q in this vst wrapper has always been a little buggy when loading/saving presets or opening and closing the configuration UI multiple times (opening too fast after closing).

  • Propheticus
  • [*][*][*]
foo_vst: VST 2.4 adapter
Reply #388
This problem still exists. I performed a bit of trial and error and found out the hang/crash* on restart only occurs when I'm using both foo_out_wasapi in EVENT mode AND foo_vst with actual VSTs loaded in the DSP chain.
Foobar does not crash when using either DirectSound or Wasapi PUSH mode output though.

Therefore, my current workaround for this problem is switching to push mode Wasapi output.



*even doing nothing at all and trying to close foobar will result in a 'program is not responding'...


  • Alexa
  • [*]
foo_vst: VST 2.4 adapter
Reply #389
It doesn't work with Ozone 5

foo_vst: VST 2.4 adapter
Reply #390
After reading the thread I am still confused about something.  Is it or is it not possible to have the controls of a VST plugin available in a window for tweaking while simultaneously having the controls of the fb2k main window available for controlling it?

  • Propheticus
  • [*][*][*]
foo_vst: VST 2.4 adapter
Reply #391
I've just tested this for you. Yes, you can control Foobar's main window while editing VST dsp settings. However, you cannot edit other settings or control the preferences window.

foo_vst: VST 2.4 adapter
Reply #392
I've just tested this for you. Yes, you can control Foobar's main window while editing VST dsp settings. However, you cannot edit other settings or control the preferences window.


Thanks for that.  I was doing something wrong.  With "Configure selected" I can get the plug's UI in a window and tweak it while I'm operating the main fb2k window just fine.  The only nag is that the Preferences:DSP Manager window is locked.  I guess that is standard fb2k operation when configuring any plug but it prohibits further manipulation of active plugins or their UI's.  Wish they'd fix that.  :-)


  • applegate
  • [*]
foo_vst: VST 2.4 adapter
Reply #393
VST plugin works great with Foobar200 version 1.26, ASIO on Windows 8 64 bits and GlissEQ (example filter: dynamic equalizer)

  • Last Edit: 26 May, 2013, 05:10:11 AM by applegate

  • foomark
  • [*][*]
foo_vst: VST 2.4 adapter
Reply #394
Great component!! 

I'm just curious to know one thing now...what VST do you use the most? any recommended one?

  • J.Fleming
  • [*]
foo_vst: VST 2.4 adapter
Reply #395
Both zipped DLL attachments are corrupt. All unpackers report corrupted archive, as well as Foobar2000 1.2.4.

Please fix the attachments.

  • Propheticus
  • [*][*][*]
foo_vst: VST 2.4 adapter
Reply #396
unpacks without trouble here... I guess your browser/virusscanner is at fault.

  • Zippy7
  • [*]
foo_vst: VST 2.4 adapter
Reply #397
When I only wanted to use one VST with foobar2000, I used George Yohng's VST Wrapper, which suited my needs.  When I wanted to add a second VST, I tried adding Acon Digital's EffectChainer.  However, I could not find a way to configure it so that the VST chain and all VST settings restore automatically when I run foobar2000.  Has anybody else figured out how to do this?

I replaced them both with Yegor Petrov's VST 2.4 adapter, and it is working fine for me.  I am using the ASIO output on foobar2000 v1.2.9, and I can close foobar2000 while a track is playing without any crash.  I like it that I can insert foobar2000 DSP in between VSTs in the chain.

If someone is having compatibility problems between Yegor's component and some VST, I wanted to offer another option.  You could use George Yohng's component for the problematic VST and use Yegor's component for the other VSTs.

My thanks to Yegor for developing this component!

  • foomark
  • [*][*]
foo_vst: VST 2.4 adapter
Reply #398
Any way to include a VST plugin inside a panel?
Maybe with WSH panel ??
Just wondering...i know that most of the plugin aren't resizable so i don't think it would be easy

  • Chodi
  • [*]
foo_vst: VST 2.4 adapter
Reply #399
I have this vst plugin working with foobar and TB Isone for use with headphones. It works great for me but I have a question about the channel selection that appears in the upper left corner of the TB Isone window when I use this plugin. I am only using the one dsp. In the upper left corner it lets me choose 1,2 or auto setting for channels. If I choose 1 it is obviously limiting things to something like mono. If I choose 2 it sounds clearly like two channels, but if I choose auto the sound stage expands in width and depth and opens considerably? I thought auto would be the same as "2" since I am only listening to 2 channel flac recordings. I don't understand why selecting 2 and selecting auto do not produce the same results? Further, if I select auto and then later exit the program, when I re-enter foobar it selects "2" rather than remembering I had it set for auto?

Any advice about this setting to be used with 2 channel recordings in foobar would be appreciated? I am particularly interested in why the 2 setting and auto setting sound different when I am only using 2 channel stereo recordings.