Skip to main content

Topic: foo_vst: VST 2.4 adapter (Read 321234 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #275
This is plug-ins problem. Every plug-in must have its own unique ID.

  • zradu
  • [*]
foo_vst: VST 2.4 adapter
Reply #276
Thanks for the reply Yegor

I was informed by Jeroen Breebaart that the problem will be solved.

  • zmejce
  • [*]
foo_vst: VST 2.4 adapter
Reply #277
Hello,
I must say big thanks for this plugin, it does a great job,
but im dissapointed because it cant load the cheap CrySonic Cry-Q vst equalizer,
it displays "Cant load module." pages. Any help on this side please!?

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #278
Although they...
Quote
strongly encourage you to download our free demo versions and test them thoroughly with your setup until satisfied.
... I don't see this particular plug-in listed in their demos. But I'll try to contact them.

  • gyohng
  • [*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #279
Regarding plugin ID, most of other applications actually do not depend on its uniqueness and also hash plugin file name.

@Yegor: By the way, thank you for the other suggestion you posted for my adapter. I will look into it further, when time permits, and if it makes sense.

I still like to know if anybody is preferring my adapter, and whether I should develop it further.

Thanks,
George.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #280
Quote
Regarding plugin ID, most of other applications actually do not depend on its uniqueness and also hash plugin file name.
Ok, I'll make it this way. Thank you!

  • zradu
  • [*]
foo_vst: VST 2.4 adapter
Reply #281
Yegor, thanks for this component.
Is possible to make autohide toolbar, visible only when mouse is over system menu of editor windows (mouse on the window's titlebar)? Or, maybe better visible while holding down the shift key to show toolbar, like in foobar2000 hide menu item.



which is good (in my opinion) for clean appearance:


Edit: First screenshoot is from ubuntu but the requirement is for windows.
  • Last Edit: 03 June, 2011, 06:20:49 AM by zradu

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #282
Yes and no. I'm agree there should be an option to hide the panel, but switching it on mouse hover doesn't seem a good decision to me. I can add an advanced option for setting the default state and put a show/hide item in the system menu.

As for keyboard-driven solutions, they won't be reliable because plug-ins range from those that do nothing with keyboard to those that intercept just about every stroke.
  • Last Edit: 03 June, 2011, 06:33:59 AM by Yegor

  • zradu
  • [*]
foo_vst: VST 2.4 adapter
Reply #283
I can add an advanced option for setting the default state and put a show/hide item in the system menu.


Wonderful. Thanks!
PS off topic: I sincerely hope that you had success with graduation paper! 
  • Last Edit: 03 June, 2011, 06:46:54 AM by zradu

  • puciak
  • [*]
foo_vst: VST 2.4 adapter
Reply #284
Is it possible to add bypass button in plugins window? I want also to remind about Esc shortcut for closing plugins windows
  • Last Edit: 04 June, 2011, 11:21:54 AM by puciak

  • Sandrine
  • [*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #285
I found the first VST adapter that I couldn't get to work with your plug-in: ambio.one

  • lvqcl
  • [*][*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #286
Works here... fb2k 1.1.7, foo_vst 0.9.0.2.

Added: updated foo_vst to 0.9.0.3 and it works too.
  • Last Edit: 05 June, 2011, 01:38:43 PM by lvqcl

  • Sandrine
  • [*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #287
Strange, my setup is the same. Can't get it to work.

Could not load VST DLL. You may have tried to use x64 DLL or there is an internal error in the plug-in.

C:\Program Files (x86)\audio\Vst\ambio.one.dll

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #288
It works fine for me as well. What exactly happens / doesn't happen? Ok, it might have something to do with paths, I'll check it later. Though my system is 32 bit and I may not be able to reproduce the bug (64 bit win applies some path substitutions if I am not mistaken).
Quote
Is it possible to add bypass button in plugins window?
Yep.
Quote
I sincerely hope that you had success with graduation paper!
Yeah, thanks, I successfully upheld it three days ago, so I have some free time now. Still, I need to prepare for English exams (a separate course).
  • Last Edit: 05 June, 2011, 02:15:30 PM by Yegor

  • Sandrine
  • [*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #289
I've put it in a neutral path c:\vst but doesn't work either. Also, even stranger, I had removed the 2 VSTs I had previously installed to avoid conflicts, and now I can't add one of them back either - same error message.

Update: Now I've installed and again removed George Yohng's VST wrapper, and lo and behold, suddenly I can add all DLLs again. Scratch, scratch.
  • Last Edit: 05 June, 2011, 02:24:50 PM by Sandrine

  • marabundo
  • [*]
foo_vst: VST 2.4 adapter
Reply #290
Quote
Could't instantiate a VST effect ... \WaveShell-VST 5.2.dll

But first it says that none of Waves plug-ins could be found, right? I remember that. Does the bundle work in any other VST host? Perhaps, not. So at this stage it's Waves VST shell problem, not the adapter's. But I have to admit that at the next stage the adapter would just show you only one plug-in because of lack of VST shell api support.

I have same problem (WaveShell-VST 5.0.dll+foobar 2000 v.1.1.7+foo_vst v.0.9.0.3)
Error messages:

Could't instantiate a VST effect. This can be caused by an internal error or by the copy protection system of the plug-in.
D:\Program Files\Sound Plugins\Waves\Waveshells\WaveShell-VST 5.0.dll

Could not load VST DLL. The file has no entry procedure and hence doesn't appear to be a VST plug-in. Plug-ins may consist of multiple DLLs. Please try to specify a different one.
D:\Program Files\Sound Plugins\Waves\Plug-Ins\Waves5.0.DLL

Could not load VST DLL. You may have tried to use x64 DLL or there is an internal error in the plug-in.
D:\Program Files\Sound Plugins\Waves\Plug-Ins\C360.dll

But from Acoustica Premium Edition 5.0 this VST`s successfully loaded.
Please, help and thank you for your work.

  • tribaljet
  • [*][*]
foo_vst: VST 2.4 adapter
Reply #291
I noticed that foobar 1.1.7 has displaying an odd behavior. When playing back online streams, there is a 2-3 seconds input freeze, even though audio is playing back fine.

Any ideas on what might be causing this? I ask because it's kind of a big deal for me, and if I find no solution, I'll have to go back to 1.1.6.

  • lhaymehr
  • [*]
foo_vst: VST 2.4 adapter
Reply #292
Great work, finally! Thanks for this plugin and maybe a suggestion: can you detect player start/stop (ignore crossfades) and clear the plugin stream buffer so that things like reverbs don't have the tail of previous track.

  • tribaljet
  • [*][*]
foo_vst: VST 2.4 adapter
Reply #293
I noticed that foobar 1.1.7 has displaying an odd behavior. When playing back online streams, there is a 2-3 seconds input freeze, even though audio is playing back fine.

Any ideas on what might be causing this? I ask because it's kind of a big deal for me, and if I find no solution, I'll have to go back to 1.1.6.


Seems completely unrelated to the VST wrapper, it's foobar 1.1.7 version that's faulty. I'm back at 1.1.6, with everything working perfectly.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #294
Great work, finally! Thanks for this plugin and maybe a suggestion: can you detect player start/stop (ignore crossfades) and clear the plugin stream buffer so that things like reverbs don't have the tail of previous track.

There is no way to reset a VST plug-in. But I made an imitation of a reset. Whenever a playback event is fired, plug-ins get fed with zeroed data chunks. You can adjust the size of these chunks in the advanced preferences section. The default value works pretty well for non-delay effects. The step size for the declicker is 256 samples.

foo_vst: VST 2.4 adapter
Reply #295
Hello Yegor
This plugin supports VST synchronization transport (play, pause, stop)? --necessary for VST plugins with play/pause sync button--
  • Last Edit: 01 July, 2011, 11:40:42 AM by auditorium

  • tedych
  • [*]
foo_vst: VST 2.4 adapter
Reply #296
Hi Yegor. Yet another great plugin I find through my recent migration from Winamp to Foobar2000.

It works great with the VSTs I use currently (some are the same I use in my sound editor).
But I will second the wish I read here somewhere about a Bypass button. Some VSTs are resource intensive and whether I set their parameters to 0 (zero) they don't seem to take it as a private case and turn themselves off, still experiencing high CPU usage. Removing/adding them from the Preferences everytime I want a special effect/preview, is cumbersome.

I'd really like to see a Bypass button to avoid such cases. Thanks.

  • DDRRE
  • [*]
foo_vst: VST 2.4 adapter
Reply #297
Could a feature be implemented that allows certain VSTs to process channels by selection?

I am using a De-esser VST that works in stereo, meaning that giving it 4ch or 6ch files to process outputs stereo, the first 2 channels processed, with the other channels ignored (not passed-through - silenced).

Many other VSTs work in mono/stereo, so could the adapter have a feature to assign channels to a VST? for example, adding 1 stereo VST or 2 mono VSTs to process the front inputs, and all channels not assigned with a VST will be passed-through unprocessed?

P.S. with the exception of the above issue (actually not an issue, merely a workaround request) the plugin works flawlessly. And that's a lot of work. Well done!
  • Last Edit: 02 July, 2011, 02:09:25 PM by DDRRE

  • puciak
  • [*]
foo_vst: VST 2.4 adapter
Reply #298
I don't know if it is good place for this case.
I'm using BootEQ plugin. It works great when I'm playing audio, but when I try to convert files with additional processing (with BootEQ), only EQ section is working (there is also Gain/Output knob which seems to not work - I turned this output section on). Is it case of VST adapter or foobar?

foo_vst: VST 2.4 adapter
Reply #299
Argh, the one VST I really wanted to be able to use (iZotope Vinyl) is 64bit.

I fail.

EDIT: I am a moron.  I somehow clicked into the 64-bit "Program Files" twice by mistake somehow, and thereby didn't see the one in the x86 folder.

Stellar component, yegor.  Спасибо!
  • Last Edit: 21 July, 2011, 07:48:44 PM by Soviet Commissar