Skip to main content

Topic: foo_vst: VST 2.4 adapter (Read 319362 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • almosely
  • [*]
foo_vst: VST 2.4 adapter
Reply #225
I tried to add some Waves VSTs (e.g. L3 Ultramaximizer), but without success. These VSTs are using some kind of entry-shell where the actual VST has to be chosen from.

Error Message 1, when I tried the regular entry-dll (works with foo_dsp_vst.dll and foobar 0.9.5.2 or with both AND xlupex vst chainer):

"Could't instantiate a VST effect ... \WaveShell-VST 5.2.dll"

Error Message 2, when I tried the normally not working dll:

"Could not load VST DLL ... \L3.dll"

Of course, I tried YOUR plug-in with foobar 1.x (1.1.1. actually).

Any idea? But it's not urgent.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #226
Quote
sadly you need an iLok Dongle to use the demos
Way too paranoid. Could you send me your vst_entries.bin? It's in AppData/Foobar2000 if you have a standard installation.
Quote
Could't instantiate a VST effect ... \WaveShell-VST 5.2.dll
But first it says that none of Waves plug-ins could be found, right? I remember that. Does the bundle work in any other VST host? Perhaps, not. So at this stage it's Waves VST shell problem, not the adapter's. But I have to admit that at the next stage the adapter would just show you only one plug-in because of lack of VST shell api support.

  • almosely
  • [*]
foo_vst: VST 2.4 adapter
Reply #227
I could not find the requested vst_entries.bin in the specified folder. There are files like "database.fpl" or "foobar2000.cfg" and a subfolder named "playlists". I don't know if this folder belongs to foobar 0.9.x or foobar 1.x - I have installed both.

And no, the Waves plug-ins does not work with any VST host. Steinberg WaveLab 5 e.g. does not recognize the Waves VST-plug-ins. But they work just fine with foobar 0.9.x and the foo_dsp_vst.dll ... Other VSTs are working fine with your adapter.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #228
Quote
I could not find the requested vst_entries.bin in the specified folder.
It's ok since the request wasn't addressed to you anyway  And fine, may be I'm gonna get some freewares to improve the adapter's compatibility later. Apparently, you'll have to wait. It'll be much sooner if you find a trial of that old version.
  • Last Edit: 12 March, 2011, 05:48:38 AM by Yegor

foo_vst: VST 2.4 adapter
Reply #229
Hi,

I have found the file, but don't know how to send it with PM.

Maybe I have to add, that I am not using the Waveshell, but individual Plugins (there is this little utillity shelltovst that splitts the shell into individial vsts. With the shell itself of have many problems in various hosts....

  • almosely
  • [*]
foo_vst: VST 2.4 adapter
Reply #230
So, I stumbled upon XLUTOP's Shell2VST and with this tiny tool Waves' plug-ins work like a charm with your adapter :-) No need to look any further.
  • Last Edit: 13 March, 2011, 01:09:30 AM by almosely

foo_vst: VST 2.4 adapter
Reply #231
So, I stumbled upon XLUTOP's Shell2VST and with this tiny tool Waves' plug-ins work like a charm with your adapter :-) No need to look any further.


That may be good for you, but for me they don't work. I can't open the gui....


  • almosely
  • [*]
foo_vst: VST 2.4 adapter
Reply #232
So, I stumbled upon XLUTOP's Shell2VST and with this tiny tool Waves' plug-ins work like a charm with your adapter :-) No need to look any further.


That may be good for you, but for me they don't work. I can't open the gui....


Oh, I only spoke for me an my shell-version. "My personal case is closed" - that was my statement.

  • Alexa
  • [*]
foo_vst: VST 2.4 adapter
Reply #233
Hi

Is anynone else getting short "pop-ups" when the song is starting and fading is enabled?

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #234
Which fading do you mean exactly and how long is it? Anyway, try adjusting the VST declicker size in the advanced preferences section (the reasonable range is 1 to 1000). Getting rid of clicks and pops was one of the most important goals for me.
  • Last Edit: 14 March, 2011, 12:16:38 PM by Yegor

  • Alexa
  • [*]
foo_vst: VST 2.4 adapter
Reply #235
I have enabled fade out 6000 ms (it makes really cool transitions). I adjusted the declicker to 1000 like you suggested and the click effect is less noticeable, but it's still there

  • Squeller
  • [*][*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #236
Am I to stupid to find it? I do not see it in the DSP settings (Win7x64/latest fb2k). It's installed:It was a clear case of RTFM. Thanks for the plugin, well done. Now I can use that useful destroy fx as found on http://smartelectronix.com/

Do you have any plans to implement a settings window for vst fx without an own gui?

Can anyone give a link for any free free vst plugins please?
kvraudio.com is undoubtly the centre of the scene for years now. BTW is slsk still existing?
  • Last Edit: 14 March, 2011, 06:02:46 PM by Squeller

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #237
Quote
Do you have any plans to implement a settings window for vst fx without an own gui?
Quote
Yes, the feature is essential to any VST host and it'll be implemented by 1.0 release.

  • artyomk3d
  • [*]
foo_vst: VST 2.4 adapter
Reply #238
Hi!

1st. Thank You very much for such a great tool.

2nd. Is there any chance to implement some kind of "Always on top" feature for a plugin window? As it couldn't be 'builtin' in the foobar's window, this will help a lot, especially on visualization plugins. They often become obscured by main window during songs navigation.

Best regards.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #239
Unfortunately, no. DSPs handle their windows themselves.

  • artyomk3d
  • [*]
foo_vst: VST 2.4 adapter
Reply #240
Unfortunately, no. DSPs handle their windows themselves.


But You somehow added "Load FXP..." and "Save FXP..." to DSP window title. So it might be possible add "Always on top" option, which will set the appropriate window "flag". Right now I can do this with external utility, but it would be great to have this feature "built-in".

Best regards.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #241
In this case it'll be on top of everything else, not just the main window. And it will only be aplicable to VST plug-ins.

It's easy to put an item into the window's menu, but with Foobar2000 it's somewhat difficult to get window things working right. As I said before in this thread you are not supposed to have modeless DSP config windows in Foobar2000 at all. Nevertheless, if on-top-of-everything is ok for you, then I'll add that option.
  • Last Edit: 24 March, 2011, 07:56:07 AM by Yegor

  • zradu
  • [*]
foo_vst: VST 2.4 adapter
Reply #242
something news about version 1.0?

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #243
Nope. I'm way too busy at the moment.

  • dyermaker
  • [*]
foo_vst: VST 2.4 adapter
Reply #244
thanks alot for this plugin yegor.. ive had some fun messing around with it

i was wondering would it be possible to embed a vst as an element in foobars ui?

id love to have a nice vst scope or parametric equalizer as part of the interface.. (one can only dream)

keep up the good work

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #245
Yes, it might be cool. But VST plug-ins don't allow to change the editor window size and it's not very easy to keep track of plug-in instances. And in most cases plug-ins GUI isn't supposed to be embeddable.

  • bsw11
  • [*][*][*]
foo_vst: VST 2.4 adapter
Reply #246
Any ETA on the multi-channel update?

If its going to be much longer a simple tweak to just take the plugin out of the chain on multi-channel tracks would be greatly appreciated.

Thanks!

foo_vst: VST 2.4 adapter
Reply #247
This is a great plugin, thanks. I like the way it integrates with Foobar2000 normal dsp plugins, and appears in the list for tweaking from the view menu. Pretty cool.
I'm running Win 7 with an i7 multicore processor, and got lots of ram etc. and using lots of different vst plugins, including some talked about in posts here. I don't experience any crashes so far. it runs most and is stable. Glitches only seem to occur when other programs in Windows get busy. I would recommend this above any other vst enablers around.

  • Mr.Duck
  • [*][*]
foo_vst: VST 2.4 adapter
Reply #248
I don't mean to nag for the v1.0 update... I just had the idea that for plugins with no GUI, could just open some cfg file for manual control adjustment. If that helps making the programming a lot easier? Then you don't need to write a GUI system with sliders etc.

  • tribaljet
  • [*][*]
foo_vst: VST 2.4 adapter
Reply #249
This is a great plugin, thanks. I like the way it integrates with Foobar2000 normal dsp plugins, and appears in the list for tweaking from the view menu. Pretty cool.
I'm running Win 7 with an i7 multicore processor, and got lots of ram etc. and using lots of different vst plugins, including some talked about in posts here. I don't experience any crashes so far. it runs most and is stable. Glitches only seem to occur when other programs in Windows get busy. I would recommend this above any other vst enablers around.


Given that not everyone has an i7 cpu or tons of ram, people have to make compromises. I'm running 4 items on my DSP chain, including a relatively heavy mastering suite, and I have zero issues whatsoever running on a core duo cpu. We are talking about a player, so tweaking buffer settings, optimal DSP ordering and avoiding the cpu to do the audio hardware resampling are all good ways to avoid any glitches.

That being said, I experienced no crashes since day one when using foo_vst, only a slightly slower foobar startup. This VST wrapper is highly recommended over all competing solutions (and I was a fan of George Yohng's wrapper).