Skip to main content
Topic: foo_playlist_organizer (aka foo_plorg) (Read 147933 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_playlist_organizer (aka foo_plorg)

Reply #200
I have massage after set v 1.9.1: "Failed to load DLL: foo_plorg.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000."

My Foobar v 1.1.6

What can i do?



foo_playlist_organizer (aka foo_plorg)

Reply #203
Have you even tried?
Windows 10 Pro x64 // foobar2000 1.3.10



foo_playlist_organizer (aka foo_plorg)

Reply #206
a request:
since I use drag'n'drop of music tracks really frequently, holding CTRL every time to target a playlist is nonsense. If someone finds that feature useful, could there at least be an option to reverse drag and drop behavior (Left mouse to drop a selection to playlist; Left mouse+CTRL to create a new playlist)?


yes, this would be fine.

Now implemented in the  new version. The Ctrl key has no more effect and its behavior is implemented in standard drag&drop operations.
Please also install Microsoft Visual C++ 2010 Redistributable Package if necessary.

foo_playlist_organizer (aka foo_plorg)

Reply #207
I load v2.1 - no good result!

"Failed to load DLL: foo_plorg.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000."


Foobar v 1.1.6
Windows  XP SP2 32

Please give old version.

foo_playlist_organizer (aka foo_plorg)

Reply #208
The required dependency is 4 meg. Is it really a problem to click on a link and install? Keep in mind that, oftentimes, program authors may not want to support old versions. Guess you can sit and wait for someone to supply you an old version, you can follow the simple requirements of the current version or just use google and source the old version yourself, or repeat the same message again.

 

foo_playlist_organizer (aka foo_plorg)

Reply #209
I found a bug with 2.1
I select a playlist where I want to copy a track to another playlist
then drag'n'drop the item on my target playlist
the number of items counts up, the source playlist stays active and selected.
Now I check the target playlist and click and it is magically filled with the complete content of the source playlist, or with itself.
The more I try to switch the more same items are added.
This happens mostly directly after copying.
If I wait some seconds it works methinks.
I suppose there is some background library action to be finished?
Maybe it's my fault - but in previous versions (with holding the Ctrl Key) it worked.



foo_playlist_organizer (aka foo_plorg)

Reply #212
Now fixed in the  new version.
Please redownload or use foobar builtin updater.

foo_playlist_organizer (aka foo_plorg)

Reply #213
When I start foobar the console shows me:
Columns UI/Tab stack: Warning: Playlist Organizer panel was visible on creation! This usually indicates a bug in this panel.

I get no misbehavior or whatsoever though. Just to let you know.
The very act of observing, influences what happens.

foo_playlist_organizer (aka foo_plorg)

Reply #214
Although all requirements are fullfilled (MS Visual C++ 2010 Package x86 and x64) quicksearch and plorg cannot be loaded. At startup i am told that "procedures couldn't be found" (probaly not the correct translation from german).

Win7 x64 SP1
foobar 1.1.6
latest versions of quicksearch and plorg


foo_playlist_organizer (aka foo_plorg)

Reply #216
Can I ask why did you change to dynamic runtime linking? I'm just wondering if it is worth the added pain for the users...

foo_playlist_organizer (aka foo_plorg)

Reply #217
Works here. Although I have Microsoft Visual C++ 2010 SP1 Redistributable Package installed.

Thanks, I'll update the link on the first post.

Can I ask why did you change to dynamic runtime linking? I'm just wondering if it is worth the added pain for the users...

Because of VS2010 ... and it was worth the added pain for the developer.


foo_playlist_organizer (aka foo_plorg)

Reply #219
I think the VS2010 does not need dynamic linking... I've compiled my queuecontents a while (almost since the start if I remember correctly) using VS2010.

foo_playlist_organizer (aka foo_plorg)

Reply #220
I think the VS2010 does not need dynamic linking... I've compiled my queuecontents a while (almost since the start if I remember correctly) using VS2010.

Compiled statically, I mean.


foo_playlist_organizer (aka foo_plorg)

Reply #222
Can I ask why did you change to dynamic runtime linking? I'm just wondering if it is worth the added pain for the users...
Because of VS2010 ... and it was worth the added pain for the developer.
Which pain did you have? Normally, it should be only a matter of switching the code generation from /MD to /MT. I made the last updates of some of my components already with VS2010 and static linking against the runtime library without any problems.

foo_playlist_organizer (aka foo_plorg)

Reply #223
[quote author=q-stankovic link=msg=753921 date=1304103100]Just installed and no success to load the components.[/quote]
Copy msvcp100.dll and msvcr100.dll to foobar2000 folder and try again... Maybe this will help.

foo_playlist_organizer (aka foo_plorg)

Reply #224
Thanks, that solved the issue.

 
SimplePortal 1.0.0 RC1 © 2008-2019