Skip to main content

Topic: foo_quicksearch (Read 128574 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • NEMO7538
  • [*][*][*][*][*]
  • Developer
foo_quicksearch
Reply #75
Could you consider to expand the size of the history in a later version, please? Actually I have reached its limit (32 entries).
Done.
  • Last Edit: 08 May, 2010, 06:16:19 AM by NEMO7538

  • kerpondile
  • [*][*][*]
  • Developer
foo_quicksearch
Reply #76
Would it be possible to define action for "enter" key (specifically playing the search results)?

I like to keep autosearch very fast but I would expect it to start playing the search results by pressing enter.

Thanks

  • NEMO7538
  • [*][*][*][*][*]
  • Developer
foo_quicksearch
Reply #77
I have added this option to the todo list.
BTW I was having a look at the classes (DropSourceImpl and the like ... from foo_queuecontents) and wondering whether I could reuse them since I am now working to implement drag & drop capability in foo_plorg. As far as I can read from the license terms it is feasible. Can you confirm?

  • kerpondile
  • [*][*][*]
  • Developer
foo_quicksearch
Reply #78
I have added this option to the todo list.
BTW I was having a look at the classes (DropSourceImpl and the like ... from foo_queuecontents) and wondering whether I could reuse them since I am now working to implement drag & drop capability in foo_plorg. As far as I can read from the license terms it is feasible. Can you confirm?


Thanks!

About foo_queuecontents: Yep, go ahead! It's good to know that it's useful to somebody. If you want, send me a PM and I might be able to explain more about it.

  • watercolor
  • [*][*][*]
foo_quicksearch
Reply #79
>Please note that the context menu is not available (and grayed) when several entries are selected in the playlist view.
Why? Please make available Search for same menu when selecting multiple track on playlist.
Or, Do I have to use old version Quick Search Toolbar?

  • NEMO7538
  • [*][*][*][*][*]
  • Developer
foo_quicksearch
Reply #80
The old version was using only one entry.

  • Falstaff
  • [*][*][*][*][*]
foo_quicksearch
Reply #81
Bonjour NEMO,

a display issue : white background flashes (custom bg colour set to a drak grey one) when i resize my foobar window, and sometimes, the bg of the quicksearch toolbar stay white after my window resize (rare but happens).

i display quicksearch in a panel stack splitter in a CUI layout.

another issue, always after a resize, the cursor is nor more displayed, even if i put focus on quicksearch toolbar

could you tell me if it can be fixed ?

thanx.

EDIT: tested on v1.7 and v1.8
  • Last Edit: 08 May, 2010, 02:48:11 PM by Falstaff

  • watercolor
  • [*][*][*]
foo_quicksearch
Reply #82
The old version was using only one entry.

Yes, I know. But old version can execute Search for Same menu command on multiple track.
I don't hope multiple value search.
Simply, When all selected tracks artist or album is same, I want to do Search for Same Artist or Album menu execute.
Of course, If Quick Search use last select track value, problem is nothing like cause different value between selected tracks.

Sorry my poor English. Thank you.

  • Robertina
  • [*][*][*][*][*]
  • Banned
foo_quicksearch
Reply #83
Could you consider to expand the size of the history in a later version, please? Actually I have reached its limit (32 entries).
Done.

Thank you very much.
Robertina.
This is HA. Not the Jerry Springer Show.

  • NEMO7538
  • [*][*][*][*][*]
  • Developer
foo_quicksearch
Reply #84
a display issue : white background flashes (custom bg colour set to a drak grey one) when i resize my foobar window, and sometimes, the bg of the quicksearch toolbar stay white after my window resize (rare but happens).
i display quicksearch in a panel stack splitter in a CUI layout.

another issue, always after a resize, the cursor is nor more displayed, even if i put focus on quicksearch toolbar
I will investigate the flickering ... but I am not sure I can reproduce the cursor vanishing

  • Falstaff
  • [*][*][*][*][*]
foo_quicksearch
Reply #85
a display issue : white background flashes (custom bg colour set to a drak grey one) when i resize my foobar window, and sometimes, the bg of the quicksearch toolbar stay white after my window resize (rare but happens).
i display quicksearch in a panel stack splitter in a CUI layout.

another issue, always after a resize, the cursor is nor more displayed, even if i put focus on quicksearch toolbar
I will investigate the flickering ... but I am not sure I can reproduce the cursor vanishing


ok, thanx. To reproduce the cursor vanishing (and the rest), you can install my Tech config (it encounters the pb)

Regards,
  • Last Edit: 12 May, 2010, 06:27:55 AM by Falstaff

  • Falstaff
  • [*][*][*][*][*]
foo_quicksearch
Reply #86
cursor vanishing don't happen on windows XP, only on Seven, damned, when will you install Seven NEMO to fix it ?
  • Last Edit: 14 May, 2010, 07:00:08 AM by Falstaff

  • Falstaff
  • [*][*][*][*][*]
foo_quicksearch
Reply #87
cursor vanishing fixed and flickering too ... my bad (or PSS ?) when used in a Panel Stack Splitter, we have to place panels by using $movepanel_c() function instead of manual placing by using padding values ...

now it's perfect

  • NEMO7538
  • [*][*][*][*][*]
  • Developer
foo_quicksearch
Reply #88
cursor vanishing fixed and flickering too ... my bad (or PSS ?) when used in a Panel Stack Splitter, we have to place panels by using $movepanel_c() function instead of manual placing by using padding values ...

now it's perfect

Well .. it's strange because I did reproduce some flickering on my side (not using PSS). It is now fixed and I just uploaded a new version which eliminates the flickering, at least on XP. Please redownload and confirm. Thanks.

  • WilB
  • [*][*][*][*]
foo_quicksearch
Reply #89
I find that on XP using PSS & $movepanel_c(), flickering occurs on track change but not on window size change. Using straight placement in PSS results in flickering on window resize but not on track change.

Edit: I will try the new version just uploaded after I originally posted.

Edit again: The new version resolves the flickering in PSS on track change or window resize using either $movepanel_c() or straight placement.

Thanks for the fix.
  • Last Edit: 14 May, 2010, 01:44:52 PM by WilB

  • Falstaff
  • [*][*][*][*][*]
foo_quicksearch
Reply #90
thanx a lot for the fix, i'll try it tomorrow

  • Falstaff
  • [*][*][*][*][*]
foo_quicksearch
Reply #91
ok, v1.9 tested, no more flickering at all, but still a bug display if i maximize the foobar window or when i restore default size ==> bad refresh, the quicksearch background goes white truncated

it was ok on v1.8.

i hope you'll ba able to find what's the pb.

EDIT: display corrected when i mouse over the bad display
  • Last Edit: 15 May, 2010, 09:44:37 AM by Falstaff

  • NEMO7538
  • [*][*][*][*][*]
  • Developer
foo_quicksearch
Reply #92
I'm sorry but I cannot reproduce this behavior.

  • Emcee
  • [*]
foo_quicksearch
Reply #93
[Request] Direct access to the history via drop-down menu would be nice >> two mouse clicks less... 

  • ayuyaia
  • [*]
foo_quicksearch
Reply #94
Could not get this to work. With foobar 1.0.2 (portable install), after putting it in the components folder, I got an error message (missing dependencies) on startup (despite using the newest Columns UI). Then, the foobar 1.0.3 installer, updating my installation, popped up a dialog box saying it would delete this dll. Am confused...
  • Last Edit: 20 May, 2010, 07:31:37 PM by ayuyaia

  • NEMO7538
  • [*][*][*][*][*]
  • Developer
foo_quicksearch
Reply #95
Could not get this to work. With foobar 1.0.2 (portable install), after putting it in the components folder, I got an error message (missing dependencies) on startup (despite using the newest Columns UI). Then, the foobar 1.0.3 installer, updating my installation, popped up a dialog box saying it would delete this dll. Am confused...

I am not aware of specific dependencies, not even with CUI. Are you sure you are using the latest version?

  • ayuyaia
  • [*]
foo_quicksearch
Reply #96
Yes, I just reinstalled the latest version (dated 14 May 2010) and obtain the error message
Code: [Select]
Failed to load DLL: foo_quicksearch.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.

  • ArianneG
  • [*]
foo_quicksearch
Reply #97
Hello. Just tried to download the component using the link provided in your first post and failed. I cannot access it in either Firefox or IE, keep getting a blank page and no prompts to save any files. Is the site/server/whatever hosting the file down?

  • NEMO7538
  • [*][*][*][*][*]
  • Developer
foo_quicksearch
Reply #98
Yes, I just reinstalled the latest version (dated 14 May 2010) and obtain the error message
Code: [Select]
Failed to load DLL: foo_quicksearch.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.
I'm sorry but I cannot reproduce ... (just tested with a plain foobar + CUI install. in portable mode on XP)


Hello. Just tried to download the component using the link provided in your first post and failed. I cannot access it in either Firefox or IE, keep getting a blank page and no prompts to save any files. Is the site/server/whatever hosting the file down?
The server is up and running at the moment.

  • biatche
  • [*]
foo_quicksearch
Reply #99
anybody mind mirroring the latest version to rapidshare or something. i think i have bad routing here, i can't seem to download from the posted link in #1

thanks!