Skip to main content

Topic: Lame Encoder (Read 4006 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • cunningvan
  • [*]
Lame Encoder
Hi all,

I have downloaded the lame source code. Now i wish to try to encode a wav file into mp3

I am currently on vista. From cmd, when i cd into the directory, i type lame --help.

But they return 'lfnfor' is not recognised as an internal or external command.

What is wrong here?

  • memomai
  • [*][*][*][*]
Lame Encoder
Reply #1
You first have to compile the source code before getting it worked.
Just download newest stable and compiled lame version here:
http://rarewares.org/mp3-lame-bundle.php
FB2K,APE&LAME

  • cunningvan
  • [*]
Lame Encoder
Reply #2
You first have to compile the source code before getting it worked.
Just download newest stable and compiled lame version here:
http://rarewares.org/mp3-lame-bundle.php


Thanks memomai.. But if i want to compile the code which file do i compile? I downloaded cygwin.. Then i try to compile the file encoder.c.. But it return me lots and lots of errors. Im sure i have did something wrong.

Can anyone correct me?

  • memomai
  • [*][*][*][*]
Lame Encoder
Reply #3
the link I've posted for you contains pre-compiled LAME bundles. You don't have to compile anymore.

But if you want to compile the source code on your own, you have to use visual studio with an compiler for example.

download visual studio express from microsoft.com, it is free for use (LAME is written with C). Try it out.

EDIT: Correction of the programming language from VB to C.
  • Last Edit: 10 September, 2009, 07:49:35 AM by memomai
FB2K,APE&LAME

  • Xire
  • [*]
Lame Encoder
Reply #4
download visual studio express from microsoft.com, it is free for use (I think Lame is written with VB). Try it out.


That was funny 
If Lame was written in VB, it would take ages to compress one file and it would most probably crash at the end, anyway.
Lame is written in C and you can compile with VC++ express (open solution file provided with the soulrce) or cygwin (run ./configure and then make).

  • memomai
  • [*][*][*][*]
Lame Encoder
Reply #5
sorry for the mistake. I've corrected it anyway. I was too busy with good old Monkey's Audio Version History at this moment
FB2K,APE&LAME