Skip to main content

Topic: foo_playlist_attributes (Read 96387 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • mrinferno
  • [*][*][*]
foo_playlist_attributes
Reply #175
thanks for the update.

might have found a regression though.

looks like after a close and reopen of foobar, it always goes back to the last playing song on previous run of app.
no matter if i have "Bookmark last playback position" turned off or on; i've also tried to override it with "Playback on active playlist" and it still always goes back to the last played song.
Double clicking on a song on a different playlist or highlighting a different playing and clicking the play button.

i have to hit play then stop then switch to another playlist, then hit play again.

  • amalone
  • [*]
foo_playlist_attributes
Reply #176
I would like to set the attributes for all playlists using a Template, but exclude the Default and Audio CD playlists. I would like the restrictions for Default and Audio CD to always remain as "Disable removing the playlist only". I don’t see in the help file how to do this.

Thank you for your work on this component.

  • fbuser
  • [*][*][*][*][*]
  • Developer
foo_playlist_attributes
Reply #177
looks like after a close and reopen of foobar, it always goes back to the last playing song on previous run of app.
Please, check if "Main menu -> File -> Preferences -> Advanced -> Tools -> Playlist attributes -> Use last playing playlist for playback after program restart" is checked. If yes, please uncheck it. Otherwise the described behaviour is not reproducible.

no matter if i have "Bookmark last playback position" turned off or on
Bookmarking sets only a marker on the relevant playlist, which will be considered, when the playback starts on this playlist, but it does not choose the playlist, from which to play.

i've also tried to override it with "Playback on active playlist" and it still always goes back to the last played song.
The option mentioned above has precedence over this option.

I have to hit play then stop then switch to another playlist, then hit play again.
Small correction, in case the option mentioned above is activated.


I would like to set the attributes for all playlists using a Template, but exclude the Default and Audio CD playlists. I would like the restrictions for Default and Audio CD to always remain as "Disable removing the playlist only". I don’t see in the help file how to do this.
It is not possible to exclude playlists while using a template.

  • mrinferno
  • [*][*][*]
foo_playlist_attributes
Reply #178
looks like after a close and reopen of foobar, it always goes back to the last playing song on previous run of app.
Please, check if "Main menu -> File -> Preferences -> Advanced -> Tools -> Playlist attributes -> Use last playing playlist for playback after program restart" is checked. If yes, please uncheck it. Otherwise the described behaviour is not reproducible.


yep, that was it.
sorry, didn't realize there were some extra settings in there.

works like a champ now.
thanks again for the update!

  • exxecutor
  • [*][*]
foo_playlist_attributes
Reply #179
Thanks for the update!

However: since the new version I have problems using "Remove played tracks" together with "Continue on playlist...". Now, when finishing a track which is not the last track of the playlist, it plays the next track (like it is supposed to) but just for a split second (Opening track... appears in the Console) and then it rapidly switches to the other playlist. I think it should only switch after the last track of the playlist. Can anyone confirm this?

  • fbuser
  • [*][*][*][*][*]
  • Developer
foo_playlist_attributes
Reply #180
Confirmed. There is definitely something wrong. Thanks for the report.

foo_playlist_attributes
Reply #181
Thanks for all your hard work.

I think I'm seeing something different about the new release. It seems to make the current playing playlist active each time I begin play. Is this by design 'cos it's rather annoying?
  • Last Edit: 05 June, 2012, 04:25:52 PM by Black_Over_Bills_Mothers

  • fbuser
  • [*][*][*][*][*]
  • Developer
foo_playlist_attributes
Reply #182
Is this by design
This depends on your settings. But it was indeed necessary for one or two options to activate the playing playlist, where it was not done before.

foo_playlist_attributes
Reply #183
Following on from my previous post regarding the new version making the current playing playlist active. Since I find this 'feature' annoying, I have tried several settings and have stumbled upon a way to prevent it. If I set 'Start Playback On First Track' to disabled playlist activation no longer happens. Curious!

  • fbuser
  • [*][*][*][*][*]
  • Developer
foo_playlist_attributes
Reply #184
This is no surprise. "Start playback on the first track" is one of the mentioned options, where the behaviour changed.

foo_playlist_attributes
Reply #185
since the new version I have problems using "Remove played tracks" together with "Continue on playlist...". Now, when finishing a track which is not the last track of the playlist, it plays the next track (like it is supposed to) but just for a split second (Opening track... appears in the Console) and then it rapidly switches to the other playlist. I think it should only switch after the last track of the playlist. Can anyone confirm this?


Confirmed. There is definitely something wrong. Thanks for the report.


have the same problem but without the combination with "Continue on playlist...":  a second is played and playback stops. Before that happened i tested prioritized playlist and after deleting it i remarked what exxecutor described but it continued playing on last playing playlist (nothing setted for "continue on ..."!). Now - for whatever resons - playback just stops like described in my first sentence. It doesn't matter if the remove-function is setted globally or just for a special playlist.
  • Last Edit: 07 June, 2012, 08:24:54 PM by q-stankovic
german support forum: www.foobar-users.de / user: qwert73

  • delusion
  • [*][*]
foo_playlist_attributes
Reply #186
i have similar problems...
we use fb2k with playlist attributes and scheduler to arrange our community radio station shuffle playout.
i work with up to 20-30 playlists, arranged by music-style like World, Rock, R&B, etc.

i use the following command in scheduler to switch from one playlist to another, enqueue a random track and switch to another playlist:
C:\Program Files\foobar2000\foobar2000.exe /playlist-activate:"Jingles" /command:"Enqueue Random" /playlist-activate:"Pop"

another way to jump from one playlist to another, including fade-change from overlap to fade.
C:\Program Files\foobar2000\foobar2000.exe /playlist-activate:"Jingles" /command:"Flush playback queue" /command:"Enqueue Random" /playlist-activate:"Pop" /command:"Overlap instead of crossfade"

this system ran stable since a few weeks.
but from then on, foobar jumps, from almost any of the playlists the scheduler switched to, into the playlist "World".

i did not set any global prioritised, "continue on..." playlists or "playback on active playlist".
when there is a "StartPlayback-Command" in the scheduled task, it then plays from the right playlist.
but not if i switch into another playlist with the first of my above commands "on-the-fly" during a track playing. then it plays from "world".

tomorrow i will test to remove playlist attributes from foobar, and see how this behaviour would look like without playlist attributes.

i must admit, i am not sure to exactly understand the meaning of the function "playback on active playlist".
the way i want to switch on-the-fly from a playlist to another, i wouldn't need this option activated?"
as far as i understand, a playlist will not become the active one, when i use /command:"playlist-activate:"Jingles", but will be visible.
i have to use a play-command to make it visible AND active.
if not, the last active playlist stays activated and foobar will play a track from this one and not from the one visible.

for example when ececuting a scheduled task when playlist 2 is active and playing:
1. /command:playlist-activate:"1" => playlist 1 becomes visible (highlighted in playlist-organizer), but playlist 2 stays active one (with a frame around the playlist name)
2. fb2k plays one track of (visible but not active) playlist 1

if i would add a "Start-Playback-Command" as 3. command playlist 1 would become the active one? is this assumed correctly?

i am really confused now! i think i don't see any forest, because of so much trees...

although i face problems now, I really really enjoy your hard work and want to say thank for you for this tool!!!
  • Last Edit: 25 June, 2012, 06:57:55 AM by delusion

  • delusion
  • [*][*]
foo_playlist_attributes
Reply #187
i did remove any component, the online-troubleshooter told me to, incl. playlist attributes + config

one question => where are the playlist attributes settings stored?
because i did remove the playlistattributes.cfg file before reinstalling and the options are set as before?
i did not expect to keep the playlist-attributes-settings when deleting the cfg-file...

so for now, let's see, what fb2k does now, maybe i can now see the forest...

  • j-t-r
  • [*]
foo_playlist_attributes
Reply #188
Despite the changelog says that "duplicate playback of the last track in the playlist" behaviour is fixed since v0.5 was released, I’m still encountering this issue.
I’m using Fv1.1.1.12a and these components:
7-zip reader
album list
cd audio decoder
converter
default user interface
foobar2000 core
playlist attributes
rar reader
replay gain scanner
standard dsp array
standard input array
zip/gzip reader
Any idea what to do with this? Thanks in advance.
  • Last Edit: 22 July, 2012, 05:16:15 AM by j-t-r

  • fbuser
  • [*][*][*][*][*]
  • Developer
foo_playlist_attributes
Reply #189
Any idea what to do with this?
No, the information you provided is not sufficient to analyze the problem. But it might help to describe your problem and your settings like in the post here.
  • Last Edit: 23 July, 2012, 01:27:32 PM by fbuser

  • Emerelle
  • [*][*][*]
foo_playlist_attributes
Reply #190
I seem to have a problem with the order of tracks when I send an entire album to a playlist via *add and play* option - some tracks are out of order, though not completely scrambled.

Any known problems regarding this? Otherwise extremely useful addon, many thanks for it!

  • fbuser
  • [*][*][*][*][*]
  • Developer
foo_playlist_attributes
Reply #191
This is not related to foo_playlist_attributes. Neither an option "add and play" is provided by this plugin, nor the order of the tracks in a playlist is touched in any way.

  • Emerelle
  • [*][*][*]
foo_playlist_attributes
Reply #192
Oh - I checked twice. Geez, sorry to bother. Some more research then.

  • fbuser
  • [*][*][*][*][*]
  • Developer
foo_playlist_attributes
Reply #193
since the new version I have problems using "Remove played tracks" together with "Continue on playlist...". Now, when finishing a track which is not the last track of the playlist, it plays the next track (like it is supposed to) but just for a split second (Opening track... appears in the Console) and then it rapidly switches to the other playlist. I think it should only switch after the last track of the playlist. Can anyone confirm this?

have the same problem but without the combination with "Continue on playlist...":  a second is played and playback stops. Before that happened i tested prioritized playlist and after deleting it i remarked what exxecutor described but it continued playing on last playing playlist (nothing setted for "continue on ..."!). Now - for whatever resons - playback just stops like described in my first sentence. It doesn't matter if the remove-function is setted globally or just for a special playlist.
Actually, I couldn't reproduce exactly the described behaviours, but as mentioned before, I could identify some problems, which are fixed now. If the problems still occur, please provide some more details, like it is done here.

foo_playlist_attributes
Reply #194
fbuser, that part of your component i don't use on a daily basis, i just tested what the component offers. I would have to take some time for describing the behaviour which i don't have now. I noticed the new version and will try to see in the next time if i can repeat the behaviour
german support forum: www.foobar-users.de / user: qwert73

  • gob
  • [*][*][*][*]
foo_playlist_attributes
Reply #195
Great plugin, been using it for ages. It would be great if this plugin could support the feature of foo_stopaftercuralbum, or better yet, re-create it all together since the source code exists..

http://www.hydrogenaudio.org/forums/index....showtopic=72420

  • Lesmo16
  • [*][*]
foo_playlist_attributes
Reply #196
Is it actually possible to use color control syntax <dim> and >highlight< as playlist attributes?
I would much more prefer to dim a played track than to remove it.

  • fbuser
  • [*][*][*][*][*]
  • Developer
foo_playlist_attributes
Reply #197
Is it actually possible to use color control syntax <dim> and >highlight< as playlist attributes?
No, currently not. And it won't be possible in the future, as it out of the scope of this component to make such a functionality possible. Direct support for this isn't possible anyway due to technical reasons.

  • zaede
  • [*]
foo_playlist_attributes
Reply #198
Is it actually possible to use color control syntax <dim> and >highlight< as playlist attributes?
I would much more prefer to dim a played track than to remove it.


Do you know foo_uie esplaylist ?
With this playlist you even have $rgb(0,0,0) function.

Make new tab and add foo_uie_esplaylist !
foobar2000 best player ever

  • Lesmo16
  • [*][*]
foo_playlist_attributes
Reply #199
I know foo_uie_esplaylist and it's customisation abilities, but it's foo_playlist_attributes that gives the triggers to do something with the played tracks - i.e. removing them from playlist.