Skip to main content

Topic: Auto correct DST not working (Read 7828 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Akkurat
  • [*][*][*][*][*]
  • Developer
Auto correct DST not working
I just noticed that the "Auto correct DST" setting is not working. When I set it on, clock is 1 hour behind. When I set it off and set "Is daylight saving time in effect?" on, the clock is right. What's wrong?

My time zone GMT+2 (Finland).

  • NightOwl
  • [*][*]
Auto correct DST not working
Reply #1
I experienced the same problem too. I'm in eastern Canada, EDT (GMT-4 right now).

I didn't have this problem before. Is this problem related to the move to the new server earlier this year?

  • Akkurat
  • [*][*][*][*][*]
  • Developer
Auto correct DST not working
Reply #2
Still doesn't work. has anybody tried to locate/fix this problem? Thanks.

  • Robertina
  • [*][*][*][*][*]
  • Banned
Auto correct DST not working
Reply #3
On my system (Windows XP) this situation (one hour time difference between time as shown on the HA-forum and my real local time) only occurs if I deactivate Windows own "Auto correct DST" function, accessible through Windows time/date settings (and if the system time is set manually by me to the correct time of day).

Could it be that you have deactivated the "Auto correct DST" function in your operating system as well?


This is HA. Not the Jerry Springer Show.

  • Akkurat
  • [*][*][*][*][*]
  • Developer
Auto correct DST not working
Reply #4
No I haven't.. and besides it shouldn't matter what my system settings are, I don't understand how you got the results you got. Just to be sure I tested all possible combinations; no matter what I set in my system, the time, DST setting, forum time doesn't change at all, just as expected.

  • Akkurat
  • [*][*][*][*][*]
  • Developer
Auto correct DST not working
Reply #5
Topical issue, still doesn't work. Just changed all clocks in the house and remembered this.

  • Speedskater
  • [*][*][*]
Auto correct DST not working
Reply #6
Could it be that different countries are switching to DST on different dates?
This year the US switched on March 14th.
Kevin Graf :: aka Speedskater

  • Garf
  • [*][*][*][*][*]
  • Developer (Donating)
Auto correct DST not working
Reply #7
Aha, Europe switched this weekend. But Akkurat is in Europe too.

It's correctly working for me so I really can't even reproduce Akkurats problem.
  • Last Edit: 29 March, 2010, 06:17:44 AM by Garf

  • Akkurat
  • [*][*][*][*][*]
  • Developer
Auto correct DST not working
Reply #8
That's odd.. and sadly a "won't/can't fix" then. Alright, manual change it is then every time.

All I can report is that whether I check or uncheck the "Auto correct DST" (& save setting of course), the board clock for me doesn't change at all. What is the "If selected, your DST setting is automatically adjusted when you next load the board index"? What does that actually mean? Main page?? I've tried opening that after setting that setting on but no change.

The "Is daylight saving time in effect" setting works as expected though.

Edit: tried to add the trailing question mark in the URL, but forum software always moves it after the closing /url tag.. hence the double question marks.
  • Last Edit: 29 March, 2010, 11:35:45 AM by Akkurat

  • [JAZ]
  • [*][*][*][*][*]
Auto correct DST not working
Reply #9
It does not work for me either (and didn't work last time).

My settings are for Spain (GMT +01, brussels, copenhagen, madrid, paris).

If i set right now to "auto correct DST", it tells me 16:45.
If i deselect it and select  "daylight saving time in effect?" it shows me 17:45.

If i set it at "auto correct DST", i log out, i log in again, and go to check, the time is still not using daylight savings (so still at 16:xx ).


  • Garf
  • [*][*][*][*][*]
  • Developer (Donating)
Auto correct DST not working
Reply #10
Can you guys try something?

Uncheck auto correct DST, and then flip the "is DST in effect" checkbox, and then recheck auto correct DST. Then force a reload on the index page.

  • Akkurat
  • [*][*][*][*][*]
  • Developer
Auto correct DST not working
Reply #11
Ok, accidentally landed on a solution.

1) Set "Auto correct DST" on ("Is daylight saving time in effect" doesn't have to be on) & save settings.
2) Open Forums link. This page load changes/applies the correct time, but notice that you can't see the correct time on that page yet, you have to load that page or some other HA page again.

That's it. Couple of things:

1) "If selected, your DST setting is automatically adjusted when you next load the board index" is misleading.
EDIT: 1.1) So, does this actually mean that I must remember to load that "Forums" page again every time after DST changes, i.e. 2 times per year? If yes, that explains the following 2nd question below. EDIT2: And if yes, basically that means that there's no "auto" DST for users like me who very rarely go to that page.
2) Why the code responsible of "applying" the Auto DST isn't in the "Board Settings" page where you actually change that setting? And so that the time changes without extra page reload. (I guess this is a question to IPB)
  • Last Edit: 30 March, 2010, 08:08:44 AM by Akkurat

  • [JAZ]
  • [*][*][*][*][*]
Auto correct DST not working
Reply #12
Indeed!

It requires that one goes to the forums (sub)page, instead of the main page. Now it changed for me too.