Skip to main content

Topic: Twitter Post (Read 40159 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #25
????Twitter??????????????????????????????????????
As Twitter is blocked in China, a proxy setting is really heavilly needed. can you add this setting to the plugin or let us set own APIs?
That will be a GREAT help!
Thanks

I released new version "foo_twitter_post v1.8.1".
This version enable to set proxy.
Check this version.

Download here

  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #26
@kitahei:
Is there any way to change twitter API URL?
since twitter.com is blocked here, I'd like to switch to a twitter api proxy, such as nest.onedd.net/api
Thanks in advance.

I released new version "foo_twitter_post v1.8.1".
This version enable to set proxy.
Check this version.

Download here

Twitter Post
Reply #27
ええ~ 出来た~!
Viaプロクシサーバはちょっと遅い。でも、ホントに助かったよ。ありがとう。

Fantastic it works!
Although it is much slower to send tweets via proxy, it is better than blocked so it really helps so... Thank you!

Moderation:Removed unnecessary full quote of the preceding post.
  • Last Edit: 09 January, 2010, 07:38:23 AM by Yirkha

  • gutzz
  • [*]
Twitter Post
Reply #28
How about autopost on album change?
I think it would be a great options..

IMO, autopost on every track change is very annoying even with intervals .

Twitter Post
Reply #29
Would it be possible to get a recompile of this with the latest foobar sdk? As it doesn't work with foobar 1.0

  • Jubei
  • [*][*]
Twitter Post
Reply #30
Great! Just downloaded.

  • Meez01
  • [*]
Twitter Post
Reply #31
love this plugin, but i don't see the twitter post option in the tray icon.??

  • radwimp
  • [*]
Twitter Post
Reply #32
I don't get any submenu in the context menu either, even though it's set up to be there...

Twitter Post
Reply #33
It's under Playback in foobar 1.0

  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #34
2010/02/21

I released new version "foo_twitter_post v2.0.1".

Note
  • Foobar2000 v1.0 series is needed since this version.
  • The Twitter password is reset, and please set the password in preferences page again when updating it from the version before foo_twitter_post v1.8.1 to this version.

Change Log
  • Rebuild with latest SDK.
  • Changed: OK/Cancel/Apply button in preferences page was enabled.
  • Fixed: The "Post to Twitter" menu was displayed from the Now Playing context menu.
  • Changed: The preservation method of the Twitter password was changed.
  • Changed: The Automatic Post Settings group was made to contain the Other Settings group (preferences page).

Download here

  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #35
How about autopost on album change?
I think it would be a great options..

IMO, autopost on every track change is very annoying even with intervals .

Sorry. Autopost on album change  is impossible.

  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #36
Would it be possible to get a recompile of this with the latest foobar sdk? As it doesn't work with foobar 1.0

Done. Please check new version "foo_twitter_post v2.0.1".

Download here

  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #37
love this plugin, but i don't see the twitter post option in the tray icon.??

Please use new version "foo_twitter_post v2.0.1" if you are using foobar2000 v1.0.

Download here

  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #38
I don't get any submenu in the context menu either, even though it's set up to be there...

Please use new version "foo_twitter_post v2.0.1" if you are using foobar2000 v1.0.

Download here

Twitter Post
Reply #39
Thanks for the component.

While using the plugin I get the error message on the console
Code: [Select]
j.mp Error Code : 201
j.mp Error Message : Missing parameter longUrl


For the message I use this code:
Code: [Select]
[%meta genre%-]Tip des Tages: $if([%album artist%],$cut(%album artist%,38))$if([%album%], - "$cut(%album%,38)")$if(%date%, $char(91)%date%$char(93),) $if(%DISCOGS_LABEL%,$char(91)$cut(%DISCOGS_LABEL%[ %DISCOGS_Catalog%],38)$char(93),[%publisher%])


And for the URL I use:
Code: [Select]
$if(%DISCOGS_RELEASE_ID%,'http://www.discogs.com/release/'%DISCOGS_RELEASE_ID%,)


The post is posted but not the link. What am I doing wrong?

Regards,

Chris
  • Last Edit: 21 February, 2010, 06:37:52 AM by Chris Norman

  • Yirkha
  • [*][*][*][*][*]
  • Moderator
Twitter Post
Reply #40
Sorry. Autopost on album change  is impossible.
Why?
Full-quoting makes you scroll past the same junk over and over.

  • Andu
  • [*][*][*]
Twitter Post
Reply #41
The component is really crash happy (using v.2.0.1 on foobar 1.0.3) and posting without comment doesn't work at all.

  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #42
I am sorry for the reply's slowing.

Code: [Select]
$if(%DISCOGS_RELEASE_ID%,'http://www.discogs.com/release/'%DISCOGS_RELEASE_ID%,)

Perhaps, %DISCOGS_RELEASE_ID% is empty.
Please use a new version v3.0.1.

Download here


  • Andu
  • [*][*][*]
Twitter Post
Reply #43
kitahei I hope you managed to make the crashes go away. Right now foobar2000 considers this to be crashware if you run the troubleshooter.

Twitter Post
Reply #44
Tried the new version and it doesn't post to twitter. It gives this in the console each time I try and use it.
Twitter Post: Unauthentication.

I've made sure under the preferences that it succeeds with my login details.

  • Andreasvb
  • [*][*][*][*][*]
Twitter Post
Reply #45
I had the same issue.

Delete the auth and enter again.

Hope it works, did for me.
Windows 10 Pro x64 // foobar2000 1.3.10

  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #46
Tried the new version and it doesn't post to twitter. It gives this in the console each time I try and use it.
Twitter Post: Unauthentication.

I've made sure under the preferences that it succeeds with my login details.


Please try following.
  • Authentication is made to succeed.
  • OK/Apply button down in preferences page - important
  • Play next track - important
  • Post to Twitter


  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #47
I had the same issue.

Delete the auth and enter again.

Hope it works, did for me.

Please try following.
  • Authentication is made to succeed.
  • OK/Apply button down in preferences page - important
  • Play next track - important
  • Post to Twitter

  • kitahei
  • [*][*]
  • Developer
Twitter Post
Reply #48
kitahei I hope you managed to make the crashes go away. Right now foobar2000 considers this to be crashware if you run the troubleshooter.

V2.0.1 has the possibility of crashing and please make it to crashware.
I will have fixed the bugs of the crash in v3.0.1.

Twitter Post
Reply #49
Works now many thanks!