Skip to main content


Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: FFmpeg 0.5 "Bike Shed" (Read 29075 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

FFmpeg 0.5 "Bike Shed"

Reply #25
I think its better to use shared mode, so we can update dll's without recompiling it.

@ john - did you apply mp3 patch from my previous post? I dont see sources...

@ aradzish - why not to use only all inclusive version?

Forgive me if I'm being a bit dense, but I don't see a patch there other than the one to libavcodec.c that confirms the 'bug'? If someone has a fix for this, I'm more than happy to apply it.

I note and agree with the comments regarding the shared mode, I was just happy to put a full build together that seemed to work as expected!  If I receive the lame patch, I'll try a full shared mode build.

FFmpeg 0.5 "Bike Shed"

Reply #26
Could someone please share the latest ffmpeg precompiled for linux with static libs?

FFmpeg 0.5 "Bike Shed"

Reply #27
- Seems work fine the new parameter -drc_scale <float>. Remember use -drc_scale 0.0 when you need ac3 audio to transcode.

- The multichannel audio (ac3, aac, ogg, mlp) still have problems with the wrong channelmapping.

FFmpeg 0.5 "Bike Shed"

Reply #28

It's worth pointing out that ffmpeg still maintains the property that if you request vorbis via -acodec vorbis you get the "ffmpeg internal" vorbis encoder while -acodec libvorbis is required to get the external encoder.

This is relevant because the internal encoder is very simplistic and clearly underperforms the reference implementation (and AoTUV, of course).  I can say this on purely objective grounds— it frequently misses bitrate targets and produces streams with bad granpos values which wedge some decoders, but the encoder is also artifact prone enough that it has caused quality related complaints where users have unwittingly used it (and you can compare for yourself, I threw up some examples notice the significant birdie artifacts), so it even fails a simple unintentional blind test.

It's impressive and laudable work that the FFMpeg has implemented their own independent encoder that works at all. As far as I'm aware it's the only publicly available encoder not derived from libvorbis. But at the same time the quality is very low so the decision to place that encoder where users will use it without a conscious decision to do so is very unfortunate. I hope that a future version either improves the internal encoder to match libvorbis, replaces it with libvorbis (which is BSD licensed for a reason…), or at least stops giving the internal codec to users without a stern warning.


FFmpeg 0.5 "Bike Shed"

Reply #29
It has been a very long time since we last made a release and many did not think we would make one again but, back by popular demand, we are proud to announce a new release: FFmpeg 0.5


Check out the release notes and changelog

Both links are broken

  • Significant work to support at least decoding of all widespread mainstream proprietary codecs, such as:
  • RealAudio Cooker and fixes for 14.4 and 28.8
  • RealVideo RV30/40

Real support became real

  • Theora (and encoding via libtheora)
  • Ogg (FLAC, Theora and Vorbis only)

Any BUGzilla around ? It's buggy

Anyone can encode this one: into Theora: FFW2 -i g.yuv g.ogv BTW, using AVI as output format doesn't have this problem.

Tried both executables advertised here, same result: Page Fault :-( The EIP's do differ but the offending code is very same, some huge and boring MMX'ed code (sorry I didn't upload the full disassembly, as this probably would crash the HA server  , also the addresses are resolved poorly) :
Used FFMPEG binary (but all do crash) mirrored here:

PS: the files are 7-ZIP's

Crash report (apparently ineligible for inline posting here):