Skip to main content

Topic: foo_upnp (Read 1202356 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • dag0
  • [*]
Reply #1700
Guys i need your help. What is the ''procedure'' to remote control foobar2000 from another notebook where i have installed another instance of foobar? I need to have the library showed up. I tried it with but i was not able to get the playback on the computer(server). I got the playback (wrongly) on the notebook in streaming...

The best way to show your library on your notebook should be to create a network share on your PC and load it in the foobar media Library on your Notebook. In foobar on your NB select Main Menu/View/UPnP Controller, select "foobar2000 Renderer" (it should show up from your PC). Media Renderer should be started in Preferences/UPnP/Server/Basic Settings on your PC.

  • dag0
  • [*]
Reply #1701
I am using Bubble Upnp on my Android to control my foobar-installation on my PC. Works fine, but I notice some strange behaviour. Lyrics of the curently played track are loaded and shown in "lyrics Show3"-Panel, but are not saved in my tags as it does normaly (it is configured this way). Even if I manually click "save" in the lyrics-panel nothing happens!

Less tragic: The Album-art of the currently played track is not shown up and there seems to be no possibility to see which track is currently played in foobar when it is remote-controlled (eg by double-clicking in the status bar as i normally do)? The playlists "UpnP-controller playback queue" and "upnp browser selection" are empty.
  • Last Edit: 19 January, 2013, 12:15:45 PM by dag0

Reply #1702
In foobar on your NB select Main Menu/View/UPnP Controller, select "foobar2000 Renderer" (it should show up from your PC). Media Renderer should be started in Preferences/UPnP/Server/Basic Settings on your PC.

I'm having issues with this. I get to the point you're describing, and I can see what my desktop is playing on my laptop, however I cannot perform every function. For example I cannot skip to the next track or it will stop playback. I cannot show controller playlist. I cannot start playback when it is stopped, however I can pause and resume playback and adjust the volume.

I am seeing this in the console:

Code: [Select]
foo_upnp: Denied WAN request (ip:, User Agent: UPnP/1.0 DLNADOC/1.50 Platinum/ / foobar2000)

If it thinks I am a WAN user for some commands, why not for the others? I'll point out that my desktop PC is a DMZ client on my internet router.
  • Last Edit: 19 January, 2013, 10:18:27 PM by CyberTootie
Project Leader of DDResampled

  • dag0
  • [*]
Reply #1703
What exactly do you want to do? Listen music on your stereo wich is connected to your PC? Remote controlled with by your NB? On your PC can you select "foobar playback stream capture" in Upnp Controller? This is the way I do it: Select "foobar stream capture" on my fantech media-player connected to my stereo. The music played on my PC-foobar (remote controlled by my Smartphone or not) is played on my stereo. Cant say anything about your network problems...
  • Last Edit: 20 January, 2013, 04:56:39 AM by dag0

  • bebopfreak
  • [*]
Reply #1704
Even if excluding FLAC to be decoded as WAV in the default profile, UPnPlay still pick up the compat WAV stream over the FLAC one for whatever reason (probably because it considers WAV to be better than FLAC).
So it doesn't seem possible to stream straight unmodified FLAC to UPnPlay, unless I add an option to not add compat WAV and LPCM stream URLs, which I've added for the next version.

Alternatively add some DLNA notation: CI=0 for non-transcoded files, as those are preferred.

  • bgunn
  • [*]
Reply #1705
New to the forum, couldn't get the search to return what I'm looking for, so I'll ask here. I'm trying to stream from a Win7 laptop w/foobar200 UPnP controller and have had some mixed results. The FLACs are being pushed to an Oppo 105.

Two things:

    1. When I first start the controller (View > UPnP Controller), only the ... button is available, the drop-down list is inactive. After some time (3 - 5 minutes) the drop-down is selectable. This cant be as designed can it? Even if it's reconnecting with the Oppo (home wireless network) it shouldn't take that long to exchange user/pwd.


    2. I was experimenting and wanted to see what Playback Stream Capture does, and it seems to be stuck in this mode. How do I exit the stream capture?


Thanks in advance!

  • Jonbooi
  • [*]
Reply #1706
Is there any way to get upnp controller to scrobble flac tracks that I am streaming to my Marantz? I can get the tracks to scrobble with foo_audioscrobbler when I play them to my PC speakers and also when I use the playback stream capture. My problem with the playback tream capture is that it plays the music out of sync with my speakers and Marantz. 

  • Kazeyomi
  • [*]
Reply #1707
Hello, great thanks for the great plugins. I am using BubbleUPnP on android and it works fine expect for two small issues:

I've set the server profile for BubbleUPnP to transfer FLAC audio to my phone without decoding it to WAV, when I play a track added by an FLAC file, it works, I see audio type FLAC on my phone. But if I play a track indexed by a CUE file, it turns out that the track will be decoded to wav. I see audio type WAV on my phone.
Similarly, a track in an archive will always be decoded to WAV, even if it's a archive of MP3 files.

I hope this two issues could be fixed, thank you.

  • simi8
  • [*]
Reply #1708
Hi, I've a problem with the last version of foo_upnp plugin. I use it to play music from my NAS(upnp) to my WD TV LIVE, it works but it stop after every song, seem like that it can't read the "UPNP Controller Playback Queue" playlist. With the earlier version I don't remember this problem.
Someone have a solution ?
Thanks in advance

  • MaxPower
  • [*]
Reply #1709
The UPnP Media Server could not be started. Port 56923 *might* be in use by another application or foo_upnp instance.

I am still facing this error message, almost on every start of foobar2000. foobar2000 (v1.1.16) / foo_upnp (v0.99.41) is started on my computer automatically at boot time. When this message appears, the foo_upnp server cannot be started, and therefore foobar2000 is not found by UPNP clients like "BubbleUPnP".

I already reported this phenomenon in posting 69664/813221 of Nov 4 2012.

Does anyone have a hint how I can solve this problem? Am I the only person facing this problem?

Interestingly, the error message text slightly changed in the very last version of the foo_upnp plugin:

v0.99.40: "UPnP Media Server could not be started. Port 56923 might be in use by another application"
v0.99.41: "The UPnP Media Server could not be started. Port 56923 *might* be in use by another application or foo_upnp instance."

I don't know if you're still having this problem, but Google brought me here for the same reason and I haven't seen a solution anywhere. In my case, the problem began when I re-installed windows on an SSD, which caused programs to start before the network was connected. I solved it by creating a batch file which delays foobar by 30 seconds, and inserted a shortcut to the .bat in my list of startup programs, in place of a direct shortcut to foobar.  Here is the .bat I use:

@echo off

rem for 30 sec delay..

timeout /t 30 > nul

rem starting delayed start programs

start /d "C:\Program Files (x86)\foobar2000" foobar2000.exe

The cmd window appears for 30 seconds, foobar launches with no errors, and cmd closes. May require modification to match your file path. Hope this helps!

  • R1200CL
  • [*]
Reply #1710
Can Foobar play flac 192/24 without any conversion ?

The question is only relevant for DNLA / UPNP, as I'm feeding a Oppo player (Actually it's a Theta Compli Blu 3D) over my home network.

The reason for me to be doubt this, is that the Oppo 95 feeds a receiver (Theta CB III HD) over HDMI, and it is not suppose to play Hi Res files, but I'm still getting sound.
The Oppo, yes should play 192/24, but not the CB III HD. I suspect the "error" may be the foobar, or my foobar setting. I'm able to get PCM, WAW and Flac on the display of the Oppo,and all plays well.

Im 100% sure the file is a 192/24 file, cause that is stated by foobar, og also the file is bought at HD Tracks.

I suppose these settings are correct. (At least, they give flac).
  • Last Edit: 20 February, 2013, 10:18:22 PM by R1200CL

  • litolf
  • [*]
Reply #1711
Hi Mr. bubbleguuum

First of all, congrats to you, the Developer.
For years i enjoy my daily hour of classical music with foo_upnp feeding my ONKYO 3007 with 2ch|44,1kHz|16bit flacs.
It always worked like a charm.

Thinking it's worth to try some high-res files, i had to recognize that neither the ONKYO nor any other receiver on the market is capable to playback multichannel delivered through network (neither flac nor lpcm).
Current AVR's are only able, to play multichannel delivered to them as lpcm via HDMI. (if some one wants to correct me, i would be happy and buy the stuff)

I thought, i was lucky, owning an OPPO-BDP83, which can deliver multichannel via HDMI.

I try to list, what works and what fails.(all files 24bit, 96kHz)

a.) OPPO as "client" browsing the upnp-tree and initializing the playback
   5.0 ch -> works == arrives at AVR as 5.0
   5.1 ch -> fails == arrives at AVR as 5.1 but channelmapping messed up (played like vinyl with 2* rpm)

b.) OPPO as "slave" listening to playback-streamcapture, fb-ui initializing the playback
   5.0 ch -> fails == arrives at AVR as 2ch (played like vinyl with 1/2 rpm)
   5.1 ch -> fails == arrives at AVR as 2ch (played like vinyl with 1/2 rpm)

My streaming profile:
Renderer Capabilities, 44100 to 192000, 24 bit, stereo only unchecked
Decoding to PCM, always to lpcm
Playback Stream Capture, lpcm 96000 16bit(can't change < greyed out)

Failing playback 5.1 seems to be a problem of the OPPO firmware, that won't be fixed any more.
So my question to the Developer are these:

1.)Is it possible (and are you willing) to implement a solution, which enables the user, to set parameters of your Component to workaround the OPPO's 5.1 bug?

2.)Why does 5.0 work in a.) and not in b.)

3.)Should 5.0/5.1 work with a non buggy renderer listening to PLAYBACK STREAM CAPTURE ?

4.)Why is Playback stream capture always limited to 16 bits by the ui when set to stream as LPCM ?

For the future i hope there will be an AVR dealing with MCH via upnp.
For the present, it will be nice, if 5.0/96kHz/24bit via Playback Stream Capture will work, because handling a large library with the fb-ui works much better than with the poor ui of upnp-renderer/player and gapless is only possible via Playback Stream Capture to.

  • R1200CL
  • [*]
Reply #1712

My Compli Blu 3D, that is an Oppo 95. Foobar with the setting in my privious post work just fine. I have verified that these settings gives 192/24 out.
Maybee time to upgrade your Oppe 
  • Last Edit: 24 February, 2013, 06:40:31 PM by R1200CL

  • Geo_log
  • [*]
Reply #1713
Is it possible .. to implement a solution, which enables the user, to set parameters of your Component to workaround the OPPO's 5.1 bug?
- already implemented. Try "Streaming Profiles" -> "Audio Procesing" and add  Matrix Mixer DSP. Then make configuration (5.0) that is  suitable for your OPPO.

  • Malcolm80
  • [*]
Reply #1714
I hope someone can help me with a problem. I use foobar with uPnP to stream music stored on my laptop wirelessly to a wd tv live media player. It works like a charm, with one exception. I cant stream wav-files.
Why? I can play them in foobar locally with no problem, and using windows media player I can stream the files with the "Play To"-feature so the problem is not with the wd.

Everything else works fine, Flac, mp3, u name it..but not wav.


  • mpuckett
  • [*][*]
Reply #1715
I must be overlooking something regarding how to do this but I cannot figure it out and would appreciate if anyone can tell me how to do this using foo_upnp.

Is there any way to have foo_upnp send a shuffled playlist to a upnp renderer? I would like to be able to select content and then using the right click context menu send it to the renderer shuffled.

Is it possible for foo_upnp to shuffle content before sending it to the renderer?

  • ziekke
  • [*]
Reply #1716
I am using foo_upnp on a foobar2000 client, and a foobar2000 server.

I am using the *default* "Streaming Profile" settings on the server, and attempting to do an override on the transcoding settings for lossless files on the client. It never seems to recognize this setting and I am still being streamed the full FLAC file.

The only way I could get it to transcode is to go into the server config for the user-agent foobar2000 and set it to always transcode, and uncheck lossless.

I don't want all foobar2k clients to be transcoded, only the ones that override. Any ideas why this could be happening?

Reply #1717
Sorry that i post directly in a conversation.

Since i change my System from Win 7 to Windows Server 2012 i got massive problems with the UPNP Play Plugin.
First i thought it was a hardware problem, because Foobar stoped working from time to time. Because the problem didn't occur very often, it was hard to find the Problem. If foobar stoped working, it was not possible to "shoot out" the process (even with very agressiv tools). Finally i had to restart my homeserver everytime Foobar stopped working.
Finally i noticed that Foobar didn't close as it should (needs a lot of time).
I removed the UPNP Plugin, and now my Foobar seems to be working fine. I already updated the UPNP Plugin, but it didn't helped out.

Strange isn't it?

Id like to use UPNP again 

  • Topology
  • [*]
Reply #1718

I'm having a problem with foo_upnp. When I first start foobar and the upnp server starts, everything works great. Instant detection by all my different devices, Nexus 7, PS3, Samsung Phone, three computers. However, when I put my computer to sleep overnight and resume it, on resume foo_upnp starts taking 2/3 minutes to be detected by any of my devices, if it gets detected at all. My guess is that it stops sending alive messages properly. Stopping and starting the upnp server fixes the problem.

It seems to be a problem that I can consistently reproduce on my setup. Running Windows 7 x64 SP1, foo_upnp 0.99.45 + foobar v1.1.18.

I've provided a log. At line 481 you can see where my computer resumes from sleeping, as evidenced by the timestamp difference.



Reply #1719
[Feature request] Access other file types (than audio) via foo_upnp

foobar2000 is a pure audio player, and that is good.

However, when accessing my audio library over UPNP (foo_upnp), letting foobar2000 act as a UNPN server, I miss the possibility to also access scanned image data (mostly .jpg) and pdf's contained in the album folders.

When I transcode a music CD into MP3, I use to also scan the booklet (resulting in multipe .jpg files in the album folder). When I find an interesting article on a certain album (on Wikipedia or at another place), I also save this article as .pdf in the album folder.

It would be great to get this meta-information files accessible via foo_upnp (especially in the "folder perspective").

"Use Case perspective":

You start to hear to your favorite album, accessing your foobar2000 library via foo_upnp, controling it with your Tablet computer and an UPNP controller app like BubbleUPnP.

Meanwhile, you use the UPNP controller app (BubbleUPnP) to also watch the .jpg and .pdf data in the same media folder.

  • litolf
  • [*]
Reply #1720
does anyone know, wether Playback stream capture is limited to stereo.

I tried to playback multichannel tracks on a client-PC(with foo_upnp as renderer ) served by a server-PC (with foo_upnp_server) .
When the client played tracks accessed from upnp-Librarytree all worked fine.
When the client played back the streamcapture, output was 2channel only. (no matter wav or lpcm was checked in streamingprofile).

So, is this a limitation by design or the upnp-spec or a bug ?

PS: I wanted to try it by controlling the client-PC from the Controlpoint on the server, but the client-PC wasn't shown in the Dropdownbox ???

  • GregoryJ
  • [*]
Reply #1721
When my music library reaches a certain size the UPnP Browser will no longer list the contents under the Music folder. It displays "loading..." for about a second and then does nothing. Consequently I'm unable to access any music content on my media server.

Does anyone know if this problem is being addressed?


foobar2000 1.2.3 w/ UPnP plugin

Media server(s):
Windows Media player (library)
BubbleUPnP Server 0.6.4 (Internet access)

Windows 7 Ultimate

Media library size:
55.7 GB
12,751 files
  • Last Edit: 22 March, 2013, 04:25:05 PM by GregoryJ

  • NEMO7538
  • [*][*][*][*][*]
  • Developer
Reply #1722
I have a problem, here is a short description :
  • Until now I had two machines on my LAN with fb2k, one acting as the server and the controller and the other as the renderer. Fine !
  • I bought myself a tablet and the excellent BubbleUpnp which I use as the controller with one machine as the server (with BubleUPnPServer as a proxy but that does not matter I think), the other one as the renderer.
    Generally speaking it works very well, except that in this configuration, metadata for compilations (I use %album artist% to tag them) are not passed the same way and on the renderer, instead of getting the artist in the %artist% tag I get this combination: %artist%; %album artist%. I tried to get rid of the ; %album artist% part after %artist% but with no success.

This is embarrassing because scrobbling is only feasible on the renderer if I want to benefit from the OpenHome renderer playlist persistence when my tablet is powered off. As well, last fm bio does not work on the renderer for compilations.
If that could help, I have also noticed that when using a controler on the server, in the "UPnP controller playback queue" playlist is updated the same way (%artist% is transformed to %artist%; %album artist%) when a track is played.
I hope it is clear enough.

Additional questions and comments :
  • From the playlist view in BubbleUpnp, the option "Show Album in Library" does not seem to work.
  • Feature request #1: Do you foresee any possibility that I could use BubbleUPnP to rate tracks and pass that information to the server ?
  • Feature request #2: It would be nice to search only in the playlist on BubbleUPnP (e.g. make the search function contextual depending on whether it is used from the playlist view or the library view)

Congratulations for you work, bravo ...  and thanks for your support.

Edit: Additional information, annoyance reporting and feature requests.
  • Last Edit: 01 April, 2013, 02:15:47 AM by NEMO7538

  • gjweb
  • [*]
Reply #1723

Is it possible to hide an artist from the Artists list in the MediaLibraryTree when "Album Artists" is "Various Artist" ?

  • BenB
  • [*][*][*][*][*]
Reply #1724

Is it possible to hide an artist from the Artists list in the MediaLibraryTree when "Album Artists" is "Various Artist" ?

That can be accomplished by modifying the foo_upnp_ml_tree.xml file located in foobar's configuration folder. If you can elaborate a bit more on what you want to display and how you want it to display, I may be willing to help you further if what you want is possible. If not, I'll let you know.
  • Last Edit: 31 March, 2013, 07:25:41 PM by BenB