Skip to main content

Topic: foo_upnp (Read 1182999 times) previous topic - next topic

0 Members and 2 Guests are viewing this topic.
  • mtr
  • [*]
foo_upnp
Reply #1675
I'm having a problem with foo_upnp and UPnPlay (on android) that I can't figure out. Even made this new account since I can't seem to login to my old one (haven't been around for ages, sorry  ). Any help is appreciated.
The problem is I can't listen to FLAC files via UPnPlay on a tablet but mp3's work just fine. The odd thing is I tried BubbleUPnP on the same tablet and that works just fine. Reinstalled foobar (1.1.8) and checked for updated plugin (0.99.40). I tried making the default stream profile the same as the BubbleUPnP one to no avail. Nothing seems to work while I know the combination has worked before. It looks to me like it is a stream profile issue where FLAC's are not decoded & streamed, but i do not see any errors i the (debug) console. I must be missing something obvious but don't see it.


I've just checked and it worked on my Nexus7. UPnPlay uses the default profile which unmodified will transcode FLAC to WAV. Maybe your tablet has problems playing WAV.
Even if excluding FLAC to be decoded as WAV in the default profile, UPnPlay still pick up the compat WAV stream over the FLAC one for whatever reason (probably because it considers WAV to be better than FLAC).
So it doesn't seem possible to stream straight unmodified FLAC to UPnPlay, unless I add an option to not add compat WAV and LPCM stream URLs, which I've added for the next version.

Quote
Also (minor issue): when foobar is already running at UPnPlay startup, it is not recognized as library/device. On restarting foobar it is immediately.


I cannot reproduce this

Thanks for the detailed response. I've been able to do a few more tests over the holidays and I think it must be a configuration issue either on the tablet or on my music PC since I had no issues streaming FLAC to my phone. Will try another tablet soon to verify. The foobar library not showing up when running occurs on both devices though. After a server stop/restart it is immediately recognized as a media server. I will try installing foobar on another pc to see if I can duplicate.

  • bubbleguuum
  • [*][*][*][*][*]
  • Developer
foo_upnp
Reply #1676
0.99.44 is available

This is a small bugfix release:

- (regression) fix the foo_upnp renderer not working properly when being controlled gaplessly by foo_upnp (the default)
- fix the foo_upnp renderer possibly playing first track twice on some systems when being controlled gaplessly
  • Last Edit: 31 December, 2012, 09:25:16 AM by bubbleguuum

  • Calabi-Yau
  • [*]
foo_upnp
Reply #1677
0.99.44 is available

This is a small bugfix release:

- (regression) fix the foo_upnp renderer not working properly when being controlled gaplessly by foo_upnp (the default)
- fix the foo_upnp renderer possibly playing first track twice on some systems when being controlled gaplessly

At first I would like to thank you for this marvellous plugin, I'm using it to stream music to my Linn ADSM.

Until release 0.99.40 everything was fine.

Unfortunately, the newer releases don't show up at my control points (BubbleDS on Android and Kinsky on Windows 7) after a wake-up from Windows-standby, I have to manually stop/start UPnP Media Server or restart foobar2000.

I hope it will be possible to correct this behaviour in a future release.

Thank you very much in advance

  • swimmer
  • [*]
foo_upnp
Reply #1678
I've got an interesting problem, and I can't pinpoint when it started since I update my foobar plugins more often than I use foo_upnp. Here's the general setup:

foobar2k (v 1.2), foo_upnp (latest version through component updater)

Windows 7 comp with foobar2k -> Wireless network -> Xbox360 native music player

The 360 isn't compatible with FLAC, which is fine. I've always had the auto-transcode to WAV functionality enabled. However, for some reason, that functionality of the plugin is no longer working for me. .flac hasn't been inadvertently added to the list of exceptions. When I select any FLAC files on the Xbox, it provides an unsupported format error.

My only thought is perhaps a new feature was added that makes the sound incompatible. I noticed settings for the bit depth/sample rate output that I don't recall being there before, perhaps the Xbox only plays files at 48kHz? But unless the plugin was doing this conversion natively before, I can't think that it'd suddenly stop working at 44.1kHz now.

Also am I crazy or did gapless playback of MP3s stop working? Just had a stutter at the end of a track I'm testing now.

Any help would be much appreciated

  • BenB
  • [*][*][*][*][*]
foo_upnp
Reply #1679
I had a similar problem with a PS3 the other day after updating to 0.99.42. Although it was set to "Decode always to lpcm except mp3", foo_upnp would only decode to wave regardless of the settings.

The 'fix' for me was to uninstall and reinstall the component. I haven't used it since then so I guess I should check to make sure it's still working after the recent updates.
  • Last Edit: 02 January, 2013, 05:48:47 PM by BenB

  • bubbleguuum
  • [*][*][*][*][*]
  • Developer
foo_upnp
Reply #1680
I've got an interesting problem, and I can't pinpoint when it started since I update my foobar plugins more often than I use foo_upnp. Here's the general setup:

foobar2k (v 1.2), foo_upnp (latest version through component updater)

Windows 7 comp with foobar2k -> Wireless network -> Xbox360 native music player

The 360 isn't compatible with FLAC, which is fine. I've always had the auto-transcode to WAV functionality enabled. However, for some reason, that functionality of the plugin is no longer working for me. .flac hasn't been inadvertently added to the list of exceptions. When I select any FLAC files on the Xbox, it provides an unsupported format error.


Streaming LPCM to Xbox360 is indeed broken since a few versions of the plugin (it worked in my debug build of the plugin, but not the release build!).

Now fixed in 0.99.45 available here.




  • frutis
  • [*]
foo_upnp
Reply #1681
Hello,

I'm trying to play some music files on my Bravia TV using UPnP Controller. TV supports LPCM (L16) and MP3 formats.
I can play mp3 files without any problems but when I'm trying to play flac files (converted to lpcm, wav or mp3) foobar hangs up (foo_upnp logs).

Regards
frutis

  • BenB
  • [*][*][*][*][*]
foo_upnp
Reply #1682
foo_upnp incorrectly splits any tag containing a comma (,) when using %<TAG>%. I see in the changelog that this was a problem before but was remedied. Unfortunately, it seems to be back, but I'm not aware of when it happened. I'm using 0.99.45.

  • Cyaneyes
  • [*][*][*][*]
foo_upnp
Reply #1683
Just a suggestion: under the Playstation profile, the "Can decode HTTP and MMS streams directly" should be checked by default (at least it works on my 2009 PS3 slim). I don't know if this changed with an update at some point, or if I accidentally unchecked it, but I was having problems streaming a foobar playlist of radio station steam URLs and checking this option fixed the issue. Thanks for a great component!

  • bobbel
  • [*]
foo_upnp
Reply #1684
This is a very nice plugin.
Unfortunatly I'm not able to stream a cue-sheet refering to a single dts-file out of foobar to my popcornhour (A-110 or A-200 or A-300):
Upnp-controler tries buffering, stops and goes to the next song with same result...
It works fine with single dts-files w/o cue.
  • Last Edit: 05 January, 2013, 05:27:44 PM by bobbel

  • myvision
  • [*]
foo_upnp
Reply #1685
Maybe a stupid question but I noticed this only here:

For covers I use the following string: $replace(%album artist% - %album%,:,_,.,_,?,_,/,_,",_).jpg

This works fine in foobar. But when using foo_upnp all covers with ":" and "/" and "," e.g.: "Beastie Boys - Anthology: The Sounds of Science" don't get broadcasted. Covers with a point "." show up.

Anyone know the solution? Thank you.

Edit:
Just noticed that this problem exists with all "forbidden letters" like \ / : * ? " < > |
  • Last Edit: 07 January, 2013, 09:44:19 AM by myvision

foo_upnp
Reply #1686
Flac wont play with upnp 0.99.45 and WD TV Live. I don't know if it worked with previous versions. Problem is that i cant test because i can't find any older versions of foo_upnp. The WD TV Live is suppose to read the Flac format.

Edit: PCM won't play either 

I also have a problem with radio streams. I can play them in foobar but they wont play with the upnp controller to wd tv live. Does anyone recognize these problems and is there a fix?
  • Last Edit: 08 January, 2013, 04:20:58 AM by Tuupmeister

foo_upnp
Reply #1687
More problems occur  ....I found different versions of the component and tested them. Nothing resolved the problem. So i went back to the latest version (0.99.45). But now after playing a mp3 song, the rest of the playlist will not play. The program simply stops. How is that possible?

A small remark about the flac files that won't play: In the statusbar it says: "stopped". In other words, it is not buffering.


  • DonJuape
  • [*]
foo_upnp
Reply #1688
I have an Arctic Audio Relay device connected to my local network. This is a DLNA/UPnP device. I can access it through it's IP address and I can push audio to it with JRiver Media Center, probably also with the "Play to" feature in WMP12 but I do not have that because I run XP. Anyway, to me this means the device seems to working fine.

Next I installed Foobar2000 and the foo_upnp component.

Now, I can not see the Arctic Audio Relay under view, UPnP browser. How can I get Foobar and/or foo_upnp to "add" it? Is there somewhere where I can specify the IP address?

I appreciate your replie(s).

  • Moglie
  • [*]
foo_upnp
Reply #1689
Hello 

First i want to say that this plugin is very nice, but i got some questions to it while iam not an "foo_upnp pro" yet.

Informations about my setup:

1. My music collection in foobar2000 contains mostly; FLAC (in 16/44 + 24/96) + mp3 files.
2. As renderer I got an Onkyo TX-8050 it works very nice. Here are the Supported Audio File Formats (sorry for the long list) of my Onkyo TX-8050.

Quote
MP3 (.mp3 or .MP3)
• MP3 files must be MPEG-1/MPEG-2 Audio Layer 3
format with a sampling rate of 8 kHz, 11.025 kHz,
12 kHz, 16 kHz, 22.05 kHz, 24 kHz, 32 kHz,
44.1 kHz, 48 kHz and bitrates of between 8 kbps and
320 kbps. Incompatible files cannot be played.

WMA (.wma or .WMA)
WMA stands for Windows Media Audio and is an audio
compression technology developed by Microsoft
Corporation. Audio can be encoded in WMA format by
using Windows Media
®
Player.
• WMA files must have the copyright option turned off.
• Sampling rates of 8 kHz, 11.025 kHz, 12 kHz,
16 kHz, 22.05 kHz, 24 kHz, 32 kHz, 44.1 kHz,
48 kHz, bitrates of between 5 kbps and 320 kbps, and
WMA DRM are supported.
• WMA Pro/Voice formats are not supported.

WMA Lossless (.wma or .WMA)
• Sampling rates of 44.1 kHz, 48 kHz, 88.2 kHz,
96 kHz are supported.
• Quantization bit: 16 bit, 24 bit

WAV (.wav or .WAV)
WAV files contain uncompressed PCM digital audio.
• Sampling rates of 8 kHz, 11.025 kHz, 12 kHz,
16 kHz, 22.05 kHz, 24 kHz, 32 kHz, 44.1 kHz,
48 kHz, 64 kHz, 88.2 kHz, and 96 kHz are supported.
• Quantization bit: 8 bit, 16 bit, 24 bit

AAC
(.aac/.m4a/.mp4/.3gp/.3g2/.AAC/.M4A/.MP4/ .3GP or
.3G2) AAC stands for MPEG-2/MPEG-4 Audio.
• Sampling rates of 8 kHz, 11.025 kHz, 12 kHz,
16 kHz, 22.05 kHz, 24 kHz, 32 kHz, 44.1 kHz,
48 kHz, 64 kHz, 88.2 kHz, 96 kHz and bitrates of
between 8 kbps and 320 kbps are supported.

FLAC (.flac or .FLAC)
FLAC is a file format for lossless audio data compression.
• Sampling rates of 8 kHz, 11.025 kHz, 12 kHz,
16 kHz, 22.05 kHz, 24 kHz, 32 kHz, 44.1 kHz,
48 kHz, 64 kHz, 88.2 kHz, and 96 kHz are supported.
• Quantization bit: 8 bit, 16 bit, 24 bit

Ogg Vorbis (.ogg or .OGG)
• Sampling rates of 8 kHz, 11.025 kHz, 12 kHz,
16 kHz, 22.05 kHz, 24 kHz, 32 kHz, 44.1 kHz,
48 kHz and bitrates of between 48 kbps and 500 kbps
are supported. Incompatible files cannot be played.

LPCM (Linear PCM)
• Sampling rates of 8 kHz, 11.025 kHz, 12 kHz,
16 kHz, 22.05 kHz, 24 kHz, 32 kHz, 44.1 kHz,
48 kHz, 64 kHz, 88.2 kHz, and 96 kHz are supported.
• Quantization bit: 8 bit, 16 bit, 24 bit
* Only for playback via network.



Questions:

1. In the following picture you can see how my "foo_upnp settings" look like, can someone tell me if its optimized for my Onkyo TX-8050?

[a href="http://www.abload.de/image.php?img=foo6qk25.png" target="_blank"]

  • sorth
  • [*]
foo_upnp
Reply #1690
Hi,

I have Sony SA-NS410 wifi speaker, and I'm not able to see it in the device list of UPnP Controller window. It does work with 'Play to' feature of Windows Media Player. Is it possible to make it work?

The speaker shows in the debug log of foo_upnp but does not show in the combobox:

Code: [Select]
foo_upnp: 4104.4104333: PLT_CtrlPoint::InspectDevice(1269)/5576: INFO: Inspecting device "5f9ec1b3-ed59-1900-4530-5453ed14bf79" detected @ http://192.168.0.101:8080/description.xml
foo_upnp: 4105.4105078: PLT_CtrlPoint::ProcessGetDescriptionResponse(1394)/4524: INFO: Device "5f9ec1b3-ed59-1900-4530-5453ed14bf79" is now known as "SA-NS410"
foo_upnp: 4105.4105181: LinnDsRendererController::Create(117)/6680: INFO: couldn't find urn:av-openhome-org:service:Product:1 service


You can find description.xml here if it helps: description.xml

Thanks
  • Last Edit: 13 January, 2013, 08:15:02 AM by sorth

  • Lurker
  • [*]
foo_upnp
Reply #1691
2. Iam very happy that "foo_upnp" allows me to use DSPs (I use the Equalizer, thats what i missed at the Onkyo TX8050), so i activated it in the options as you can see on the screenshot above. The bad thing is; if DSPs are active it forces always PCM output so it converts all FLACs to PCM (no native playback anymore?) Does this converting-process make lose audio-quality?

Because FLAC is lossless format, quality speaking, it does not matter who converts it to PCM: foobar or Onkyo. It is only a matter of network load, because, being packed with FLAC, the amount of data to transfer is smaller. But it should not create any problems even if you have very old 10Mbps network hardware at home.

What does really affect the quality is DSP plug-in  But that's the distortion you like!

  • Moglie
  • [*]
foo_upnp
Reply #1692
2. Iam very happy that "foo_upnp" allows me to use DSPs (I use the Equalizer, thats what i missed at the Onkyo TX8050), so i activated it in the options as you can see on the screenshot above. The bad thing is; if DSPs are active it forces always PCM output so it converts all FLACs to PCM (no native playback anymore?) Does this converting-process make lose audio-quality?

Because FLAC is lossless format, quality speaking, it does not matter who converts it to PCM: foobar or Onkyo. It is only a matter of network load, because, being packed with FLAC, the amount of data to transfer is smaller. But it should not create any problems even if you have very old 10Mbps network hardware at home.

What does really affect the quality is DSP plug-in  But that's the distortion you like!


Hello and thanks for your explainment the amount of data to transfer isnt that important while i have a 1Gbit Network here, but the Onkyo TX8050 only is able to use 100Mbit. Its nice to know that it does not lose quality by converting FLAC to PCM by foobar2000.

Well does it lose audio-quality while i use the DSP Equalizer for real? I only want warmer sound and i do the mids +3db (200hz-600hz), hmm thats not nice to know.

foo_upnp
Reply #1693
I have the TX8050 and found it to be quite a clinical amp. One way to make the sound warmer/fuller is to keep the volume lower and increase the 'Intellivolume'  in the source setup by a couple of db.
Which sound mode do you use? ie Pure audio, stereo etc

  • Moglie
  • [*]
foo_upnp
Reply #1694
I have the TX8050 and found it to be quite a clinical amp. One way to make the sound warmer/fuller is to keep the volume lower and increase the 'Intellivolume'  in the source setup by a couple of db.
Which sound mode do you use? ie Pure audio, stereo etc


Yes same feeling for me here, i use stereo modus with "Intellivolume" +3db and this EQ settings, maybe try them for me they are very good.

[a href="http://www.abload.de/image.php?img=eqhbooc.png" target="_blank"]
  • Last Edit: 14 January, 2013, 11:19:26 AM by Moglie

foo_upnp
Reply #1695
More problems occur  ....I found different versions of the component and tested them. Nothing resolved the problem. So i went back to the latest version (0.99.45). But now after playing a mp3 song, the rest of the playlist will not play. The program simply stops. How is that possible?

A small remark about the flac files that won't play: In the statusbar it says: "stopped". In other words, it is not buffering.


Resolved!!! I've made a firmware downgrade of de WD TV Live to 1.11.14. Now the renderer does play the flacs!

foo_upnp
Reply #1696
Lyric Show Panel 3.

This is a nice component, but how come it does't work with the foo_upnp? It only starts when i do not use a renderer like wdtv live.

foo_upnp
Reply #1697
I have the TX8050 and found it to be quite a clinical amp. One way to make the sound warmer/fuller is to keep the volume lower and increase the 'Intellivolume'  in the source setup by a couple of db.
Which sound mode do you use? ie Pure audio, stereo etc


Yes same feeling for me here, i use stereo modus with "Intellivolume" +3db and this EQ settings, maybe try them for me they are very good.

[a href="http://www.abload.de/image.php?img=eqhbooc.png" target="_blank"]

Thanks, but to be honest I don't like using the foobar eq.  I sometimes use compressor/limiter vst plugins in my dsp line and I prefer setting the eqs on this. I also use the bass and treble controls on my tx8050. My greatest disappointment with this amp is that you cannot add an eq to it as I have a very good azden graphic eq. I recently changed my speakers to some 20 year old TDL Studio 0.5 transmission line speakers and it has made a great difference to the sound. I find you need to be careful with this amp as to which speakers you pair it with. If they are bright speakers then the sound will be grating.

  • bsw11
  • [*][*][*]
foo_upnp
Reply #1698
I just want to use my Galaxy Note 2 phone as a stream receiver for the exact sound coming from my FB2K that is playing out the main system.

I would like it to have my DSP inline as well - I don't care about if it changes format.

So I need to know:

What I need to setup on the FB2K side in the settings of UPnP.?

What player I should use to playback the stream in my phone?

I have tired a few players but they all crash FB2K when I go to try and play the stream.

btw - the reason this is all I need is I use the Foobar2000 Player on android to browse and control FB2k perfectly!

foo_upnp
Reply #1699
Guys i need your help. What is the ''procedure'' to remote control foobar2000 from another notebook where i have installed another instance of foobar? I need to have the library showed up. I tried it with but i was not able to get the playback on the computer(server). I got the playback (wrongly) on the notebook in streaming...

Can you help me?