Skip to main content

Topic: foo_podcatcher (Read 152213 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
foo_podcatcher
Reply #25
predator29: I'll also look at the feed:// issue. As you say they work if you change the url to http:// so it should be easy...

Nausea, if you re gonna fix the above(not an issue really), mind you can register feed:// (or even itpc//) using new foobar versions.

Quote
Third party components can now register custom protocols with the File Types preferences page.


Secondly I dont know how you plan to implement "Playlist genereting UI", but a simple quick n dirty one is like album's list will do just fine imho. Just a Generate playlist's name textbox with a defaultĀ  tagz value sth like: "%_pcast_name% podcast". If the user wants a unified playlist just removes %_pcast_name%.


Thanks for your work many many kudos!!!
  • Last Edit: 17 March, 2009, 07:05:17 AM by thecircusfreak

  • ingver
  • [*]
foo_podcatcher
Reply #26
awesome plugin. I've been waiting for this..
A couple requests/bugs:
  • Ability to automatically tag downloaded files f.e. - Genre: Podcast, maybe using title formatting too (album name - podcast name)
  • Ability to disable tray notifications
    i use a custom tray icon and the notifications change it to default for some reason. Also, when it's finished downloading (showing tray notifications), the tray icon disappears completely. My settings are - always show notification area icon, minimize to notification area, use a custom icon.
  • Separate autoplaylists for separate feeds
  • When i select 1 music file in a feed and press download selected, it downloads the rest (under the first one in the list) of the files too.
    Maybe it's because I selected all and pressed download selected at first and later aborted the process
  • Last Edit: 01 April, 2009, 04:55:22 PM by ingver

  • tpijag
  • [*][*][*][*][*]
foo_podcatcher
Reply #27
Small buglet.

I've XP set with Foobar in the quick launch area of the Task Bar.
Also, Foobar preference is set to minimize to notification area.

Foobar open but quiet [not sure yet if matters whether current status is paused or stopped]
Podcast runs one of it's 30minute updates.

Foobar will no longer respond to the notification icon to open. A mouse over the icon with show a pop up of "podcast" as current track.
Foobar will respond to the quick launch icon and appropriately opens the existing instance and all reverts back to normal.

just FYI

terry
  • Last Edit: 07 April, 2009, 03:34:30 PM by tpijag

foo_podcatcher
Reply #28
Forgive my ignorance with using Foobar, I'm new to it.  This is my first post.  I am really impressed with Foobar's ability to convert 24-bit/96khz FLAC's to WAV's while maintaining their full integrity.

I'm trying to use Pod_Catcher to subscribe to the Burnout Paradise CrashTV podcasts.  I'm not quite sure what exactly I should be doing to set up the podcast. 

I'm having the same problem as bellingsman did.  Except, I'm not using a proxy at all with either of these links.

http://criteriongames.com/podcast/

itms://ax.itunes.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=282477732&ign-mscache=1
I have even changed that to "http" and still nothing happens.

My is E:\My Videos\Burnout Podcasts

If you'd look at the site, you'll see the "Subscribe to" link on the right side.  When I click on that, Winamp launches and it cannot load the podcast properly.  I'm wondering if there might be some sort of issue with the BOP podcasts that are causing problems?
  • Last Edit: 09 April, 2009, 05:44:55 PM by DaveTheStalker

  • tpijag
  • [*][*][*][*][*]
foo_podcatcher
Reply #29
Very new to podcasts with Foobar myself....but are not those Video podcasts?
Foobar is a audio program.

terry
  • Last Edit: 09 April, 2009, 05:43:32 PM by tpijag

foo_podcatcher
Reply #30
Very new to podcasts with Foobar myself....but are not those Video podcasts?
Foobar is a audio program.

terry


Yeah, you've got a good point.  I was just assuming FB had a video component like Winamp does.  Even with the video option checked in Winamp they don't load.
  • Last Edit: 09 April, 2009, 05:51:30 PM by DaveTheStalker

  • tpijag
  • [*][*][*][*][*]
foo_podcatcher
Reply #31
No

terry

  • nausea
  • [*][*][*]
  • Developer
foo_podcatcher
Reply #32
Updated to version 0.0.4 (alpha).

Implemented some of the planned changes, but not all of them yet.

Main change for this version are the podcatcher playlists which update as the feeds do. The notification icon conflict problems should also be fixed now, as the component now has its own icon. The icon does sometimes remain, which is a bug.

It seems to be stable, but let me know of any crashes or hangs.

Edit: quick release of v0.0.4b, which adds support for feed:// and itpc:// urls (including registering them in recent versions of foobar2000).
  • Last Edit: 24 April, 2009, 09:12:13 PM by nausea

  • halabund
  • [*][*][*]
foo_podcatcher
Reply #33
Why is the seek bar often disabled in foo_podcatcher playlists?  (I think it's only disabled on first play of each track, not the second one.)  This doesn't look like it's intentional, as the files are already downloaded, and seeking does work with keyboard shortcuts (just not with the seek bar).

  • ingver
  • [*]
foo_podcatcher
Reply #34
halabund,
Umm are u sure those are downloaded tracks? I thought it played not dled tracks too... maybe i understood wrong...
EDIT: I checked, it seems to play tracks that are not downloaded in foo_potcatcher playlists. At first, when it's not locally cached, the seekbar doesn't work, which is logical as the file has not been downloaded fully. Additionally, it doesnt get the artist name when you haven't played the track yet. Downloaded tracks work all OK.
nausea,
anyway... great update but the icon is rather ugly. I've made a better one (imo) for u to use if you want.



also, it's weird but the podcatcher doesn't automatically download... i have to manually check and download every time...
and the last published/published column on all music files in the manager window is always the same - 1601-01-01 03:00:00
  • Last Edit: 09 May, 2009, 05:58:38 PM by ingver

  • halabund
  • [*][*][*]
foo_podcatcher
Reply #35
Yes, I am talking about downloaded tracks.  The very first time they are played after having been downloaded, the seek-bar is disabled (the handle does move, but cannot be moved with the mouse).  Despite this, seeking works with keyboard shortcuts.

With non-downloaded tracks, the seek handle does not move and cannot be moved---that is reasonable.  But I was talking about downloaded tracks.

  • ingver
  • [*]
foo_podcatcher
Reply #36
well maybe the podcathcer ignores the fact that the tracks are downloaded and streams *all* the tracks from the playlist. In that case, it's a bug and should be fixed.
EDIT: so the downloaded tracks behave different from the not downloaded tracks. In that case my theory is incorrect . I personally don't have that problem... i think.

That is only possible when you play the tracks in the autoplaylist generated by the podcatcher. If the downloaded tracks have the same problem globally, then it's probably not the components problem. It could be a problem with the rss feed you're subscribed to.
  • Last Edit: 13 May, 2009, 01:45:54 PM by ingver

  • Xezzy
  • [*][*][*]
foo_podcatcher
Reply #37
It would be nice to have tag mappings on the go. All podcasters seems to use different tagging scheme, which breaks grouping in foobar...

foo_podcatcher
Reply #38
I started using this today. This is hot! Thanks!

  • nausea
  • [*][*][*]
  • Developer
foo_podcatcher
Reply #39
Released version 0.0.5. Available from all the usual outlets.

  • nausea
  • [*][*][*]
  • Developer
foo_podcatcher
Reply #40
Now at version 0.0.6.

This version has a fix for garbage being appended to downloaded files, which caused problems with playback of non-mp3 files.

foo_podcatcher
Reply #41
I get object not found errors with both versions .5 .6. Although server responds ok (200, as I see sniffing it) pod catcher responds with object not found. None of my subscriptions works, is it only me, why noone reported sth like that yet?

Also there is a bug in the way it handles (I think the years in)dates, test case subscription: http://www.awaretek.com/python/index.xml. I get this "Podcatcher: Error in RFC822 time formatting (31 Apr 2006 20:19:00 -0400).", when I am trying to update the podcast subscription
  • Last Edit: 14 September, 2009, 01:14:39 PM by thecircusfreak

  • halabund
  • [*][*][*]
foo_podcatcher
Reply #42
I'm glad this useful component is still being developed

I've just upgraded to version 0.0.6.  It seems that the seek-bar bug is still present:  the seek bar is non functioning (greyed out and not moving) the very first time a track is played from the playlist (but it is possible to seek using the shortcut keys).  This is about already downloaded tracks.

Also, in this new version the dates look a bit funny.
  • Last Edit: 14 September, 2009, 04:52:03 PM by halabund

  • nausea
  • [*][*][*]
  • Developer
foo_podcatcher
Reply #43
thecircusfreak:
I get the "object not found" error when the download location is not valid. Is that the problem you have?
Also, 2006 is ok, but April only has 30 days 

halabund:
I can't reproduce the seek-bar problem. Perhaps there is a conflict with another component. As they are simply mp3s on your hard-drive after downloading (but perhaps not in your media library) can you reproduce the problem with some other unplayed file?
The date problem will be fixed for the next version. I was using superscript st, nd, rd, and th for the dates, but I guess not all fonts have those characters.

Thanks for the feedback.

foo_podcatcher
Reply #44
Ouch, didnt think the feed was to blame!

Now  as far as the object not found problem, I checked it before reporting it, and the download location is there. I also tried  removing the subscription and readding it, but the problem remains. Check this for example: http://tv.nationalreview.com/uncommonknowledge/audio.xml

  • nausea
  • [*][*][*]
  • Developer
foo_podcatcher
Reply #45
Quote from: thecircusfreak link=msg=0 date=
Ouch, didnt think the feed was to blame!

Don't worry, it's still worth knowing about. I can add it to my test case list and at some point in the distant future when every other feature is implemented I can work on some sloppy date formatting code.

Quote from: thecircusfreak link=msg=0 date=
Now  as far as the object not found problem...

The next version should help to identify the point of failure more precisely, and we can try to work it out.


foo_podcatcher
Reply #46
duh, it was the download dir at the local drive which was set at the wrong place.

...and now  I also noticed that s exactly what you probably meant above. What I can say, maybe I'm a little on the slow side...   

Thanks for all your efforts nausea.


  • halabund
  • [*][*][*]
foo_podcatcher
Reply #47
nausea,

The seekbar problem seems to only be present when using Columns UI.  I removed %appdata%\foobar2000, removed all 3rd party components (except podcatcher and Columns UI), and then tested it with both UIs (removing the settings directory between the tests).

I'll post this in the Columns UI thread too then, but still: I've never experienced problems like this, except with podcatcher's playist.

The strange thing is that the problem occurs only the very first time the (downloaded) track is played.  If it is stopped, then played again, the seekbar is fine.

For the reference, here are the exact steps to reproduce:

1. Use a clean foobar2000 install (remove the settings files, %appdata%\foobar2000).  Make sure Columns UI is installed.
2. Start foobar2000, choose to use Columns UI (the program offers the option on first start).
3. Configure the download dir for podcatcher, subscribe to a podcast feed, and download the first podcast.
4. Create a playlist using podcatcher.
5. Play the downloaded track from the playlist.  Observe that the seekbar is greyed out and not moving.

EDIT: component versions:  podcatcher: 0.0.6, columns ui: 0.3.8.0

EDIT2: link to post in columns ui thread
  • Last Edit: 15 September, 2009, 05:27:06 PM by halabund

  • nausea
  • [*][*][*]
  • Developer
foo_podcatcher
Reply #48
Cool. I'll see what there is that can be done about it. Just guessing, but it may be something to do with the track not having any length info associated with it before the first play. Neither the RSS or Atom standards include this, but I think podcast feeds formatted for itunes (i.e. all of them) have an <itunes:duration> element which I'll try using in the next version.

In the meantime v0.0.7 is out with a few small changes.
  • Last Edit: 16 September, 2009, 04:44:41 AM by nausea

  • nausea
  • [*][*][*]
  • Developer
foo_podcatcher
Reply #49
There's a serious bug in foo_podcatcher v0.0.7. Anyone who downloaded it should upgrade to 0.0.7b now: http://www.unkempt.co.uk/fb2k/foo_podcatcher.html

Apologies to anyone this affected, and no more late night updates I think...