Skip to main content

Topic: DarkOne (Read 162870 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #50
1.) No, not in DarkOne. Maybe in another skin later
I thought about a little volume indicator (made with the wsh panel) in the display but there's no place for it (at least on display resolutions at about 1280*x and below...). And then i thought: why just an indicator and not a volume slider?
But not in DarkOne. Wouldn't fit to the concept.
Btw. you can easily see the current volume by activating the statusbar...

2.) Planned for the next release (coming soon)
But only Default, Random and Repeat (track), because i think these three are the most used modes (or not? I don't know, i only use default and random). I could integrate a fourth one if it is really needed, but this i have to know very soon. v1.4 shall be released in a few days...

Look at this post and the screenshot:
http://www.hydrogenaudio.org/forums/index....st&p=617044

3.) Would be better i know, but for only optical reasons i made it with "-" and "+" (to fit to the volume buttons).

4.) Not possible to my knowledge, sorry.
But the buttons should be self-explanatory (most of them at least ).

EDIT:
To your edit.

Yes it is possible.

Go to the ELPlaylist Settings (right-click on the ELPlaylist and choose "Settings"), go to the "grouping" tab and enter in "row number of group header":
$ifequal(%el_item_count%,1,0,3)

Btw.
i've seen that your resolution is only 1024*x.
The skin is made for higher resolutions so you will have problems with the big image view (because the buttons will be overlayed over the art indicator display)...
  • Last Edit: 24 February, 2009, 04:38:21 PM by tedgo

  • ton
  • [*][*]
DarkOne
Reply #51


But you can do the following:
Go into the script and search all entries that begins with $font(Arial Black,... and set the size from 5 to 4.
Then search all entries that begins with $font(DarkOne,... and change the size from 14 to 11.
It may still look ugly, but is the only solution that works on DPI higher than 96.


Thanks, that did the job and it is NOT ugly at all.
However the Total column is still empty.
Track number, Elapsed, Remain and Kbps do show up nicely.

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #52
Do you have a total tracks tag in your files?

  • ton
  • [*][*]
DarkOne
Reply #53
Do you have a total tracks tag in your files?


It turned out that that was not so. When I add that tag it does work. But it will be a hell of a job to add it to all my albums. I think I will leave it so.
Thanks again for the help.

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #54
On yevi's screenshot there is a thing that made me attentive...

In the ELPlaylist should be a blinking note instead of a square.
Has anyone else only a square on that place?

@ton
Should be easy to solve with the properties dialogue and "auto track number"
  • Last Edit: 24 February, 2009, 05:07:11 PM by tedgo

  • ton
  • [*][*]
DarkOne
Reply #55
@ton
Should be easy to solve with the properties dialogue and "auto track number"


Great !
I still have to learn a lot about foobar.... 

Btw, that has to be done per album or per group of albums of the same artist (when in an Artist folder) ?

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #56
You should be able to do it for the whole playlist (it should edit per album automatically).
But i'm not sure, because i tag my files correctly from the beginning... 

You should probably try it first with two albums.

  • yevi
  • [*]
DarkOne
Reply #57
Btw.
i've seen that your resolution is only 1024*x.
The skin is made for higher resolutions so you will have problems with the big image view (because the buttons will be overlayed over the art indicator display)...


What big image are you talking about, cd cover?

Quote
Go to the ELPlaylist Settings (right-click on the ELPlaylist and choose "Settings"), go to the "grouping" tab and enter in "row number of group header":
$ifequal(%el_item_count%,1,0,3)


This works good, but it was a bad idea in the first place that i didn't think about.
Because now I cant see the artist's name in the list only the name of the song.

1)What should I change in grouping of ELplaylist, to group by album and not my artist name?
2)Is it possible to quick-change grouping of ELplaylist (if i have more then 1 presets)? maybe with right click?

Quote
On yevi's screenshot there is a thing that made me attentive...

In the ELPlaylist should be a blinking note instead of a square.
Has anyone else only a square on that place?

Why i don't have this sign??
  • Last Edit: 24 February, 2009, 06:30:34 PM by yevi

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #58
I'm talking about the big cover view (by clicking on the right of the three buttons above the playlist)

To the artist's name:
Go to settings --> "field definition" tab --> double-click on the entry __COLUMN_ONE_TEXT__ and replace in the definition box the content with this string:
$ifequal(%el_item_count%,1,[$upper(%artist%) $char(9679) ],[$upper(%track artist%) $char(9679) ])%title%[ '('%version%')']

To your questions:
1.) You can use all titleformatting fields you want.
If you really only want to group by album (a bad idea when you have for instance some "Greatest Hits" albums from different artists...) you may want to enter %album% on the grouping tab --> group format.

2.) Yes you can.
Just add a new preset (the same tab --> group by --> new)
Then enable the "group by" context menu on the "behaviour" tab (choose it from the dropdown menu and tick "Show")

Why you don't have the sign?
I don't know...
There may be different reasons.
Maybe you haven't enabled unicode support on your OS?
  • Last Edit: 24 February, 2009, 07:41:18 PM by tedgo

  • yevi
  • [*]
DarkOne
Reply #59
Another question  (I know i am giving you a head ache ):
I have a Greatest Hit collection set : a folder that contains 8 folders cd1 cd2 ... (each song has it's tag data)
but when i drag the collection (or each cd) from album panel to playlist, i don't get 8 separated albums instead i get all files!
How can i fix that?


p.s.
I didn't group by album!
  • Last Edit: 25 February, 2009, 03:20:06 AM by yevi

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #60
Couldn't happen with the default grouping scheme if your albums are correctly tagged already...

Try to give your 8 discs album an additional tag called ALBUM ARTIST "Various Artists" or "VA".
Otherwise you'll get this because ELPlaylist groups your albums with the ARTIST tag (and as each song has another artist, it will not goup at all, because you have forced ELPlaylist with the string i posted you - $ifequal(%el_item_count%,1,... - to not group single files).
  • Last Edit: 25 February, 2009, 03:52:54 AM by tedgo

  • yevi
  • [*]
DarkOne
Reply #61
Couldn't happen with the default grouping scheme if your albums are correctly tagged already...

Try to give your 8 discs album an additional tag called ALBUM ARTIST "Various Artists" or "VA".
Otherwise you'll get this because ELPlaylist groups your albums with the ARTIST tag (and as each song has another artist, it will not goup at all, because you have forced ELPlaylist with the string i posted you - $ifequal(%el_item_count%,1,... - to not group single files).


Thanks.

Great work, can't wait for your next release.
(I hope the installation of the new one will be easy so i wouldn't have to apply all "our" tweaks all over again )



Regarding the music note char:
The font that in use is: Segoe UI right?
Well I couldn't  find this char in character map, can you check in what group of unicode this char appears?

For instance for arial font the character appears in symbols & dingbats:
[a href="http://img21.imageshack.us/my.php?image=76494184.jpg" target="_blank"]
  • Last Edit: 25 February, 2009, 04:54:32 AM by yevi

  • yevi
  • [*]
DarkOne
Reply #62
Another thing that is bothering me a lot:
In my "various" folder (mix of different mp3s),
I don't know why but playlist groups some songs together without no reason!! (different album and artist)



Maybe this happens because Album title is empty? If this is so, how can i fix that (without setting an album name for every song of course) ?
  • Last Edit: 25 February, 2009, 05:12:35 AM by yevi

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #63
To the last post:
This happens because, if there is no ALBUM tag, the ELPlaylist is forced to group the directory...
You should give all files correct tags.

This could be another solution for you:
Only group by directory, so all your single mp3 files would be grouped in one group, all albums would be grouped by their folder.
(just enter %directoryname% in group format).

To the other post:
The font for the note sign is Tahoma. It should automatically choose an unicode charset, while Segoe UI doesn't.
Go to the "Script"-->"Per Second" tab and change the font to Arial Unicode MS or (if you have it "Dotum" or any other charset that has the character.

In v1.3 - that version you have - it is possible to display a back cover too.
Go to Preferences --> Columns UI --> "Artwork" tab and add your back cover.
Than you can change the artwork display with a right-click --> Artwork-type --> Back.

  • yevi
  • [*]
DarkOne
Reply #64
To the other post:
The font for the note sign is Tahoma. It should automatically choose an unicode charset, while Segoe UI doesn't.
Go to the "Script"-->"Per Second" tab and change the font to Arial Unicode MS or (if you have it "Dotum" or any other charset that has the character.

Done and works!

Another question:
Is it possible to cancel the rename inputbox when i double click on playlist?

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #65
Go to: Preferences --> Playlist Switcher and disable "Double click renames playlist"

  • yevi
  • [*]
DarkOne
Reply #66
In next version, can you recolor  the menu(file, edit, view...) ?

p.s
Is there any functionality for ratings, or only visual?
  • Last Edit: 25 February, 2009, 09:47:48 AM by yevi

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #67
I can't change the colours for the menu bar because it uses the system colours.
I had to create a "fake" menubar with Panel Stack Splitter instead, but this would only allow a selection of the menu entries not all of them.
It would blow up the configuration unnecessarily because you don't click all times in the menu.

I have another solution for you:
If you often go to the menu, search for foo_menu_addon and you'll get the menu entries as context menu to the files in your playlist.

There is a rating panel in my configuration and a really detailed documentation for it in the User Guide...
  • Last Edit: 25 February, 2009, 09:55:16 AM by tedgo

  • yevi
  • [*]
DarkOne
Reply #68
I understand.

Did i tell you that this is the best foobar build ever (at least for me)?


I know how to change and add rating to files and database but what those ratings do?
  • Last Edit: 25 February, 2009, 10:06:24 AM by yevi

  • yevi
  • [*]
DarkOne
Reply #69
And another question regarding artist's picture.

my path settings:
$puts(artist.pic,D:\MP3\Artist Pictures\$replace(%artist%,/, ,\, ,*, ,?, ,", ,<, ,>, ,|, ,:, ).jpg)

in this folder i have picture, let's say nelly.jpg.
But when his song is played i don't see his picture...

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #70
The image has to have the EXACT name as the artist tag!
If your artist is called Nelly and your picture is called Nellie or Nelly_, the configuration can't find it.

Or do you have a problem displaying artist pictures at all?

  • yevi
  • [*]
DarkOne
Reply #71
The image has to have the EXACT name as the artist tag!
If your artist is called Nelly and your picture is called Nellie or Nelly_, the configuration can't find it.

Or do you have a problem displaying artist pictures at all?

It has the same name.

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #72
Would you please be a little more detailed?
What is the exact tag of the artist field of the file that isn't displayed?
What is the exact name of the artist picture that isn't displayed?
Maybe there is an invalid character inside and my replacement scheme isn't suitable for this.

Does all artist pictures refuse to load or only a few?

EDIT:
Oh and i forgot to answer your rating question.
The only functionality of rate a song is: rate a song...
And maybe sort them or create an autoplaylist from songs with a specified rating.
  • Last Edit: 25 February, 2009, 11:23:58 AM by tedgo

  • yevi
  • [*]
DarkOne
Reply #73
LOL
Nevermind, I am an IDIOT. 

  • yevi
  • [*]
DarkOne
Reply #74
To the artist's name:
Go to settings --> "field definition" tab --> double-click on the entry __COLUMN_ONE_TEXT__ and replace in the definition box the content with this string:
$ifequal(%el_item_count%,1,[$upper(%artist%) $char(9679) ],[$upper(%track artist%) $char(9679) ])%title%[ '('%version%')']


Now, this works with default grouping, but it doesn't work when "Directory" grouping that you've suggested
with following relevant parameters:



Thank you again for your time and help!