Skip to main content

Topic: DarkOne (Read 162866 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • tedgo
  • [*][*][*][*][*]
DarkOne

A Columns UI + Panel Stack Splitter + WSH Panel mod configuration

Actual screenshot with a link to a list of required files, changelog and downloadlink:
http://tedgo.deviantart.com/
  • Last Edit: 03 June, 2009, 06:01:13 AM by Yirkha

  • lokioki
  • [*][*][*]
DarkOne
Reply #1
I love this theme :3
e. and it works like a charm o/
  • Last Edit: 31 January, 2009, 07:39:28 AM by lokioki

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #2
Thank you

  • Jakuchu
  • [*]
DarkOne
Reply #3
Thank you, extremely nice config.

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #4
I corrected an error in the english user guide today and updated the download.
No changes on the skin itself

Sorry for the bad english in the user guide. Nevertheless I hope you'll understand it 

EDIT:
UPDATE 2009-02-02:
Fixed some minor issues with online radio and grouping in ELPlaylist one of my betatesters only reported today...
Sorry for the troubles
  • Last Edit: 01 February, 2009, 10:14:15 PM by tedgo

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #5
UPDATE 2009-02-04
- Fixed: Forgot the queue index in playlists
- Fixed: some minor string optimizations
- Added: a custom image view in big cover view
- updatet the user guide

Sorry again, for the troubles
I hope i finally haven't forgotten something else to fix... 

  • lokioki
  • [*][*][*]
DarkOne
Reply #6
There was problems in this ?  Thanks ^^

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #7
Minor problems, very smaaaaaal problems

DarkOne
Reply #8
Your config is brilliant...good work

Hope to see you doing more configs in the future

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #9
Thank you
I have some ideas for a new config based on DarkOne. Possibly with a switchable mini player mode.
But it seems that there is no solution that fits my needs and my ideas for a new config aren't fully-grown at the moment...
I'm still on improving the strings in DarkOne first (i'm a perfectionist and can't sleep without getting erased all possible errors  )
  • Last Edit: 05 February, 2009, 07:16:46 PM by tedgo

DarkOne
Reply #10
Hii Tedgo,

Keep up the good work.

Maybe it's an idea to automatically download artist pictures and album covers and maybe also some artist bio. But I'm not sure if this is possible in Foobar ?

Best Nighthawk

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #11
You can get artist pictures and album art with foo_discogs (if they are available in the discogs database and you configured foo_discogs to download them).

Album art can be saved with Albumart Downloader too.

Look at this short discussions:
http://www.hydrogenaudio.org/forums/index....;hl=foo_discogs
http://www.hydrogenaudio.org/forums/index....;hl=foo_discogs

And theses threads:
http://www.hydrogenaudio.org/forums/index....showtopic=57392
http://www.hydrogenaudio.org/forums/index....;hl=foo_discogs

DarkOne
Reply #12
Hi Tedgo, many thanks for your quick reply. I will look into it this weekend.

Best,

Nigthawk

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #13
My first DarkOne MiniPlayer outline:


I could come round with it...
But would have to "enhance" the DarkOne.ttf since it was not intended for displaying text with non-basic latin characters.
  • Last Edit: 06 February, 2009, 06:25:58 PM by tedgo

  • Godsh0t
  • [*]
DarkOne
Reply #14
I'm having trouble getting the background of the EL playlist to display the artist background image like you have in your screenshots, any idea on what could be wrong?

Edit: Problem resolved. Ignore.
  • Last Edit: 06 February, 2009, 08:39:38 PM by Godsh0t

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #15
@Godshot
I can't ignore this. Maybe my user guide is mistakable.
If so, please write me why you have had problems to display the artist picture and i can rewrite the user guide or could at least give some advices to avoid this problem or similar ones
I tried to make a skin that doesn't decrease foobar2000's usability with DarkOne, so that beginners are able to use it too. But maybe i thought around corners sometimes...

  • oxyd21
  • [*]
DarkOne
Reply #16
Hi,

my foobar looses the buttons regularly. So that i have to reload des fcs file.



Regs, oxyd21

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #17
The Panel Stack Splitter is a bit buggy, especially on Windows Vista there seems to be that problem (i've never had this bug on XP so far).
But if you enqueue files from Windows Explorer, the buttons and images always won't show up on startup.

If the buttons disappear on every startup please set the relative paths used in the splitter settings to the absolute path of the DarkOne folder.
To do it, right-click on the place you miss the buttons --> Splitter Settings --> Script --> PerTrack and change the path under
////// Path //////
$puts(imagepath,'./DarkOne\')
to
$puts(imagepath,<ENTER YOUR PATH TO THE DARKONE FOLDER>, e. g. C:\Program files\foobar2000\DarkOne\)

That should solve the problem.
  • Last Edit: 07 February, 2009, 02:20:00 PM by tedgo

  • oxyd21
  • [*]
DarkOne
Reply #18
seems to work now.
thanks

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #19
I'm working on version 1.4 now (will be released soon).

But i have a little problem:
How are your artist pictures named?
How do you get rid of invalid characters?

I currently replace all invalid characters with "space", but is it really a good idea?
What would you recommend for replacing the following characters:
/, ,\, ,*, ,?, ,", ,<, ,>, ,|, ,:

Should i replace some of them with an underscore instead?
Or replace with nothing?
And which ones?

How do you replace these characters when naming your artist pictures?

DarkOne
Reply #20
I would replace all of them by "_" - it's easy to read and can cause no trouble. Space might cause some trouble with old/bad applications.

  • 77Pat
  • [*]
DarkOne
Reply #21
I just installed this and like it a lot, but there is one problem I am having.  Everything shows up except for the buttons.  I tried reloading the flc file and changing the path, but they still will not show up.  When I click where they are supposed to be, they will work, but they just do not show up.  I am using Windows XP.  What do you think the problem could be?

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #22
If the %artist% tag is filled with AC/DC then your artist picture is stored as AC_DC.jpg?
But with N*SYNC would you name your artist picture N_SYNC.jpg?
Hm, i should consider it. Maybe i change the behaviour to replace invalid characters with "_".

@77Pat
Have you probably made a typo in your path?
I never heard about one having problems with it on XP...

Oh, wait:
Have you at least one playlist filled with music files?
It seems that Panel Stack Splitter has a problem when all playlists are blank.

EDIT:
I tried it now.
Panel Stack Splitter ALWAYS has a problem when the startup playlist is blank...
It tried it with DarkOne and KAMELEON, so its not the fault of my config.
But if you change to a playlist that contains some musics or play a file (double-click on it) the buttons appear.

Another reason for me to say, the forthcoming v1.4 will be my last update of DarkOne until the developer of Panel Stack Splitter finally solves his problems with loading images...
  • Last Edit: 21 February, 2009, 05:01:30 PM by tedgo

DarkOne
Reply #23
Hi Tedgo,

I have a question about the automatic lyrics display. All Artist are shown in CAPITAL like BEE GEES instead of Bee Gees. How can I change this. In the Filename and Tags it's shown as Bee Gees.

Best,

Nighthawk

  • tedgo
  • [*][*][*][*][*]
DarkOne
Reply #24
You mean when there's no lyric available, right?
Right-click on lyrics panel --> Settings --> Formatting string tab and change the first line

$char(1)C[$upper(%artist%)]$char(10)

to

$char(1)C[%artist%]$char(10)

Btw.
These are the previews of the forthcoming final 1.4
Normal view


Compact view expanded:


Compact view collapsed:
  • Last Edit: 21 February, 2009, 06:01:48 PM by tedgo