Skip to main content

Topic: CUETools versions 1.9.5 through 2.1.5 (current) (Read 1321917 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • X0R
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1050
Wow Custom Proxy implemented!
Awesome stuff again Gregory !

-When set to encode mode, with no audio output, using the same file extension as the source files, (flac in this case,
& using [%directoryname%\]%filename%-new[%unique%].cue, you will get an error saying
"Exception: Source and destination audio files path cannot be the same".

(obviously If you use a new dir path like [%directoryname%\]new[%unique%]\%filename%.cue, all is well).
Thanks !
  • Last Edit: 30 May, 2010, 05:28:45 PM by X0R

  • Roger7
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1051
Yes, the drive that cannot overread into Lead-out and positive offset will loose the last few samples and they will be replaced by zeroes. Number of lost samples equals drive offset.
So for best results you might want to use drive with small offset or better yet drive that can overread into leadout.
But keep in mind, that 6 samples is not very much audio, about 0.1 millisecond, and that audio in that part of CD is usually very close to silence anyway, so i wouldn't worry very much about it.

OK, so why are AR CRC accurate ? How is it count ?

Thanks

CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1052
2940 last samples are ignored by AR.
CUETools 2.1.4

  • X0R
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1053
I Think I found another bug,

-When Encoding, unticking the Embed Image, image still gets  embedded.[checked again & again -  bug still happens]
-The image embedded gets resized even if the Resize threshold is set higher,(to 6000 here, so it can be avoided). [could not get it to happen again.]
  • Last Edit: 30 May, 2010, 08:21:48 PM by X0R

  • X0R
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1054
Is there away to enable the "pressing #X" in the reports?
  • Last Edit: 30 May, 2010, 10:00:03 PM by X0R

  • greynol
  • [*][*][*][*][*]
  • Global Moderator
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1055
FWIW, #X has no definitive meaning in terms of the pressing.

Go back over this thread as this question has been asked already.

http://www.hydrogenaudio.org/forums/index....st&p=643854
  • Last Edit: 30 May, 2010, 10:16:26 PM by greynol
13 February 2016: The world was blessed with the passing of a truly vile and wretched person.

Your eyes cannot hear.

CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1056
-When Encoding, unticking the Embed Image, image still gets  embedded.[checked again & again -  bug still happens]

It seems that when "Copy album art tags" is enabled, image gets embedded even if it comes from a file.
CUETools 2.1.4

  • El Kabong
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1057
Been using CUETools for verifying purposes for quite a time now. Really a nice and time-saving app, so thanks everybody envolved.
Now I'm experiencing a tricky issue since the last update (i.e 2.0.9). All profiles work fine, I can do all my usual tasks, but can't
switch between different profiles. I can jump from "default" to any other, but next switch always outputs an "unhandled exception...
blah-blah-blah... error generating XML document"
. I may ignore and go on but... just pisses me off! (Oops, sorry!  )

Previous version (2.0.4a to me) worked just perfect. My system: XP SP3, NET Framework 2.0/3.0/3.5, Visual C++ 2005/2008. All updated.
What should I do? Will keep on using old version in the meantime.

Best regards and thx in advance... for all!

  • Surfi
  • [*][*][*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1058
::

CUERipper doesn't overread (into leadout) with my Plextor PX-760. Is this intended?
What do I have to do to get an output like "Queen [1976] A Night At The Opera.cue"?


Greetings, Surf ...

::

CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1059
I don't have a drive capable of overreading, so i couldn't implement it yet. I know it's important for some users, but it will take some time.

Try the following template:
%music%\%artist%[ - '['%year%']'] - %album%.cue
CUETools 2.1.4

  • Surfi
  • [*][*][*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1060
I don't have a drive capable of overreading, so i couldn't implement it yet. I know it's important for some users, but it will take some time.
::

No problem, keep up the good work. Thanks for the great program!

::
Try the following template:
%music%\%artist%[ - '['%year%']'] - %album%.cue
::

It works. Thank you very much.

::

  • bit4bit
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1061
I'm archiving all my CDs as single file flac archives. I am using EAC to rip the CDs as wav and CUETools for further processing, and usually everything works well. But I've got some CDs which cannot be ripped accurately by EAC. When testing with CueTools it reports these tracks as "No match but offset". Here is one example from the CD "The Diary of Alicia Keys".

Code: [Select]
[CUETools log; Date: 02.06.2010 11:43:43; Version: 2.0.9]
CD-Extra data track length 06:29:57.
[CTDB TOCID: iU4E1m24Moh64VNA4F0gdiW4nDY-] disk not present in database.
[AccurateRip ID: 00204005-017582d7-e40fae10] found.
Track  [ CRC    ] Status
 01    [3b4075b2] (63/63) No match but offset
 02    [0e3a61e9] (53/53) No match but offset
 03    [a825faf6] (59/59) No match but offset
 04    [ea23f312] (63/65) No match but offset
 05    [6caa3fae] (51/51) No match but offset
 06    [ceaef50f] (62/62) No match but offset
 07    [c7847c85] (64/64) No match but offset
 08    [48e16522] (60/60) No match but offset
 09    [9a0338cf] (59/59) No match but offset
 10    [274b1d53] (64/64) No match but offset
 11    [f5caba62] (58/58) No match but offset
 12    [473e8077] (68/68) No match but offset
 13    [073b8142] (64/64) No match but offset
 14    [078d46d7] (58/58) No match but offset
 15    [c3b240e9] (58/60) No match but offset
Offsetted by -6:
 01    [8b86f3b2] (00/63) No match
 02    [0def6ee7] (00/53) No match
 03    [899baafc] (00/59) No match
 04    [b5b56c6d] (02/65) No match but offset
 05    [63ba64c7] (00/51) No match
 06    [923771f6] (00/62) No match
 07    [e826ae81] (00/64) No match
 08    [812b4e72] (00/60) No match
 09    [47027c6d] (00/59) No match
 10    [e0ece63e] (00/64) No match
 11    [2ac98e95] (00/58) No match
 12    [ed8c154e] (00/68) No match
 13    [a412f21a] (00/64) No match
 14    [a5d8d624] (00/58) No match
 15    [c5e4e5b8] (02/60) No match but offset

Track Peak [ CRC32  ] [W/O NULL]
 --  100,0 [20320805] [4B10FC0D]         
 01  99,9 [1FFFB333] [6B393E9F]         
 02  99,9 [6B81A9D3] [8066306B]         
 03  100,0 [7FD0EC70] [83FBFD85]         
 04  99,9 [CD645887] [374E49A5]         
 05  96,8 [270F1320] [DFB78AE3]         
 06  99,9 [A6B08FB7] [2FE16BBA]         
 07  99,9 [E4276564] [FE8F03E0]         
 08  99,9 [FCE4F7D3] [294E461B]         
 09  99,9 [256BA34D] [CCBA33A6]         
 10  100,0 [49D67666] [04280299]         
 11  99,9 [7E260F85] [7A69795F]         
 12  89,0 [13499D76] [8D5DFD33]         
 13  99,9 [AF6998AF] [06AA9E27]         
 14  99,9 [330D8400] [AB49CF81]         
 15  99,9 [2999782F] [F5E465BA]         
Does this mean, that the tracks are ripped without error but with the wrong offset? Can CUETools fix this error?
Or is this an inaccurate rip without any chance for a repair?

CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1062
This seems to be an inaccurate rip without any chance for a repair - errors in each track.
CUETools 2.1.4

  • bit4bit
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1063
Gregory, thank you for your fast reply. I was always wondering how other 50 - 65 people were able to make an accurate rip. This leads me to another question. Is it in any way possible to retrieve information about the CD-Drives these people used from the AccurateRip database?

  • maiolina
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1064
Hi, and thanks for this very useful application!
I've read in some posts that there's a script that checks automatically for the "usual" pregap times (32, 37 ms etc), where can I find it?
Thanks!

CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1065
This leads me to another question. Is it in any way possible to retrieve information about the CD-Drives these people used from the AccurateRip database?

Nope. If you don't have such problems with other CDs, most probably it's just a bad CD.

I've read in some posts that there's a script that checks automatically for the "usual" pregap times (32, 37 ms etc), where can I find it?

Ahem, [a href='index.php?act=findpost&pid=707559']one page earlier[/a]
CUETools 2.1.4

  • maiolina
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1066
Ooops you're right, I've surrender some pages before...
How do I apply the custom script to CT 2.0.9?

CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1067
Go to advanced settings (by clicking the gray cog-wheel at the top), proceed to the Scripts tab, click on any script, press Insert. Enter the name of new script, paste the code on the right, and check the 'Verify' option for this script.
CUETools 2.1.4

  • maiolina
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1068
Thanks, now it's time to test it!

  • krafty
  • [*][*][*][*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1069
Gregory, this is what I get in Ubuntu 10.04 when I run CUETools and press "Settings" button....
Am I missing a package or is it a bug?

Code: [Select]
user@orion-desktop:~/win32/CUETools_2.0.6$ mono CUETools.exe
System.NullReferenceException: Object reference not set to an instance of an object
  at JDP.frmSettings.encodersBindingSource_CurrentItemChanged (System.Object sender, System.EventArgs e) [0x00000]
  at System.Windows.Forms.BindingSource.OnCurrentItemChanged (System.EventArgs e) [0x00000]
  at System.Windows.Forms.BindingSource.<ConnectCurrencyManager>m__5 (System.Object o, System.EventArgs args) [0x00000]
  at System.Windows.Forms.CurrencyManager.OnCurrentChanged (System.EventArgs e) [0x00000]
  at System.Windows.Forms.CurrencyManager.ChangeRecordState (Int32 newPosition, Boolean validating, Boolean endCurrentEdit, Boolean firePositionChanged, Boolean pullData) [0x00000]
  at System.Windows.Forms.CurrencyManager.UpdateIsBinding () [0x00000]
  at System.Windows.Forms.CurrencyManager.ListChangedHandler (System.Object sender, System.ComponentModel.ListChangedEventArgs e) [0x00000]
  at System.Windows.Forms.BindingSource.OnListChanged (System.ComponentModel.ListChangedEventArgs e) [0x00000]
  at System.Windows.Forms.BindingSource.ResetBindings (Boolean metadataChanged) [0x00000]
  at System.Windows.Forms.BindingSource.SetList (IList l) [0x00000]
  at System.Windows.Forms.BindingSource.ResetList () [0x00000]
  at System.Windows.Forms.BindingSource.OnParentCurrencyManagerChanged (System.Object sender, System.EventArgs args) [0x00000]
  at System.Windows.Forms.CurrencyManager.OnMetaDataChanged (System.EventArgs e) [0x00000]
  at System.Windows.Forms.CurrencyManager.ListChangedHandler (System.Object sender, System.ComponentModel.ListChangedEventArgs e) [0x00000]
  at (wrapper delegate-invoke) System.ComponentModel.ListChangedEventHandler:invoke_void__this___object_ListChangedEventArgs (object,System.ComponentModel.ListChangedEventArgs)
  at System.Windows.Forms.BindingSource.OnListChanged (System.ComponentModel.ListChangedEventArgs e) [0x00000]
  at System.Windows.Forms.BindingSource.ResetBindings (Boolean metadataChanged) [0x00000]
  at System.Windows.Forms.BindingSource.SetList (IList l) [0x00000]
  at System.Windows.Forms.BindingSource.ResetList () [0x00000]
  at System.Windows.Forms.BindingSource.set_DataSource (System.Object value) [0x00000]
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.BindingSource:set_DataSource (object)
  at JDP.frmSettings.frmSettings_Load (System.Object sender, System.EventArgs e) [0x00000]
  at System.Windows.Forms.Form.OnLoad (System.EventArgs e) [0x00000]
  at System.Windows.Forms.Form.OnLoadInternal (System.EventArgs e) [0x00000]
System.ObjectDisposedException: The object was used after being disposed.
  at System.Windows.Forms.Control.CreateHandle () [0x00000]
  at System.Windows.Forms.Form.CreateHandle () [0x00000]
  at System.Windows.Forms.Control.get_Handle () [0x00000]
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.Control:get_Handle ()
  at System.Windows.Forms.Application.RunLoop (Boolean Modal, System.Windows.Forms.ApplicationContext context) [0x00000]
  at System.Windows.Forms.Form.ShowDialog (IWin32Window owner) [0x00000]
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.Form:ShowDialog (System.Windows.Forms.IWin32Window)
  at JDP.frmCUETools.toolStripButtonSettings_Click (System.Object sender, System.EventArgs e) [0x00000]
  at System.Windows.Forms.ToolStripItem.OnClick (System.EventArgs e) [0x00000]
  at System.Windows.Forms.ToolStripButton.OnClick (System.EventArgs e) [0x00000]
  at System.Windows.Forms.ToolStripItem.HandleClick (System.EventArgs e) [0x00000]
  at System.Windows.Forms.ToolStripItem.FireEvent (System.EventArgs e, ToolStripItemEventType met) [0x00000]
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.ToolStripItem:FireEvent (System.EventArgs,System.Windows.Forms.ToolStripItemEventType)
  at System.Windows.Forms.ToolStrip.OnMouseUp (System.Windows.Forms.MouseEventArgs mea) [0x00000]
  at System.Windows.Forms.Control.WmLButtonUp (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.ScrollableControl.WndProc (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.ToolStrip.WndProc (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000]
  at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000]
user@orion-desktop:~/win32/CUETools_2.0.6$

  • X0R
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1070
-When Encoding, unticking the Embed Image, image still gets  embedded.[checked again & again -  bug still happens]

It seems that when "Copy album art tags" is enabled, image gets embedded even if it comes from a file.


Thanks for verifying this.
I have another question, when using CueRipper, it ignores the proxy settings I use in CueTools,
Am I missing something, or did I just submit another feature request  ?

CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1071
In the fake EAC log when using burst mode, are there really two passes (test and copy)? It's been my experience with a scratched disc that the disc is only ripped once in burst mode, because I am getting matching CRCs in CUERipper where it seems nearly impossible to get matching CRCs.

If you are really only making one pass, please make the log indicate such. Otherwise, it's INCREDIBLY misleading. If I rip a disc that's not in the AR or CT databases, and there are no errors in the log, I would come to the conclusion that the rip was good because the log indicates matching CRCs.

Here are two rips of the same track.


Code: [Select]
Track 18

     Peak level 85.1 %
     Track quality 100.0 %
     Test CRC A70CFB1B
     Copy CRC A70CFB1B
     Cannot be verified as accurate (confidence 2)  [63C66920], AccurateRip returned [0DB83FED]
     Copy OK



Code: [Select]
Track 18

     Suspicious position 0:00:00 - 0:00:04
     Suspicious position 0:00:07 - 0:00:24
     Suspicious position 0:00:35 - 0:01:07
     Suspicious position 0:01:09
     Suspicious position 0:01:14 - 0:01:33
     Suspicious position 0:02:13 - 0:02:24
     Suspicious position 0:02:26 - 0:02:36

     Peak level 99.8 %
     Track quality 100.0 %
     Test CRC 5B1D0D44
     Copy CRC 5B1D0D44
     Cannot be verified as accurate (confidence 2)  [BEDCF086], AccurateRip returned [0DB83FED]
     Copy OK



  • Wooops
  • [*]
CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1072
One minor question, since 2.0.9 how can you display the summary and the verification log? If I select Multibrowser or dragĀ“n drop mode it only shows the summary i.e. "AR: offset 681, rip accurate (7/7), CTDB: disk not present in database.", while in folder mode or without browser it only displays the log. :S

btw been using CT for some time and works great, thank you a lot!

CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1073
I noticed a weird behavior on some of my rips... I verified & submitted my library today and some lines in the log caught my eye:
Quote
B:\Music\hack//G.U\[Album] hack//G.U. Game OST I  Disc #1.flac: AR: offset -499, rip not accurate (2/2), CTDB: disk not present in database, z6E00y3ZcDQWhRDTr0EoMeovtQU- has been uploaded.
B:\Music\hack//G.U\[Album] hack//G.U. Game OST I  Disc #2.flac: AR: rip not accurate (2/2), CTDB: disk not present in database, TJbX55eCSO6YmSH5qOBoNsjOMk8- has been uploaded.
B:\Music\Kajiura Yuki\[Album] Kajiura Yuki - Noir - Blanc dans Noir II.flac: HDCD detected, AR: offset 30, rip not accurate (0/5), CTDB: disk not present in database, will not submit.
What I wonder is, why does it submit anything to the CTDB if the rip is not accurate? Also, the Noir CD is a simple audio CD and not a HDCD (what's that, anyway oO)

Also, it seems like simply checking if the disk exists on AR isn't a good idea. CueTools found some of the single flac tracks lying around my HDD in AR and submitted them as albums to CTDB ._.
Maybe you should add a length check to it? I doubt there are singles out that are <10 mins long.
Scratch that, i just looked at the log again and it seems CUETools was smart enough to treat them as albums and not single tracks. That's great
edit2: There is one problem though, looks like it checks the %album% tag only. I have some rips that have the same %album% tag and only differ by %discnumber% tags. Cuetools treated this album as 1 CD...

One more thing, could you pleas add a "Yes to all"/"No to all" buttons? When one verifies the whole library, it's really annoying to sit there an confirm you want to overwrite the logs.
Also, why is CUETools still writing "Disk not found in CTDB" in the log if it just submitted the album to the DB itself?

edit: just ran verify a second time to test if the 2 "not accurate" rips were really submitted:
Code: [Select]
B:\Music\hack//G.U\[Album] hack//G.U. Game OST I  Disc #1.flac: CUEToolsDB: verified OK, confidence 2.
B:\Music\hack//G.U\[Album] hack//G.U. Game OST I  Disc #2.flac: CUEToolsDB: verified OK, confidence 2.
  • Last Edit: 17 June, 2010, 11:19:41 AM by ChronoSphere

CUETools versions 1.9.5 through 2.1.5 (current)
Reply #1074
Also, the Noir CD is a simple audio CD and not a HDCD (what's that, anyway oO)

HDCDs are simple audio CDs with (allegedly) higher quality due to tricks that allow a 20-bit depth in the standard 16-bit audio. If CUETools says it's HDCD, it most certainly is, and you'll see in the options the ability to decode to 20-bits.

One more thing, could you pleas add a "Yes to all"/"No to all" buttons? When one verifies the whole library, it's really annoying to sit there an confirm you want to overwrite the logs.

x1000!