Skip to main content

Topic: My Columns UI config · FooSune (Read 165326 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Mutier
  • [*]
My Columns UI config · FooSune
Reply #100
Sune, thx for this nice config. I really like it and it works like a charme.... except it doesn't seem to remember the layout settings. It would be really cool, if there would be an update with chronflow and this nice mini mode, which someone posted in this thread.

Again, I really appreciate your work. Thx!!

Ciao
Mutier
  • Last Edit: 06 September, 2008, 01:13:34 PM by Mutier

  • Nitrius
  • [*][*]
My Columns UI config · FooSune
Reply #101
Nice config, and zero problems so far =)

  • Sasori
  • [*]
My Columns UI config · FooSune
Reply #102
Hello, I've got a little problem. When I open foo from song file (ex. mp3), gui is deformed ;/

I have to import config again ;/ But when I open Foobar from it's shortcut, everything is OK. What's the problem?
  • Last Edit: 10 September, 2008, 09:53:56 AM by Sasori

  • Onkel Andy
  • [*][*]
My Columns UI config · FooSune
Reply #103
Hello, I've got a little problem. When I open foo from song file (ex. mp3), gui is deformed ;/ [a href="http://img229.imageshack.us/my.php?image=foosunedn7.jpg" target="_blank"]
  • Last Edit: 10 September, 2008, 10:44:05 AM by Onkel Andy

  • Falstaff
  • [*][*][*][*][*]
My Columns UI config · FooSune
Reply #104

Hello, I've got a little problem. When I open foo from song file (ex. mp3), gui is deformed ;/ [a href="http://img229.imageshack.us/my.php?image=foosunedn7.jpg" target="_blank"]


i confirm. PSS bug

  • wallen
  • [*]
My Columns UI config · FooSune
Reply #105
First of all, thanks for the configuration - it's impressively good-looking. I made some changes here and there to my liking; the only thing I'd like to change but I can't really find in the Splitter Settings is the Font Size of the Time Played/Total Time string in the right upper corner above the seekbar. Could anyone give me a hand here?

  • Sasori
  • [*]
My Columns UI config · FooSune
Reply #106


Hello, I've got a little problem. When I open foo from song file (ex. mp3), gui is deformed ;/ [a href="http://img229.imageshack.us/my.php?image=foosunedn7.jpg" target="_blank"]


i confirm. PSS bug


Aww, then problem will be fixed, when new PSS version go out?

  • Nitrius
  • [*][*]
My Columns UI config · FooSune
Reply #107
The playlist switcher and playlist tabs on the bottom of the playlist, is it possible to turn these off? Not off, but everytime i start the player it keeps showing up, because i tend to use the little circle to "turn it off" but on every restart of the play it comes back.

  • Scottyyy
  • [*]
My Columns UI config · FooSune
Reply #108
Other than the opening files through explorer bug, it's a really nice config.

Thanks

  • florin
  • [*]
My Columns UI config · FooSune
Reply #109
I love FooSune but I cannot use it because of that plug in that doesn't work on older CPUs. Can you make a mod without that. I am sure it will still look and fell great. pleeeeeeease

  • Sasori
  • [*]
My Columns UI config · FooSune
Reply #110
The playlist switcher and playlist tabs on the bottom of the playlist, is it possible to turn these off? Not off, but everytime i start the player it keeps showing up, because i tend to use the little circle to "turn it off" but on every restart of the play it comes back.

Yes, when you turn them off, right mouse button on dot -> splitter settings -> playlist tabs(on left side), tick "hide on startup"
  • Last Edit: 13 September, 2008, 05:15:25 AM by Sasori

  • Scottyyy
  • [*]
My Columns UI config · FooSune
Reply #111
edit: nevermind, it was the .cue file in the folder trying to play. I deleted it and the tracks stopped repeating.

For some reason the tracks are the repeating, but with question marks for the length. I can delete them from the playlist, but if I go to another page (a different artist for example) then switch back, the duplicated tracks will appear again.



Any ideas what's going on here?

Thanks
  • Last Edit: 13 September, 2008, 11:24:22 AM by Scottyyy

My Columns UI config · FooSune
Reply #112
edit: nevermind, it was the .cue file in the folder trying to play. I deleted it and the tracks stopped repeating.

For some reason the tracks are the repeating, but with question marks for the length. I can delete them from the playlist, but if I go to another page (a different artist for example) then switch back, the duplicated tracks will appear again.



Any ideas what's going on here?

Thanks

Go To Edit, and remove dead items. I don't think your problem is do to this config, but give that a try and see if that works, should.

  • tbinta
  • [*]
My Columns UI config · FooSune
Reply #113
I am a novice user trying out your config. After going through your instructions and setting everything up I got this problem:


  • chevalmeow
  • [*]
My Columns UI config · FooSune
Reply #114
Sune,

I signed up today, mainly to thank you for this thread.  I really like your creation and have installed it without problems.  I'll be experimenting with the lyrics aspect and trying out all the possibilities.

Looks and works awesome!!

Many Thanks!!!!!!!

  • Last Edit: 21 September, 2008, 08:15:32 PM by chevalmeow

  • tgpo
  • [*][*]
My Columns UI config · FooSune
Reply #115
I've continued to update and refine my mini mode.  I've begun to change some colors and styles and may eventually fold this out into a new config, who knows.

My goal is to have a nice, clean config that is light on graphics, but still very stylish.  I also want the mini mode to be as compact of possible while still giving controls and info to the user.


  • myclie
  • [*]
My Columns UI config · FooSune
Reply #116


hm, how do you add the picture to the album? I don't seen any way  i suck


Install Album Art Downloader.  Install the Run Services plugin.  Add the following as a Run Service named Coverdownload:

Code: [Select]
"C:\Program Files\foobar2000\AlbumArtDownloader\AlbumArt.exe" "%artist%" "%album%" "$replace(%path%,\%filename_ext%,)/folder.jpg"


Add this as a button:

Code: [Select]
$button(72,16,0,0,27,20,images\FooSune/BUTTONS\foobarforum.png,images\FooSune/BUTTONS\foobarforum_over.png,Coverdownload,)


You will need to play with the placement to make the button appear where you want it.

In a nutshell this button will launch the Album Art Downloader program, feed it the artist info it needs, and allow you to download the cover art you need.  It will automatically place the file in the correct folder, and the playlist will autoupdate with the new artwork.


thx for this. its working fine here too.

Unfortunately since i'm using this skin, I get a run time error r625(?) when I close foobar. one of the components might cause this. any ideas about this error? it also does not happen always...

ps: i'm using vista 64


Remove the playlists dropdown components, cause it's unstable in vista. try it!

  • heid
  • [*]
My Columns UI config · FooSune
Reply #117


Does anyone know what's wrong with the top? Everything is fine except for those black lines to the left of the spectrum and that bar that the song's time is on.

  • heid
  • [*]
My Columns UI config · FooSune
Reply #118
One more problem I'm having is that sometimes the album art doesn't display on the left, but it will display in the playlist. Help?

  • sune
  • [*][*][*]
My Columns UI config · FooSune
Reply #119
@ heid : that is really strange, it seems the header image is somehow "fading" to the right, I have no idea why, but maybe you could try different versions of panel stack splitter and see if it fixes it
Yes, it's actually a version problem. Go to http://foo2k.chottu.net/ and download v0.3.4a. That should fix it

@ everyone: I've been away from this forums for a long time. I've been very very busy and have not had time to look into all your problems, I apologise. Right now I find myself with a little more free time and I'm starting to make a new version of this config with more stable components and Vista-compatible.

It will probably take a while, but I'll post an update at some point

and thanks to everyone who has helped other users in this thread
  • Last Edit: 03 November, 2008, 11:12:47 AM by sune

  • Falstaff
  • [*][*][*][*][*]
My Columns UI config · FooSune
Reply #120
@ heid : that is really strange, it seems the header image is somehow "fading" to the right, I have no idea why, but maybe you could try different versions of panel stack splitter and see if it fixes it
Yes, it's actually a version problem. Go to http://foo2k.chottu.net/ and download v0.3.4a. That should fix it

@ everyone: I've been away from this forums for a long time. I've been very very busy and have not had time to look into all your problems, I apologise. Right now I find myself with a little more free time and I'm starting to make a new version of this config with more stable components and Vista-compatible.

It will probably take a while, but I'll post an update at some point

and thanks to everyone who has helped other users in this thread

nice to see u again sune

keep the good work.

  • sune
  • [*][*][*]
My Columns UI config · FooSune
Reply #121
thanks falstaff

I've been looking at your kung foo config, great job! but what I really like is the last version of Ibiza. keep it up!

  • pnG
  • [*]
My Columns UI config · FooSune
Reply #122
hey everybody. I am really really enjoying Foo_sune, one of the best non-PUI configs i have tried.

I have one customization i would like to make, but im not much of a coder, and im not into ElPlaylist at all, so thought you guys might help me out

I tag all my favorite tracks with FAV "1", and would like to place a webdings star in front of the trackname, when browsing songs.

also, if i could place a star after the albumart, when the albums are collapsed, if the album contains a song with FAV "1".

Im trying to solve the first problem, with little luck,  but i have absolutely no idea on how to do the second one.

thank you

  • sune
  • [*][*][*]
My Columns UI config · FooSune
Reply #123
The star in the album header is not possible, unless the track tagged as FAV is the FIRST on in the album..

For the star in front of the track name, you have to add this line in Elplaylist settings > Track List tab
       
Code: [Select]
$if($strcmp(%fav%,1),$font(wingdings,9,)$drawtext($char(171),$add($get(tracknumber_indent),13),0,,%el_height%,%_color_title_text_%,vcenter),)$font(calibri,8,)


You have to add that in 3 places (bolded here so you can see where to put it:)

$if($stricmp(%comment%,'single'),
        $drawtext($char(8226),$sub($get(tracknumber_indent),3),1,,%el_height%,%_color_title_text_%,vcenter)
        $if($strcmp(%fav%,1),$font(wingdings,9,)$drawtext($char(171),$add($get(tracknumber_indent),13),0,,%el_height%,%_color_title_text_%,vcenter),)$font(calibri,8,)
        $drawtextex(%album artist%  -  %title%,$get(title_indent),1,$get(left_text_width_single),%el_height%,$if(%el_isplaying%,223-234-255,%_color_title_text_%),vcenter end_ellipsis)
        $drawtext(%length%,-$add(%_right_track_%,4),1,,%el_height%,%_color_tracknumber_text_%,vcenter right)
        $drawtext($if($stricmp(%album artist%,%artist%),['(' %album% ')'],$if(%album%,[%artist%  ]['(' %album% ')'],[%artist%])),-$get(title_indent_right),1,,%el_height%,%_color_artist_text_%,vcenter right)
,
  $if($stricmp(%album artist%,%artist%),
        $drawtext([%tracknumber%],$get(tracknumber_indent),0,,%el_height%,%_color_tracknumber_text_%,vcenter)
        $if($strcmp(%fav%,1),$font(wingdings,9,)$drawtext($char(171),$add($get(tracknumber_indent),13),0,,%el_height%,%_color_title_text_%,vcenter),)$font(calibri,8,)
        $drawtextex(%title%,$get(title_indent),0,$sub(%el_width%,220),%el_height%,$if(%el_isplaying%,223-234-255,%_color_title_text_%),vcenter end_ellipsis)
        $drawtext(%length%,-$add(%_right_track_%,4),0,,%el_height%,%_color_tracknumber_text_%,vcenter right)
        ,
        $drawtext([%tracknumber%],$get(tracknumber_indent),0,,%el_height%,%_color_tracknumber_text_%,vcenter)
        $if($strcmp(%fav%,1),$font(wingdings,9,)$drawtext($char(171),$add($get(tracknumber_indent),13),0,,%el_height%,%_color_title_text_%,vcenter),)$font(calibri,8,)
        $drawtextex(%title%,$get(title_indent),0,$get(left_text_width),%el_height%,$if(%el_isplaying%,223-234-255,%_color_title_text_%),vcenter end_ellipsis)
        $drawtext(%length%,-$add(%_right_track_%,4),0,,%el_height%,%_color_tracknumber_text_%,vcenter right)
        $drawtext(%artist%,-$get(title_indent_right),0,,%el_height%,%_color_artist_text_%,vcenter right )
  )
)

My Columns UI config · FooSune
Reply #124
sune, thank you very much for your configuration !!
I am using it now and everything works as it should work.
I tried many configs and yours is the first I really like. It's very handy (especially the artist, album and year browser), looks great and it's not bloated. It's exactly what I was searching for.
Also thanks for fixing the issue with group headers not showing when there is only one track inside the group.
I have one little question. I have my music collection in the Flac format. When playing the flac files, the group header shows FLAC, a question mark and the bitrate (for example FLAC ? 762). Is it possible to change it so that it shows VBR instead of a question mark or that it just shows only FLAC and bitrate?
Also the shown bitrate is the average bitrate for the first song only. Is it possible that it shows the average bitrate for the complete album?

Thanks again very much.
  • Last Edit: 11 November, 2008, 02:35:31 PM by JellyBelly