Skip to main content

Topic: tgpo Foobar Config (Read 31304 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • tgpo
  • [*][*]
tgpo Foobar Config
tgpo Foobar2000 Config


Full View
Download v1.1

Required Components
Columns UI - Link
Panel Stack Splitter - Link
Track Info Mod - Link
Single Column Playlist - Link
Graphical Browser - Link
Quick Search Toolbar - Link
Playlist Dropdown - Link
Album List
WSH panel - Note: WSH panel is included in the Problematic Components list.  While I've had not problems with this component, be advised that others have.


Fonts Used
Arial

Installation
1) Unzip tgpo.zip in your foobar/themes folder.
2) Go to File/Preferences, Display/ColumnsUI, Main Tab, Under FCL importing and exporting click the Import... button and import the tgpo.fcl file.
3) Click View/Layout and select tgpo
4) Be sure to properly set the theme folder at the top of each plugin settings panel.

Design inspired by Elegance

Please post any bugs, errors, or problems you encounter.

Version History

1.1
  • Complete UI redesign
  • Added Mute button
  • Added Volume Bar
  • Remove all fonts used except Arial
1.03
  • Reworked padding on Tracks in Playlist Mode
  • Added Seekbar (display only) to Playlist Mode
1.02
  • Fixed bug that caused folder.jpg images not to display
  • Fixed Mini Mode track info background error
1.01Fixed Mini Mode Background Error
1.0 Initial Release

To Do List
  • Convert Design to Fluid Width/Height
  • Non WSH Panel Version
  • Add Playlist Sorting
  • Stylize Playlist Dropdown
  • Stylize Quick Search
  • Add Playback Order (Shuffle/Normal) Button
  • Last Edit: 06 October, 2008, 07:42:15 AM by tgpo

  • d0ng
  • [*][*]
tgpo Foobar Config
Reply #1
Testing it right now, nice of you releasing your config.

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #2
Fixed an error on the Mini mode that caused the top background not to show up.

It will be in the next release.

  • Nii2
  • [*]
tgpo Foobar Config
Reply #3
Hi,

it's nice, but for me it doesn't work and I don't understand why...I can't see the covers, and I can't see the satus bar. I will try again later.

  • labou
  • [*][*][*]
tgpo Foobar Config
Reply #4
did u update it???

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #5
did u update it???


Yeah, the config has been updated to fix the MINI mode error.

  • labou
  • [*][*][*]
tgpo Foobar Config
Reply #6
cool. but i still got a problem... whenever i change from album to playlist or any of the others i have to resize foobar cuz the menu will got out of place.

edit:

btw... what theme r u using???
  • Last Edit: 28 June, 2008, 02:27:03 PM by labou

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #7
cool. but i still got a problem... whenever i change from album to playlist or any of the others i have to resize foobar cuz the menu will got out of place.


Sounds Like not all the settings are intact.  I may not have explained everything in my directions.  As I said, this is my first ever release of a foobar config, so I'm unsure how much the fcl file includes and how much I need to explain outright.

On Monday, when I'm at my computer next, I'll update the instructions and make sure everything is properly explained.

btw... what theme r u using???


Microsoft Zune Theme.

tgpo Foobar Config
Reply #8
Nice looking theme, I'll try this out later and help if i can with bugs.
Edit: any chance for a non-WSH panel version please?
Edit: Could you have and artist, button to switch. (just like you have for albums)
Edit: The only way to leave mini-mode is to hit browse and then play list.*ONLY* if you want the small play list to show, otherwise you'll have to re-size it again.
Edit: Could  you also add better support for full screen? So that the album art stretches with the outline border around it does, that would fix the full mode, is this possible?
Edit: A play list selector ability would be great.Some how i did not notice play list drop down, LOL sorry about that. Everything else would be a good feature to have.
Edit: A option to stop showing that mini mode with your website address would be nice.
Edit: Start up can be set to play list(would be a nice feature)

My playback buttons will not show any idea why?
  • Last Edit: 29 June, 2008, 12:54:34 AM by ActiveThoughts

  • Nii2
  • [*]
tgpo Foobar Config
Reply #9
Hi,

it's nice, but for me it doesn't work and I don't understand why...I can't see the covers, and I can't see the satus bar. I will try again later.


I have updated, so now it works better...the only issue is that it doesn't show the covers in mini and playlist mode. They are all named "folder.jpg\png" in the album's folder.
  • Last Edit: 28 June, 2008, 11:04:45 PM by Nii2

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #10
Edit: any chance for a non-WSH panel version please?
Edit: Could you have and artist, button to switch. (just like you have for albums)
Edit: A option to stop showing that mini mode with your website address would be nice.
Edit: Start up can be set to play list(would be a nice feature)


I'll see what I can do for the next release.

Edit: The only way to leave mini-mode is to hit browse and then play list.*ONLY* if you want the small play list to show, otherwise you'll have to re-size it again.


You can't just go straight to play list?  If not, that's a bug.  All other view modes should expand the window.

Edit: Could  you also add better support for full screen? So that the album art stretches with the outline border around it does, that would fix the full mode, is this possible?


We'll see.  I'm a fix width kinda guy.  I've never been much of a liquid design kinda person, but perhaps I'll make an exception.

My playback buttons will not show any idea why?


And you did set the theme folder setting?  If you see the background image, you should see the buttons unless there is something off about the panel settings.


I have updated, so now it works better...the only issue is that it doesn't show the covers in mini and playlist mode. They are all named "folder.jpg\png" in the album's folder.


It should be picking up the folder.jpg no problem.  If they're in the album's folder, make sure the custom image folder setting is unchanged.  If it is still the default, then we've got a bug.

  • Nii2
  • [*]
tgpo Foobar Config
Reply #11
It should be picking up the folder.jpg no problem.  If they're in the album's folder, make sure the custom image folder setting is unchanged.  If it is still the default, then we've got a bug.


Thanks for the answer...but where can I find the custom image folder setting, please?

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #12
Thanks for the answer...but where can I find the custom image folder setting, please?


Well, If you don't know where it is, then I guess it's safe to assume you didn't change it.

It's located at the top of the settings of each component that shows the images.  It allows you to specify a specific folder for images it it's outside of the folder with the MP3 files.

tgpo Foobar Config
Reply #13
Hi, tgpo thanks for the replys. I have no problem with your slim look design i think it's a nice feature, so making a full mode is just a wishlist kinda deal. I did not change the folder settings at all, except where to look for cover art, everything else (buttons) show but my playback buttons. I will try again.  Thanks, i noticed that if i have this, Folder wise order, /themes/tgpo/tgpo/images settings tgpo.fcl (my playback buttons don't show) however if i just take the second tgpo folder and have this /themes/tgpo/images settings tgpo.fcl My buttons (playback) show fine. So everything so far is now cool.
Edit: just found out that playbutton does not show at all, but the pause button is in it's place at all times. Weird
  • Last Edit: 29 June, 2008, 02:44:50 PM by ActiveThoughts

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #14
Hi, tgpo thanks for the replys. I have no problem with your slim look design i think it's a nice feature, so making a full mode is just a wishlist kinda deal. I did not change the folder settings at all, except where to look for cover art, everything else (buttons) show but my playback buttons. I will try again.  Thanks, i noticed that if i have this, Folder wise order, /themes/tgpo/tgpo/images settings tgpo.fcl (my playback buttons don't show) however if i just take the second tgpo folder and have this /themes/tgpo/images settings tgpo.fcl My buttons (playback) show fine. So everything so far is now cool.


That explains it.  It should only have one tgpo folder.  I'll add this point to my instructions.  It should be /themes/tgpo/*files*

Edit: just found out that playbutton does not show at all, but the pause button is in it's place at all times. Weird


That's actually how it is right now, until we get %isplaying% or %ispaused% support in Panel Splitter.  If it bothers you, you can switch their placement in the if statement in the config code.

tgpo Foobar Config
Reply #15
That's actually how it is right now, until we get %isplaying% or %ispaused% support in Panel Splitter.  If it bothers you, you can switch their placement in the if statement in the config code.

Ok, thanks. Then everything seems to be straight and working good. A rating feature would be a nice/handy feature to have with your design.

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #16
Ok, thanks. Then everything seems to be straight and working good. A rating feature would be a nice/handy feature to have with your design.


Just so I know how much info I need to give on each release.  How much info did the fcl include, and what did you have to manually add?

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #17
Found a bug that would cause folder.jpg covers not to show up in Mini and Platlist modes.  The fix will be in the next release.

tgpo Foobar Config
Reply #18
Quote
Just so I know how much info I need to give on each release.  How much info did the fcl include, and what did you have to manually add?


Hi, if you're asking about what i changed to make the rating fucntion, that is nothing ( never did it) But if you're also talking about in (general) i had to edit the path, /tgpo/tgpo, example but i then just extracted the folder with the one /tgpo and i didn't have to edit anything.

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #19
Quote
Just so I know how much info I need to give on each release.  How much info did the fcl include, and what did you have to manually add?


Hi, if you're asking about what i changed to make the rating fucntion, that is nothing ( never did it) But if you're also talking about in (general) i had to edit the path, /tgpo/tgpo, example but i then just extracted the folder with the one /tgpo and i didn't have to edit anything.


I mean per component what did you have to do?  Did you have to copy/paste the setting for Track Info Mod, or was it already there?

tgpo Foobar Config
Reply #20
Quote
I mean per component what did you have to do? Did you have to copy/paste the setting for Track Info Mod, or was it already there?
Nope it was already to go. Had to do NO editing. When i installed the skin in the correct path. It was fine. on my end.

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #21
Quote
I mean per component what did you have to do? Did you have to copy/paste the setting for Track Info Mod, or was it already there?
Nope it was already to go. Had to do NO editing. When i installed the skin in the correct path. It was fine. on my end.


Killer!  From a maintenance standpoint, that makes my life 1000x easier.

  • tgpo
  • [*][*]
tgpo Foobar Config
Reply #22
Version 1.1 Released

  • Janny
  • [*]
tgpo Foobar Config
Reply #23
Hey, it's abydos from 5/8. Posting here so you don't have to look in both threads for the same thing
I have a problem, I installed it and downloaded all the plugins, but it won't play anything when I double click. It just sits there as if it's on pause.



Also, will it be possible to make it show the bitrate of albums? As in V0, V2, FLAC, etc?
How did you make the volume bar active on mouse over with the wheel?
Are there any shortcuts to switch through viewing modes?
  • Last Edit: 08 July, 2008, 12:38:12 PM by Janny

tgpo Foobar Config
Reply #24
Hi, nice new re-design. Though i have found a slight problem, besides full mode(which looks good with the album art but everything else ain't right), i noticed when i have the play list at start up instead of the mini-mode, and when i hit play i see a piece of my album art at the top track info part. But when i click like mini-mode, or browser, and then click back into the play list the album art disappears and appears normally without it. Can you fix this?
Edit: Also, when i re size the window a little bit to show the track ino panel a little more when clicking the GB, graphical browser(acutally clicking any of the buttons) then  it re size the window back to the way it was instead of keeping it (the way i changed it too)
Here is some screen shots
             
The first one, is the album art in my track info in start-up with playlist not hidden, and the second one is when i resized my window a little to show the track info more like your screen shot, and the third one is after i click a button and the window then becomes re-sized back to normal which isn't right on my end.
  • Last Edit: 08 July, 2008, 04:41:49 PM by ActiveThoughts