Skip to main content

Topic: EAC/REACT - Missing Cuesheet error (Read 9170 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Skinjob
  • [*]
EAC/REACT - Missing Cuesheet error
I just recently upgraded to the latest EAC (0.99pb4) and REACT (2.0.ssb16p).  Now, whenever I try to rip to FLAC tracks, I get an error message "REACT: Missing Cuesheet" with the description "Unable to move cuesheet.  File does not exist".

I'm ripping tracks, not images, and I have CreateAllCuesheets=0 in my REACT.ini, so I'm not sure why it's trying to create a cuesheet.  I poked around in the source code and it seem like fGUICreateGleanCuesheet is called unconditionally.  Is this be design?

The problem seems to be that EAC won't create a cue sheet.  Even when I try to create one manually from the Action\Create Cuesheet menu it won't do it.  I don't get any error message, but no cue file is created.  But again, I'm not sure why REACT is trying to create one in the first place.

Sythetic Soul, it you're out there, could you please offer some advice?

  • Skinjob
  • [*]
EAC/REACT - Missing Cuesheet error
Reply #1
Never mind, I'm an idiot.  I was missing a trailing backslash in the EAC extraction folder path.  It's creating the cue file correctly now.

Still not sure why the cue file is needed, but at least it's working now.

  • Synthetic Soul
  • [*][*][*][*][*]
  • Global Moderator
EAC/REACT - Missing Cuesheet error
Reply #2
I'm ripping tracks, not images, and I have CreateAllCuesheets=0 in my REACT.ini, so I'm not sure why it's trying to create a cuesheet.  I poked around in the source code and it seem like fGUICreateGleanCuesheet is called unconditionally.  Is this be design?
Later versions of my mod create a cuesheet in track mode to determine the number of audio tracks on the CD.  EAC reports the total number of tracks - which may include data tracks - so this workaround is necessary to ensure that post-processing code is always run.

I'm glad that you managed to resolve it.
I'm on a horse.

  • Skinjob
  • [*]
EAC/REACT - Missing Cuesheet error
Reply #3
Later versions of my mod create a cuesheet in track mode to determine the number of audio tracks on the CD.  EAC reports the total number of tracks - which may include data tracks - so this workaround is necessary to ensure that post-processing code is always run.

So you're saying that the post-rip processing (ReplayGain, etc.) at the end of the .cfg file will actually run now on disks that have a data session?  If so, that's a very nice fix.

Do you still have to select the last audio track for this to work, or will it work with arbitrarily selected tracks that don't include the last one?  This would come in handy when you get errors and have to rerip a few tracks.  It would be nice if the ReplayGain was recalculated in that case.  I always seem to forget it.

Anyway, thanks for the quick reply and thanks for continuing REACT development.  As nice as dbPowerAmp is becoming, it still doesn't come close to the control and customization you have with EAC/REACT.

Moderation: Quotation fixed.
  • Last Edit: 14 April, 2008, 12:38:17 PM by greynol

  • Altair
  • [*]
EAC/REACT - Missing Cuesheet error
Reply #4
I got REACT working but I still have a small bug.  I too am getting an error message from 'React v2.0.akku.b03' saying "Unable to move cusheet.  File does not exit.  Canceling will abort rip."  I get choices retry or cancel.

I'm ripping to FLAC and Mp3 tracks with cuesheets=  in my .INI file.  There is a terminal backslash in my EAC path as described above.  If I just keep hitting 'retry' everything works fine, but...?  Any ideas?

  • Akkurat
  • [*][*][*][*][*]
  • Developer
EAC/REACT - Missing Cuesheet error
Reply #5
I too am getting an error message from 'React v2.0.akku.b03' saying "Unable to move cusheet.  File does not exit.  Canceling will abort rip."  I get choices retry or cancel.

If I just keep hitting 'retry' everything works fine, but...?  Any ideas?

1) Does this happen with every CD?
2) Does pressing retry once solve the problem?
3) Do you see an "Analyzing" window with "Detecting Track Indices" (this is crucial, there are other "analyzing" windows) text in it when starting a rip?
  3.1) Does it stay visible long? (about seconds)
4) You said something like "had to downversion EAC" in the other thread, what did you mean, i.e. what EAC version are you using?

Put DebugMode=1 in INI and try to rip a CD (+retry until you succeed) and post the debugging.txt file (in REACT folder) contents to here (in CODEBOX tags). You can cancel the rip once it starts extracting the tracks.

  • Altair
  • [*]
EAC/REACT - Missing Cuesheet error
Reply #6
Quote
1) Does this happen with every CD?

Only on CD's subsequent to a CD whose album art cannot be located by aad.

Quote
2) Does pressing retry once solve the problem?

Retry only brings another error of the same in a short while.

Quote
3) Do you see an "Analyzing" window with "Detecting Track Indices" (this is crucial, there are other "analyzing" windows) text in it when starting a rip?

Only analyzing window is: "Detecting Pre Track Gaps", which appears when I cancel the missing cue sheet message.

  
Quote
3.1) Does it stay visible long? (about seconds)

    It is present for about a minute on a 1hr CD

Quote
4) You said something like "had to downversion EAC" in the other thread, what did you mean, i.e. what EAC version are you using?

I am using EAC .95beta4

Before I "debug" my guess is the message is related to my closing aad in a wrong fashion when it does not find any or doesn't find an acceptable piece of album art.  In these cases I have tried additional searches in aad by modifying the album name/artist as read from freedb.  Sometimes I may try 3 or 4 times to find a classical cover.  Each attempt opens a new aad window.  I think perhaps REACT is linked only to the first window and my 'X'ing out of the additional windows after saving the art from an unlinked window creates the problem.   

When I rip a CD that has artwork found by aad and saved by my clicking on it, the process goes smoothly and I move on to the next CD seamlessly.

So with this in mind, 2 questions:
1) What is the proper way to handle aad when it comes up empty handed?
2) .95beta4 doesn't have accuraterip, may I use .99prebeta4, and how would I upgrade without screwing up REACT?



  • Akkurat
  • [*][*][*][*][*]
  • Developer
EAC/REACT - Missing Cuesheet error
Reply #7
Before I "debug" my guess is the message is related to my closing aad in a wrong fashion when it does not find any or doesn't find an acceptable piece of album art...

I can't reproduce your problem.

1) What is the proper way to handle aad when it comes up empty handed?
2) .95beta4 doesn't have accuraterip, may I use .99prebeta4, and how would I upgrade without screwing up REACT?

1) With my tests, any way you like.. but that's not working with you right now. P.S. Opening new windows doesn't screw up the process since they do NOT open in new instances.. REACT just waits for the program to be closed (if RunCoverDownloader is set to 1 or 2 in INI (in track mode)).
2) Of course you can use the newest EAC. Updating EAC doesn't touch REACT settings.

I suggest that you update EAC to the latest version (.99pb4). If you still after that have problems, please post here a list of steps to reproduce the problem.

  • Akkurat
  • [*][*][*][*][*]
  • Developer
EAC/REACT - Missing Cuesheet error
Reply #8
@Altair: I just had an idea; have you tried to change the "EAC -> Drive Options -> Gap Detection" settings? The about 1 minute duration of the "Detecting Pre Track Gaps" window you mentioned sounds a bit too long to me.. you could try to change the detection method. I have this 1 CD (out of about 400 CDs) which fails weirdly the gap detection method I've chosen and because of this, REACT gives me warning messages. Maybe the CD drive, gap detection method chosen & some of your CDs combination fails with you too. Long shot but easy and fast to try out.. you never know.  I don't know if the "detection accuracy" affect the process, I've it set to "Secure", but it maybe worth to try out also that setting.

  • dag0
  • [*]
EAC/REACT - Missing Cuesheet error
Reply #9
I have the same problem as Altair since upgrade to Win7 with Eac 0.99 (wich I used before with WinXP) but not with eac 0.95 beta4. My akkumod is b04. What could be the reason and what the disadvantage of EAC 0.95?
  • Last Edit: 08 October, 2012, 04:26:06 PM by dag0

  • dag0
  • [*]
EAC/REACT - Missing Cuesheet error
Reply #10
I have the same problem as Altair since upgrade to Win7 with Eac 0.99 (wich I used before with WinXP) but not with eac 0.95 beta4. My akkumod is b04. What could be the reason and what the disadvantage of EAC 0.95?


Silly me, I had only a "\" in my EAC-Config as Outdir. I thought this was automatically configured  correctly by REACT. Now it works!
Other question: How do I get this "Additional Metadata Dialog" working. I can se my individual tags as configured in REACT.ini in the dialog, but they do not appear as tags in my encoded files. What do I have to do? I am encoding to flac-image plus cue-sheet.
  • Last Edit: 25 October, 2012, 12:09:30 PM by dag0