Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foobar 0.9.5.1beta2: Installer deletes components (Read 6811 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foobar 0.9.5.1beta2: Installer deletes components

I just installed foobar 0.9.5.1 beta 2.
The installer overrides the components folder and deletes all previous installed components.
I'm using Vista 32bit Home Premium.

EDIT: Can't reproduce that problem. Don't know what happened.

foobar 0.9.5.1beta2: Installer deletes components

Reply #1
No such problems in Windows XP SP2.

foobar 0.9.5.1beta2: Installer deletes components

Reply #2
Didn't happen to me in Vista Ultimate x64.

foobar 0.9.5.1beta2: Installer deletes components

Reply #3
Can't confirm this either (Vista 32 Home Premium)

 

foobar 0.9.5.1beta2: Installer deletes components

Reply #4
This is known to happen only if you've done one of the following:
  • Deleted installer.ini from your foobar2000 installation directory
  • Made your original install with one of license-violating third-party repacks which don't produce a valid installer.ini
We are the bork. Your software bugs will be added to our own. Resistance is futile.

foobar 0.9.5.1beta2: Installer deletes components

Reply #5
Likely your old foobar installation lost its infos (installer.ini in foobar installation folder and/or some reg entries). I don't know for sure though.

EDIT: Gah, Peter is faster and obviously more accurate.

foobar 0.9.5.1beta2: Installer deletes components

Reply #6
Peter und thuan, you're right. I inadvertently deleted installer.ini. Found it in Recycled. I'll do that never again!

foobar 0.9.5.1beta2: Installer deletes components

Reply #7
This is known to happen only if you've done one of the following:
  • Deleted installer.ini from your foobar2000 installation directory
  • Made your original install with one of license-violating third-party repacks which don't produce a valid installer.ini

By the way, the XP->Vista upgrade process quarantines all .ini files from the Program Files folder.
.

foobar 0.9.5.1beta2: Installer deletes components

Reply #8
Use 7-Zip to extract the installer.

I don't know how many times I've written about this "issue" with the installer.
Windows 10 Pro x64 // foobar2000 1.3.10

foobar 0.9.5.1beta2: Installer deletes components

Reply #9
Use 7-Zip to extract the installer.

I don't know how many times I've written about this "issue" with the installer.

I've search for posts by you that contain the word "installer". I'm counting eight posts where you recommend to just use 7-Zip to extract files from the installer. In six of these posts you explain that you always do this because the installer deleted your components folder once. Now, would you please stop spreading panic?

By the way, an installation created using 7-Zip will not contain a valid installer.ini, which would trigger this issue on any subsequent attempt to update this installation using the installer.