Skip to main content

Topic: foo_vis_shpeck (Read 548533 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • tpijag
  • [*][*][*][*][*]
foo_vis_shpeck
Reply #650
Not sure exactly the issue, but you do seem confused.  There is no reason to treat foo_vis_shpeck.dll any different than any other foobar component.

It goes where they all go, in their own folder - under your user-components foobar folder.

If you would install components via the install button on the foobar preferences>Components page it will be done correctly for you. If it is showing in Foobar, are you sure you have not multiple version scattered about? Since foobar finds it, let's move on.

You do not need an entire winamp installation. You need nothing from winamp. Winamp viz plugin such as milkdrop wants to install within a winamp directory structure by default so shpeck looks for installed wiz there. ie, [:\Program Files\Winamp ]  Let the plugins install themselves there or point them wherever you want. Just make sure they are installed = where shpeck thinks they are as per the top option in shpeck preference dialog. Let's move on.

You do not see any availalbe plugins in the shpeck dialog. Have you any installed under [:\Program Files\Winamp]?
  • Last Edit: 01 February, 2011, 01:32:02 PM by tpijag

  • Xyzzy
  • [*]
foo_vis_shpeck
Reply #651
Hello

I have run Shpeck with no problem, with AVS and MilkDrop, but I have problem determining one thing- how to make AVS automatically change "effect"?
Milkdrop changes itself OK (configurable in Preferences), but how to set AVS?

TIA

Self service:
In AVS toolbar menu go to AVS Editor, then Settings> Presets / Hotkeys, check Randomly switch presets...
  • Last Edit: 07 February, 2011, 05:18:10 PM by Xyzzy

  • Cheung
  • [*]
foo_vis_shpeck
Reply #652
How do you get this to work? I've put foo_vis_shpeck.dll in the Plugins-folder. Shpeck appears in foobar Preferences. But I don't get anything to show under Available plugins... I've placed a WinAmp installetion .exe under C:\Programs, is this not how you are supposed to do?


1. You must place the foo_vis_shpeck.dll in the \foobar2000\components folder.
2. Place the entire Winamp folder (the Winamp folder that arrived in your milkdrop.2.23.7z  download) in your  \foobar2000\ root directory.
Yes, I know that it is okay to place it elsewhere too, but I prefer to place it in the foobar2000 root directory where I can easily locate it.  And don't go picking out and moving parts from that Winamp folder 
3. Launch Foobar and go to: File / Preferences / Visualizations / Shpeck /
In the upper right corner of the window, and immediately underneath the words "Winamp directory" you will see a field box.  Make sure that the path to the Winamp folder is entered in there correctly. Then click on the "OK" tab at the far right of that field box.
4. If you don't see "Milkdrop v2.23 / Milkdrop v2.23" in the Available Plugins window then click on the Refresh List tab.

Addendum: If you are a power user with a strong GPU then configure Milkdrop as follows:
1.  Desktop and Full screen and Windowed to 60 fps.
2. Disable the option to "Save CPU by loosely enforcing Max Framerate".
3. Configure it to start in full screen with your highest native resolution.

Enjoy Milkdrop, it's dazzling.

Cheung

  • Last Edit: 07 February, 2011, 11:39:15 PM by Cheung

  • ionreflex
  • [*]
foo_vis_shpeck
Reply #653
I just want to report that since foobar2000-1.1.1, shpeck-0.3.7 won't work to display %listening_now% for Digsby (build 29036)... revert to fb2k-1.1 and working again!

Didn't do any troubleshoot, quite frankly wouldn't know what to look for, but if I could help in some way, just PM me!


Seems appropriate to report it's working now with fb2k-1.1.2 and Digsby (build 29291)...
[^]
___
ion][reflex
[reflexion]

  • tribaljet
  • [*][*]
foo_vis_shpeck
Reply #654
So, any news about the famous (and hopefully still planned to) new release of shpeck, Yirkha?

It's a very useful component, one that's essential for me, and since I read somewhere around here something about a possible 0.4.0 release (this many months ago), I'm still eagerly awaiting for such news that will bring pure bliss to every living soul

foo_vis_shpeck
Reply #655
Milkdrop always starts with the same visualization. It's random after that ...

The same thing happens to me as well. Is there a fix for this? I don't like getting bored of a preset I see too often.

Edit: Nevermind. I think I have a different problem.
  • Last Edit: 14 February, 2011, 08:17:59 PM by Dodecahedron

foo_vis_shpeck
Reply #656
Alright, whenever I run MD 2.23 it seems to be stuck on the same few predefined sequences of presets. There's no real randomness like in Winamp even with the default settings.

foo_vis_shpeck
Reply #657
I keep getting "the plugin crashed during rendering."  >:C


  • bakis
  • [*]
foo_vis_shpeck
Reply #658
Did anyone get milkdrop to work with foobar and Shpeck yet?
I installed it all, all setup, config is working properly (v1.04 Milkdrop) but when starting the plugin i get "The plugin crashed during frame rendering.".
Win7 64bit user, latest Foobar.
  • Last Edit: 06 March, 2011, 08:20:01 PM by bakis

  • tribaljet
  • [*][*]
foo_vis_shpeck
Reply #659
Milkdrop 2.2 works fine over here, with a slimmed down portable Winamp 5.56 folder. After that version, it seems some Resource Hacker must be used due to manifest messing Milkdrop showing up on shpeck's list.

Is there a specific reason you use 1.04?

  • bakis
  • [*]
foo_vis_shpeck
Reply #660
Ah sweet. Got it to work after a few tries of different Winamp versions.
Seems Winamp v5.5 is workig perfectly with Shpeck, even got it in a nice UI element and not only fullscreen on one of my two screens.

On another matter, just started to use Foobar today and I got trouble getting some UI element to show cue info for mix mp3s.
If anyone got some ideas pop by http://www.hydrogenaudio.org/forums/index....mp;#entry747267
  • Last Edit: 06 March, 2011, 08:57:23 PM by bakis

  • Chesteta
  • [*]
foo_vis_shpeck
Reply #661
MilkDrop 2.23 package for foobar2000 is ready.

Changelog (Winamp 5.6.0.3080):
Fixed: [vis_milk2] Some presets not loading under locales other than English

Download link 1 (RS)
Download link 2 (HF)

Please use latest 7zip (7.20) or compatible for extraction


I am running 7-zip 9.20 and keep getting an error that says "Unsupported compression method for '[directory/file name]"

I downloaded the file from both hotfile and rapidshare (both did not work for me) could you please re-upload? Thank you.

  • cmyden
  • [*]
foo_vis_shpeck
Reply #662
So I got MilkDrop 2.2 up and running, a big thanks to Yirkha for creating this component, and to bukem for providing the MilkDrop packs.  It truly is a thing of beauty to have this running in Foobar.  I went a little Milkdrop crazy and downloaded a package containing over 35,000 presets, gotta love it.

Can anyone tell me a bit more about G-Force?  Is it still in development?  Does it work well with Shpeck?  Which version works the best?
  • Last Edit: 09 April, 2011, 05:54:05 PM by cmyden

  • bukem
  • [*][*][*]
foo_vis_shpeck
Reply #663
I am running 7-zip 9.20 and keep getting an error that says "Unsupported compression method for '[directory/file name]"
I downloaded the file from both hotfile and rapidshare (both did not work for me) could you please re-upload? Thank you.

@Chesteta:
Links and files are OK. Please try to download them again.

ALCON:
MilkDrop 2.23 has been temporarily reverted to 2.22 version in latest Winamp 5.601 release. If you have stability problems with MilkDrop 2.23 please revert to MilkDrop 2.22 too.

  • DoctorO
  • [*]
foo_vis_shpeck
Reply #664
to clarify the Milkdrop versioning *fun* seen recently, Winamp 5.60x ships with v2.23 whereas Winamp 5.61 was meant to ship with v2.2 but in fact is shipping with v2.21 which was accidental (and not as per the versions stated in the above post or the Winamp changelog).

also the main reason for the reversion is due to some localisation related issues when run in Winamp and with a language pack matching the user's locale which leads to some cases of unresponsiveness in the presets or other compatibility issues. in the context of being used in Foobar that shouldn't be something which happens (unless this component it completely replicating all of the api_language service Milkdrop uses for localisation).

and whilst i remember, thank you to those people who pointed out some issues with Milkdrop running under this component with titles and a few other things - wouldn't have known to fix it over the v2.2x builds if people hadn't mentioned it here

-daz
  • Last Edit: 11 April, 2011, 07:23:33 AM by DoctorO

  • Chesteta
  • [*]
foo_vis_shpeck
Reply #665
I extracted it at school with winrar and it worked, so I'm not sure what was wrong at home...

foo_vis_shpeck
Reply #666
I'm having some trouble getting AVS to work.

I tried using the AVS plugin found in the newest release of winamp, and it either crashed on startup or never displayed anything. Once it displayed a single frame of data, but it never updated.

I read earlier in the thread that the 556 version is more stable, so I'm trying to setup that version now, and I'll see whether that helps.

Does anyone have any tips / a working AVS install they can share?

  • tribaljet
  • [*][*]
foo_vis_shpeck
Reply #667
I'm having some trouble getting AVS to work.

I tried using the AVS plugin found in the newest release of winamp, and it either crashed on startup or never displayed anything. Once it displayed a single frame of data, but it never updated.

I read earlier in the thread that the 556 version is more stable, so I'm trying to setup that version now, and I'll see whether that helps.

Does anyone have any tips / a working AVS install they can share?


Winamp 5.56 folder with all working default vis plugins, including Milkdrop 2.2 and AVS: http:// www.mediafire.com/ ?ybv4a39yrp4l15m

  • manaox2
  • [*]
foo_vis_shpeck
Reply #668
Thank you for this. It works amazingly well, really wanted this for a long time.

  • emk2203
  • [*]
foo_vis_shpeck
Reply #669
Thanks for the link to the plugins folder including AVS (I'm mainly running milkdrop, but once in a while...)

and also a BIG thanks to Yirkha for this awesome plugin! I would also ask for the Shpeck 0.40 update - even if it just brings Shpeck again to the focus for new users. It is simply too amazing to be neglected.

  • emk2203
  • [*]
foo_vis_shpeck
Reply #670
Winamp 5.56 folder with all working default vis plugins, including Milkdrop 2.2 and AVS: http:// www.mediafire.com/ ?ybv4a39yrp4l15m

Since I wanted to give something back, I traced the DLL dependencies and added the one missing from Winamp to the pack (IE compatibility dll? wtf?).

This is a "lean and mean" archive which contains everything to run Shpeck with Milkdrop2 (2.23), AVS and Nullsoft Tiny. This should be the bare minimum needed for the three visualisations. Works for me under Windows 7 (64-bit).

http:// www.megaupload.com/ ?d=3BUQU7W9

You need to remove the spaces since links to filehosters are not allowed. If somebody gets mad over this, please point out a "legal" alternative...

  • tribaljet
  • [*][*]
foo_vis_shpeck
Reply #671
Winamp 5.56 folder with all working default vis plugins, including Milkdrop 2.2 and AVS: http:// www.mediafire.com/ ?ybv4a39yrp4l15m

Since I wanted to give something back, I traced the DLL dependencies and added the one missing from Winamp to the pack (IE compatibility dll? wtf?).

This is a "lean and mean" archive which contains everything to run Shpeck with Milkdrop2 (2.23), AVS and Nullsoft Tiny. This should be the bare minimum needed for the three visualisations. Works for me under Windows 7 (64-bit).

http:// www.megaupload.com/ ?d=3BUQU7W9

You need to remove the spaces since links to filehosters are not allowed. If somebody gets mad over this, please point out a "legal" alternative...


So basically, you just updated Milkdrop, as everything else was already running on the Winamp 5.56 package.

BTW, what Winamp version is your folder based on?

  • emk2203
  • [*]
foo_vis_shpeck
Reply #672
So basically, you just updated Milkdrop, as everything else was already running on the Winamp 5.56 package.

BTW, what Winamp version is your folder based on?

I took the existing Milkdrop 2.23 version from the forum and while trying to add your folder, I discovered that there is a lot more in there than just the visualisations. That bugged me, and so I added just the vis_* stuff - but it didn't work.

So I had to trace the missing dependencies and added just the needed dlls to the components folder. I zipped this minimum package and uploaded it in case that anyone else would like to see a components folder with just the needed files, not more.

I agree that it is purely cosmetic because your folder works, but still - I wanted only the needed files, not the other stuff.
  • Last Edit: 11 June, 2011, 02:42:42 PM by emk2203

  • tribaljet
  • [*][*]
foo_vis_shpeck
Reply #673
Ah, I see. But from what version of Winamp did you take Milkdrop 2.23 from?

  • emk2203
  • [*]
foo_vis_shpeck
Reply #674
Ah, I see. But from what version of Winamp did you take Milkdrop 2.23 from?

Simply from Chesteta's link above. Didn't bother to install WinAmp again (even though I have a WinAmp license, but Foobar2000 is so much better...). 

PS: Here is the download link (MU) again via TinyURL so it's clickable.
  • Last Edit: 12 June, 2011, 08:59:06 AM by emk2203