Skip to main content

Topic: problem with albumart source (Read 2970 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Kenny^2K
  • [*]
problem with albumart source
Hi all,

Iam using foobar and iam very happy with it. But there seems to be a bug in the albumart component.
I use:

"C:\Programme\foobar2000\coverdownloader\cover\%artist%_$replace(%album%,:,).jpg"

for the source.. The Preview displays:

"C:\Programme\foobar2000\coverdownloader\cover\Timbaland_Presents Shock Value.jpg"

for example...
that is totaly right. But albumart won't load artworks with a removed ":". The files are there... but albumart doesn't load them :-(

Anyone had the same problem?

Thanks for help.

  • gfngfgf
  • [*][*][*][*][*]
problem with albumart source
Reply #1
It's not a bug, just not the behavior you're expecting.  Invalid filename characters in tags (such as ':' and '/') are replaced with the wildcard '?' before any other titleformatting functions (such as $replace) are evaluated.  That means you can't define exactly how invalid characters are replaced.

  • Kenny^2K
  • [*]
problem with albumart source
Reply #2
OK!. for example:

artist: John Williams
album: Star Wars Episode III: Revenge Of The Sith

the cover is correctly stored here:
C:\Programme\foobar2000\coverdownloader\cover\John Williams_Star Wars Episode III Revenge Of The Sith.jpg

what is the correct string for albumart to display it?

thx for help.

  • gfngfgf
  • [*][*][*][*][*]
problem with albumart source
Reply #3
You'll have to rename the cover to something like:

C:\Programme\foobar2000\coverdownloader\cover\John Williams_Star Wars Episode III_ Revenge Of The Sith.jpg

The point is, you have to replace the ":" with another character in the filename.  As far as I know, there is no way to make it work with the colon removed.

  • Kenny^2K
  • [*]
problem with albumart source
Reply #4
AHhhhhhhhh.
Big thx. finaly working. I didn't thought about replacing with another legit character.