Skip to main content

Topic: Album Art Downloader XUI (Read 1261881 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Eli
  • [*][*][*][*][*]
Album Art Downloader XUI
Reply #2525
Alex,
Amazon script seems to be struggling to get the full size image. I have found this frequently but thought you would like an example, so here is the last one I noticed:

http://www.amazon.com/Electric-Warrior-T-Rex/dp/B006HH5Y6K

Eli

Thanks for the report. When I do a search for that album with the Amazon (.com) v0.11s script, I get:

http://www.amazon.com/Electric-Warrior-Mar.../dp/B000002KP3/
http://www.amazon.com/Electric-Warrior-Ses.../dp/B000001JKJ/

Not the B006HH5Y6K one you mention. I notice on the page you posted that the image is only 300x300 and has an AutoRip stamp stuck on top of it, so I'm not too concerned about not getting that one...


The embedded image is 1425x1425 and the one that showed up in AAD. However AAD was never able to download the 1425x1425 image. If I go to the web page, show source and search for jpg I can find the source image (for when you scroll over the thumbnail with autorip, and you get

http://ecx.images-amazon.com/images/I/71El...hL._SL1425_.jpg

I think the ones I am running into are these AutoRip images, where there is an embedded large image (hover your mouse over the image). Somehow AAD can see them, but doesn't manage to download them.
  • Last Edit: 30 April, 2014, 07:54:29 AM by Eli

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2526
The embedded image is 1425x1425 and the one that showed up in AAD. However AAD was never able to download the 1425x1425 image. If I go to the web page, show source and search for jpg I can find the source image (for when you scroll over the thumbnail with autorip, and you get

http://ecx.images-amazon.com/images/I/71El...hL._SL1425_.jpg


Hmm. Seems to work OK for me. I search for "T Rex" / "Electric Warrior" with Amazon (.com) v0.11s, and the first result is B006HH5Y6K. When I click the thumbnail, it resolves to 1425x1425 (150 KB). Clicking the save button saves it out as Folder.jpg with no problem.

  • Jeroma
  • [*]
Album Art Downloader XUI
Reply #2527
I'm trying to figure this out. Is it possible to search for album art based on ID3 tags? If so, how would I do that? In addition, I don't like adding Album names for my Singles (I just leave it blank). Therefore, iTunes can't find the album art for the songs, since it only searches for "Artist - Album". It would be nice if I could use the title of a song as the Album title to solve this problem.

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2528
Is it possible to search for album art based on ID3 tags?

Yes, just use the File Browser, and make sure it is set in the options to "Use ID3 tags from files" rather than file path pattern matching.

It would be nice if I could use the title of a song as the Album title to solve this problem.

You can do this, but not if you are using tags! If you are using a file path pattern, and your files are named in a regular way so that it's easy to extract the artist name and the song title from the file name and folder, then you could do it. For example, if your files were in folders named for the artist, and the track was named as simply the song title.mp3, then the pattern to use would be \%artist%\%album%.mp3

  • thorazine
  • [*]
Album Art Downloader XUI
Reply #2529
Google Play Music, on the other hand, does look quite promising, with good quality high res images. Here's a script for it, if you'd like to try it out and give me any comments before I make it available through online updates: google-play.boo. It would also be useful to know if you find any full-size images that are not 1448×1448 pixels - if I can be reasonably sure that they are all that size, I will have the script report them as such rather than "Unknown".


Hi, the script worked fine for me until a month ago or so, I guess Google changed something in their page?
BTW, I found this great google-play source just by accident, so I thought maybe I'm missing some other great scripts, maybe you should include a list of test, trial, beta scripts not included in the program in the first post of this thread for everybody to see and try?

Also, have you thought about adding an AllMusic script? They have lots of covers and some of them are in high resolution...

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2530
Hi, the script worked fine for me until a month ago or so, I guess Google changed something in their page?
BTW, I found this great google-play source just by accident, so I thought maybe I'm missing some other great scripts, maybe you should include a list of test, trial, beta scripts not included in the program in the first post of this thread for everybody to see and try?

Also, have you thought about adding an AllMusic script? They have lots of covers and some of them are in high resolution...

Thanks for reporting this, I've uploaded an updated google-play.boo.

There is a list of scripts that's kept up to date, and can be queried by Album Art Downloader itself. There should be a "Get more scripts" link which will give you a list of scripts from that URL that you haven't installed yet.

I guess it would be nice to have scripts classified as test, trial, beta, etc. but to be honest they never go through that rigorous a process. If someone requests one, and I think it's worth doing and write it, then I ask the person who requested it to test it out for a bit, then I publish it on the main list. All scripts break frequently as the source sites get updated, so none can really be regarded as mature and stable. I do try and fix any that are reported broken though.

  • maynak00
  • [*]
Album Art Downloader XUI
Reply #2531
how to use original filename for albumarts?
this not help: Folder%preset%[%source%][%name%].%extension%

http://a5.mzstatic.com/us/r30/Music2/v4/34...200x1200-75.jpg
I want: UMG_cvrart_00602537402540_01_RGB72_1800x1800_13UMGIM59022.1200x1200-75.jpg or iTunes_id646228740_UMG_cvrart_00602537402540_01_RGB72_1800x1800_13UMGIM59022.1200x1200-75.jpg

http://a5.mzstatic.com/us/r30/Music2/v4/df...200x1200-75.jpg
I want: UMG_cvrart_00602537409785_01_RGB72_1800x1800_13UMGIM59023.1200x1200-75.jpg or iTunes_id646191408_UMG_cvrart_00602537409785_01_RGB72_1800x1800_13UMGIM59023.1200x1200-75.jpg
sorry for my English.

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2532
how to use original filename for albumarts?

There's no general way to do this, as there is not necessarily anything that could be considered a "filename" for the art downloaded. Sometimes (but not always) there is a URL for the art downloaded, but to extract something useful as a filename out of this would need to be done individually by each script. If you wanted to modify a script to do so, then the best thing to do would be to use that as the name of the result, which could then be accessed as %name% in the pattern.

  • mea
  • [*]
Album Art Downloader XUI
Reply #2533
hi Alex,

I was wondering a few months ago if someone figured out how to make AAD usable in osx by using winebottler. do you have any idea of the parameters I should use to make it run under osx ?
By the way, is the memory allocation problem that makes the RAM be used more and more till the app crash now fixed ? I can't run the scan for more than, lets say, 500 albums, the RAM is used as cache and when totally used, the app crashes 



  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2534
I was wondering a few months ago if someone figured out how to make AAD usable in osx by using winebottler. do you have any idea of the parameters I should use to make it run under osx ?
Last time I checked WPF wasn't supported, so it simply wouldn't work. If they've got WPF working under wine now then it's entirely possible that AAD is usable, but I've no idea what special parameters it might need, sorry.

I can't run the scan for more than, lets say, 500 albums, the RAM is used as cache and when totally used, the app crashes
Do you mean in the file browser? There is a little memory consumed for each album in the list, to hold the details of it, and the UI objects of the list entry itself, but 500 isn't going to take up much. The only thing that takes up a lot of memory in AAD are images, and those should be released whenever you close the search window that is displaying them. If you are finding that you are running out of memory *without* a lot of images in an open window, then there may be a bug.

Alex

  • rael71
  • [*]
Album Art Downloader XUI
Reply #2535
Hi,

I'm new here.
I recently passed from windows 7 to 8.1 pro and now when I launch AAD it shows the error screen.

When I click on "reset all settings to default and restart", I got this error "Could not determine path to configuration file"


Here's the log:
Album Art Downloader encountered an error when attempting to read its
configuration settings, and could not start.
If you wish to report this error, please include this information, which
has been written to the file: C:\Users\andrea\AppData\Local\Temp\AAD_errorlog.txt

App version: 1.0.1.0, running on Microsoft Windows NT 6.2.9200.0 (64 bit)

System.Configuration.ConfigurationErrorsException: Dichiarazione imprevista nella sezione di configurazione 'connectionStrings'.
  in System.Configuration.ConfigurationManager.get_ConnectionStrings()
  in System.Configuration.PrivilegedConfigurationManager.get_ConnectionStrings()
  in System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties)
  in System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider)
  in System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName)
  in System.Configuration.SettingsBase.get_Item(String propertyName)
  in System.Configuration.ApplicationSettingsBase.GetPropertyValue(String propertyName)
  in System.Configuration.ApplicationSettingsBase.get_Item(String propertyName)
  in AlbumArtDownloader.Properties.Settings.get_ApplicationVersion()
  in AlbumArtDownloader.App.Main(String[] args)

Can anyone help me?

Thanks in advance and bye

Andrea

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2536

Hi Andrea,

The solution would be to delete the configuration file, however I don't know why AAD has been unable to determine the path to it to delete it automatically, when you click the reset all settings button.

To do it manually, I'd recommend going to the "%localappdata%\AlbumArtDownloader" folder (should resolve to "C:\Users\andrea\AppData\Local\AlbumArtDownloader" for you)and deleting it. This will remove all album art downloader settings, which should hopefully let it start up successfully next time.

Alex

  • rael71
  • [*]
Album Art Downloader XUI
Reply #2537

Hi Andrea,

The solution would be to delete the configuration file, however I don't know why AAD has been unable to determine the path to it to delete it automatically, when you click the reset all settings button.

To do it manually, I'd recommend going to the "%localappdata%\AlbumArtDownloader" folder (should resolve to "C:\Users\andrea\AppData\Local\AlbumArtDownloader" for you)and deleting it. This will remove all album art downloader settings, which should hopefully let it start up successfully next time.

Alex


Alex Thank you for your reply.

The strange thing is that I haven't any AlbumArtDownloader Folder in appdata!
I tried uninstalling and reinstalling aad but got no AlbumArtDownloader Folder in appdata....
I tried to create manually the folder in appdata but got the same message from AAD

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2538
The strange thing is that I haven't any AlbumArtDownloader Folder in appdata!

Huh, I guess that would explain why it couldn't determine the path to it, then. What it doesn't explain is how there can be config file errors if there aren't any config files. Could you check in the folder you installed it to (usually C:\Program Files\AlbumArtDownloader) and see if there is an AlbumArt.exe.config file there? Or any other .config files, for that matter, there shouldn't be any with a fresh install...

If there aren't, then there's a problem with the .NET Framework on your computer. I'd recommend going to the Programs and Features control panel, and clicking on the link to change installed windows features, then uncheck .NET Framework 3.5 to remove it. Once it's removed, go back and re-check the box to install it again. With a bit of luck, it might repair itself.

Alex

  • rael71
  • [*]
Album Art Downloader XUI
Reply #2539
The strange thing is that I haven't any AlbumArtDownloader Folder in appdata!

Huh, I guess that would explain why it couldn't determine the path to it, then. What it doesn't explain is how there can be config file errors if there aren't any config files. Could you check in the folder you installed it to (usually C:\Program Files\AlbumArtDownloader) and see if there is an AlbumArt.exe.config file there? Or any other .config files, for that matter, there shouldn't be any with a fresh install...

If there aren't, then there's a problem with the .NET Framework on your computer. I'd recommend going to the Programs and Features control panel, and clicking on the link to change installed windows features, then uncheck .NET Framework 3.5 to remove it. Once it's removed, go back and re-check the box to install it again. With a bit of luck, it might repair itself.

Alex


First of all sorry for the late but I've been very busy in the last few days.

Anyway, Alex you're a genius!!!!!!
I unistalled AAD anf then disabled and enabled again .net 3.5, reinstalled AAD and now it works perfectly!!

Thanks so much!

Andrea

  • k76
  • [*]
Album Art Downloader XUI
Reply #2540
Downloaded AAD yesterday, installed on my WIN7x64, on clicking AlbumArt.exe it opens for a few seconds and then automatically closes:

App version: 1.0.1.0, running on Microsoft Windows NT 6.1.7601 Service Pack 1 (64 bit)

System.Configuration.ConfigurationErrorsException: The 'system.serviceModel/services' configuration section cannot be created. The machine.config file is missing information. Verify that this configuration section is properly registered and that you have correctly spelled the section name. For Windows Communication Foundation sections, run ServiceModelReg.exe -i to fix this error.
  at System.ServiceModel.Configuration.ConfigurationHelpers.UnsafeGetAssociatedSection(ContextInformation evalContext, String sectionPath)
  at System.ServiceModel.Configuration.ServicesSection.UnsafeGetSection()
  at System.ServiceModel.Description.ConfigLoader.LookupService(String serviceConfigurationName)
  at System.ServiceModel.ServiceHostBase.ApplyConfiguration()
  at System.ServiceModel.ServiceHostBase.InitializeDescription(UriSchemeKeyedCollection baseAddresses)
  at System.ServiceModel.ServiceHost..ctor(Object singletonInstance, Uri[] baseAddresses)
  at AlbumArtDownloader.InstanceMutex.RunAppAsServiceHost(IPriorInstance instance, String channelUri)
  at AlbumArtDownloader.App.Main(String[] args)

I cannot see a machine.config file anywhere, it sure is not at c:\Program Files (x86)\AlbumArtDownloader\ or c:\Users\xxx\AppData\Local\AlbumArtDownloader\ or any of its subfolders.

The installer went through without any errors.

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2541
I cannot see a machine.config file anywhere, it sure is not at c:\Program Files (x86)\AlbumArtDownloader\ or c:\Users\xxx\AppData\Local\AlbumArtDownloader\ or any of its subfolders.

machine.config is not Album Art Downloader specific, it is for machine-wide configuration settings for .net. It can be found in "C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CONFIG" (or Framework instead of Framework64 if not on a 64bit system).

I'm afraid I have no idea what's gone wrong with yours, though, this isn't something Album Art Downloader or its installer would touch.

Alex

  • k76
  • [*]
Album Art Downloader XUI
Reply #2542
Ran Microsoft's NetFxRepairTool, it didn't claim to find anything wrong. Uninstalled .NET 3.0 from "Install/uninstall Windows Components" (that's the only selection available there, even if 2.0 is also installed here) and reinstalled it. Installed newest .NET 4.5.2. Ran NetFxRepairTool again, it won't find anything wrong.

The funny thing i don't have any issues with any other programs. The error is still the same.

Wait, there is a little improvement! I was so discouraged by the same error again, didn't even try to run it a second time. But this time there is a small screen giving 3 choices, reset, view config, create error report. Chose "Reset all settings to defaults and restart", there's a popup saying "Could not delete configuration file: Access to the path 'C:\Windows\Microsoft.NET\Framework64\V2.0.50727\Config\machine.config' is denied".

View configuration file shows it in the folder...can't claim to understand any of that.

Create error report produces this:

Album Art Downloader encountered an error when attempting to read its
configuration settings, and could not start.
If you wish to report this error, please include this information, which
has been written to the file: C:\Users\xxx\AppData\Local\Temp\AAD_errorlog.txt

App version: 1.0.1.0, running on Microsoft Windows NT 6.1.7601 Service Pack 1 (64 bit)

System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize ---> System.Configuration.ConfigurationErrorsException: Unrecognized configuration section system.serviceModel. (C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Config\machine.config line 134)
  at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
  at System.Configuration.BaseConfigurationRecord.ThrowIfInitErrors()
  at System.Configuration.ClientConfigurationSystem.EnsureInit(String configKey)
  --- End of inner exception stack trace ---
  at System.Configuration.ClientConfigurationSystem.EnsureInit(String configKey)
  at System.Configuration.ClientConfigurationSystem.PrepareClientConfigSystem(String sectionName)
  at System.Configuration.ClientConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.R
efreshConfig(String sectionName)
  at System.Configuration.ConfigurationManager.RefreshSection(String sectionName)
  at System.Configuration.ClientSettingsStore.ReadSettings(String sectionName, Boolean isUserScoped)
  at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties)
  at System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider)
  at System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName)
  at System.Configuration.SettingsBase.get_Item(String propertyName)
  at System.Configuration.ApplicationSettingsBase.GetPropertyValue(String propertyName)
  at System.Configuration.ApplicationSettingsBase.get_Item(String propertyName)
  at AlbumArtDownloader.Properties.Settings.get_ApplicationVersion()
  at AlbumArtDownloader.App.Main(String[] args)

It doesn't recognize the section system.serviceModel? I dont know what it is, but it seems proper XML when viewing it in editor...

Starting at line 134:

  <system.serviceModel>
    <extensions>
      <behaviorExtensions>

Does this tell you anything? There's some PublicKeyTokens so i'm hesitant to post the entire section in public. The previous xml tag </system.web> seems also to be closed properly. Can't see any obvious syntactic errors in here. Then again i have no idea what i'm looking at.

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2543

I've done some searching, and this looks like it might be a known bug with .net. Certainly lots of other people are reporting it, in various circumstances. The suggested fixes (from a Microsoft Connect issue) are to run:

"%windir%\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\ServiceModelReg.exe" /r /x
%windir%\Microsoft.NET\Framework\v3.5\WFServicesReg.exe /c

Alex

  • k76
  • [*]
Album Art Downloader XUI
Reply #2544
The suggested fixes failed (Microsoft quality software...not surprised), so i ended up doing a Windows 7 inplace upgrade to fix my installation.
Now AAD works, hurrah!
  • Last Edit: 26 June, 2014, 12:39:36 AM by k76

  • javacat
  • [*]
Album Art Downloader XUI
Reply #2545
there seems to be a bug in hitparade.boo

when "unknown" is checked in "filter by cover types", hitparade always returns 

the cover for Madeline Juno's "The Unknown".

------

Thanks for a well crafted piece of work!

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2546
there seems to be a bug in hitparade.boo

when "unknown" is checked in "filter by cover types", hitparade always returns 

the cover for Madeline Juno's "The Unknown".

How strange, thanks for reporting it. It appears hitparade always include this album, but commented out in the html source (and the script doesn't check for comment markers). Anyway, I've updated the script to ignore it: hitparade.boo

Alex

  • SigHunter
  • [*][*]
Album Art Downloader XUI
Reply #2547
Hi Alex,
would you please consider the following two things:
(pictures say more than words)

Ability to resize the searchlist and the sources


Add Artist and Albumtags that are being searched for
currently it only shows the found result. I always need to compare the image to what was searched.
Plus, a decent font size would be nice
  • Last Edit: 15 July, 2014, 08:15:27 AM by SigHunter

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Album Art Downloader XUI
Reply #2548
Hi Alex,
would you please consider the following two things:

Thanks for the suggestions. I've added feature requests for these (except the font size, I'm happy with the current size). If I ever do another version of AAD then I expect I'll at least get the artist and album searched for into the result tile, that shouldn't be too tricky.

For the moment, though, what you can do is select the album in the top area, and that will highlight it in the bottom area, that way you know what the result for that search was.

Alex

  • SigHunter
  • [*][*]
Album Art Downloader XUI
Reply #2549
Hi Alex,
would you please consider the following two things:

Thanks for the suggestions. I've added feature requests for these (except the font size, I'm happy with the current size). If I ever do another version of AAD then I expect I'll at least get the artist and album searched for into the result tile, that shouldn't be too tricky.

For the moment, though, what you can do is select the album in the top area, and that will highlight it in the bottom area, that way you know what the result for that search was.

Alex


my screen is 2560x1440 pixels, the fonts are pretty damn small :/
maybe you could make it scale with the size of the pictures or add some simple option "large fonts"-checkbox