Skip to main content

Topic: ICY-streamed titles with semicolons do not display properly (Read 4555 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • mjb2006
  • [*][*][*][*][*]
ICY-streamed titles with semicolons do not display properly
When playing a SHOUTcast HTTP stream, titles containing semicolons are mangled: an apostrophe is added to the beginning of the title, and everything from the first semicolon and beyond is missing.

The problem does not occur when playing static files.

This is with foobar2000 0.9.4.3 on Win2K SP4.

Is this the correct forum in which to report this bug?

  • mjb2006
  • [*][*][*][*][*]
ICY-streamed titles with semicolons do not display properly
Reply #1
This bug persists in foobar2000 1.1 on WinXP.

Also, when a semicolon isn't present, the way the stream title metadata is parsed by foobar2000 seems to be roughly this: everything before the first dash is trimmed of (leading and?) trailing whitespace and goes into %artist%, and the rest is trimmed of leading (and trailing?) whitespace and goes into %title%. In Feb. 2009 I [a href='index.php?act=findpost&pid=616101']reported[/a] that this wasn't ideal because titles typically come through as "artist - title", where artist can have dashes in it. So for example "A-Ha - Take On Me" gets parsed as %artist% "A" and %title% "Ha - Take On Me".

Is it possible to get this behavior changed?

(While you're in there...In that same thread, users lamented the lack of metadata field for accessing the Icy-Name value, which typically has the station name. This value goes into %title% but gets overwritten by in-stream titles. Any chance that could be addressed?)

Thanks
  • Last Edit: 19 January, 2011, 09:17:29 PM by mjb2006

  • ExUser
  • [*][*][*][*][*]
  • Read-only
ICY-streamed titles with semicolons do not display properly
Reply #2
Are you certain this is a foobar2000 bug? Some of the "problems" you're describing sound more like problems on the encoding/streaming end, not the playback end.

  • mjb2006
  • [*][*][*][*][*]
ICY-streamed titles with semicolons do not display properly
Reply #3
Are you certain this is a foobar2000 bug? Some of the "problems" you're describing sound more like problems on the encoding/streaming end, not the playback end.

Yes, I am sure. I captured the raw stream to a file and I looked at it in a hex editor. Here are some examples of actual metadata in the stream:

Code: [Select]
StreamTitle='A-Ha - Take On Me';StreamURL='';

This is parsed as
%artist% = A
%title% = Ha - Take On Me

Code: [Select]
StreamTitle='Nina Simone - Black is the Color of My True Love's Hair [1964 NY session; stereo]';StreamURL='';

This is parsed as
%artist% = 'Nina Simone
%title% = Black is the Color of My True Love's Hair [1964 NY session

StreamURL is normally an empty string. I'm not sure how to get it to be anything different. I don't think it matters.

The station name and URL are only sent in the icy-name and icy-url headers at the beginning of the response:
Code: [Select]
ICY 200 OK
icy-notice1:<BR>This stream requires <a href="http://www.winamp.com/">Winamp</a><BR>
icy-notice2:SHOUTcast Distributed Network Audio Server/Linux v1.9.8<BR>
icy-name:Edited for Privacy
icy-genre:
icy-url:http://edited.for/privacy/
content-type:audio/aacp
icy-pub:0
icy-metaint:8192
icy-br:128

  • ExUser
  • [*][*][*][*][*]
  • Read-only
ICY-streamed titles with semicolons do not display properly
Reply #4
Acknowledged and added to known problems. Might be changed for next release. Thanks for the detailed report.