Skip to main content

Topic: Nero AAC & EAC Why Isn't This Working? (Read 20533 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • CheechOZ
  • [*]
Nero AAC & EAC Why Isn't This Working?
I've just decided to rip my small CD collection (200 CD's) into AAC files, and I want to use EAC, as that is the only ripper that I ever used (and want to use).  I followed the guide in the Nero AAC Recommended Settings post, I think to a "T", but after the ripping process, nothing happens, and the encoding process just fails!!  Some notes as to how I set it up might shed some light as to why it doesn't work:  I use the file extension as m4a, then I copy and paste the command line that is in the post, of course, changing the path used for the encoder, and my preference for quality value.  I use EAC 0.9 b4, as that is the version I use for Uber standard ripping.  Can someone please help me to get this to work correctly? Thanks in advance!

  • HeXeR
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #1
If your path to the nero encoder has spaces, you have to put it in ".

So "C:\Path with spaces\neroenc"

  • CheechOZ
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #2
I checked to make sure the path was copied perfectly with all the correct spaces, but still the cmd window just flashes and doesn't encode!    I am using Vista, I hope that has nothing to do with it 

This is my command line:
/c C:\Program Files\NeroDigitalAudio\neroAacEnc.exe -q 0.65 -if %s -of %d && C:\path\to\Neroaactag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"
  • Last Edit: 11 June, 2007, 10:05:52 AM by CheechOZ

  • HeXeR
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #3
This is my command line:
/c C:\Program Files\NeroDigitalAudio\neroAacEnc.exe -q 0.65 -if %s -of %d && C:\path\to\Neroaactag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"


Funny thing  ^^

It should mean:

/c "C:\Program Files\NeroDigitalAudio\neroAacEnc.exe" -q 0.65 -if %s -of %d && "C:\path\to\Neroaactag.exe" %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"

At "C:\path\to\Neroaactag.exe" you must insert the path to the Neroaactag.exe. And don't forget to set the " ! 

Cheers

  • CheechOZ
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #4

This is my command line:
/c C:\Program Files\NeroDigitalAudio\neroAacEnc.exe -q 0.65 -if %s -of %d && C:\path\to\Neroaactag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"


Funny thing  ^^

It should mean:

/c "C:\Program Files\NeroDigitalAudio\neroAacEnc.exe" -q 0.65 -if %s -of %d && "C:\path\to\Neroaactag.exe" %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"

At "C:\path\to\Neroaactag.exe" you must insert the path to the Neroaactag.exe. And don't forget to set the " ! 

Cheers



My hopes were very high, and I kicked myself in the "A", but I did exactly like you said, and still it doesn't work!  I made sure the path to the encoder and the tagger were set up just right, and even added the ", but sorry it's still not working for me!

  • Shocking
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #5
I also spent a few hours trying to get Nero AAC working with EAC myself yesterday after finally getting a new PC running Vista. I had it set up perfectly on my old PC, however, it just didn't wanna work on this one. I did eventually get it working again, exactly like before. Here are my exact settings... give 'em a go and see if it works.

Firstly, in my EAC folder in my C:\Program Files, I created a new folder called Nero AAC and placed the neroAacEnc.exe and neroAacTag.exe in there.

Now I have 'Use external programme for compression' checked

Parameter passing scheme: User Defined Encoder

Use file extension: .m4a

Programme, including path, used for compression: C:\Windows\System32\Cmd.exe

Additional command line options: /c C:\"Program Files\Exact Audio Copy\Nero AAC"\neroAacEnc.exe -q 0.55 -if %s -of %d && C:\"Program Files\Exact Audio Copy\Nero AAC"\neroAacTag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:year="%y"

Hope this helps. It works like a dream for me. Good luck!

  • Last Edit: 11 June, 2007, 11:04:29 AM by Shocking

  • CheechOZ
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #6
Thanks for helping me out, but I just can't get this to work, and it's probably the simplest thing too!!!  I used the exact same string as you are using, and still nothing! 

  • HeXeR
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #7
Shocking's way of putting the tagger is right. Sorry, my bad! I didn't try it out, I only remembered the time where I ripped to AAC and I had the same problem, too. Now I rip to FLAC and do the lossy compression with Foobar2000.

Shocking's command line is good, only the genre is missing. So here is the real thing (again)

/c C:\"Program Files"\NeroDigitalAudio\neroaacenc.exe -q 0.55 -if %s -of %d && C:\"Program Files"\NeroDigitalAudio\Neroaactag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"

You see, you just have to put the tagger where there is a space.
Example 1: C:\"Program Files"\Nero\neroaacenc.exe
Example 2: C:\"Program Files\Exact Audio Copy\Nero Enc"\neroaacenc.exe

This time I tested it and it works!

And sorry for my bad english.
  • Last Edit: 11 June, 2007, 11:50:47 AM by HeXeR

  • CheechOZ
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #8
Thanks again HeXer, but I copied it exactly as you have it, and still nothing!!

Nothing wrong with your english!!




And this is the command line I copied:

/c C:\"Program Files"\NeroDigitalAudio\neroaacenc.exe -q 0.65 -if %s -of %d && "C:\"Program Files"\NeroDigitalAudio\Neroaactag.exe" %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"
  • Last Edit: 11 June, 2007, 11:59:31 AM by CheechOZ

  • muaddib
  • [*][*][*][*]
  • Developer
Nero AAC & EAC Why Isn't This Working?
Reply #9
Maybe you should use:

"C:\Program Files\NeroDigitalAudio\neroaacenc.exe"

and

"C:\Program Files\NeroDigitalAudio\Neroaactag.exe"

  • CheechOZ
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #10
Can someone else please try and give me the correct command line, I have been playing with this for many hours with no results at all, but I appreciate all the help from everybody, I know that I would do my best to get someone up and running if I could!

  • Alex B
  • [*][*][*][*][*]
Nero AAC & EAC Why Isn't This Working?
Reply #11
Personally I would just rip in the single wave file & cue sheet format. I would rip a few CDs at a time and check the rip logs.

After that I would drag the cue sheets to foobar, check tagging and possibly add or fix some tags and convert. Foobar has easy predefined options for the Nero encoder.

In addition, I would compress the disc image wave files with a lossless codec and archive them for possible future use. If HD space is an issue the lossless files & cue sheets can burned to DVD discs.

  • HeXeR
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #12
And this is the command line I copied:

/c C:\"Program Files"\NeroDigitalAudio\neroaacenc.exe -q 0.65 -if %s -of %d && "C:\"Program Files"\NeroDigitalAudio\Neroaactag.exe" %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"


Copy this:

/c C:\"Program Files"\NeroDigitalAudio\neroaacenc.exe -q 0.55 -if %s -of %d && C:\"Program Files"\NeroDigitalAudio\Neroaactag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"

The version you copied had two taggers too much. I have also edited my post. This command line works 100% for me.
Are you sure you the two encoders are in the right folder? Neroaacenc.exe and Neroaactag.exe have to be in 'C:\Program Files\NeroDigitalAudio' in your case. Do you understand what the command line means?
Which version of EAC are you running? I ask because I have one more option in the compression options: 'Check for external programs return code'.

  • greynol
  • [*][*][*][*][*]
  • Global Moderator
Nero AAC & EAC Why Isn't This Working?
Reply #13
From http://www.ss64.com/nt/cmd.html

Code: [Select]
The following logic is used to process quote (") characters:

    1.  If all of the following conditions are met, then quote characters
        on the command line are preserved:

        - no /S switch
        - exactly two quote characters
        - no special characters between the two quote characters,
          where special is one of: &<>()@^|
        - there are one or more whitespace characters between the
          the two quote characters
        - the string between the two quote characters is the name
          of an executable file.

    2.  Otherwise, old behavior is to see if the first character is
        a quote character and if so, strip the leading character and
        remove the last quote character on the command line, preserving
        any text after the last quote character.
13 February 2016: The world was blessed with the passing of a truly vile and wretched person.

Your eyes cannot hear.

  • Synthetic Soul
  • [*][*][*][*][*]
  • Global Moderator
Nero AAC & EAC Why Isn't This Working?
Reply #14
I must admit the above flumoxes me! 

Easiest way:  put the EXEs in your windows folder and just use:

Code: [Select]
/c neroAacEnc.exe -q 0.55 -if %s -of %d && neroAacTag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"

... or, use the 8.3 syntax:

Code: [Select]
/c C:\Progra~1\NeroDigitalAudio\neroAacEnc.exe -q 0.55 -if %s -of %d && C:\Progra~1\NeroDigitalAudio\neroAacTag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"

Both work here.

Edit: HeXeR's string works too.
  • Last Edit: 11 June, 2007, 02:22:45 PM by Synthetic Soul
I'm on a horse.

  • greynol
  • [*][*][*][*][*]
  • Global Moderator
Nero AAC & EAC Why Isn't This Working?
Reply #15
I just add a pair of sacrificial quotes around the entire string when this happens.

...anyway, whatever works.  I just thought I'd tell you guys why this is happening.
  • Last Edit: 11 June, 2007, 02:25:29 PM by greynol
13 February 2016: The world was blessed with the passing of a truly vile and wretched person.

Your eyes cannot hear.

  • CheechOZ
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #16
I must admit the above flumoxes me! 

Easiest way:  put the EXEs in your windows folder and just use:

Code: [Select]
/c neroAacEnc.exe -q 0.55 -if %s -of %d && neroAacTag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"

... or, use the 8.3 syntax:

Code: [Select]
/c C:\Progra~1\NeroDigitalAudio\neroAacEnc.exe -q 0.55 -if %s -of %d && C:\Progra~1\NeroDigitalAudio\neroAacTag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"

Both work here.

Edit: HeXeR's string works too.


Obviously, something else has to be wrong here!    I have this feeling that this version of EAC might not be the proper version to handle this string.  You said yours works fine, plus HeXer's also, well, both of them still don't work for me!!  Both the neroaacenc.exe, and neroaactag.exe files are both in the NerDigitalAudio folder in my C:\Program Files directory.  I will try a newer version of EAC, but I'de rather not, because the only version I am allowed to use for Uber Standard is my current version!


EDIT:  HUURAAAAAYYY!!!!!!!  FINALLY!!

Thanks a million Synthetic Soul, I used the first string that you wrote, and dropped both Nero files into my System32 folder, and low and behold, it finally works!!      Now I'm gonna change the file to the sse2 exe, so I can get the most out of my processor's abilities.

But I still wonder why the normal way of ripping and encoding didn't work for me, I'm guessing it has something to do with administrator privileges on Vista, or something else that I still can't figure out.  Thanks again!
  • Last Edit: 11 June, 2007, 04:37:59 PM by CheechOZ

  • Shocking
  • [*]
Nero AAC & EAC Why Isn't This Working?
Reply #17
Shocking's way of putting the tagger is right. Sorry, my bad! I didn't try it out, I only remembered the time where I ripped to AAC and I had the same problem, too. Now I rip to FLAC and do the lossy compression with Foobar2000.

Shocking's command line is good, only the genre is missing. So here is the real thing (again)

/c C:\"Program Files"\NeroDigitalAudio\neroaacenc.exe -q 0.55 -if %s -of %d && C:\"Program Files"\NeroDigitalAudio\Neroaactag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"

You see, you just have to put the tagger where there is a space.
Example 1: C:\"Program Files"\Nero\neroaacenc.exe
Example 2: C:\"Program Files\Exact Audio Copy\Nero Enc"\neroaacenc.exe

This time I tested it and it works!

And sorry for my bad english.


Oops! thanks for pointing that out HeXeR. I never realised that I never had the genre in my tags. I do now! 

  • Alex B
  • [*][*][*][*][*]
Nero AAC & EAC Why Isn't This Working?
Reply #18
The OP (CheechOZ) asked the following by PM. I decided to answer here so that others can benefit from the answer too...
Quote
Hi Alex, I'm very interested in ripping my cd collection into the wave cue sheet format, then later having the option to do whatever I want with the files!  If you can, I would appreciate if you could point me to any helpful links that will show me the way to do this.  Hard drive space is not an issue for me, as I have over 1.3 TB of space 

Thanks in advance.

I posted my previous reply because it seems that people are trying to do something that is trivial to me in an overly complex way.

Ripping in wav + cue format is very simple in EAC. After you have configured EAC's drive options properly (this part does not differ from ripping to separate track files) you can start ripping from Action > Copy Image and Create CUE Sheet... or by using the Alt+F7 shortcut.

Wave files can't be tagged, but the cue sheet will automatically hold the standard album and track info that you had in EAC before ripping.

Later on you can simply drag the cue sheet (or several cue sheets) to foobar2000 and it will show you the individual album tracks. You can easily convert all or a selection of these tracks to AAC MP4 by using foobar's Convert tool. Foobar will ask the encoder path when it needs it for the first time. (You need to download the free Nero commandline encoder separately.)


Personally, I use EAC's internal Monkey's Audio compression option when I create disc image files. Then the cue files will automatically contain links to the losslessly compressed .ape files instead of the .wav files.
(After the Monkey Audio v.3.99 package is installed this option is available: Compression Options > Waveformat > Monkey's Audio Lossless Encoder v3.99 dll)

However, naturally the AAC conversion is slower if the source file needs to be decoded first. If I were to convert 200 CDs I would use uncompressed wave and compress the disc image files later.
  • Last Edit: 13 June, 2007, 04:45:56 AM by Alex B

Nero AAC & EAC Why Isn't This Working?
Reply #19
Code: [Select]
/c neroAacEnc.exe -q 0.55 -if %s -of %d && neroAacTag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:genre="%m" -meta:year="%y"


I'm a long time EAC and MP3 user. I thought I would give neroAAC a try and through my research I across this thread. The command line above provided by Synthetic Soul worked great. However, I do have one question. What is the syntax for adding a comment to the command line? Any help would be appreciated.

Nero AAC & EAC Why Isn't This Working?
Reply #20
I also spent a few hours trying to get Nero AAC working with EAC myself yesterday after finally getting a new PC running Vista. I had it set up perfectly on my old PC, however, it just didn't wanna work on this one. I did eventually get it working again, exactly like before. Here are my exact settings... give 'em a go and see if it works.

Firstly, in my EAC folder in my C:\Program Files, I created a new folder called Nero AAC and placed the neroAacEnc.exe and neroAacTag.exe in there.

Now I have 'Use external programme for compression' checked

Parameter passing scheme: User Defined Encoder

Use file extension: .m4a

Programme, including path, used for compression: C:\Windows\System32\Cmd.exe

Additional command line options: /c C:\"Program Files\Exact Audio Copy\Nero AAC"\neroAacEnc.exe -q 0.55 -if %s -of %d && C:\"Program Files\Exact Audio Copy\Nero AAC"\neroAacTag.exe %d -meta:artist="%a" -meta:album="%g" -meta:track="%n" -meta:title="%t" -meta:year="%y"

Hope this helps. It works like a dream for me. Good luck!




work very good . tnx for help . if someone have windows vista or 7 check path to enc because on 64bit OS program files look like this : Program Files (x86) this path is good for windows xp. just add (x86) and must work. tnx again

  • hlloyge
  • [*][*][*][*][*]
Nero AAC & EAC Why Isn't This Working?
Reply #21
To add a question to a question: is it possible to hide encoding commandline window? I've checked the option for that, but still I have popups for every encoding file.

  • greynol
  • [*][*][*][*][*]
  • Global Moderator
Nero AAC & EAC Why Isn't This Working?
Reply #22
13 February 2016: The world was blessed with the passing of a truly vile and wretched person.

Your eyes cannot hear.

  • hlloyge
  • [*][*][*][*][*]
Nero AAC & EAC Why Isn't This Working?
Reply #23
OK, I will play a bit with that, thank you, greynol.

Nero AAC & EAC Why Isn't This Working?
Reply #24
I am getting crazy to use the Nero AAC encoder with AAC-

I am just following the instruction reported here http://wiki.hydrogenaudio.org/index.php?title=EAC_and_AAC

AAC encoder is there C:\Program Files\Nero\AAC encoder\win32\neroAacEnc.exe

if i put in the external parameter window

-q 0.5 -if %s -of %d

as suggested by that URL i got the following error:

"Invalid Replacement Tag found!"

if i remove these option i obviously get 'no input /output file specified' (I run test encoder for this ...) and i cannot move on ...

Did anybody tried this?
  • Last Edit: 31 January, 2012, 11:19:37 AM by marco.stanzani