Skip to main content

Topic: Foobar v0.9.4.3 Beta (Read 21011 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • GeSomeone
  • [*][*][*][*][*]
Foobar v0.9.4.3 Beta
There is a new beta version

0.9.4.3
    * Fixed multiple bugs in ReplayGain Scanner
    * Musepack decoding bug fixes
    * Fixed a rare crash in the Properties dialog
    * Fixed bugs in File Types preferences page

P.S. see the changelog above, it doesn't really help to complain about other things in this thread.
In theory, there is no difference between theory and practice. In practice there is.

  • Matyas
  • [*][*][*]
Foobar v0.9.4.3 Beta
Reply #1
Do I have to rescan my whole collection of music with regards to the Replaygain bugs?

Foobar v0.9.4.3 Beta
Reply #2
* Musepack decoding bug fixes


Hmmm... With this beta installed, I know have a certain track which starts with 2 seconds of disortion on the right channel. Same track plays fine again with 0.9.4.2

Foobar v0.9.4.3 Beta
Reply #3
0.9.4.3
        * Musepack decoding bug fixes


What exactly was wrong with Musepack decoding? I never noticed any problems with 0.9.4.2?

  • musicmusic
  • [*][*][*][*][*]
  • Developer
Foobar v0.9.4.3 Beta
Reply #4
If you are running Vista, with UAC on an admin account the foobar2000 process spawned of by the installer has admin priviledges. If you are updating foobar2000 and aren't using per user settings, this wrecks havoc as previously all the settings were stored virtualised in the VirtualStore folder.. I ended up losing all my settings.
.

  • Andreasvb
  • [*][*][*][*][*]
Foobar v0.9.4.3 Beta
Reply #5
Is the Rescan Media Library slow for anyone else?

It's takes about 1:30 min to scan about 6000 files, before it took about 5-10 sec.
Windows 10 Pro x64 // foobar2000 1.3.10

  • askoff
  • [*][*][*][*]
Foobar v0.9.4.3 Beta
Reply #6
I'm also intrested about how much the replaygain bug affects the scanning results if it does.

  • Borisz
  • [*][*][*][*]
Foobar v0.9.4.3 Beta
Reply #7
Sometimes you get a ridiculous value like +65db on Replaygain scanning, thats the only bug I know of.

  • mig
  • [*][*]
Foobar v0.9.4.3 Beta
Reply #8
Do the "file type preferences page" bugs that were fixed address the issue I reported about Vista's preview handler registration?
  • Last Edit: 16 April, 2007, 01:09:04 PM by mig

Foobar v0.9.4.3 Beta
Reply #9
I am interessted in what those replaygainscanner bugs were

  • Squeller
  • [*][*][*][*][*]
Foobar v0.9.4.3 Beta
Reply #10
It's takes about 1:30 min to scan about 6000 files, before it took about 5-10 sec.
I don't see a difference here.

Thanks for the update. It would be helpful if the developer was present here, there are so many unanswered questions around. But I see Peters last post is from september 2006.
  • Last Edit: 17 April, 2007, 03:26:41 AM by Squeller

  • gob
  • [*][*][*][*]
Foobar v0.9.4.3 Beta
Reply #11
It's takes about 1:30 min to scan about 6000 files, before it took about 5-10 sec.
I don't see a difference here.

Thanks for the update. It would be helpful if the developer was present here, there are so many unanswered questions around. But I see Peters last post is from september 2006.



thats strange that you were able to scan 6000 tracks in 5-10 seconds. it would probably take me atleast 3 minutes to scan 6000 tracks. it takes me just over 5 minutes to scan 11,000 tracks as it is. then again, the majority of my music is lossless. does this sound like the typical time frame considering the hardware im running?

specs:
Athlon XP 2500 (stock speed)
1GB DDR
WD 320GB PATA 8MB cache

  • Andreasvb
  • [*][*][*][*][*]
Foobar v0.9.4.3 Beta
Reply #12
The first time it takes long time, but if you scan again then it's very fast, in 0.9.4.2.

In the 0.9.4.3 beta it's like every scan is like first time scan.
Quote
CPU: AMD Athlon™ 64 Processor 3400+ [x86 Family 15 Model 4 Stepping 10] [DEP enabled]
Operating System: Windows Vista ™ Ultimate [version: 6.0.6000 ]
Installed RAM: 1022 MBytes
Core version: foobar2000 v0.9.4.3 beta
Build time: 21:45:51 on 14 April 2007
Windows 10 Pro x64 // foobar2000 1.3.10

  • cmdrpaddy
  • [*][*]
Foobar v0.9.4.3 Beta
Reply #13
Is the Rescan Media Library slow for anyone else?

It's takes about 1:30 min to scan about 6000 files, before it took about 5-10 sec.


Whenever I've reinstalled foobar it takes a while to scan my library but whenever I rescan having not reinstalled it only takes a few seconds. Does the scanner only check for changes after it has scanned once or will it rescan everything even if it has already scanned before  ?

  • Andreasvb
  • [*][*][*][*][*]
Foobar v0.9.4.3 Beta
Reply #14
Seems like the beta rescans everything, everytime. Atleast for me.
Windows 10 Pro x64 // foobar2000 1.3.10

  • Peter
  • [*][*][*][*][*]
  • Administrator
Foobar v0.9.4.3 Beta
Reply #15
Hmmm... With this beta installed, I know have a certain track which starts with 2 seconds of disortion on the right channel. Same track plays fine again with 0.9.4.2
In case nobody from Musepack Development Team has contacted you yet, it would help to upload a file that triggers the problem so we can examine it.

I am interessted in what those replaygainscanner bugs were
Crash on high-sample-rate input, rare GUI glitches. Nothing affecting results.

Seems like the beta rescans everything, everytime. Atleast for me.
Nothing Media Library related has changed between 0.9.4.2 and 0.9.4.3, you are imagining things. It seems someone is reporting "faster ML rescans" or "slower ML rescans" or "better tonal purity" or alike about every time there's a new version out regardless of real changes.
  • Last Edit: 17 April, 2007, 12:29:27 PM by Peter

  • powernemo
  • [*]
Foobar v0.9.4.3 Beta
Reply #16
WEE !  Finally a new version
No Foobar? No music

  • shakey_snake
  • [*][*][*][*][*]
  • Moderator
Foobar v0.9.4.3 Beta
Reply #17
thanks for replying, peter.
elevatorladylevitateme

Foobar v0.9.4.3 Beta
Reply #18
In case nobody from Musepack Development Team has contacted you yet, it would help to upload a file that triggers the problem so we can examine it.

Done.

http://www.hydrogenaudio.org/forums/index....howtopic=54263#

Edit: Fixed quote.
  • Last Edit: 18 April, 2007, 09:32:10 AM by Frank Bicking

  • Alex B
  • [*][*][*][*][*]
Foobar v0.9.4.3 Beta
Reply #19

    * Musepack decoding bug fixes


Hmmm... With this beta installed, I know have a certain track which starts with 2 seconds of disortion on the right channel. Same track plays fine again with 0.9.4.2


In case nobody from Musepack Development Team has contacted you yet, it would help to upload a file that triggers the problem so we can examine it.

Done.

http://www.hydrogenaudio.org/forums/index....howtopic=54263#


This is an interesting phenomenon. I tried the provided sample file and can confirm that the files decoded with fb2k 0.9.4.2 and 0.9.4.3b are different. (It seems that you used the plain --quality 4 setting and the encoder v. 1.16.)

I created a new 5s sample from the beginning of the same track using the original lossless source (I happen to have access to that soundtrack album). I encoded it at --quality 4 and --quality 7 (encoder v.1.16) and noticed that the both mpc files trigger a similar decoding error. This 5s lossless sample is available here: http://www.hydrogenaudio.org/forums/index....=486461?

EDIT

I also tried two other samples that start abruptly with quite loud and full audio content, but I couldn't reproduce the problem. Both foobar versions converted bit to bit identical wave files from my test mpc files.
  • Last Edit: 19 April, 2007, 08:16:50 AM by Alex B

Foobar v0.9.4.3 Beta
Reply #20
I encoded it at --quality 4 and --quality 7 (encoder v.1.16) and noticed that the both mpc files trigger a similar decoding error. This 5s lossless sample is available here: http://www.hydrogenaudio.org/forums/index....=486461?


My original mpc encode was Q10 (yes, I call it my psychoacoustic lossless model ), but that was quite a biggy for the upload. So I made a q4 from my Wavpack source after I have verified that the error appears as well.

With 12.904 mpc files I better keep 0.9.4.2 a while for playback:)

  • Peter
  • [*][*][*][*][*]
  • Administrator
Foobar v0.9.4.3 Beta
Reply #21
Thank you for your feedback,

A DLL with fixed Musepack decoder (libmpcdec 1.2.6) attached to the message (extract to your components directory). The noise problem reported above should be fixed.

  • 4nt1
  • [*][*][*][*]
Foobar v0.9.4.3 Beta
Reply #22
Hi Peter the new version tests pretty good, I have one concern that has popped up with PanelsUI - when i play a new song it does a screen redraw of the app and lags the display for 2-3 seconds... like it is updating a tag in but hiding it in the background...

hard to troubleshoot as I dont know if its my collection of 50,000+ songs or panels.

all in all great work - are there any new features we can look forward to in coming releases?

  • Alex B
  • [*][*][*][*][*]
Foobar v0.9.4.3 Beta
Reply #23
Thank you for your feedback,

A DLL with fixed Musepack decoder (libmpcdec 1.2.6) attached to the message (extract to your components directory). The noise problem reported above should be fixed.


Thanks Peter,


I wanted to confirm that the fix works and did a "little" test:

- I gathered all 205 problem samples that I have collected over the last few years (mostly from HA) and encoded them with the following encoder versions and settings (I happened to have these settings predifined):
1.14b / --xlevel --quality 8 --ms 15
1.15v / --quality 5
1.16 / --quality 4
1.16 / --quality 7
1.16 / --quality 8 --ms 15

- decoded the samples to wave with
0.9.4.2
0.9.4.3 b unfixed
0.9.4.3 b fixed

- I used 0.9.4.2 and the bitcompare tool and compared the resulting 3075 wave files.


As a result, I can confirm that 0.9.4.3 with the fixed dll produced bit to bit identical wave files with 0.9.4.2.

The results of the unfixed dll were interesting. About 7-9% of the 205 files in each set were decoded erroneously. Most of the incorrect wave files were from the same audio samples, but each encoder version/setting resulted some incorrect wave files that were fine in the other sets.


Edit: typo
  • Last Edit: 20 April, 2007, 09:48:39 AM by Alex B

  • nacho666
  • [*]
Foobar v0.9.4.3 Beta
Reply #24
Are the devs working on a following version, or is this version supposed to fix all the big bugs known at the moment?

I am not complaining, but I am asking because two bugs that I reported and that are fairly important to people with network storage are still present.

edit: here is the link in case someone wants to look: http://www.hydrogenaudio.org/forums/index....showtopic=53411
  • Last Edit: 20 April, 2007, 05:09:00 PM by nacho666