Skip to main content

Topic: Omni Encoder 1.0 Released (Read 221720 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • music_man_mpc
  • [*][*][*][*][*]
  • Members (Donating)
Omni Encoder 1.0 Released
Reply #25
Okay, I fixed the drifting settings problem (so 0.95 stays as such when you choose it) and got rid of that debugging message box that I thought i'd removed (doh!), but i can't reproduce your more serious bug. Since you have that helpful debugging message anyhow that gives the command line, could you perhaps tell me what it says when you're for instance encoding with quality 0.9?


Thanks for the quick replys!  The debugging message box reports the selected -q value but, unless that value is 1.0, i get an ~10kb/s file.  I'll try encoding some stuff command line with the nero encoder, maybe its a bug on there side or my system ( I am running XP x64 if that makes a difference).  I'll post back in a couple of minutes to let you know if I can replicate the bug with only the encoder or not.

-Tyler

edit: typo
  • Last Edit: 26 December, 2006, 08:18:14 PM by music_man_mpc
gentoo ~amd64 + layman | ncmpcpp/mpd | wavpack + vorbis + lame

  • music_man_mpc
  • [*][*][*][*][*]
  • Members (Donating)
Omni Encoder 1.0 Released
Reply #26
Sorry I forgot to post again last night.  It seems that the problem is coming from my computers lingual confusion, using an alternative shell to explorer and switching from French to English all the time is much harder then it sounds and it has some weird effects.  Some programs I install come out in french, others in english.  Omni encoder is in english in every respect except that it choose -q 0,5 instead of -q 0.5 and a quick test in DOS proved that this is the cause, it seems nothing is read after the comma so any q less then 1 is 0 but a q of 1 is still a q of 1.

Probably mostly a problem on my side but if there is anything you can do about it i would greatly appreciate it.
gentoo ~amd64 + layman | ncmpcpp/mpd | wavpack + vorbis + lame

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #27
Sorry I forgot to post again last night.  It seems that the problem is coming from my computers lingual confusion, using an alternative shell to explorer and switching from French to English all the time is much harder then it sounds and it has some weird effects.  Some programs I install come out in french, others in english.  Omni encoder is in english in every respect except that it choose -q 0,5 instead of -q 0.5 and a quick test in DOS proved that this is the cause, it seems nothing is read after the comma so any q less then 1 is 0 but a q of 1 is still a q of 1.

Probably mostly a problem on my side but if there is anything you can do about it i would greatly appreciate it.

There are a bunch of internationalization issues I will work out eventually once all the other kinks are out, but I can't be more specific. The other things you reported are fixed now though, and 1.1.1 is on its way (once I take a closer look at this iTunes crash thing).

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #28
Version 1.1.1 is now available.

* Bug fixes in the Nero, Vorbis, iTunes and Musepack modules.
* Subtle usability improvements in the main application.

iTunes may still crash once in a while... I'm quite convinced at this point that it is iTunes itself and not my fault

  • gordo
  • [*]
Omni Encoder 1.0 Released
Reply #29
1.1.1 seems much improved with itunes alac - I just test converted 4 albums with no crash - now ready to try a 7000 song flac->alac conversion - report back in a few days...

Well it didn't take a few days - out of memory error when I started the conversion on a list of 2700 files.  Scaling back my ambitions I tried 400 files in a batch which started OK but died on itunes error after 10% or so.  Looks like frequency was reduced but the problem is still with us.  If it is an itunes problem the best solution might be a resume feature to pickup where it left off?

Update - I was able to get through 407 files using local disk vs network drive (samba).  Now trying 700 files.

Curiousity - if I convert without adding album art to the tag the result files streams to a Roku Soundbridge (which uses alac for lossless).  If I add album art it doesn't work...
  • Last Edit: 28 December, 2006, 11:44:48 AM by gordo

  • Preuss
  • [*][*]
Omni Encoder 1.0 Released
Reply #30
I have just tried Omni Encoder for the first time.

The is only one problem and that is when I add one of my FLAC or MP3 files it throws an SystemFormatException. But it's not all the files.

It must be when you parse the tags. Because it's only happens when I have written "2002 02 07" it the year tag. It's the dbPowerAmp that have written it, and it will always come with an exception.


I hope you can fix it, because I can't even use it.

[EDIT]
Have made some more tests and I have more problems, I can't seem to understand why it's not working. And it all comes down to the Tag parser.
[/EDIT]
  • Last Edit: 29 December, 2006, 09:39:24 AM by Preuss

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #31
I have just tried Omni Encoder for the first time.

The is only one problem and that is when I add one of my FLAC or MP3 files it throws an SystemFormatException. But it's not all the files.

It must be when you parse the tags. Because it's only happens when I have written "2002 02 07" it the year tag. It's the dbPowerAmp that have written it, and it will always come with an exception.


I hope you can fix it, because I can't even use it.

[EDIT]
Have made some more tests and I have more problems, I can't seem to understand why it's not working. And it all comes down to the Tag parser.
[/EDIT]


Is that specifically MP3s, or FLAC files that are throwing that exception? or both?

  • Preuss
  • [*][*]
Omni Encoder 1.0 Released
Reply #32
Is that specifically MP3s, or FLAC files that are throwing that exception? or both?

It's tags in both MP3 and FLAC files.

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #33
Version 1.1.2 released.

Okay, it shouldn't throw exceptions when encountering bad tags anymore (but it WILL ignore them: "2002 02 07" is SO not a year ). Also fixed a crash when running in EAC mode when it tried to start a second conversion operation before the first one finished.

STOP FINDING BUGS DAMNIT! (Nah, just kidding.. thanks for all the feedback everyone! Hopefully I've got a pretty stable app by this point).
  • Last Edit: 29 December, 2006, 05:52:41 PM by Jebus

  • Demonanya
  • [*]
Omni Encoder 1.0 Released
Reply #34
So far apart from my Japanese language music not liking it everything seems to be working fine.  I've just got one request though, unless you can already do this and I'm missing the obvious.  Could you make it so your program passes through disc number information.  It's mainly me being lazy as after encoding everything with Omni I then have to go into ITunes to retag my multi disc albums.  Like I said though I could be missing something obvious

  • Preuss
  • [*][*]
Omni Encoder 1.0 Released
Reply #35
Okay, it shouldn't throw exceptions when encountering bad tags anymore (but it WILL ignore them: "2002 02 07" is SO not a year ). Also fixed a crash when running in EAC mode when it tried to start a second conversion operation before the first one finished.


Just a small request. Please try and test if the first 4 chars "2002" is a number.
Because now all my year is gone completely.


STOP FINDING BUGS DAMNIT! (Nah, just kidding.. thanks for all the feedback everyone! Hopefully I've got a pretty stable app by this point).

Nice working, now working with all my files. No bugs anymore  .
  • Last Edit: 29 December, 2006, 07:48:34 PM by Preuss

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #36
Just a small request. Please try and test if the first 4 chars "2002" is a number.
Because now all my year is gone completely.


Vorbis comments are infuriating because there is no standard format, particularly for the "DATE" frame. For now i've added what you asked for, and eventually i'll make it search for a 4-digit # instead. I've PM'd a test version to you... will be added in the next release.

So far apart from my Japanese language music not liking it everything seems to be working fine.  I've just got one request though, unless you can already do this and I'm missing the obvious.  Could you make it so your program passes through disc number information.  It's mainly me being lazy as after encoding everything with Omni I then have to go into ITunes to retag my multi disc albums.  Like I said though I could be missing something obvious


I haven't added that, no. I personally tend to rip multi-disc albums as one big album instead (why should your files care about what piece of physical media they came on?).

Eventually i'll add the ability to edit custom frames, but for now... gotta go the iTunes route, sorry

  • samesong
  • [*]
Omni Encoder 1.0 Released
Reply #37
I have a question regarding album art. Your feature that automatically downloads album art from Amazon.com is great, but what about files that already have album art? I converted a FLAC album that already had embedded album art, but I noticed that when converting to LAME, the artwork didn't carry over. Would it be difficult to implement a method of automatically transferring pre-existing album art?

edit: and maybe this is being picky, but it would be nice if you could select which source files you wanted deleted after converstion, instead of the current all-or-none approach.

I love your program, keep up the great work =)
  • Last Edit: 31 December, 2006, 07:55:32 AM by samesong

  • kanak
  • [*][*][*][*][*]
Omni Encoder 1.0 Released
Reply #38
Just downloaded the program. Looks good. I have a couple of "Feature requests":

1. Would it be possible to implement a "task queue" like in Virtualdub? So we could set up multiple encoding tasks and leave them to run overnight or something?

2. Would it be possible to implement a "log file" writing after every task? It would help in "troubleshooting" in case something went awry in the conversion process.

Thanks.

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #39
I have a question regarding album art. Your feature that automatically downloads album art from Amazon.com is great, but what about files that already have album art? I converted a FLAC album that already had embedded album art, but I noticed that when converting to LAME, the artwork didn't carry over. Would it be difficult to implement a method of automatically transferring pre-existing album art?

It should be reading the art out of the FLAC files, and you can choose to save it to a Folder.jpg if you check that option. The LAME module doesn't, as of yet, support embedded album art at all.
edit: and maybe this is being picky, but it would be nice if you could select which source files you wanted deleted after converstion, instead of the current all-or-none approach.

Sounds needlessly complicated to me. If you want some deleted and some not, do it in 2 batches.

Just downloaded the program. Looks good. I have a couple of "Feature requests":

1. Would it be possible to implement a "task queue" like in Virtualdub? So we could set up multiple encoding tasks and leave them to run overnight or something?

2. Would it be possible to implement a "log file" writing after every task? It would help in "troubleshooting" in case something went awry in the conversion process.

Thanks.


1. It is a good idea, and something I've considered. Will add it to my TODO list.

2. Also doable, but less urgent. Right now its pretty good at bailing out at the first sign of error.

  • DJED
  • [*]
Omni Encoder 1.0 Released
Reply #40
This proggie is really cool.

However, a few things I have noticed...

When converting the directory tree, the mirror option sometimes just dumps the files into root folder.

When using as EAC plugin, having option for multi encode would be useful like (FLAC & MP3).

Otherwise, very nice utility - easily outperforms FB2K for the tasks I want.

Thanks!!!!

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #41
Version 1.2 Released:

* WavPack (lossless and hybrid) support added!
* Some trivial bug fixes.

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #42
When converting the directory tree, the mirror option sometimes just dumps the files into root folder.



The mirror option is sort of weird in the way it works... it takes the nearest common directory and mirrors that one to wherever. So if you only choose a bunch of files in one directory, it is THAT directory's contents that get copied to the mirror location. if they're spread across a 3-layer deep tree of directories, the closest common "trunk" and all subdirectories are what get copied. Does that sort of make sense?

I prefer to use the tag-based method... I added mirroring mostly just for people with incorrectly tagged files.
  • Last Edit: 03 January, 2007, 04:47:24 PM by Jebus

  • phaedra
  • [*][*]
Omni Encoder 1.0 Released
Reply #43
Version 1.2 Released:

Just wondering ... do you have any plans to release a linux version of your software at any point in the future?

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #44
Since I've added all the "necessary" codecs at this point, and (I think) all the important bugs have been squashed, here is my tentative plan for version 1.3 (some might be put off for 1.4):

Improved art dialog
  - Ability to select small/medium/large covers.
  - Ability to enter alternate search criteria in case nothing comes up.
  - Ability to import existing jpeg images in the filesystem.

Cuesheet support
  - Opening a FLAC or WavPack cuesheet should fill the list with all the included tracks.

Conversion summary dialog
  - A summary window after encoding showing the total conversion time, track count, etc.

Queued tasks
  - Convert to multiple formats without intervention (much requested)
  • Last Edit: 03 January, 2007, 05:12:23 PM by Jebus

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #45
Just wondering ... do you have any plans to release a linux version of your software at any point in the future?


No, unfortunately. It is written in C#, but the Mono project has incomplete support for Windows Forms, and I access a lot of auxilliary programs that are native Win32 applications. I use linux myself extensively (you might notice the source code is hosted on a Linux box ), but not as a desktop OS.
  • Last Edit: 03 January, 2007, 05:11:50 PM by Jebus

  • qrwe
  • [*]
Omni Encoder 1.0 Released
Reply #46
Is FAAC encoded files supported?

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #47
Is FAAC encoded files supported?


You can certainly read/transcode from them, but i don't have an encoder, no.

If/when FAAC development actually begins again, then I'll happily consider it.

  • krabapple
  • [*][*][*][*][*]
Omni Encoder 1.0 Released
Reply #48
Just tried this for converting Flac 1.1.0 files (-5 and -8)  to Flac 1.1.3 (-8) -- and I'm noticing

1) even though I have 'include Flac comments' checked, they aren't preserved in the reencoded flacs

2) the 'composer' tag isn't preserved (and I have lots of classical files to re-encode  )

  • wraithdu
  • [*][*][*][*]
Omni Encoder 1.0 Released
Reply #49
Exactly what options in EAC are changed when installing Omni Encoder?  I ask because I had saved my default (complete) profile in EAC, then saved (compression) only profiles for using either LAME, LAME+EAC id3 tagging, or Omni.  I found that after installing Omni, if I tried to load one of my (compression) only LAME profiles, the wrong commandline was used regardless that the lame.exe path was correct in EAC's compression settings.  It's impossible to see the entire commandline that is called, but it looks like EAC is still trying to call the EACEncoder.exe file in the Omni directory.

If I reload my default (complete) profile my LAME encodes once again work as they should.  After reloading my default (complete) profile, if I try to load the Omni (compression) only profile, I get errors and it doesn't work.  Once again, it passing the wrong commandline/path, but I cannot see exactly what it is trying to send.  A little help please?

EDIT:

User error on the LAME problem.  I put in the wrong commandline.

However, if Omni is selected and I try to Compress WAV files from the Tools menu in EAC, Omni fails with commandline errors.  Which makes sense since the TAG data is missing in that circumstance.  Maybe for next version, have Omni ignore missing TAG data to prevent this error?
  • Last Edit: 04 January, 2007, 07:05:04 PM by wraithdu