Skip to main content

Topic: Omni Encoder 1.0 Released (Read 221742 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • zilexa
  • [*]
Omni Encoder 1.0 Released
Reply #225
Good questions!

Actually, I tried it again and it really happens after ENcoding first track. So Decoding goes fine, Encoding goes till the end of the first track, then the error shows. I can see the mp3 file has been created. (I tried several tracks from different flac albums).

Settings I changed: selected mp3 encoder, checked the quality and it was set to 2 so I left that one like it was.
I did checked the box "Add cover art as metadata" in the ID3 tagging options.

The flac files I tried all have tags, at least Artitst, album and title. Some miss track number. and 1 of the 5 albums had cover art in tag.
2 didn't but Omni automatically found the cover art (great feature btw!) for one.
Strangely, it didn't find the cover art for Buena Vista Social Club - Rhythms del Mundo: Cuba. I did found the art on Amazon, added it with Winamp to the tag. After that, I tried flac -> mp3 with omni and got the same error.

I unchecked the add cover art... checkbox, same results!
And I did not enabled anything about replaygain.

path to the flac files:
D:\Music\Albums\[FLAC] Alicia Keys - As I Am
D:\Music\Albums\[FLAC] Buena Vista Social Club - Rhythms Del Mundo
D:\Music\Albums\[FLAC] Katie Melua - Pictures
D:\Music\Albums\[FLAC] Kanye West - Graduation
D:\Music\Albums\[FLAC] Katie Melua - Call Off The Search

  • gottkaiser
  • [*][*][*]
Omni Encoder 1.0 Released
Reply #226
That makes sense. It is easy to include, for sure. Will be a 2.0 feature though (i've sort of abandoned 1.x).

Any approximate date in sight for v2.0? :-)

  • zilexa
  • [*]
Omni Encoder 1.0 Released
Reply #227
hey what happened? Is this project dying?
I've used BonkEnc for now... but I like Omni encoder...
  • Last Edit: 22 January, 2008, 11:24:06 AM by zilexa

  • Jose Hidalgo
  • [*][*][*][*]
  • Banned
Omni Encoder 1.0 Released
Reply #228
Omni Encoder looks great, it's just what I was looking for.

However, something grieves me : can't we select a "source folder" and a DIFFERENT "destination folder" ??? 

I have just received a new HD and I need to copy ALL my music library (FLAC) to it. But I'd like to seize this opportunity to re-encode all my files to latest FLAC and copy them to the new HD, in a single operation.

If Omni Encoder can't do this, could you please advise me another utility that could ?
- Select a "source folder"
- Scan all its contents, including all its (numerous) sub-folders
- Re-encode all its FLAC files
- Write the re-encoded files to a "destination folder", respecting the same folder hierarchy of course.

Thanks in advance.

  • Moguta
  • [*][*][*]
Omni Encoder 1.0 Released
Reply #229
If Omni Encoder can't do this, could you please advise me another utility that could ?
- Select a "source folder"
- Scan all its contents, including all its (numerous) sub-folders
- Re-encode all its FLAC files
- Write the re-encoded files to a "destination folder", respecting the same folder hierarchy of course.

I'm pretty sure that foobar2000's converter can do this... although I'm *not* certain if it will satisfy your last point of retaining the folder hierarchy.

EDIT: I just tested, and foobar indeed does not preserve folders by default.  However, by mucking around with the "Output File Names" converter options, you should be able to get what you desire.  (This reference for all the possible values & expressions should be helpful.)
  • Last Edit: 22 January, 2008, 07:32:00 PM by Moguta

  • twochannel
  • [*]
Omni Encoder 1.0 Released
Reply #230
Using Omni Encoder 1.4.2.0 on Windows XP64. The following error (see end) occurs when going from .flac to .m4a aac lossless.

In the past this has worked. The only changes that might have any impact have been itunes updates.

The file it is looking for briefly appears in the location it is looking in, but vanishes once the "encoding done" chime sounds. This is also the point at which the error dialog box appears.

.flac to lame .mp3 works.

I have tried the various tag/itunes options on and off.
I have tried running oe in Win XP compat mode as well.
Even a file simply named test.flac failed (incase it was some combo of odd characters in the filename)
Fails on a x86 system as well (vmware guest)

Please let me know if you need any more information.

Thanks,
Chris



See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileNotFoundException: Could not find file 'C:\Documents and Settings\Administrator\My Documents\My Music\iTunes\iTunes Music\Unknown Artist\Unknown Album\01-Symphony No. 3, Op. 36 I. Lento -.m4a'.
File name: 'C:\Documents and Settings\Administrator\My Documents\My Music\iTunes\iTunes Music\Unknown Artist\Unknown Album\01-Symphony No. 3, Op. 36 I. Lento -.m4a'
  at OmniEncoder.Frontend.ConvertForm.converter_ConversionCompleted(Object sender, RunWorkerCompletedEventArgs e)
  at OmniEncoder.Converter.worker_RunWorkerCompleted(Object sender, RunWorkerCompletedEventArgs e)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase: file:///c:/WINDOWS/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
OmniEncoder
    Assembly Version: 1.4.2.0
    Win32 Version: 1.4.2.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/OmniEncoder.exe
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
FLACModule
    Assembly Version: 2.0.1.0
    Win32 Version: 2.0.1.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/FLACModule.DLL
----------------------------------------
iTunesModule
    Assembly Version: 2.0.1.0
    Win32 Version: 2.0.1.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/iTunesModule.DLL
----------------------------------------
AxInterop.QTOControlLib
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/AxInterop.QTOControlLib.DLL
----------------------------------------
Interop.QTOLibrary
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/Interop.QTOLibrary.DLL
----------------------------------------
LAMEModule
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/LAMEModule.DLL
----------------------------------------
MACModule
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/MACModule.DLL
----------------------------------------
MetaMP3Module
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/MetaMP3Module.DLL
----------------------------------------
TagModule
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/TagModule.DLL
----------------------------------------
VorbisModule
    Assembly Version: 2.0.1.0
    Win32 Version: 2.0.1.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/VorbisModule.DLL
----------------------------------------
WavPackModule
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/WavPackModule.DLL
----------------------------------------
Interop.iTunesLib
    Assembly Version: 1.9.0.0
    Win32 Version: 1.9.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Omni%20Encoder/Interop.iTunesLib.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

  • gordo
  • [*]
Omni Encoder 1.0 Released
Reply #231
I have the same problem (file not found on flac->m4a lossless) using windows vista 32 - only since most recent itunes update...

  • twochannel
  • [*]
Omni Encoder 1.0 Released
Reply #232
I have the same problem (file not found on flac->m4a lossless) using windows vista 32 - only since most recent itunes update...



Glad its not just me!


help us baby jeebus help us

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #233
Oh man, really didn't want to dig up 1.4.2 any more... i don't even have visual studio 2005 installed! I'll see what i can do though... might import it into VS2008. There are a few bugs now that need fixing and v2.0 is still a ways off.

which iTunes broke it? 7.6?
  • Last Edit: 03 February, 2008, 05:41:02 PM by Jebus

  • twochannel
  • [*]
Omni Encoder 1.0 Released
Reply #234
Yes,

7.6.0.29 Is the current version I have installed.

Also, the Make A Donation link from the Help menu 404's.  Is there another link, or what email addy should be used.


Thanks,

Oh man, really didn't want to dig up 1.4.2 any more... i don't even have visual studio 2005 installed! I'll see what i can do though... might import it into VS2008. There are a few bugs now that need fixing and v2.0 is still a ways off.

which iTunes broke it? 7.6?

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #235
Yes,

7.6.0.29 Is the current version I have installed.

Also, the Make A Donation link from the Help menu 404's.  Is there another link, or what email addy should be used.


Thanks,


Yeah I changed the website urls but didn't update the app... you can donate off the main website. Thanks for the donation, and the reminder to fix that as well
  • Last Edit: 04 February, 2008, 02:03:11 AM by Jebus

  • DJED
  • [*]
Omni Encoder 1.0 Released
Reply #236
Hi -

I am having an issue as well. A fresh install did not help. .net 1.1 and 2.0 is installed.

Thanks!

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ComponentModel.Win32Exception: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem
  at OmniEncoder.Frontend.ConvertForm.converter_ConversionCompleted(Object sender, RunWorkerCompletedEventArgs e)
  at OmniEncoder.Converter.worker_RunWorkerCompleted(Object sender, RunWorkerCompletedEventArgs e)
  at System.ComponentModel.BackgroundWorker.OnRunWorkerCompleted(RunWorkerCompletedEventArgs e)
  at System.ComponentModel.BackgroundWorker.AsyncOperationCompleted(Object arg)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.832 (QFE.050727-8300)
    CodeBase: file:///C:/WINNT/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
OmniEncoder
    Assembly Version: 1.4.2.0
    Win32 Version: 1.4.2.0
    CodeBase: file:///F:/Omni%20Encoder/OmniEncoder.exe
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.832 (QFE.050727-8300)
    CodeBase: file:///C:/WINNT/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.832 (QFE.050727-8300)
    CodeBase: file:///C:/WINNT/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.832 (QFE.050727-8300)
    CodeBase: file:///C:/WINNT/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.832 (QFE.050727-8300)
    CodeBase: file:///C:/WINNT/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.832 (QFE.050727-8300)
    CodeBase: file:///C:/WINNT/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.832 (QFE.050727-8300)
    CodeBase: file:///C:/WINNT/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
MetaMP3Module
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///F:/Omni%20Encoder/MetaMP3Module.DLL
----------------------------------------
MusepackModule
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///F:/Omni%20Encoder/MusepackModule.DLL
----------------------------------------
FLACModule
    Assembly Version: 2.0.1.0
    Win32 Version: 2.0.1.0
    CodeBase: file:///F:/Omni%20Encoder/FLACModule.DLL
----------------------------------------
WavPackModule
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///F:/Omni%20Encoder/WavPackModule.DLL
----------------------------------------
TagModule
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///F:/Omni%20Encoder/TagModule.DLL
----------------------------------------
LAMEModule
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///F:/Omni%20Encoder/LAMEModule.DLL
----------------------------------------
VorbisModule
    Assembly Version: 2.0.1.0
    Win32 Version: 2.0.1.0
    CodeBase: file:///F:/Omni%20Encoder/VorbisModule.DLL
----------------------------------------
MACModule
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///F:/Omni%20Encoder/MACModule.DLL
----------------------------------------
Accessibility
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINNT/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #237
Bad news, guys. I went to look into these issues last weekend and sorta kinda discovered that my only 1.x source code was on a hard drive that failed a few months back



The good news is, 2.0 is coming along nicely though there is still lots of work to do. In the meantime, I'm afraid I won't be able to fix the iTunes thing.



In regards to "invalid configuration" errors... check in your documents and settings folder under "Application Data" (you might need to turn on hidden/system files) and delete the "Jeremy Herbison" and/or "Omni Encoder" folders. Then reinstall the app and see if it works again.



All configuration is done in there... there is nothing else on the system that could be causing the problem. I'd recommend not checking the iTunes option during installation though.

  • NappyHead
  • [*][*][*]
Omni Encoder 1.0 Released
Reply #238
Bad news, guys. I went to look into these issues last weekend and sorta kinda discovered that my only 1.x source code was on a hard drive that failed a few months back



The good news is, 2.0 is coming along nicely though there is still lots of work to do. In the meantime, I'm afraid I won't be able to fix the iTunes thing.



In regards to "invalid configuration" errors... check in your documents and settings folder under "Application Data" (you might need to turn on hidden/system files) and delete the "Jeremy Herbison" and/or "Omni Encoder" folders. Then reinstall the app and see if it works again.



All configuration is done in there... there is nothing else on the system that could be causing the problem. I'd recommend not checking the iTunes option during installation though.



Is this project dead?

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #239

Bad news, guys. I went to look into these issues last weekend and sorta kinda discovered that my only 1.x source code was on a hard drive that failed a few months back



The good news is, 2.0 is coming along nicely though there is still lots of work to do. In the meantime, I'm afraid I won't be able to fix the iTunes thing.



In regards to "invalid configuration" errors... check in your documents and settings folder under "Application Data" (you might need to turn on hidden/system files) and delete the "Jeremy Herbison" and/or "Omni Encoder" folders. Then reinstall the app and see if it works again.



All configuration is done in there... there is nothing else on the system that could be causing the problem. I'd recommend not checking the iTunes option during installation though.



Is this project dead?


No, the new version is just a lot more complex, and i'm doing it the right way with unit testing and whatnot to avoid the myriad bugs in the 1.x releases. Unfortunately as my real job has been really busy, i've had little energy for coding when I'm home. This has been improved somewhat as of late and I am again working on it quite a bit. Sorry though - I won't be able to fix/improve version 1.x.

  • NappyHead
  • [*][*][*]
Omni Encoder 1.0 Released
Reply #240
Thank you, because I really like the program.

NH

  • miko
  • [*]
Omni Encoder 1.0 Released
Reply #241
will add iTunes AAC true VBR mode support?

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #242
Thank you, because I really like the program.

NH

Thanks! Good to hear. The new version will definitely stick to the principles of version 1, just be a lot more useful, faster and more stable.
will add iTunes AAC true VBR mode support?

Absolutely.
  • Last Edit: 12 June, 2008, 12:47:08 PM by Jebus

  • BadDrafter
  • [*]
Omni Encoder 1.0 Released
Reply #243
Will there be a release before September?

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #244
Will there be a release before September?


What's in September?

I'm not going to commit to dates, sorry! Depends entirely on how much time I spend indoors this summer
  • Last Edit: 01 July, 2008, 02:57:11 PM by Jebus

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #245
Sorry sorry sorry... DNS issues for a few weeks now and I just got around to fixing it. Download links are working again.

  • jamesbaud
  • [*][*][*]
Omni Encoder 1.0 Released
Reply #246
I recently discovered this program. Pretty nifty.

It would be nice if, in the next version, one could just drop in an .EXE file to update to the latest LAME or FLAC, just like dropping in the latest Nero .EXE.

Keep up the good work!

-jb

  • NappyHead
  • [*][*][*]
Omni Encoder 1.0 Released
Reply #247
Will there be a release before September?


What's in September?

I'm not going to commit to dates, sorry! Depends entirely on how much time I spend indoors this summer



Can we expect an update anytime soon?

Omni Encoder 1.0 Released
Reply #248
Omni Encoder ate my WAVs!
i aborted when i realized my setting were wrong.  the WAVs were gone from the folder and i could  not find them in any of the usual temp locations nor in the Recycle folder.
where were they moved/stored or am i SOL?

  • NappyHead
  • [*][*][*]
Omni Encoder 1.0 Released
Reply #249
Is this now dead?