Skip to main content

Topic: Omni Encoder 1.0 Released (Read 222069 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Alex B
  • [*][*][*][*][*]
Omni Encoder 1.0 Released
Reply #200
Aw crap... i know what the problem is too... i stopped using temporary art files and instead read it in as a bitmap right in memory.... but when I write it back out, i don't think its recompressing. doh! I'll look at it soon.

Actually, you should not decompress and recompress lossy jpeg files. Is it not possible to maintain the original image quality?

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #201
Aw crap... i know what the problem is too... i stopped using temporary art files and instead read it in as a bitmap right in memory.... but when I write it back out, i don't think its recompressing. doh! I'll look at it soon.

Actually, you should not decompress and recompress lossy jpeg files. Is it not possible to maintain the original image quality?




Its a good point. I should probably just be storing the jpeg as a byte array or something, instead of reading it in to an image (bitmap) object.

  • JILost
  • [*]
Omni Encoder 1.0 Released
Reply #202
There seems to be a pretty severe bug which has existed for several versions and is still present in 1.4.2 on Windows XP SP2.  When trying to convert tracks from two different folders (adding them to the list with "Add Folder"), when it hits the files from the second folder, rather than decoding them, Omni Encoder stalls and returns:

An error occurred while writing the track:
filenameoftrack

(with "filename of track" replaced with the actual filename, that is)

...and everything stops.  It is very annoying trying to transcode 400-some files only to be stopped every 10, remove the first folder's contents from the list, and start again.

Edit:  Correction.  It's when the destination folder changes.
  • Last Edit: 21 October, 2007, 02:55:47 AM by JILost

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #203
There seems to be a pretty severe bug which has existed for several versions and is still present in 1.4.2 on Windows XP SP2. When trying to convert tracks from two different folders (adding them to the list with "Add Folder"), when it hits the files from the second folder, rather than decoding them, Omni Encoder stalls and returns:

An error occurred while writing the track:
filenameoftrack

(with "filename of track" replaced with the actual filename, that is)

...and everything stops. It is very annoying trying to transcode 400-some files only to be stopped every 10, remove the first folder's contents from the list, and start again.




are they one different drives? Could you give me some path examples?

  • JILost
  • [*]
Omni Encoder 1.0 Released
Reply #204
are they one different drives? Could you give me some path examples?


I'm attempting to do Castlevania: Portrait of Ruin, which has three different composers, changing from song to song.  When I attempt to use the third option ("Create a tag-based folder structure in..."), it'll decode everything by the first Artist and convert fine, then hang up when it starts on the second.  It creates the first and second Artist's destination folder fine, but then doesn't want to decode the second Artist's songs. 

The source folder is the same for the entire album.

I'm trying to transcode from FLAC to Apple AAC (though this problem occurs during any transcoding), from H:\Lossless Discographies\Castlevania\Akumajo Dracula -Gallery of Labyrinth-\ to C:\Castlevania\Michiru Yamane\Akumajo Dracula -Gallery of Labyrinth\ (first Artist) and C:\Castlevania\Yuzo Koshiro\Akumajo Dracula -Gallery of Labyrinth-\ (second Artist).

Like I said...it'll do Yamane just fine, but then when it hits Koshiro's tracks, it hangs and won't decode.  Bizarre.

Edit: Correction.  It did the same thing at the same time when I chose "Mirror the Source Location(s) to...", which leads me to believe it's whenever anything changes other than the Title field.  (That is...it worked fine doing all the Yamane tracks, but then returned the error when Koshiro came up.)  I can run some experiments if you want me to test different situations or anything, just let me know what.
  • Last Edit: 21 October, 2007, 03:24:56 AM by JILost

Omni Encoder 1.0 Released
Reply #205
Does this program support unicode?

  • atka
  • [*]
Omni Encoder 1.0 Released
Reply #206
I have the same problem on any multiple artist cd's omni encoder fails when the artist changes.  You can delete the songs that have already been encoded and start again and it works.  However on a compilation cd that doesn't work to well.

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #207
Does this program support unicode?


No. Well, technically MY code all supports unicode, but i'm calling command-line programs which don't.

Version 2.0 (which i'm working on now) will have full internationalization support, because I'm writing the tagging algorithms myself instead of calling external console apps.

I have the same problem on any multiple artist cd's omni encoder fails when the artist changes. You can delete the songs that have already been encoded and start again and it works. However on a compilation cd that doesn't work to well.


Yeah compilations are too difficult to implement with the 1.x codebase (hey i'm learning as I go here...). Version 2.0 supports them natively.

Here's a screenshot, by the way, of the new interface. Feedback is appreciated.



  • Last Edit: 22 October, 2007, 12:01:09 AM by Jebus

  • atka
  • [*]
Omni Encoder 1.0 Released
Reply #208
Hey looks good, thanks for working on this.


If you ever need a beta tester 

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #209
Hey looks good, thanks for working on this.

If you ever need a beta tester




I will very much need beta testers, but not for a little while. version 2 is substantially more complex, so it will require some sort of beta period for sure. I really want it to be a lot more stable than version 1.



I'm working on the conversion code now... its pretty cool. Completely multithreaded. Breaks up the conversion operation into chunks, and then works on as many as you want, concurrently. (will default to the # of processor cores, but will be configurable). This should MASSIVELY reduce the amount of time required to convert a large library.

  • BadDrafter
  • [*]
Omni Encoder 1.0 Released
Reply #210
I'm working on the conversion code now... its pretty cool. Completely multithreaded. Breaks up the conversion operation into chunks, and then works on as many as you want, concurrently. (will default to the # of processor cores, but will be configurable). This should MASSIVELY reduce the amount of time required to convert a large library.


Can this option be used with iTunes?

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #211

I'm working on the conversion code now... its pretty cool. Completely multithreaded. Breaks up the conversion operation into chunks, and then works on as many as you want, concurrently. (will default to the # of processor cores, but will be configurable). This should MASSIVELY reduce the amount of time required to convert a large library.


Can this option be used with iTunes?




I'm pretty sure not... although at least things like album wavegaining (and other kinds of processing) can happen in a separate thread while itunes does its thing.

  • atka
  • [*]
Omni Encoder 1.0 Released
Reply #212
Sounds nice and complex.  It sounds like it should be a lot faster when it is complete.

  • Jose Hidalgo
  • [*][*][*][*]
  • Banned
Omni Encoder 1.0 Released
Reply #213
Is it me or the download link is broken ? 

Omni Encoder 1.0 Released
Reply #214
Is it me or the download link is broken ? 


add me to the "not working".

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #215
Unfortunately the server had a hard-drive failure yesterday and I haven't had a chance to replace it yet... check again late Saturday or possibly Sunday.

Lost some data... eep! Currently setting up RAID so this doesn't happen again... will work on the web server this aft/tomorrow.
  • Last Edit: 18 December, 2007, 02:19:22 PM by Jebus

  • Domin
  • [*]
Omni Encoder 1.0 Released
Reply #216
Unfortunately the server had a hard-drive failure yesterday and I haven't had a chance to replace it yet... check again late Saturday or possibly Sunday.

Lost some data... eep! Currently setting up RAID so this doesn't happen again... will work on the web server this aft/tomorrow.


Would it be possible to put up a temp hosting of just the install files?

If your interrested i can provide mirroring and ftp access to you until you get your server working again.

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #217

Unfortunately the server had a hard-drive failure yesterday and I haven't had a chance to replace it yet... check again late Saturday or possibly Sunday.

Lost some data... eep! Currently setting up RAID so this doesn't happen again... will work on the web server this aft/tomorrow.


Would it be possible to put up a temp hosting of just the install files?

If your interrested i can provide mirroring and ftp access to you until you get your server working again.


Yeah sorry... i'll put up the files later today. Just an FYI I'm in Victoria visiting family now. I do have access to the server though.

  • Domin
  • [*]
Omni Encoder 1.0 Released
Reply #218
Thanks a lot :-)

Hope you have a nice holiday with your family

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #219
Sorry everyone...



The download link is back up now. Combination of exploding hard drives, lost data, and being away for 2 weeks made getting the site back up difficult.



Cheers!

  • gottkaiser
  • [*][*][*]
Omni Encoder 1.0 Released
Reply #220
@Jebus
Maybe you can implement a feature to set the process priority for the program?


Gottkaiser
  • Last Edit: 08 January, 2008, 06:22:33 AM by gottkaiser

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #221
@Jebus
Maybe you can implement a feature to set the process priority for the program?


Gottkaiser




I've never found that setting the priority is all that helpful, have you? All it seems to do is make multitasking unresponsive, and if you aren't trying to multitask then it doesn't really have any benefit anyhow (higher priority than what?)



Unless you disagree

  • zilexa
  • [*]
Omni Encoder 1.0 Released
Reply #222
Hi there, I just found out about Omni Encoder, downloaded 1.4.2. Switched to mp3 encoder, added a folder with flac files (an album, separate flac files). Omni automatically found Cover art. I selected all tracks and pressed the green button.

Once the upper bar was filled twice (1st track of 13) and I would expect the 2nd track to begin decoding, I got an error message. (.Net error). I have .Net 2.0 and 3.0 installed (not 1.1):

Code: [Select]
See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ComponentModel.Win32Exception: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem
   at OmniEncoder.Frontend.ConvertForm.converter_ConversionCompleted(Object sender, RunWorkerCompletedEventArgs e)
   at OmniEncoder.Converter.worker_RunWorkerCompleted(Object sender, RunWorkerCompletedEventArgs e)
   at System.ComponentModel.BackgroundWorker.OnRunWorkerCompleted(RunWorkerCompletedEventArgs e)
   at System.ComponentModel.BackgroundWorker.AsyncOperationCompleted(Object arg)


************** Loaded Assemblies **************
mscorlib
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.42 (RTM.050727-4200)
   CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
OmniEncoder
   Assembly Version: 1.4.2.0
   Win32 Version: 1.4.2.0
   CodeBase: file:///C:/Program%20Files/Omni%20Encoder/OmniEncoder.exe
----------------------------------------
System
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.42 (RTM.050727-4200)
   CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.42 (RTM.050727-4200)
   CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.42 (RTM.050727-4200)
   CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.42 (RTM.050727-4200)
   CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.42 (RTM.050727-4200)
   CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.42 (RTM.050727-4200)
   CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
FLACModule
   Assembly Version: 2.0.1.0
   Win32 Version: 2.0.1.0
   CodeBase: file:///C:/Program%20Files/Omni%20Encoder/FLACModule.DLL
----------------------------------------
LAMEModule
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.0.0
   CodeBase: file:///C:/Program%20Files/Omni%20Encoder/LAMEModule.DLL
----------------------------------------
MetaMP3Module
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.0.0
   CodeBase: file:///C:/Program%20Files/Omni%20Encoder/MetaMP3Module.DLL
----------------------------------------
NeroModule
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.0.0
   CodeBase: file:///C:/Program%20Files/Omni%20Encoder/NeroModule.DLL
----------------------------------------
TagModule
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.0.0
   CodeBase: file:///C:/Program%20Files/Omni%20Encoder/TagModule.DLL
----------------------------------------
VorbisModule
   Assembly Version: 2.0.1.0
   Win32 Version: 2.0.1.0
   CodeBase: file:///C:/Program%20Files/Omni%20Encoder/VorbisModule.DLL
----------------------------------------
Accessibility
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.42 (RTM.050727-4200)
   CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
System.Web.Services
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.42 (RTM.050727-4200)
   CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Web.Services/2.0.0.0__b03f5f7f11d50a3a/System.Web.Services.dll
----------------------------------------
v6uvyjdx
   Assembly Version: 1.4.2.0
   Win32 Version: 2.0.50727.42 (RTM.050727-4200)
   CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
Microsoft.JScript
   Assembly Version: 8.0.0.0
   Win32 Version: 8.0.50727.42
   CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.JScript/8.0.0.0__b03f5f7f11d50a3a/Microsoft.JScript.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
   <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
[!--sizeo:1--][span style=\"font-size:8pt;line-height:100%\"][!--/sizeo--]Moderation: Please use "codebox" for long logs like this.[/size]
  • Last Edit: 08 January, 2008, 01:12:16 PM by greynol

  • gottkaiser
  • [*][*][*]
Omni Encoder 1.0 Released
Reply #223
I've never found that setting the priority is all that helpful, have you? All it seems to do is make multitasking unresponsive, and if you aren't trying to multitask then it doesn't really have any benefit anyhow (higher priority than what?)

Unless you disagree

I didn't mean higher priority. I thought about lower priority. So the PC doesn't slow down as much.
When I lower the priority, I'll still be able to use other programs while it's transcoding. If I don't lower the priority other programs run so slow.

For me it would be useful. I don't know about others.
Anyway, thanks for considering.

Gottkaiser

  • Jebus
  • [*][*][*][*][*]
  • Developer
Omni Encoder 1.0 Released
Reply #224

I've never found that setting the priority is all that helpful, have you? All it seems to do is make multitasking unresponsive, and if you aren't trying to multitask then it doesn't really have any benefit anyhow (higher priority than what?)

Unless you disagree

I didn't mean higher priority. I thought about lower priority. So the PC doesn't slow down as much.
When I lower the priority, I'll still be able to use other programs while it's transcoding. If I don't lower the priority other programs run so slow.

For me it would be useful. I don't know about others.
Anyway, thanks for considering.

Gottkaiser




That makes sense. It is easy to include, for sure. Will be a 2.0 feature though (i've sort of abandoned 1.x).



Hi there, I just found out about Omni Encoder, downloaded 1.4.2. Switched to mp3 encoder, added a folder with flac files (an album, separate flac files). Omni automatically found Cover art. I selected all tracks and pressed the green button.

Once the upper bar was filled twice (1st track of 13) and I would expect the 2nd track to begin decoding, I got an error message. (.Net error). I have .Net 2.0 and 3.0 installed (not 1.1):




Some questions:



Are the FLAC files tagged completely, or is some information missing?

Where are they located? (full path please).

My understanding is that this crash occurred during the decoding phase, correct?

Do you have replaygain analysis enabled?



That particular error would tend to be thrown if the xml configuration file (where settings are stored) was manually edited with incorrect parameters. Did you try uninstalling and then reinstalling? Did you alter any settings from the FLAC or MP3 defaults?